Merge branch 'geni-v3' of ssh://git.onelab.eu/git/sfa into geni-v3
[sfa.git] / sfa.spec
index d3a5a90..ba883a6 100644 (file)
--- a/sfa.spec
+++ b/sfa.spec
@@ -1,6 +1,6 @@
 %define name sfa
 %define version 3.1
-%define taglevel 0
+%define taglevel 1
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -34,7 +34,7 @@ Requires: python-psycopg2
 Requires: python-sqlalchemy
 Requires: python-migrate
 # the eucalyptus aggregate uses this module
-Requires: python-xmlbuilder
+#Requires: python-xmlbuilder
 # for uuidgen - used in db password generation
 # on f8 this actually comes with e2fsprogs, go figure
 Requires: util-linux-ng
@@ -79,8 +79,13 @@ Summary: the SFA layer around NITOS
 Group: Applications/System
 Requires: sfa
 
-%package senslab
-Summary: the SFA layer around SensLab
+%package iotlab
+Summary: the SFA layer around IotLab
+Group: Applications/System
+Requires: sfa
+
+%package cortexlab
+Summary: the SFA layer around CortexLab
 Group: Applications/System
 Requires: sfa
 
@@ -94,11 +99,6 @@ Summary: sfatables policy tool for SFA
 Group: Applications/System
 Requires: sfa
 
-%package xmlbuilder
-Summary: third-party xmlbuilder tool
-Group: Applications/System
-Provides: python-xmlbuilder
-
 %package tests
 Summary: unit tests suite for SFA
 Group: Applications/System
@@ -129,8 +129,11 @@ The SFA driver for FEDERICA.
 %description nitos
 The SFA driver for NITOS.
 
-%description senslab
-The SFA driver for SensLab.
+%description iotlab
+The SFA driver for IotLab.
+
+%description cortexlab
+The SFA driver for CortexLab.
 
 %description dummy
 The SFA driver for a Dummy Testbed.
@@ -140,10 +143,6 @@ sfatables is a tool for defining access and admission control policies
 in an SFA network, in much the same way as iptables is for ip
 networks. This is the command line interface to manage sfatables
 
-%description xmlbuilder
-This package contains the xmlbuilder python library, packaged for
-convenience as it is not supported by fedora
-
 %description tests
 Provides some binary unit tests in /usr/share/sfa/tests
 
@@ -221,9 +220,12 @@ rm -rf $RPM_BUILD_ROOT
 %files nitos
 %{python_sitelib}/sfa/nitos
 
-%files senslab
+%files iotlab
 %{python_sitelib}/sfa/iotlab
 
+%files cortexlab
+%{python_sitelib}/sfa/cortexlab
+
 %files dummy
 %{python_sitelib}/sfa/dummy
 
@@ -232,9 +234,6 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/sfatables
 %{python_sitelib}/sfatables
 
-%files xmlbuilder
-%{python_sitelib}/xmlbuilder
-
 %files tests
 %{_datadir}/sfa/tests
 
@@ -265,6 +264,25 @@ fi
 #[ "$1" -ge "1" ] && service sfa-cm restart || :
 
 %changelog
+* Tue Dec 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-3.1-1
+- -- core
+- clean up rspecs.
+- GENIv3 rspecs enhirits everything from pgv2.
+- fix dbsession mgt by attributing each incoming API call has its own dbsession.
+- update all drivers and v2_to_v3_adapter according to dbsession fix.
+- fix DB migration.
+- -- client
+- fix sfi.py myslice.
+- sfi.py new option "my_pkcs12".
+- sfi.py defaulr rspec version is GENIv3
+- sfi.py trusted target either Registry interface or Slice interface.
+- -- PlanetLab
+- rebase all pl driver operations around the objects HRNs.
+- ignore objects (Site/Slice/Person/Node) coming from MyPLC peering.
+- importer ignores sites with tag sfa_created='True'.
+- -- IoTLab
+- In progress writing of native AM API v3 compliant driver.
+
 * Thu Oct 10 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-3.0-2
 - -- core
 - Extend all versions of rspecs in order to support "links" and "channels" management methods