do not allow a user to extract the credential, if his account on PlanetLab is disabled
[sfa.git] / sfa.spec
index f0efa0a..f84ab9e 100644 (file)
--- a/sfa.spec
+++ b/sfa.spec
@@ -6,7 +6,7 @@
 
 %define name sfa
 %define version 0.9
-%define taglevel 6
+%define taglevel 10
 
 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
 %global python_sitearch        %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
@@ -29,29 +29,39 @@ Group: Applications/System
 
 BuildRequires: make
 Requires: python
-Requires: pyOpenSSL >= 0.7
 Requires: m2crypto
 Requires: libxslt-python
 Requires: python-ZSI
-Requires: python-psycopg2
-Requires: myplc-config
 
-# python 2.5 has uuid module added, for python 2.4 we still need it
-%define has_uuid %(`python -c "import uuid" 2> /dev/null; echo $?`)
-%if has_uuid
-%else
+# python 2.5 has uuid module added, for python 2.4 we still need it.
+# we can't really check for if we can load uuid as a python module,
+# it'll be installed by "devel.pkgs". we have the epel repository so
+# python-uuid will be provided. but we can test for the python
+# version.
+%define has_py24 %(`python -c "import sys;sys.exit(sys.version_info[0:2] == (2,4))" 2> /dev/null; echo $?`)
+%if has_py24
 Requires: python-uuid
 %endif
 
+%package cm
+Summary: the SFA wrapper around MyPLC's NodeManager
+Group: Applications/System
+Requires: sfa
+Requires: pyOpenSSL >= 0.6
+
 %package plc
 Summary: the SFA wrapper arounf MyPLC
 Group: Applications/System
 Requires: sfa
+Requires: python-psycopg2
+Requires: myplc-config
+Requires: pyOpenSSL >= 0.7
 
 %package client
 Summary: the SFA experimenter-side CLI
 Group: Applications/System
 Requires: sfa
+Requires: pyOpenSSL >= 0.7
 
 %package sfatables
 Summary: sfatables policy tool for SFA
@@ -61,8 +71,12 @@ Requires: sfa
 %description
 This package provides the python libraries that the SFA implementation requires
 
+%description cm
+This package implements the SFA interface which serves as a layer
+between the existing PlanetLab NodeManager interfaces and the SFA API.
 %description plc
-Geniwrapper implements the SFA interface which serves as a layer
+This package implements the SFA interface which serves as a layer
 between the existing PlanetLab interfaces and the SFA API.
 
 %description client
@@ -94,6 +108,9 @@ rm -rf $RPM_BUILD_ROOT
 /usr/bin/keyconvert
 /var/www/html/wsdl/*.wsdl
 
+%files cm
+/etc/init.d/sfa_cm
+# cron jobs here 
 
 %files plc
 %defattr(-,root,root)
@@ -106,6 +123,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/sfa-clean-peer-records.py*
 %{_bindir}/sfa-nuke-plc.py*
 %{_bindir}/sfa-server.py*
+%{_bindir}/gen-sfa-cm-config.py*
 
 %files client
 %config (noreplace) /etc/sfa/sfi_config
@@ -113,7 +131,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_bindir}/getNodes.py*
 %{_bindir}/getRecord.py*
 %{_bindir}/setRecord.py*
-%{_bindir}/genidump.py*
+%{_bindir}/sfadump.py*
 
 %files sfatables
 %{_bindir}/sfatables
@@ -121,10 +139,40 @@ rm -rf $RPM_BUILD_ROOT
 %pre plc
 [ -f %{_sysconfdir}/init.d/sfa ] && service sfa stop ||:
 
+%pre cm
+[ -f %{_sysconfdir}/init.d/sfacm ] && service sfacm stop ||:
+
 %post plc
 chkconfig --add sfa
 
+%post cm
+chkconfig --add sfacm
 %changelog
+* Thu Jan 21 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-10
+- This tag is quite same as the previous one (sfa-0.9-9) except that the vini and max aggregate managers are also updated for urn support.  Other features are:
+- - sfa-config-tty now has the same features like plc-config-tty
+- - Contains code to support both urn and hrn
+- - Cleaned up request_hash related stuff
+- - SM, AM and Registry code is organized under respective managers
+- - Site and Slice synchronization across federated aggregates
+- - Script to generate sfa_component_config
+
+* Fri Jan 15 2010 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-9
+- sfa-config-tty now has the same features like plc-config-tty
+- Contains code to support both urn and hrn
+- Cleaned up request_hash related stuff
+- SM, AM and Registry code is organized under respective managers
+- Slice synchronization across federated aggregates
+- some bugs are fixed
+
+* Wed Jan 06 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-8
+- checkpoint with fewer mentions of geni
+
+* Tue Jan 05 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sfa-0.9-7
+- checkpointing
+- this is believed to pass the tests; among other things:
+- reworked configuration based on the myplc config with xml skeleton (no more sfa_config)
+
 * Mon Nov 16 2009 anil vengalil <avengali@sophia.inria.fr> - sfa-0.9-6
 - This tag includes:
 - - Sfatables