92dad74bd739cb8d729c8ecffcdb373cffabd79a
[sface.git] / sface.spec
1 # these are defined by the build
2 #%define distro Fedora
3 #%define distrorelease 12
4 #%define distroname f12
5 #%define pldistro onelab
6 #%define plrelease 5.0
7
8 %define name sface
9 %define version 0.9
10 %define taglevel 4
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.gz
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %{SCMURL}
26 Summary: GUI for sfi.py from SFA
27 Group: Applications/System
28
29 BuildRequires: make
30 Requires: python >= 2.5
31 Requires: PyQt4
32 Requires: sfa-client
33
34 %description
35 this package provides GUI for sfi.py, i.e.
36 the Slice-Based Facility Architecture (SFA) command line interface.
37 The GUI let you manage you slices by adding/deleting nodes and viewing
38 the slice's RSpec with an XML pretty printer.
39
40 %prep
41 %setup -q
42
43 %build
44 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 make DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" install
49 rm -f $RPM_BUILD_ROOT/%{_datadir}/*.egg-info
50 # symlinking sface to sface-run, relative
51 cd $RPM_BUILD_ROOT/%{_bindir}
52 ln -sf ./sface-run ./sface
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %{_bindir}/sface
59 %{_bindir}/sface-run
60 %{_datadir}/sface/*
61
62 %changelog
63 * Tue Jan 24 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-4
64 - fixed crash in slicestatus screen when no slice name is defined
65 - fixed crash in mainwindow then clicking on empty list
66 - fixed failure to delete last sliver in a slice
67 - fixed inability to use config screen without pre-existing .sficonfig
68
69 * Mon Jan 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-3
70 - handle blank rspecs
71
72 * Thu Jan 05 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-2
73 - fix the way sfi.py gets located
74
75 * Tue Jan 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-1
76 - minor tag for sfa-2.0-7
77
78 * Wed Dec 07 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-21
79 - fix errors when adding/removing slice attributes
80 - fix references to sfa.util.record
81
82 * Thu Dec 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-20
83 - Added batch slice renew feature
84 - Updated XMLRPC tracker to keep history of XMLRPC calls, support scrolling, and parse fault messages
85 - Retrieve available resources and resources bound to slices from independent ListResources calls
86 - Added ability to delete slices
87 - Added SliverStatus screen
88 - Support for creating slivers directly on ProtoGENI, bypassing slice manager
89 - Support for new RSPEC methods in latest SFA code
90
91 * Fri Sep 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-19
92 - reporting of server faults to the user
93 - create slice button and dialog
94 - fix bug that caused a crash when adding tags
95 - spacebar can be used instead of double-click when adding nodes or users
96 - support for multiple config directories
97
98 * Sun Sep 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-18
99 - usable with a different directory than ~/.sfi
100 - either on the command line, or in the config. screen
101
102 * Thu Sep 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-17
103 - new user management screen to allow users to be added and deleted from slices
104 - known issue with the users screen regarding adding people who are listed as PIs to a sliver.
105 - reordered columns (new order is hostname, boot state, membership state)
106 - rewrote filtering mechanism to allow separate string search and boot state filter
107 - selection highlights the whole line instead of excluding the hostname part
108
109 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-16
110 - bugfix in managing subprocess outputs
111
112 * Mon Jun 20 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-15
113 - Fix bug preventing adding nodes to a slice.
114
115 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-14
116 - slight changes in view creation
117
118 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-13
119 - dynamically load screens from the screens directory
120
121 * Mon Jun 06 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-12
122 - Added button to renew slice.
123
124 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-11
125 - fixed the logo area on the mac
126
127 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-10
128 - show versions of sface and sfa in the configure window
129 - should work both on rpm-based and macos (build-dmg.sh) packages
130
131 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-9
132 - packaging has support for leopard as well
133 - can use vn as a skeleton for vn+1
134 - config view show SFA version
135
136 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-8
137 - dmg packaging has support for leopard, and other utility options
138 - cleaned up graphics
139
140 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-7
141 - fixed dmg packaging
142
143 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-6
144 - help script to create dmg packaging
145
146 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-5
147 - Can add and remove slice tags
148 - Numerous tweaks
149 - Simplify item model
150
151 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-4
152 - minor changes
153
154 * Thu Oct 14 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sface-0.1-3
155 - sface-0.1-3, with improvement on process output.
156
157 * Mon Sep 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-2
158 - initial version with rpm packaging
159
160 * Fri Sep 24 2010 Giovanni Gherdovich <ggherdov@sophia.inria.fr>
161 - initial package