95917386254e7065346c1dd6141de2259324fb20
[sface.git] / sface.spec
1 # these are defined by the build
2 #%define distro Fedora
3 #%define distrorelease 12
4 #%define distroname f12
5 #%define pldistro onelab
6 #%define plrelease 5.0
7
8 %define name sface
9 %define version 0.9
10 %define taglevel 2
11
12 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
13
14 Name: %{name}
15 Version: %{version}
16 Release: %{release}
17 Source0: %{name}-%{version}.tar.gz
18 License: GPL
19 Group: Applications/System
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22 Vendor: PlanetLab
23 Packager: PlanetLab Central <support@planet-lab.org>
24 Distribution: PlanetLab %{plrelease}
25 URL: %{SCMURL}
26 Summary: GUI for sfi.py from SFA
27 Group: Applications/System
28
29 BuildRequires: make
30 Requires: python >= 2.5
31 Requires: PyQt4
32 Requires: sfa-client
33
34 %description
35 this package provides GUI for sfi.py, i.e.
36 the Slice-Based Facility Architecture (SFA) command line interface.
37 The GUI let you manage you slices by adding/deleting nodes and viewing
38 the slice's RSpec with an XML pretty printer.
39
40 %prep
41 %setup -q
42
43 %build
44 make VERSIONTAG="%{version}-%{taglevel}" SCMURL="%{SCMURL}"
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 make DESTDIR="$RPM_BUILD_ROOT" datadir="%{_datadir}" bindir="%{_bindir}" install
49 rm -f $RPM_BUILD_ROOT/%{_datadir}/*.egg-info
50 # symlinking sface to sface-run, relative
51 cd $RPM_BUILD_ROOT/%{_bindir}
52 ln -sf ./sface-run ./sface
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %{_bindir}/sface
59 %{_bindir}/sface-run
60 %{_datadir}/sface/*
61
62 %changelog
63 * Thu Jan 05 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-2
64 - fix the way sfi.py gets located
65
66 * Tue Jan 03 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.9-1
67 - minor tag for sfa-2.0-7
68
69 * Wed Dec 07 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-21
70 - fix errors when adding/removing slice attributes
71 - fix references to sfa.util.record
72
73 * Thu Dec 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-20
74 - Added batch slice renew feature
75 - Updated XMLRPC tracker to keep history of XMLRPC calls, support scrolling, and parse fault messages
76 - Retrieve available resources and resources bound to slices from independent ListResources calls
77 - Added ability to delete slices
78 - Added SliverStatus screen
79 - Support for creating slivers directly on ProtoGENI, bypassing slice manager
80 - Support for new RSPEC methods in latest SFA code
81
82 * Fri Sep 16 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-19
83 - reporting of server faults to the user
84 - create slice button and dialog
85 - fix bug that caused a crash when adding tags
86 - spacebar can be used instead of double-click when adding nodes or users
87 - support for multiple config directories
88
89 * Sun Sep 04 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-18
90 - usable with a different directory than ~/.sfi
91 - either on the command line, or in the config. screen
92
93 * Thu Sep 01 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-17
94 - new user management screen to allow users to be added and deleted from slices
95 - known issue with the users screen regarding adding people who are listed as PIs to a sliver.
96 - reordered columns (new order is hostname, boot state, membership state)
97 - rewrote filtering mechanism to allow separate string search and boot state filter
98 - selection highlights the whole line instead of excluding the hostname part
99
100 * Thu Jul 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-16
101 - bugfix in managing subprocess outputs
102
103 * Mon Jun 20 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-15
104 - Fix bug preventing adding nodes to a slice.
105
106 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-14
107 - slight changes in view creation
108
109 * Wed Jun 08 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-13
110 - dynamically load screens from the screens directory
111
112 * Mon Jun 06 2011 Scott Baker <smbaker@gmail.com> - sface-0.1-12
113 - Added button to renew slice.
114
115 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-11
116 - fixed the logo area on the mac
117
118 * Mon May 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-10
119 - show versions of sface and sfa in the configure window
120 - should work both on rpm-based and macos (build-dmg.sh) packages
121
122 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-9
123 - packaging has support for leopard as well
124 - can use vn as a skeleton for vn+1
125 - config view show SFA version
126
127 * Tue Mar 15 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-8
128 - dmg packaging has support for leopard, and other utility options
129 - cleaned up graphics
130
131 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-7
132 - fixed dmg packaging
133
134 * Mon Mar 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-6
135 - help script to create dmg packaging
136
137 * Tue Mar 08 2011 Andy Bavier <acb@cs.princeton.edu> - sface-0.1-5
138 - Can add and remove slice tags
139 - Numerous tweaks
140 - Simplify item model
141
142 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-4
143 - minor changes
144
145 * Thu Oct 14 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - sface-0.1-3
146 - sface-0.1-3, with improvement on process output.
147
148 * Mon Sep 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - sface-0.1-2
149 - initial version with rpm packaging
150
151 * Fri Sep 24 2010 Giovanni Gherdovich <ggherdov@sophia.inria.fr>
152 - initial package