Setting tag sliver-openvswitch-2.2.90-1
[sliver-openvswitch.git] / debian / rules
index 6806980..799bf2e 100755 (executable)
 # Modified to make a template file for a multi-binary package with separated
 # build-arch and build-indep targets  by Bill Allombert 2001
 
-# Official build number.  Leave set to 0 if not an official build.
-BUILD_NUMBER = 0
+PACKAGE=openvswitch
+pdkms=openvswitch-datapath-dkms
+DEB_UPSTREAM_VERSION=$(shell dpkg-parsechangelog | sed -rne 's,^Version: ([0-9]:)*([^-]+).*,\2,p')
+srcfiles := $(filter-out debian, $(wildcard * .[^.]*))
 
 ifneq (,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
 PARALLEL = -j$(patsubst parallel=%,%,$(filter parallel=%,$(DEB_BUILD_OPTIONS)))
@@ -20,12 +22,19 @@ PARALLEL =
 endif
 MAKEFLAGS += $(PARALLEL)
 
+CFLAGS += -g
 ifneq (,$(filter noopt,$(DEB_BUILD_OPTIONS)))
 CFLAGS += -O0
 else
 CFLAGS += -O2
 endif
 
+# Old versions of dpkg-buildflags do not understand --export=configure.
+# When dpkg-buildflags does not understand an option, it prints its full
+# --help output on stdout, so we have to avoid that here.
+buildflags := $(shell if dpkg-buildflags --export=configure >/dev/null 2>&1; \
+                     then dpkg-buildflags --export=configure; fi)
+
 configure: configure-stamp
 configure-stamp:
        dh_testdir
@@ -36,8 +45,8 @@ configure-stamp:
        cd _debian && ( \
                test -e Makefile || \
                ../configure --prefix=/usr --localstatedir=/var --enable-ssl \
-                       --with-build-number=$(BUILD_NUMBER) \
-                       CFLAGS="$(CFLAGS)" $(DATAPATH_CONFIGURE_OPTS))
+                       --sysconfdir=/etc CFLAGS="$(CFLAGS)" \
+                       $(buildflags) $(DATAPATH_CONFIGURE_OPTS))
        touch configure-stamp
 
 #Architecture 
@@ -67,28 +76,48 @@ clean:
        rm -rf _debian
        [ ! -f Makefile ] || $(MAKE) distclean
        dh_clean 
+       rm -f python/ovs/*.pyc python/ovs/db/*.pyc
 
 install: install-indep install-arch
 install-indep: build-indep
        dh_testdir
        dh_testroot
-       dh_clean -k -i 
+       dh_prep -i
        dh_installdirs -i
+       $(MAKE) -C _debian DESTDIR=$(CURDIR)/debian/tmp install
        dh_install -i
-       sed 's/^BUILD_NUMBER = .*/BUILD_NUMBER = $(BUILD_NUMBER)/' \
-               < debian/rules.modules \
-               > debian/openvswitch-datapath-source/usr/src/modules/openvswitch-datapath/debian/rules
+       cp debian/rules.modules debian/openvswitch-datapath-source/usr/src/modules/openvswitch-datapath/debian/rules
        chmod 755 debian/openvswitch-datapath-source/usr/src/modules/openvswitch-datapath/debian/rules
        cd debian/openvswitch-datapath-source/usr/src && tar -c modules | bzip2 -9 > openvswitch-datapath.tar.bz2 && rm -rf modules
 
+       #dkms stuff
+       # setup the dirs
+       dh_installdirs -p$(pdkms) usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)
+
+       # copy the source
+       cd debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION) && tar xvzf $(CURDIR)/_debian/openvswitch.tar.gz && mv openvswitch/* . && rmdir openvswitch
+
+       # Prepare dkms.conf from the dkms.conf.in template
+       sed "s/__VERSION__/$(DEB_UPSTREAM_VERSION)/g" debian/dkms.conf.in > debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)/dkms.conf
+
+       # We don't need the debian folder in there, just upstream sources...
+       rm -rf debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)/debian
+       # We don't need the rhel stuff in there either
+       rm -rf debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)/rhel
+       # And we should also clean useless license files, which are already
+       # descriped in our debian/copyright anyway.
+       rm -f debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)/COPYING \
+               debian/$(pdkms)/usr/src/$(PACKAGE)-$(DEB_UPSTREAM_VERSION)/xenserver/LICENSE
+
 install-arch: build-arch
        dh_testdir
        dh_testroot
-       dh_clean -k -s 
+       dh_prep -s
        dh_installdirs -s
-       $(MAKE) -C _debian DESTDIR=$(CURDIR)/debian/openvswitch install
+       $(MAKE) -C _debian DESTDIR=$(CURDIR)/debian/tmp install
        cp debian/openvswitch-switch.template debian/openvswitch-switch/usr/share/openvswitch/switch/default.template
        dh_install -s
+       dh_link -s
 
 # Must not depend on anything. This is to be called by
 # binary-arch/binary-indep
@@ -103,12 +132,12 @@ binary-common:
        dh_installlogrotate
        dh_installinit -R
        dh_installcron
-       dh_installman
+       dh_installman --language=C
        dh_link
        dh_strip --dbg-package=openvswitch-dbg
        dh_compress 
-       dh_fixperms -X var/log/core
-       dh_pysupport
+       dh_fixperms
+       dh_python2
        dh_perl
        dh_makeshlibs
        dh_installdeb