Load transforward module automatically
[transforward.git] / transforward.spec
index 4a864e3..1c83431 100644 (file)
@@ -3,12 +3,11 @@
 %define taglevel 1
 
 ### legacy from locally-built kernels, used to define these
-# kernel_release, kernel_version and kernel_arch are expected to be set by the build to e.g.
-# kernel_release : 24.onelab  (24 is then the planetlab taglevel)
-# kernel_version : 2.6.27.57 | 2.6.32  (57 in the 27 case is the patch level)
+# kernel_release : 1.fc16  (24 is then the planetlab taglevel)
+# kernel_version : 3.3.7
 # kernel_arch :    i686 | x86_64
 
-# with the stock kernel
+# compute this with "rpm -q --qf .. kernel-devel" when with the stock kernel
 # this line below
 #%define module_release %( rpm -q --qf "%{version}" kernel-headers )
 # causes recursive macro definition no matter how much you quote
@@ -30,6 +29,7 @@ Vendor: PlanetLab
 Packager: PlanetLab Central <support@planet-lab.org>
 Distribution: PlanetLab %{plrelease}
 URL: %{SCMURL}
+Requires: kernel = %{kernel_version}-%{kernel_release}
 
 Summary: Kernel module that transparently forwards ports between containers
 Name: %{name}
@@ -51,12 +51,15 @@ make -C %{kernelpath} V=1 M=$(pwd) modules
 
 %install
 install -D -m 755 transforward.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/transforward/transforward.ko
+mkdir -p $RPM_BUILD_ROOT/etc/modules-load.d
+install -m 644 transforward.conf $RPM_BUILD_ROOT/etc/modules-load.d/transforward.conf
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 /lib/modules/%{kernel_id}
+/etc/modules-load.d/procprotect.conf
 
 %post