Setting tag util-vserver-pl-0.4-17
[util-vserver-pl.git] / util-vserver-pl.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name    util-vserver-pl
7 %define version 0.4
8 %define taglevel 17
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %define python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Summary: PlanetLab extensions to util-vserver
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: GPL
19 Group: System Environment/Base
20 Source0: %{name}-%{version}.tar.bz2
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 Requires: util-vserver util-vserver-core util-vserver-build util-vserver-sysv
29 Provides: util-vserver-python = %{version}-%{release}
30 Obsoletes: util-vserver-py32 resman
31 BuildRequires: libnl libnl-devel
32 BuildRequires: python python-devel
33 BuildRequires: util-vserver-core util-vserver-devel
34 BuildRequires: autoconf automake libtool
35
36 %description
37 This package contains all PlanetLab extensions to util-vserver.
38
39 %prep
40 %setup -q
41 autoreconf -fi
42
43
44 %build
45 %configure
46 make
47
48
49 %install
50 rm -fr %{buildroot}
51 make DESTDIR=%{buildroot} install
52
53 mkdir %{buildroot}/bin
54 ln -s ..%{_sbindir}/vsh %{buildroot}/bin/vsh
55
56 rm -f %{buildroot}%{python_sitearch}/vserverimpl.a
57 rm -f %{buildroot}%{python_sitearch}/vserverimpl.la
58
59 # Generate file list for python package
60 find "%{buildroot}" -name '*.py' | { while read FILE; do
61         f="${FILE#%{buildroot}}"
62         echo "${f}"
63         # need to touch these files, as they are not produced on FC4 or below
64         touch ${FILE}c
65         touch ${FILE}o
66         echo %%ghost "${f}c"
67         echo %%ghost "${f}o"
68 done } > %name-python.list
69
70
71 %post
72 # add /bin/vsh to list of secure shells
73 if [ ! -f /etc/shells ] || ! grep -q '^/bin/vsh$' /etc/shells ; then
74         echo /bin/vsh >> /etc/shells
75 fi
76
77 /usr/sbin/bwlimit init
78
79 # Migrate old style vservers to new style
80 pushd /etc/vservers
81 for i in `ls /etc/vservers` 
82 do 
83         echo "persistent,lback_allow" > $i/nflags 
84         /usr/sbin/nattribute --set --nid `cat $i/context` --flag lback_allow
85
86         sed -i -e '/tmpfs\tsize=16m/d' $i/fstab
87         rm $i/nonamespace
88         
89         mkdir -p $i/sysctl/0 
90         echo net.ipv4.ip_forward > $i/sysctl/0/setting
91         echo 1 > $i/sysctl/0/value
92         
93         echo -e "persistent\n~info_init" > $i/cflags
94         /usr/sbin/vattribute --set --xid `cat $i/context` --flag ~sched_hard
95 done
96 popd
97
98 %postun
99 # 0 = erase, 1 = upgrade
100 if [ "$1" = 0 ] ; then
101         perl -i -n -e 'next if /^\/bin\/vsh$/; print' /etc/shells
102 fi
103
104
105 %clean
106 rm -fr %{buildroot}
107
108
109 %files -f %name-python.list
110 %defattr(-,root,root,-)
111 %{_sbindir}/bwlimit
112 %{_sbindir}/disklimit
113 %{_sbindir}/vuseradd
114 %{_sbindir}/vuserdel
115 %{python_sitearch}/vserverimpl.so
116 %{_sbindir}/vip6-autod
117 %{_sysconfdir}/init.d/vip6-autod
118
119 %attr(4755,root,root) %{_sbindir}/vsh
120 /bin/vsh
121 %{_mandir}/man8/vsh.8*
122
123 %changelog
124 * Wed Jul 28 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-17
125 - Some dead code removed from repository
126
127 * Mon Jul 19 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-16
128 - * use system-wide umask
129 - * enable set_ipaddresses_config function
130 - * set more default values
131
132 * Mon Jul 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.4-15
133 - new constant VC_LIM_INFINITY
134
135 * Tue Jul 06 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-14
136 - fix setting cpu_share for slices
137
138 * Thu Jun 24 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-13
139 - start to use mount namespaces
140
141 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.4-12
142 - initscripts are ignored - handled by nodemanager and triggered by rc
143
144 * Thu Jun 17 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-11
145 - sliver name as the last argument to initscript
146
147 * Tue Jun 01 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-10
148 - remove tmpfs mounted /tmp
149
150 * Fri May 14 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-9
151 - change flags without restarting the vservers
152
153 * Thu May 13 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-8
154 - Migrate old style vservers to new style
155
156 * Thu May 13 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-7
157 - chroot_call fix
158
159 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-6
160 - fix initscript issues
161
162 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-5
163
164 * Mon May 10 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-4
165 - merged trellis branch to trunk
166
167 * Wed Feb 24 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-27
168 - Need to print the exception string as part of the self.log, or else we
169 - get a wrong number of argument error.
170
171 * Wed Feb 24 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-26
172 - This is outputted for some reason.
173
174 * Tue Feb 23 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-25
175 - Don't set bwlimits if they're disabled.
176 - Don't cleanup /var of running slivers.
177
178 * Tue Feb 23 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-24
179 - - openfd -> nofile
180
181 * Tue Feb 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-23
182 - call bwlimit init in postinstall.
183
184 * Fri Jan 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.3-22
185 - move the HTB tree one level down for DRL
186
187 * Mon Jan 25 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-21
188 - logging policy only; use /var/log/nm instead of boot.log, and give more details with (un)setdlimit
189
190 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-20
191 - Log the error as well.
192
193 * Wed Oct 28 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-19
194 - Set ulimits for NM too.
195
196 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-18
197 - bwlimit.set() now accepts the device and don't assume that it's eth0
198
199 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-17
200 - Fix runlevel clean up after reboot.
201 - Fix runlevel setup to reflect proper runlevel.
202
203 * Thu Jan 29 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-16
204 - supports disabling htbs.
205
206 * Wed Oct 29 2008 Marc E. Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-15
207 - added in support for rlimit MEM_LOCK
208 - fixed bug in reading -1 value from VSERVERCONF/<guest>/rlimits/memlock.hard file
209 - reduced compilation warnings
210
211 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-14
212 - configure/make check the version of libnl and can cope with either 1.1 or 1.0-pre6
213 - as centos does not have any of these, do build vip6-autod on fedora only
214
215 * Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-13
216 - Remove current bw limit checks before issuing tc.
217
218 * Fri Aug 29 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-12
219 - libnl 1.1 fixups.
220
221 * Thu Aug 28 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-11
222 - reads /etc/vservers/<name>/personality and behaves accordingly
223 - nicer formatting for byte rates
224
225 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-10
226 - FUSE support.
227
228 * Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-9
229 - Check running values before issuing set or on.  If same, disregard to save on forks.
230
231 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-8
232 - exempt_init shouldn't modify iptables rules.  Instead, only manipulate ipset.  Assume iptables rules are setup properly (now downloaded from nodeconfig/PlanetLabConf for I2 and defaulted to iptables/planetlab-config for all other nodes).
233
234 * Tue Jul 22 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-7
235 - Init exempt flows into "mangle" table.
236
237 * Fri Jun 27 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-6
238 - Optimized the case where it's already running.
239
240 * Thu Jun 26 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-5
241 - Ignore ESRCH for setname.
242 - Always create the home directory, regardless of configuration settings.
243
244 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-4
245
246
247 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-3
248 - Added support for vc_{set|get}_vhi_name() via util-vserver-pl.
249 - Adding a tag to include in the 4.2rc2
250
251
252 * Wed Apr 16 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-2
253
254 - * Can write vcVHI_CONTEXT
255 - * CAP_NET_BIND_SERVICE is special, in all cases. 
256 - * Check if already mounted before mounting fs in vserver
257 - * Optimized 0.0.0.0 case
258 - * Removed vcached.  DEPRECATED
259
260
261 * Fri Nov 30 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.1-1
262 - Initial release
263
264 %define module_current_branch 0.3