Setting tag util-vserver-pl-0.4-12
[util-vserver-pl.git] / util-vserver-pl.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 %define name    util-vserver-pl
7 %define version 0.4
8 %define taglevel 12
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 %define python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
13
14 Summary: PlanetLab extensions to util-vserver
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 License: GPL
19 Group: System Environment/Base
20 Source0: %{name}-%{version}.tar.bz2
21 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
22
23 Vendor: PlanetLab
24 Packager: PlanetLab Central <support@planet-lab.org>
25 Distribution: PlanetLab %{plrelease}
26 URL: %(echo %{url} | cut -d ' ' -f 2)
27
28 Requires: util-vserver util-vserver-core util-vserver-build util-vserver-sysv
29 Provides: util-vserver-python = %{version}-%{release}
30 Obsoletes: util-vserver-py32 resman
31 BuildRequires: libnl libnl-devel
32 BuildRequires: python python-devel
33 BuildRequires: util-vserver-core util-vserver-devel
34 BuildRequires: autoconf automake libtool
35
36 %description
37 This package contains all PlanetLab extensions to util-vserver.
38
39 %prep
40 %setup -q
41 autoreconf -fi
42
43
44 %build
45 %configure
46 make
47
48
49 %install
50 rm -fr %{buildroot}
51 make DESTDIR=%{buildroot} install
52
53 mkdir %{buildroot}/bin
54 ln -s ..%{_sbindir}/vsh %{buildroot}/bin/vsh
55
56 rm -f %{buildroot}%{python_sitearch}/vserverimpl.a
57 rm -f %{buildroot}%{python_sitearch}/vserverimpl.la
58
59 # Generate file list for python package
60 find "%{buildroot}" -name '*.py' | { while read FILE; do
61         f="${FILE#%{buildroot}}"
62         echo "${f}"
63         # need to touch these files, as they are not produced on FC4 or below
64         touch ${FILE}c
65         touch ${FILE}o
66         echo %%ghost "${f}c"
67         echo %%ghost "${f}o"
68 done } > %name-python.list
69
70
71 %post
72 # add /bin/vsh to list of secure shells
73 if [ ! -f /etc/shells ] || ! grep -q '^/bin/vsh$' /etc/shells ; then
74         echo /bin/vsh >> /etc/shells
75 fi
76
77 /usr/sbin/bwlimit init
78
79 # Migrate old style vservers to new style
80 pushd /etc/vservers
81 for i in `ls /etc/vservers` 
82 do 
83         echo "persistent,lback_allow" > $i/nflags 
84         /usr/sbin/nattribute --set --nid `cat $i/context` --flag lback_allow
85
86         sed -i -e '/tmpfs\tsize=16m/d' $i/fstab
87         
88         mkdir -p $i/sysctl/0 
89         echo net.ipv4.ip_forward > $i/sysctl/0/setting
90         echo 1 > $i/sysctl/0/value
91         
92         echo -e "persistent\n~info_init" > $i/cflags
93         /usr/sbin/vattribute --set --xid `cat $i/context` --flag ~sched_hard
94 done
95 popd
96
97 %postun
98 # 0 = erase, 1 = upgrade
99 if [ "$1" = 0 ] ; then
100         perl -i -n -e 'next if /^\/bin\/vsh$/; print' /etc/shells
101 fi
102
103
104 %clean
105 rm -fr %{buildroot}
106
107
108 %files -f %name-python.list
109 %defattr(-,root,root,-)
110 %{_sbindir}/bwlimit
111 %{_sbindir}/disklimit
112 %{_sbindir}/vuseradd
113 %{_sbindir}/vuserdel
114 %{python_sitearch}/vserverimpl.so
115 %{_sbindir}/vip6-autod
116 %{_sysconfdir}/init.d/vip6-autod
117
118 %attr(4755,root,root) %{_sbindir}/vsh
119 /bin/vsh
120 %{_mandir}/man8/vsh.8*
121
122 %changelog
123 * Tue Jun 22 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.4-12
124 - initscripts are ignored - handled by nodemanager and triggered by rc
125
126 * Thu Jun 17 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-11
127 - sliver name as the last argument to initscript
128
129 * Tue Jun 01 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-10
130 - remove tmpfs mounted /tmp
131
132 * Fri May 14 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-9
133 - change flags without restarting the vservers
134
135 * Thu May 13 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-8
136 - Migrate old style vservers to new style
137
138 * Thu May 13 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-7
139 - chroot_call fix
140
141 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-6
142 - fix initscript issues
143
144 * Mon May 10 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.4-5
145
146 * Mon May 10 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.4-4
147 - merged trellis branch to trunk
148
149 * Wed Feb 24 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-27
150 - Need to print the exception string as part of the self.log, or else we
151 - get a wrong number of argument error.
152
153 * Wed Feb 24 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-26
154 - This is outputted for some reason.
155
156 * Tue Feb 23 2010 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-25
157 - Don't set bwlimits if they're disabled.
158 - Don't cleanup /var of running slivers.
159
160 * Tue Feb 23 2010 Marc Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-24
161 - - openfd -> nofile
162
163 * Tue Feb 16 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-23
164 - call bwlimit init in postinstall.
165
166 * Fri Jan 29 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - util-vserver-pl-0.3-22
167 - move the HTB tree one level down for DRL
168
169 * Mon Jan 25 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-21
170 - logging policy only; use /var/log/nm instead of boot.log, and give more details with (un)setdlimit
171
172 * Thu Nov 19 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-20
173 - Log the error as well.
174
175 * Wed Oct 28 2009 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-19
176 - Set ulimits for NM too.
177
178 * Tue Oct 20 2009 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - util-vserver-pl-0.3-18
179 - bwlimit.set() now accepts the device and don't assume that it's eth0
180
181 * Tue Aug 04 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-17
182 - Fix runlevel clean up after reboot.
183 - Fix runlevel setup to reflect proper runlevel.
184
185 * Thu Jan 29 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-16
186 - supports disabling htbs.
187
188 * Wed Oct 29 2008 Marc E. Fiuczynski <mef@cs.princeton.edu> - util-vserver-pl-0.3-15
189 - added in support for rlimit MEM_LOCK
190 - fixed bug in reading -1 value from VSERVERCONF/<guest>/rlimits/memlock.hard file
191 - reduced compilation warnings
192
193 * Tue Sep 23 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-14
194 - configure/make check the version of libnl and can cope with either 1.1 or 1.0-pre6
195 - as centos does not have any of these, do build vip6-autod on fedora only
196
197 * Wed Sep 17 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-13
198 - Remove current bw limit checks before issuing tc.
199
200 * Fri Aug 29 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-12
201 - libnl 1.1 fixups.
202
203 * Thu Aug 28 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - util-vserver-pl-0.3-11
204 - reads /etc/vservers/<name>/personality and behaves accordingly
205 - nicer formatting for byte rates
206
207 * Sun Aug 17 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-10
208 - FUSE support.
209
210 * Fri Aug 01 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-9
211 - Check running values before issuing set or on.  If same, disregard to save on forks.
212
213 * Fri Jul 25 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-8
214 - exempt_init shouldn't modify iptables rules.  Instead, only manipulate ipset.  Assume iptables rules are setup properly (now downloaded from nodeconfig/PlanetLabConf for I2 and defaulted to iptables/planetlab-config for all other nodes).
215
216 * Tue Jul 22 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-7
217 - Init exempt flows into "mangle" table.
218
219 * Fri Jun 27 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-6
220 - Optimized the case where it's already running.
221
222 * Thu Jun 26 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - util-vserver-pl-0.3-5
223 - Ignore ESRCH for setname.
224 - Always create the home directory, regardless of configuration settings.
225
226 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-4
227
228
229 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - util-vserver-pl-0.3-3
230 - Added support for vc_{set|get}_vhi_name() via util-vserver-pl.
231 - Adding a tag to include in the 4.2rc2
232
233
234 * Wed Apr 16 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - util-vserver-pl-0.3-2
235
236 - * Can write vcVHI_CONTEXT
237 - * CAP_NET_BIND_SERVICE is special, in all cases. 
238 - * Check if already mounted before mounting fs in vserver
239 - * Optimized 0.0.0.0 case
240 - * Removed vcached.  DEPRECATED
241
242
243 * Fri Nov 30 2007 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.1-1
244 - Initial release
245
246 %define module_current_branch 0.3