Build the python code using automake.
[util-vserver.git] / util-vserver.spec
1 # $Id: util-vserver.spec.in 2482 2007-01-29 23:37:07Z dhozac $
2
3 ## This package understands the following switches:
4 ## --without dietlibc        ...   disable usage of dietlibc
5 ## --with xalan              ...   require/use the xalan xslt processor
6 ## --without doc             ...   disable doc generation
7 ## --with legacy             ...   enable the legacy APIs
8
9 %global confdir         %_sysconfdir/vservers
10 %global confdefaultdir  %confdir/.defaults
11 %global pkglibdir       %_libdir/%name
12 %global chkconfig       /sbin/chkconfig
13
14 %global _localstatedir  %_var
15
16 %global ver             %( echo 0.30.213 | sed 's/-.*//' )
17 %global subver          %( s=`echo 0.30.213 | grep -- - | sed 's/.*-/./'`; echo ${s:-.1} )
18 %global fullver         0.30.213
19
20
21 %define name util-vserver
22 %define version 0.30.213
23 %{!?release_func:%global release_func() 1%{?pldistro:.%{pldistro}}%{?date:.%{date}}}
24
25 %global python_sitearch %( python -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)" )
26
27 %define _without_dietlibc 1
28 %define _without_xalan 1
29
30 # don't build debuginfo RPM
31 %define debug_package %{nil}
32
33 Vendor: PlanetLab
34 Packager: PlanetLab Central <support@planet-lab.org>
35 Distribution: PlanetLab 3.0
36 URL: http://cvs.planet-lab.org/cvs/util-vserver
37
38 Summary:        Linux virtual server utilities
39 Name:           util-vserver
40 Version:        %ver
41 Release:        %release_func 0%subver
42 License:        GPL
43 Group:          System Environment/Base
44 #URL:           http://savannah.nongnu.org/projects/util-vserver/
45 Source0:        http://ftp.linux-vserver.org/pub/utils/util-vserver/%name-%version.tar.bz2
46 #Source1:       http://ftp.linux-vserver.org/pub/utils/util-vserver/%name-%version.tar.bz2.asc
47 BuildRoot:      %_tmppath/%name-%version-%release-root
48 Requires:       init(%name)
49 Requires:       %name-core = %version-%release
50 Requires:       %name-lib  = %version-%release
51 Requires:       diffutils mktemp sed
52 Provides:       vserver = %version-%release
53 Obsoletes:      vserver < %version
54 BuildRequires:  mount vconfig gawk iproute iptables
55 BuildRequires:  gcc-c++ wget which diffutils
56 BuildRequires:  e2fsprogs-devel beecrypt-devel
57 %{!?_without_doc:BuildRequires: doxygen tetex-latex}
58 Requires(post):         %name-core
59 Requires(pre):          %pkglibdir
60 Requires(postun):       %pkglibdir
61 %{!?_without_dietlibc:BuildRequires:    dietlibc >= 0:0.25}
62 %{?_with_xalan:BuildRequires:   xalan-j}
63
64 %package lib
65 Summary:                Dynamic libraries for util-vserver
66 Group:                  System Environment/Libraries
67
68 %package core
69 Summary:                The core-utilities for util-vserver
70 Group:                  Applications/System
71 Requires:               util-linux
72
73 %package build
74 Summary:                Tools which can be used to build vservers
75 Group:                  Applications/System
76 Requires:               rpm wget tar
77 Requires:               %name = %version-%release
78 Requires(pre):          %confdir
79 Requires(postun):       %confdir
80 Requires(post):         %name-core
81
82 %package sysv
83 Summary:                SysV-initscripts for vserver
84 Group:                  System Environment/Base
85 Provides:               init(%name) = sysv
86 Requires:               make diffutils
87 Requires:               initscripts
88 Requires:               %name = %version-%release
89 Requires(post):         %chkconfig
90 Requires(preun):        %chkconfig
91 Requires(pre):          %_initrddir %pkglibdir
92 requires(postun):       %_initrddir %pkglibdir
93
94 %package legacy
95 Summary:                Legacy utilities for util-vserver
96 Group:                  Applications/System
97 Requires:               %name = %version-%release
98 Requires(post):         %chkconfig
99 Requires(preun):        %chkconfig
100 Requires(pre):          %_initrddir %pkglibdir
101 requires(postun):       %_initrddir %pkglibdir
102
103 %package devel
104 Summary:                Header-files and libraries needed to develop vserver based applications
105 Group:                  Development/Libraries
106 Requires:               pkgconfig
107 Requires:               %name-lib = %version-%release
108
109 %package python
110 Summary:                Python modules for manipulating vservers
111 Group:                  Applications/System
112 Requires:               python util-python
113 Obsoletes:              util-vserver-py23 resman
114
115
116 %description
117 util-vserver provides the components and a framework to setup virtual
118 servers.  A virtual server runs inside a linux server. It is nevertheless
119 highly independent. As such, you can run various services with normal
120 configuration. The various vservers can't interact with each other and
121 can't interact with services in the main server.
122
123 This requires a special kernel supporting the new new_s_context and
124 set_ipv4root system call.
125
126 %description lib
127 util-vserver provides the components and a framework to setup virtual
128 servers.  A virtual server runs inside a linux server. It is nevertheless
129 highly independent. As such, you can run various services with normal
130 configuration. The various vservers can't interact with each other and
131 can't interact with services in the main server.
132
133 This package contains the shared libraries needed by all other
134 'util-vserver' subpackages.
135
136 %description core
137 util-vserver provides the components and a framework to setup virtual
138 servers.  A virtual server runs inside a linux server. It is nevertheless
139 highly independent. As such, you can run various services with normal
140 configuration. The various vservers can't interact with each other and
141 can't interact with services in the main server.
142
143 This package contains utilities which are required to communicate with
144 the Linux-Vserver enabled kernel.
145
146
147 %description build
148 util-vserver provides the components and a framework to setup virtual
149 servers.  A virtual server runs inside a linux server. It is nevertheless
150 highly independent. As such, you can run various services with normal
151 configuration. The various vservers can't interact with each other and
152 can't interact with services in the main server.
153
154 This package contains utilities which assist in building Vservers.
155
156 %description sysv
157 util-vserver provides the components and a framework to setup virtual
158 servers.  A virtual server runs inside a linux server. It is nevertheless
159 highly independent. As such, you can run various services with normal
160 configuration. The various vservers can't interact with each other and
161 can't interact with services in the main server.
162
163 This package contains the SysV initscripts which start and stop
164 VServers and related tools.
165
166
167 %description legacy
168 util-vserver provides the components and a framework to setup virtual
169 servers.  A virtual server runs inside a linux server. It is nevertheless
170 highly independent. As such, you can run various services with normal
171 configuration. The various vservers can't interact with each other and
172 can't interact with services in the main server.
173
174 This package contains the tools which are needed to work with VServers
175 having an old-style configuration.
176
177
178 %description devel
179 util-vserver provides the components and a framework to setup virtual
180 servers.  A virtual server runs inside a linux server. It is nevertheless
181 highly independent. As such, you can run various services with normal
182 configuration. The various vservers can't interact with each other and
183 can't interact with services in the main server.
184
185 This package contains header files and libraries which are needed to
186 develop VServer related applications.
187
188
189 %description python
190 Python modules for manipulating vservers.  Provides a superset of the
191 functionality of the vserver script (at least will do in the future),
192 but more readily accessible from Python code.
193
194
195 %prep
196 %setup -q -n %name-%fullver
197
198 aclocal -I m4
199 autoconf
200 automake --add-missing
201
202 %build
203 %configure --with-initrddir=%_initrddir --enable-release \
204            %{?_without_dietlibc:--disable-dietlibc} \
205            %{!?_without_legacy:--enable-apis=NOLEGACY} \
206            --with-initscripts=sysv --disable-static=vserverimpl
207
208 %__make %{?_smp_mflags} all
209 %{!?_without_doc:%__make %{?_smp_mflags} doc}
210
211 %install
212 rm -rf $RPM_BUILD_ROOT
213 %__make DESTDIR="$RPM_BUILD_ROOT" install install-distribution
214
215 rm -f $RPM_BUILD_ROOT/%_libdir/*.la $RPM_BUILD_ROOT%{python_sitearch}/*.la
216
217 MANIFEST_CONFIG='%config' \
218 MANIFEST_CONFIG_NOREPLACE='%config(noreplace)' \
219 contrib/make-manifest %name $RPM_BUILD_ROOT contrib/manifest.dat
220
221 # Generate file list for python package
222 find "%{buildroot}" -name '*.py' | { while read FILE; do
223         f="${FILE#%{buildroot}}"
224         echo "${f}"
225         echo %%ghost "${f}c"
226         echo %%ghost "${f}o"
227 done } > %name-python.list
228
229
230 %check || :
231 #%__make check
232
233
234 %clean
235 rm -rf $RPM_BUILD_ROOT
236
237
238 %post
239 test -d /vservers      || mkdir -m0000 /vservers
240 test -d /vservers/.pkg || mkdir -m0755 /vservers/.pkg
241
242 f="%confdefaultdir/vdirbase";  test -L "$f" -o -e "$f" || ln -s /vservers                        "$f"
243 f="%confdefaultdir/run.rev";   test -L "$f" -o -e "$f" || ln -s %_localstatedir/run/vservers.rev "$f"
244 f="%confdefaultdir/cachebase"; test -L "$f" -o -e "$f" || ln -s %_localstatedir/cache/vservers   "$f"
245
246 %_sbindir/setattr --barrier /vservers /vservers/.pkg || :
247
248
249 %preun
250 test "$1" != 0 || rm -rf %_localstatedir/cache/vservers/* 2>/dev/null || :
251
252 # add /bin/vsh to list of secure shells
253 if [ ! -f /etc/shells ] || ! grep -q '^/bin/vsh$' /etc/shells ; then
254     echo /bin/vsh >> /etc/shells
255 fi
256
257
258 %postun
259 # 0 = erase, 1 = upgrade
260 if [ "$1" = 0 ] ; then
261     perl -i -n -e 'next if /^\/bin\/vsh$/; print' /etc/shells
262 fi
263
264
265 %post   lib -p /sbin/ldconfig
266 %postun lib -p /sbin/ldconfig
267
268
269 %post sysv
270 #%chkconfig --add vservers-default
271 #%chkconfig --add vprocunhide
272 # PlanetLab Node Manager takes care of starting and stopping VServers
273 %chkconfig --del vservers-default
274 %chkconfig --del util-vserver
275 # PlanetLab does not require /proc security
276 %chkconfig --del vprocunhide
277 # vip6-autod handles IPv6 auto-assignments
278 %chkconfig --add vip6-autod
279
280
281 %preun sysv
282 #test "$1" != 0 || %_initrddir/vprocunhide stop &>/dev/null || :
283
284 #test "$1" != 0 || %chkconfig --del vprocunhide
285 #test "$1" != 0 || %chkconfig --del vservers-default
286 #test "$1" != 0 || %chkconfig --del util-vserver
287 test "$1" != 0 || %chkconfig --del vip6-autod
288
289
290 %postun sysv
291 #test "$1" = 0  || %_initrddir/vprocunhide condrestart >/dev/null || :
292
293
294 %triggerin build -- fedora-release, centos-release
295 function copy()
296 {
297     base=$1
298     shift
299
300     for i; do
301         test -r "$i" || continue
302
303         target=%confdir/.distributions/.common/pubkeys/$base-$(basename "$i")
304         cp -a "$i" "$target"
305     done
306 }
307 copy fedora /usr/share/doc/fedora-release-*/RPM-GPG-*
308 copy fedora /etc/pki/rpm-gpg/RPM-GPG-*
309 copy centos /usr/share/doc/centos-*/RPM-GPG-KEY-*
310
311
312 %post build
313 test -d /vservers/.hash || mkdir -m0700 /vservers/.hash
314
315 f="%confdefaultdir/apps/vunify/hash"; test -e "$f"/method -o -e "$f"/00 || \
316         ln -s /vservers/.hash "$f"/00
317
318 %_sbindir/setattr --barrier /vservers/.hash || :
319
320
321 %preun build
322 test "$1" != 0 || rm -f %confdir/.distributions/.common/pubkeys/fedora-*
323
324
325 ## Temporary workaround to remove old v_* files; it will conflict
326 ## somehow with the -legacy package but can be fixed by reinstalling
327 ## this package.
328 ## TODO: remove me in the final .spec file
329 %define v_services      httpd named portmap sendmail smb sshd xinetd gated
330 %triggerun sysv -- util-vserver-sysv < 0.30.198
331 for i in %v_services; do
332         %chkconfig --del v_$i || :
333 done
334
335
336 %post legacy
337 # PlanetLab Node Manager takes care of starting and stopping VServers
338 #%chkconfig --add rebootmgr
339 #%chkconfig --add vservers-legacy
340
341 # PlanetLab does not require these legacy services
342 #for i in %v_services; do
343 #       %chkconfig --add v_$i
344 #done
345
346
347 %preun legacy
348 #test "$1" != 0 || %_initrddir/rebootmgr   stop &>/dev/null || :
349
350 #test "$1" != 0 || for i in %v_services; do
351 #       %chkconfig --del v_$i
352 #done
353
354 #test "$1" != 0 || %chkconfig --del rebootmgr
355 #test "$1" != 0 || %chkconfig --del vservers-legacy
356
357 %postun legacy
358 #test "$1" = 0  || %_initrddir/rebootmgr   condrestart >/dev/null || :
359
360
361 %files -f %name-base.list
362 %defattr(-,root,root,-)
363 %doc AUTHORS COPYING ChangeLog NEWS README THANKS
364 %doc doc/*.html doc/*.css
365 /sbin/vshelper
366 %dir %confdir
367 %dir %confdefaultdir
368 %dir %confdefaultdir/apps
369 %dir %confdefaultdir/files
370 %dir %pkglibdir/defaults
371 %ghost %confdefaultdir/cachebase
372 %ghost %confdefaultdir/vdirbase
373 %ghost %confdefaultdir/run.rev
374
375 %dir %_localstatedir/cache/vservers
376 %dir %_localstatedir/run/vservers
377 %dir %_localstatedir/run/vservers.rev
378 %dir %_localstatedir/run/vshelper
379
380
381 %files lib -f %name-lib.list
382 %files sysv -f %name-sysv.list
383
384
385 %files core -f %name-core.list
386 %defattr(-,root,root,-)
387 %dir %pkglibdir
388
389
390 %files build -f %name-build.list
391 %defattr(-,root,root,-)
392 %doc contrib/yum*.patch
393 %dir %confdir/.distributions
394 %dir %confdir/.distributions/*
395 %dir %confdir/.distributions/*/apt
396 %dir %confdir/.distributions/.common
397 %dir %confdir/.distributions/.common/pubkeys
398 %dir %confdefaultdir/apps/vunify
399 %dir %confdefaultdir/apps/vunify/hash
400
401
402 %files legacy -f %name-legacy.list
403 %defattr(-,root,root,-)
404 %dir %pkglibdir/legacy
405
406
407 %files devel -f %name-devel.list
408 %defattr(-,root,root,-)
409 %{!?_without_doc:%doc lib/apidoc/latex/refman.pdf}
410 %{!?_without_doc:%doc lib/apidoc/html}
411
412
413 %files python -f %name-python.list
414 %{_sbindir}/bwlimit
415 %{_sbindir}/disklimit
416 %{python_sitearch}/vserverimpl.so
417
418
419 %changelog
420 * Mon Jul 30 2007 Daniel Hokka Zakrisson <daniel@hozac.com>
421 - add vip6-autod
422
423 * Fri Dec 29 2006 Daniel Hokka Zakrisson <daniel@hozac.com> - 0.30.213-0
424 - add --with legacy and --without doc switches
425 - add util-vserver initscript
426
427 * Fri Feb 17 2006 Steve Muir <smuir@cs.princeton.edu>
428 - add support for setting guaranteed CPU share flag in rspec
429
430 * Sun Jan 22 2006 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0.30.210-0
431 - do not require 'xalan' anymore by default
432 - removed 'Requires: apt'; apt-rpm is not maintained upstream anymore
433 - removed 'chattr' leftovers
434 - create the '/etc/vservers/.defaults/cachebase' symlink
435 - added /var/cache/vservers and the needed support
436 - set barrier attribute on /vservers/.pkg and /vservers/.hash
437 - added 'centos-release' to the list of packages in the copy-the-keys
438   trigger script
439 - create '/vservers/.hash' and add initial configuration for it
440
441 * Fri Jan 13 2006 Steve Muir <smuir@cs.princeton.edu>
442 - fix bug in python/vserverimpl.c where attempting to adjust CPU share
443   for a context that didn't exist would cause an error (it should be a
444   safe no-op)
445
446 * Fri Dec  2 2005 Steve Muir <smuir@cs.princeton.edu>
447 - fix bugs in python/vserverimpl.c where exceptions were not raised when
448   they should be and thus occured later at unexpected times
449 - add support for stopping a vserver
450
451 * Wed Nov  9 2005 Steve Muir <smuir@cs.princeton.edu>
452 - add support for removing resource limits e.g., when a slice is deleted
453
454 * Mon Nov  7 2005 Steve Muir <smuir@cs.princeton.edu>
455 - fix file descriptor leak in vduimpl
456 - clean up handling of network parameters
457 - don't rely upon /etc/vservers/foo.conf to initialise vserver object
458
459 * Wed Nov  2 2005 Steve Muir <smuir@cs.princeton.edu>
460 - fix Python modules to handling scheduling parameters correctly
461
462 * Sun Oct 30 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.209-0
463 - version 0.30.209
464 - copy centos keys
465
466 * Fri Oct 28 2005 Steve Muir <smuir@cs.princeton.edu>
467 - raise exception about being over disk limit after setting usage values
468
469 * Fri Oct  7 2005 Steve Muir <smuir@cs.princeton.edu>
470 - create common function to be used for entering a vserver and applying
471   resource limits
472
473 * Thu Aug 21 2005 Mark Huang <mlhuang@cs.princeton.edu>
474 - restore build of python modules
475
476 * Sat Aug 20 2005 Mark Huang <mlhuang@cs.princeton.edu>
477 - upgrade to util-vserver-0.30.208
478 - forward-port vbuild and legacy support until we can find a suitable
479   replacement
480 - make vsh use new vc_create_context() call
481
482 * Thu Jul 28 2005 Steve Muir <smuir@cs.princeton.edu>
483 - add support for static vserver IDs to vuseradd and vuserdel
484
485 * Thu Jul 21 2005 Steve Muir <smuir@cs.princeton.edu>
486 - add bwlimit and cpulimit modules
487
488 * Sat Jul 16 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.208-2
489 - updated URLs
490
491 * Fri Jul 15 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.208-1
492 - version 0.30.208
493 - require the -lib subpackage by -devel
494 - copy GPG keys from /etc/pki/rpm-gpg/
495
496 * Mon Jun 20 2005 Steve Muir <smuir@cs.princeton.edu>
497 - import Marc's vdu implementation
498
499 * Wed Jun 15 2005 Steve Muir <smuir@cs.princeton.edu>
500 - 'vserver-init start' functionality subsumed by Node Manager
501
502 * Thu Jun 02 2005 Marc E. Fiuczynski <mef@cs.princeton.edu>
503 - Fixed vlimit command
504
505 * Wed May 25 2005 Steve Muir <smuir@cs.princeton.edu>
506 - add Python modules for manipulating vservers
507
508 * Fri Apr 15 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.206-1
509 - added patches to make yum work in chroot environments
510 - version 0.30.206
511
512 * Thu Apr  7 2005 Steve Muir <smuir@cs.princeton.edu>
513 - vuserdel changes: don't shutdown vserver, just kill all processes;
514   unmount all mountpoints in vserver before deleting
515
516 * Thu Mar 24 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.205-0
517 - added some %%descriptions
518 - copy GPG keys from the system into the confdir
519 - buildrequire dietlibc-0.25
520 - BuildRequire beecrypt-devel
521 - cleanups
522 - use %%global instead of %%define
523 - removed 'run.rev' as a vserver-local variable and made it a system-wide setting
524
525 * Wed Jan 26 2005 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.198-0.3
526 - updated BuildRequires:
527 - use 'setattr --barrier' instead of 'chattr +t' in the %%post scriptlet
528 - moved the v_* initscripts to legacy
529 - do not ship the /vservers directory itself; as it is immutable, the
530   extraction will fail else
531
532 * Fri Nov 19 2004 Mark Huang <mlhuang@cs.princeton.edu>
533 - vcached no longer runs as a daemon
534 - do not restart vservers when package is upgraded
535
536 * Wed Nov 17 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-6.planetlab
537 + planetlab-3_0-rc4
538 - PL2445
539 - Both vcached and vuseradd now print a warning message when vbuild
540   succeeds but the resulting new vserver image is smaller in size than
541   the vserver-reference image.
542 - vuseradd: clean up some more junk on failure
543
544 * Tue Nov 16 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-5.planetlab
545 + planetlab-3_0-rc3
546 - PL3026: This is the upgraded version of vdu that maintains an
547   internal hash table of files with a nlink count > 1.  Only if vdu
548   sees all hard links to a particular inode does it add its size and
549   block count to the total.
550
551 * Fri Nov 12 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-4.planetlab
552 - PL2445 Use -b option to du to avoid rounding errors.
553
554 * Sat Nov  6 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.30-3.planetlab
555 + planetlab-3_0-rc2
556 - don't create the symbolic link /home/slice/.ssh, this is not how
557   pl_sshd works
558
559 * Mon Oct 11 2004 Marc E. Fiuczynski <mef@cs.princeton.edu>
560 - added vsh
561
562 * Thu Sep  9 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.30.194-0
563 - documented switches for 'rpmbuild'
564
565 * Wed Aug 11 2004 Mark Huang <mlhuang@cs.princeton.edu> 0.29-1.planetlab
566 - initial PlanetLab 3.0 build.
567
568 * Wed May 26 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.215-0
569 - (re)added the MANIFEST_* variables which were lost some time ago;
570   this will preserve %%config files...
571
572 * Mon Mar 15 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.202-0
573 - use file-list for sysv scripts also
574
575 * Sat Mar  6 2004 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.29.198-0
576 - added vprocunhide-service support
577 - added doxygen support
578 - updated Requires:
579
580 * Wed Oct  1 2003 Enrico Scholz <enrico.scholz@informatik.tu-chemnitz.de> - 0:0.23.5-0
581 - Initial build.