3081a98fc14220b8d0ae5b1ce8e6d6a97312bb06
[vsys-scripts.git] / root-context / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6
7 %define name vsys-scripts
8 %define version 0.95
9 %define taglevel 45
10
11 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Vendor: PlanetLab
14 Packager: PlanetLab Central <support@planet-lab.org>
15 Distribution: PlanetLab %{plrelease}
16 URL: %{SCMURL}
17
18 Summary: Vsys scripts scripts
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: GPL
23 Group: System Environment/Kernel
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
25 Requires: vsys
26
27 Source0: vsys-scripts-%{version}.tar.gz
28
29 %description
30 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
31 to which users require privileged access.
32
33 %prep
34 %setup
35
36 %build
37 rm -rf $RPM_BUILD_ROOT
38 make -C root-context
39
40 %install
41 mkdir -p $RPM_BUILD_ROOT/vsys
42 cp root-context/exec/* $RPM_BUILD_ROOT/vsys
43
44 %clean
45 rm -rf $RPM_BUILD_ROOT
46
47 %files
48 /vsys/*
49
50 %post
51
52 %postun
53
54 %changelog
55 * Wed Dec 19 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-45
56 - script 'promisc' can set a device in promiscuous mode
57
58 * Tue Sep 04 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-44
59 - new slice-oriented package vsys-wrapper (python wrapper)
60 - new layout of the module, spit between root-context and slice-context
61
62 * Fri Jul 27 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-43
63
64 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-42
65 - fix TUN devices creation (was always creating TAPs)
66
67 * Tue Jun 12 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-41
68
69 * Wed Jun 06 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-40
70
71 * Tue May 08 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-39
72 - prevent vserver from unsharing namespaces
73
74 * Thu Apr 19 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-38
75 - This change resolves the pricky issue of bind mounting across namespaces by disabling namespaces altogether.
76
77 * Mon Apr 09 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-37
78 - A new script that lets slices serve DNS by binding to UDP port 53.
79
80 * Tue Mar 20 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-36
81 - Disable namespaces for pl_netflow
82
83 * Tue Feb 14 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-35
84 - Added a script for users to create custom distributions within their slices. Use as follows:
85 - mkdir /rootfs;cd /rootfs
86 - wget <your distribution tarball>
87 - tar xvfz <tarball>
88 - [copy in PlanetLab /etc/resolv.conf and /etc/passwd files. mkdir /var/run; mkdir /var/lock]
89 - cat /vsys/switcheroo.out &
90 - echo 1 > /vsys/switcheroo.in
91
92 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
93 - Added a new script from Jude.
94
95 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
96 - Build fd_netlink, a new script that lets slices stream packet headers
97
98 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
99 - New script for slices to stream the headers of all packets going out of a node.
100
101 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
102 - vif_up has support for GRE tunnels
103 - sliceip is known to cause kernel crashes with 2.6.32 at least
104
105 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
106 - New script: claimport.
107
108 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
109 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
110 - new vroute
111
112 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
113 - Bug fix for 2.6.27+ kernels
114
115 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
116 - first draft of new scripts to handle openvswitch
117
118 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
119 - rsyncnodelogs script, make it easy to bring up tun/tap devices
120
121 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
122 - support newer kernels
123
124 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
125 - Add executable tag to vif_up to let it run.
126
127 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
128 - Added execute attribute to vif_up, the absence of which prevented it from being used.
129
130 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
131 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
132 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
133
134 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
135 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
136 - and other minor changes.
137
138 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
139 - fix dotsshmount
140
141 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
142 - change dotsshmount's mount point
143
144 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
145 - Switch fd_tuntap to 2.6.27.
146
147 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
148 - Tweak to if_port_forward script.
149
150 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
151 - Added if_port_forward script to enable slices to forward ports for their
152 - allocated IP addresses.
153
154 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
155 - - hostname filter and updated documentation for ipfw scripts - Marta
156 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
157 - (if this is not needed anymore please remove and tag again)
158
159 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
160 - Tweak to Thom Haddow's script to let a slice see packets related to
161 - existing connections.
162
163 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
164 - ipfw frontend has a rules cleanup feature
165 - ongoing work around vif_up
166 - new script 'run_with_devices'
167
168 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
169 - improve usability of the ipfw backend
170
171 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
172 - * Load the tun module if it is not already loaded
173 - * Fixed a bug in fd_tuntap
174
175 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
176 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
177
178 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
179 - This update adds Thom Haddow's custom tun/tap-device scripts.
180
181 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
182 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
183
184 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
185 - minor changes in sliceip and ipfw, new reserve_udp_port
186
187 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
188 - Added reserve_tcp_port and Giovanni's slice_ip tool.
189
190 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
191 - tweak in ipfw-be for in-node emulation
192
193 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
194 - Added the ipfw backend script
195
196 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
197 - rsync authlogs to ~/
198
199 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
200 - Security update. umount had an issue that might have been exploited.
201
202 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
203 - Adding port reservation script (goodfences)
204 - Modifying umount to be more (or less, depending on your point of view) robust
205
206
207
208 %define module_current_branch 0.7