2379ae87b58a4cd0afebca30ff040f7c7bb6493f
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 23
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
58 - Added execute attribute to vif_up, the absence of which prevented it from being used.
59
60 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
61 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
62 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
63
64 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
65 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
66 - and other minor changes.
67
68 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
69 - fix dotsshmount
70
71 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
72 - change dotsshmount's mount point
73
74 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
75 - Switch fd_tuntap to 2.6.27.
76
77 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
78 - Tweak to if_port_forward script.
79
80 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
81 - Added if_port_forward script to enable slices to forward ports for their
82 - allocated IP addresses.
83
84 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
85 - - hostname filter and updated documentation for ipfw scripts - Marta
86 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
87 - (if this is not needed anymore please remove and tag again)
88
89 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
90 - Tweak to Thom Haddow's script to let a slice see packets related to
91 - existing connections.
92
93 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
94 - ipfw frontend has a rules cleanup feature
95 - ongoing work around vif_up
96 - new script 'run_with_devices'
97
98 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
99 - improve usability of the ipfw backend
100
101 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
102 - * Load the tun module if it is not already loaded
103 - * Fixed a bug in fd_tuntap
104
105 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
106 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
107
108 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
109 - This update adds Thom Haddow's custom tun/tap-device scripts.
110
111 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
112 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
113
114 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
115 - minor changes in sliceip and ipfw, new reserve_udp_port
116
117 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
118 - Added reserve_tcp_port and Giovanni's slice_ip tool.
119
120 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
121 - tweak in ipfw-be for in-node emulation
122
123 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
124 - Added the ipfw backend script
125
126 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
127 - rsync authlogs to ~/
128
129 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
130 - Security update. umount had an issue that might have been exploited.
131
132 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
133 - Adding port reservation script (goodfences)
134 - Modifying umount to be more (or less, depending on your point of view) robust
135
136
137
138 %define module_current_branch 0.7