2a331286301dfb42ca5add0c222e73a2dab433da
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 38
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Thu Apr 19 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-38
58 - This change resolves the pricky issue of bind mounting across namespaces by disabling namespaces altogether.
59
60 * Mon Apr 09 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-37
61 - A new script that lets slices serve DNS by binding to UDP port 53.
62
63 * Tue Mar 20 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-36
64 - Disable namespaces for pl_netflow
65
66 * Tue Feb 14 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-35
67 - Added a script for users to create custom distributions within their slices. Use as follows:
68 - mkdir /rootfs;cd /rootfs
69 - wget <your distribution tarball>
70 - tar xvfz <tarball>
71 - [copy in PlanetLab /etc/resolv.conf and /etc/passwd files. mkdir /var/run; mkdir /var/lock]
72 - cat /vsys/switcheroo.out &
73 - echo 1 > /vsys/switcheroo.in
74
75 * Fri Jan 13 2012 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-34
76 - Added a new script from Jude.
77
78 * Mon Oct 24 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-33
79 - Build fd_netlink, a new script that lets slices stream packet headers
80
81 * Mon Oct 03 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-32
82 - New script for slices to stream the headers of all packets going out of a node.
83
84 * Wed Aug 31 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-31
85 - vif_up has support for GRE tunnels
86 - sliceip is known to cause kernel crashes with 2.6.32 at least
87
88 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
89 - New script: claimport.
90
91 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
92 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
93 - new vroute
94
95 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
96 - Bug fix for 2.6.27+ kernels
97
98 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
99 - first draft of new scripts to handle openvswitch
100
101 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
102 - rsyncnodelogs script, make it easy to bring up tun/tap devices
103
104 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
105 - support newer kernels
106
107 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
108 - Add executable tag to vif_up to let it run.
109
110 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
111 - Added execute attribute to vif_up, the absence of which prevented it from being used.
112
113 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
114 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
115 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
116
117 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
118 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
119 - and other minor changes.
120
121 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
122 - fix dotsshmount
123
124 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
125 - change dotsshmount's mount point
126
127 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
128 - Switch fd_tuntap to 2.6.27.
129
130 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
131 - Tweak to if_port_forward script.
132
133 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
134 - Added if_port_forward script to enable slices to forward ports for their
135 - allocated IP addresses.
136
137 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
138 - - hostname filter and updated documentation for ipfw scripts - Marta
139 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
140 - (if this is not needed anymore please remove and tag again)
141
142 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
143 - Tweak to Thom Haddow's script to let a slice see packets related to
144 - existing connections.
145
146 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
147 - ipfw frontend has a rules cleanup feature
148 - ongoing work around vif_up
149 - new script 'run_with_devices'
150
151 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
152 - improve usability of the ipfw backend
153
154 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
155 - * Load the tun module if it is not already loaded
156 - * Fixed a bug in fd_tuntap
157
158 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
159 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
160
161 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
162 - This update adds Thom Haddow's custom tun/tap-device scripts.
163
164 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
165 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
166
167 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
168 - minor changes in sliceip and ipfw, new reserve_udp_port
169
170 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
171 - Added reserve_tcp_port and Giovanni's slice_ip tool.
172
173 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
174 - tweak in ipfw-be for in-node emulation
175
176 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
177 - Added the ipfw backend script
178
179 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
180 - rsync authlogs to ~/
181
182 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
183 - Security update. umount had an issue that might have been exploited.
184
185 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
186 - Adding port reservation script (goodfences)
187 - Modifying umount to be more (or less, depending on your point of view) robust
188
189
190
191 %define module_current_branch 0.7