d12ee00c950bb362801c3e71b8208905f77e8f66
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 30
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Mon Jul 18 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-30
58 - New script: claimport.
59
60 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-29
61 - vif_down,vif_up: more tidy, pointopoint, and work around ip route get <> oddly returning nothing
62 - new vroute
63
64 * Mon Feb 21 2011 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-28
65 - Bug fix for 2.6.27+ kernels
66
67 * Wed Feb 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-27
68 - first draft of new scripts to handle openvswitch
69
70 * Tue Jan 11 2011 Andy Bavier <acb@cs.princeton.edu> - vsys-scripts-0.95-26
71 - rsyncnodelogs script, make it easy to bring up tun/tap devices
72
73 * Mon Oct 18 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - vsys-scripts-0.95-25
74 - support newer kernels
75
76 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
77 - Add executable tag to vif_up to let it run.
78
79 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
80 - Added execute attribute to vif_up, the absence of which prevented it from being used.
81
82 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
83 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
84 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
85
86 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
87 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
88 - and other minor changes.
89
90 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
91 - fix dotsshmount
92
93 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
94 - change dotsshmount's mount point
95
96 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
97 - Switch fd_tuntap to 2.6.27.
98
99 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
100 - Tweak to if_port_forward script.
101
102 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
103 - Added if_port_forward script to enable slices to forward ports for their
104 - allocated IP addresses.
105
106 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
107 - - hostname filter and updated documentation for ipfw scripts - Marta
108 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
109 - (if this is not needed anymore please remove and tag again)
110
111 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
112 - Tweak to Thom Haddow's script to let a slice see packets related to
113 - existing connections.
114
115 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
116 - ipfw frontend has a rules cleanup feature
117 - ongoing work around vif_up
118 - new script 'run_with_devices'
119
120 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
121 - improve usability of the ipfw backend
122
123 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
124 - * Load the tun module if it is not already loaded
125 - * Fixed a bug in fd_tuntap
126
127 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
128 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
129
130 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
131 - This update adds Thom Haddow's custom tun/tap-device scripts.
132
133 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
134 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
135
136 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
137 - minor changes in sliceip and ipfw, new reserve_udp_port
138
139 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
140 - Added reserve_tcp_port and Giovanni's slice_ip tool.
141
142 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
143 - tweak in ipfw-be for in-node emulation
144
145 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
146 - Added the ipfw backend script
147
148 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
149 - rsync authlogs to ~/
150
151 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
152 - Security update. umount had an issue that might have been exploited.
153
154 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
155 - Adding port reservation script (goodfences)
156 - Modifying umount to be more (or less, depending on your point of view) robust
157
158
159
160 %define module_current_branch 0.7