f37ee1e02052db316565ca49e904040b1b7708e1
[vsys-scripts.git] / vsys-scripts.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define name vsys-scripts
10 %define version 0.95
11 %define taglevel 24
12
13 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
14
15 Vendor: PlanetLab
16 Packager: PlanetLab Central <support@planet-lab.org>
17 Distribution: PlanetLab %{plrelease}
18 URL: %(echo %{url} | cut -d ' ' -f 2)
19
20 Summary: Vsys scripts scripts
21 Name: %{name}
22 Version: %{version}
23 Release: %{release}
24 License: GPL
25 Group: System Environment/Kernel
26 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
27 Requires: vsys
28
29 Source0: vsys-scripts-%{version}.tar.gz
30
31 %description
32 Vsys scripts for privileged operations on PlanetLab. These scripts are defined by maintainers of various components,
33 to which users require privileged access.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/vsys
44 cp exec/* $RPM_BUILD_ROOT/vsys
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 /vsys/*
51
52 %post
53
54 %postun
55
56 %changelog
57 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-24
58 - Add executable tag to vif_up to let it run.
59
60 * Fri Oct 15 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-23
61 - Added execute attribute to vif_up, the absence of which prevented it from being used.
62
63 * Mon Oct 11 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-22
64 - vif_up has now been modified with the ability to create tap devices and to be able to SNAT over randomly selected
65 - ports. Thanks to Matthias Goerner for his help developing and testing these changes.
66
67 * Fri Sep 17 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-21
68 - Added script fd_packetseer, also updated tun/tap script to be able to create tun devices in addition to tap devices
69 - and other minor changes.
70
71 * Mon Jul 19 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-20
72 - fix dotsshmount
73
74 * Thu Jul 01 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-19
75 - change dotsshmount's mount point
76
77 * Fri Jun 25 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-18
78 - Switch fd_tuntap to 2.6.27.
79
80 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-17
81 - Tweak to if_port_forward script.
82
83 * Fri Apr 30 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-16
84 - Added if_port_forward script to enable slices to forward ports for their
85 - allocated IP addresses.
86
87 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-scripts-0.95-15
88 - - hostname filter and updated documentation for ipfw scripts - Marta
89 - - vsys script for letting users to set the Type of Services(ToS) byte in the IPv4 header - Caglar
90 - (if this is not needed anymore please remove and tag again)
91
92 * Thu Jan 21 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-14
93 - Tweak to Thom Haddow's script to let a slice see packets related to
94 - existing connections.
95
96 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-13
97 - ipfw frontend has a rules cleanup feature
98 - ongoing work around vif_up
99 - new script 'run_with_devices'
100
101 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-12
102 - improve usability of the ipfw backend
103
104 * Wed Oct 28 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-11
105 - * Load the tun module if it is not already loaded
106 - * Fixed a bug in fd_tuntap
107
108 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-10
109 - Adds Thom Haddow's tun/tap changes. I omitted a change in my previous commit.
110
111 * Tue Oct 27 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-9
112 - This update adds Thom Haddow's custom tun/tap-device scripts.
113
114 * Wed Sep 09 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-8
115 - Added script to create UDP sockets instead of TCP sockets w/ big buffers
116
117 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-7
118 - minor changes in sliceip and ipfw, new reserve_udp_port
119
120 * Mon Aug 03 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-6
121 - Added reserve_tcp_port and Giovanni's slice_ip tool.
122
123 * Tue Jul 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-5
124 - tweak in ipfw-be for in-node emulation
125
126 * Thu Jun 11 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-scripts-0.95-4
127 - Added the ipfw backend script
128
129 * Fri Jun 05 2009 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-scripts-0.95-3
130 - rsync authlogs to ~/
131
132 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-2
133 - Security update. umount had an issue that might have been exploited.
134
135 * Thu May 14 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-scripts-0.95-1
136 - Adding port reservation script (goodfences)
137 - Modifying umount to be more (or less, depending on your point of view) robust
138
139
140
141 %define module_current_branch 0.7