Setting tag vsys-0.99-0
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define url $URL$
10
11 %define name vsys
12 %define version 0.99
13 %define taglevel 0
14
15 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
21
22 Summary: Vsys filesystem 
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: GPL
27 Group: System Environment/Kernel
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
29 #Requires: 
30 BuildRequires: inotify-tools-devel
31 BuildRequires: ocaml
32 BuildRequires: ocaml-docs
33
34 Source0: vsys-%{version}.tar.gz
35
36 %description
37 vsys is a file-system-based interface that lets slices on PlanetLab safely
38 invoke services installed by the PlanetLab administration. Slices invoke and
39 interact with these services through fifo pipes. Services can be added and
40 removed dynamically.
41
42 %prep
43 %setup
44
45 %build
46 rm -rf $RPM_BUILD_ROOT
47 make
48
49 %install
50 mkdir -p $RPM_BUILD_ROOT/usr/bin
51 mkdir -p $RPM_BUILD_ROOT/etc/init.d
52 mkdir -p $RPM_BUILD_ROOT/vsys
53 #cp factory/* $RPM_BUILD_ROOT/vsys
54 cp vsys $RPM_BUILD_ROOT/usr/bin
55 cp vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
56 cp vsys.conf $RPM_BUILD_ROOT/etc
57
58 install -D -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 /usr/bin/vsys
65 /etc/init.d/vsys
66 /vsys
67 %config(noreplace) /etc/vsys.conf
68 %{_sysconfdir}/logrotate.d/vsys
69
70 %post
71 chkconfig --add vsys
72 chkconfig vsys on
73 if [ "$PL_BOOTCD" != "1" ] ; then
74         service vsys restart
75 fi
76
77 %postun
78
79 %changelog
80 * Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
81 - Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
82 - git/master.
83
84 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
85 - fix build for f12
86
87 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
88 - The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous
89  version of vsys.
90
91 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
92 - Getting rid of factory scripts from the main vsys. They now live elsewhere.
93
94 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
95 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
96 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
97 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
98 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
99 - vsys-factory/bm_socket for more details.
100 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
101 - stability audit.
102 - * Version 0.95 (trunk) is the new development version.
103
104 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
105 - Tagging to force an update.
106
107 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
108
109 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
110
111 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
112
113 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
114 - Tagging a trivial fix.
115
116 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
117 - includes new portsummary script for CoMon
118
119 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
120 - trying to fix the taglevel relative to the branch name
121
122 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
123 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
124
125 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
126 - * Don't kill vsys twice on restarts, do it only once
127 - * Restart vsys following a reinstall
128
129 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
130 - Usability changes that are necessary for the stability of CoMon
131
132 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
133 - added patch to pl-ps needed by slicestat
134
135
136
137 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
138 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
139
140 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
141 - accept '-' in filenames also
142
143
144 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
145 - don't overwrite the config file that already exists.
146
147
148 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
149 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
150
151
152
153 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
154 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
155 - it to show up in all slices.
156
157
158
159 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
160 - Added a vsys script for CoMon.
161
162
163 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
164 - ignore non-existent directories after restart.
165
166
167 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
168 - added logrotate configuration to package.
169
170
171 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
172 - Added two new scripts for CoMon on 4.2
173
174
175 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
176
177 - Corrected directory that the script mounts to the correct one:
178 - /var/local/fprobe
179
180
181 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
182 - Pulling the latest changes for the 4.2rc2 release
183
184
185 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
186 - * daemonization, writing to a logfile, and saving the pid
187
188