Tagging module vsys - vsys-0.7-20
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define url $URL$
10
11 %define name vsys
12 %define version 0.7
13 %define taglevel 20
14
15 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
21
22 Summary: Vsys filesystem 
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: GPL
27 Group: System Environment/Kernel
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
29 #Requires: 
30 BuildRequires: inotify-tools-devel
31 BuildRequires: ocaml
32 BuildRequires: ocaml-docs
33
34 Source0: vsys-%{version}.tar.gz
35
36 %description
37 vsys is a file-system-based interface that lets slices on PlanetLab safely
38 invoke services installed by the PlanetLab administration. Slices invoke and
39 interact with these services through fifo pipes. Services can be added and
40 removed dynamically.
41
42 %prep
43 %setup
44
45 %build
46 rm -rf $RPM_BUILD_ROOT
47 make
48
49 %install
50 mkdir -p $RPM_BUILD_ROOT/usr/bin
51 mkdir -p $RPM_BUILD_ROOT/etc/init.d
52 mkdir -p $RPM_BUILD_ROOT/vsys
53 cp factory/* $RPM_BUILD_ROOT/vsys
54 cp vsys $RPM_BUILD_ROOT/usr/bin
55 cp vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
56 cp vsys.conf $RPM_BUILD_ROOT/etc
57
58 install -D -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 /usr/bin/vsys
65 /etc/init.d/vsys
66 /vsys/*
67 %config(noreplace) /etc/vsys.conf
68 %{_sysconfdir}/logrotate.d/vsys
69
70 %post
71 chkconfig --add vsys
72 chkconfig vsys on
73 if [ "$PL_BOOTCD" != "1" ] ; then
74         service vsys restart
75 fi
76
77 %postun
78
79 %changelog
80 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
81 - trying to fix the taglevel relative to the branch name
82
83 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
84 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
85
86 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
87 - * Don't kill vsys twice on restarts, do it only once
88 - * Restart vsys following a reinstall
89
90 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
91 - Usability changes that are necessary for the stability of CoMon
92
93 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
94 - added patch to pl-ps needed by slicestat
95
96
97
98 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
99 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
100
101 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
102 - accept '-' in filenames also
103
104
105 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
106 - don't overwrite the config file that already exists.
107
108
109 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
110 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
111
112
113
114 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
115 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
116 - it to show up in all slices.
117
118
119
120 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
121 - Added a vsys script for CoMon.
122
123
124 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
125 - ignore non-existent directories after restart.
126
127
128 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
129 - added logrotate configuration to package.
130
131
132 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
133 - Added two new scripts for CoMon on 4.2
134
135
136 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
137
138 - Corrected directory that the script mounts to the correct one:
139 - /var/local/fprobe
140
141
142 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
143 - Pulling the latest changes for the 4.2rc2 release
144
145
146 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
147 - * daemonization, writing to a logfile, and saving the pid
148
149