5ac9c7c0c2c9de7cbec703fb586d953358f9bdf3
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5
6 %define name vsys
7 %define version 0.99
8 %define taglevel 0
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Vsys filesystem 
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Kernel
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 #Requires: 
25 BuildRequires: inotify-tools-devel
26 BuildRequires: ocaml
27 BuildRequires: ocaml-ocamldoc
28
29 Source0: vsys-%{version}.tar.gz
30
31 %description
32 vsys is a file-system-based interface that lets slices on PlanetLab safely
33 invoke services installed by the PlanetLab administration. Slices invoke and
34 interact with these services through fifo pipes. Services can be added and
35 removed dynamically.
36
37 %package -n vsyssh
38 Summary: Vsys client
39 Group: System Environment/Libraries
40
41 %description -n vsyssh
42 vsyssh is a simple shell to use vsys through.
43
44 %prep
45 %setup
46
47 %build
48 rm -rf $RPM_BUILD_ROOT
49 make
50 make -C vsyssh
51
52 %install
53 mkdir -p $RPM_BUILD_ROOT/usr/bin
54 mkdir -p $RPM_BUILD_ROOT/etc/init.d
55 mkdir -p $RPM_BUILD_ROOT/vsys
56 #cp factory/* $RPM_BUILD_ROOT/vsys
57 cp -p vsys $RPM_BUILD_ROOT/usr/bin
58 cp -p vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
59 cp -p vsys.conf $RPM_BUILD_ROOT/etc
60 cp -p vsyssh/vsyssh $RPM_BUILD_ROOT/usr/bin
61
62 install -D -p -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(-,root,root,-)
69 /usr/bin/vsys
70 /etc/init.d/vsys
71 /vsys
72 %config(noreplace) /etc/vsys.conf
73 %{_sysconfdir}/logrotate.d/vsys
74
75 %files -n vsyssh
76 %defattr(-,root,root,-)
77 /usr/bin/vsyssh
78
79 %post
80 chkconfig --add vsys
81 chkconfig vsys on
82 if [ "$PL_BOOTCD" != "1" ] ; then
83         service vsys restart
84 fi
85
86 %postun
87
88 %changelog
89 * Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
90 - Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
91 - git/master.
92
93 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
94 - fix build for f12
95
96 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
97 - The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous
98  version of vsys.
99
100 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
101 - Getting rid of factory scripts from the main vsys. They now live elsewhere.
102
103 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
104 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
105 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
106 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
107 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
108 - vsys-factory/bm_socket for more details.
109 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
110 - stability audit.
111 - * Version 0.95 (trunk) is the new development version.
112
113 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
114 - Tagging to force an update.
115
116 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
117
118 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
119
120 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
121
122 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
123 - Tagging a trivial fix.
124
125 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
126 - includes new portsummary script for CoMon
127
128 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
129 - trying to fix the taglevel relative to the branch name
130
131 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
132 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
133
134 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
135 - * Don't kill vsys twice on restarts, do it only once
136 - * Restart vsys following a reinstall
137
138 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
139 - Usability changes that are necessary for the stability of CoMon
140
141 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
142 - added patch to pl-ps needed by slicestat
143
144
145
146 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
147 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
148
149 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
150 - accept '-' in filenames also
151
152
153 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
154 - don't overwrite the config file that already exists.
155
156
157 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
158 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
159
160
161
162 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
163 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
164 - it to show up in all slices.
165
166
167
168 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
169 - Added a vsys script for CoMon.
170
171
172 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
173 - ignore non-existent directories after restart.
174
175
176 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
177 - added logrotate configuration to package.
178
179
180 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
181 - Added two new scripts for CoMon on 4.2
182
183
184 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
185
186 - Corrected directory that the script mounts to the correct one:
187 - /var/local/fprobe
188
189
190 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
191 - Pulling the latest changes for the 4.2rc2 release
192
193
194 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
195 - * daemonization, writing to a logfile, and saving the pid
196
197