6f666cfbdfeec07e9024159d3d611162bda43535
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define url $URL$
10
11 %define name vsys
12 %define version 0.9
13 %define taglevel 3
14
15 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
21
22 Summary: Vsys filesystem 
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: GPL
27 Group: System Environment/Kernel
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
29 #Requires: 
30 BuildRequires: inotify-tools-devel
31 BuildRequires: ocaml
32 BuildRequires: ocaml-docs
33
34 Source0: vsys-%{version}.tar.gz
35
36 %description
37 vsys is a file-system-based interface that lets slices on PlanetLab safely
38 invoke services installed by the PlanetLab administration. Slices invoke and
39 interact with these services through fifo pipes. Services can be added and
40 removed dynamically.
41
42 %prep
43 %setup
44
45 %build
46 rm -rf $RPM_BUILD_ROOT
47 make
48
49 %install
50 mkdir -p $RPM_BUILD_ROOT/usr/bin
51 mkdir -p $RPM_BUILD_ROOT/etc/init.d
52 mkdir -p $RPM_BUILD_ROOT/vsys
53 #cp factory/* $RPM_BUILD_ROOT/vsys
54 cp vsys $RPM_BUILD_ROOT/usr/bin
55 cp vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
56 cp vsys.conf $RPM_BUILD_ROOT/etc
57
58 install -D -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 /usr/bin/vsys
65 /etc/init.d/vsys
66 /vsys
67 %config(noreplace) /etc/vsys.conf
68 %{_sysconfdir}/logrotate.d/vsys
69
70 %post
71 chkconfig --add vsys
72 chkconfig vsys on
73 if [ "$PL_BOOTCD" != "1" ] ; then
74         service vsys restart
75 fi
76
77 %postun
78
79 %changelog
80 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
81 - The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous version of vsys.
82
83 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
84 - Getting rid of factory scripts from the main vsys. They now live elsewhere.
85
86 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
87 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
88 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
89 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
90 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
91 - vsys-factory/bm_socket for more details.
92 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
93 - stability audit.
94 - * Version 0.95 (trunk) is the new development version.
95
96 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
97 - Tagging to force an update.
98
99 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
100
101 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
102
103 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
104
105 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
106 - Tagging a trivial fix.
107
108 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
109 - includes new portsummary script for CoMon
110
111 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
112 - trying to fix the taglevel relative to the branch name
113
114 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
115 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
116
117 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
118 - * Don't kill vsys twice on restarts, do it only once
119 - * Restart vsys following a reinstall
120
121 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
122 - Usability changes that are necessary for the stability of CoMon
123
124 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
125 - added patch to pl-ps needed by slicestat
126
127
128
129 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
130 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
131
132 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
133 - accept '-' in filenames also
134
135
136 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
137 - don't overwrite the config file that already exists.
138
139
140 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
141 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
142
143
144
145 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
146 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
147 - it to show up in all slices.
148
149
150
151 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
152 - Added a vsys script for CoMon.
153
154
155 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
156 - ignore non-existent directories after restart.
157
158
159 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
160 - added logrotate configuration to package.
161
162
163 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
164 - Added two new scripts for CoMon on 4.2
165
166
167 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
168
169 - Corrected directory that the script mounts to the correct one:
170 - /var/local/fprobe
171
172
173 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
174 - Pulling the latest changes for the 4.2rc2 release
175
176
177 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
178 - * daemonization, writing to a logfile, and saving the pid
179
180