Aesthetic change
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5
6 %define name vsys
7 %define version 0.99
8 %define taglevel 2
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Vsys filesystem 
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Kernel
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 #Requires: 
25 BuildRequires: inotify-tools-devel
26 BuildRequires: ocaml
27 BuildRequires: ocaml-ocamldoc
28
29 Source0: vsys-%{version}.tar.gz
30
31 %description
32 vsys is a file-system-based interface that lets slices on PlanetLab safely
33 invoke services installed by the PlanetLab administration. Slices invoke and
34 interact with these services through fifo pipes. Services can be added and
35 removed dynamically.
36
37 %prep
38 %setup
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42 make
43
44 %install
45 mkdir -p $RPM_BUILD_ROOT/usr/bin
46 mkdir -p $RPM_BUILD_ROOT/etc/init.d
47 mkdir -p $RPM_BUILD_ROOT/vsys
48 #cp factory/* $RPM_BUILD_ROOT/vsys
49 cp -p vsys $RPM_BUILD_ROOT/usr/bin
50 cp -p vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
51 cp -p vsys.conf $RPM_BUILD_ROOT/etc
52
53 install -D -p -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(-,root,root,-)
60 /usr/bin/vsys
61 /etc/init.d/vsys
62 /vsys
63 %config(noreplace) /etc/vsys.conf
64 %{_sysconfdir}/logrotate.d/vsys
65
66 %post
67 chkconfig --add vsys
68 chkconfig vsys on
69 if [ "$PL_BOOTCD" != "1" ] ; then
70         service vsys restart
71 fi
72
73 %postun
74
75 %changelog
76 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-2
77 - split the vsyssh package in a separate specfile
78 - so we can preinstall vsyssh in the sliver space
79
80 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-1
81 - vsyssh is a simple shell to use vsys through, in the vsys-vsyssh rpm
82 - fix build dep to require ocaml-ocamldoc instead of ocaml-docs
83
84 * Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
85 - Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
86 - git/master.
87
88 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
89 - fix build for f12
90
91 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
92 - The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous
93  version of vsys.
94
95 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
96 - Getting rid of factory scripts from the main vsys. They now live elsewhere.
97
98 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
99 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
100 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
101 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
102 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
103 - vsys-factory/bm_socket for more details.
104 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
105 - stability audit.
106 - * Version 0.95 (trunk) is the new development version.
107
108 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
109 - Tagging to force an update.
110
111 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
112
113 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
114
115 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
116
117 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
118 - Tagging a trivial fix.
119
120 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
121 - includes new portsummary script for CoMon
122
123 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
124 - trying to fix the taglevel relative to the branch name
125
126 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
127 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
128
129 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
130 - * Don't kill vsys twice on restarts, do it only once
131 - * Restart vsys following a reinstall
132
133 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
134 - Usability changes that are necessary for the stability of CoMon
135
136 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
137 - added patch to pl-ps needed by slicestat
138
139
140
141 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
142 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
143
144 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
145 - accept '-' in filenames also
146
147
148 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
149 - don't overwrite the config file that already exists.
150
151
152 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
153 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
154
155
156
157 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
158 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
159 - it to show up in all slices.
160
161
162
163 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
164 - Added a vsys script for CoMon.
165
166
167 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
168 - ignore non-existent directories after restart.
169
170
171 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
172 - added logrotate configuration to package.
173
174
175 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
176 - Added two new scripts for CoMon on 4.2
177
178
179 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
180
181 - Corrected directory that the script mounts to the correct one:
182 - /var/local/fprobe
183
184
185 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
186 - Pulling the latest changes for the 4.2rc2 release
187
188
189 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
190 - * daemonization, writing to a logfile, and saving the pid
191
192