a49dcbf87f7b85361674cb3bd07e92d50d2c2bd9
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5
6 %define name vsys
7 %define version 0.99
8 %define taglevel 3
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Vsys filesystem
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Kernel
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 #Requires:
25 BuildRequires: inotify-tools-devel
26 BuildRequires: ocaml
27 BuildRequires: ocaml-ocamldoc
28
29 Source0: vsys-%{version}.tar.gz
30
31 %description
32 vsys is a file-system-based interface that lets slices on PlanetLab safely
33 invoke services installed by the PlanetLab administration. Slices invoke and
34 interact with these services through fifo pipes. Services can be added and
35 removed dynamically.
36
37 %prep
38 %setup
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42 # for fedora 29, that comes with a change in the ocaml language
43 # picked that tip here:
44 # https://github.com/HaxeFoundation/haxe/issues/6883
45 export OCAMLPARAM="safe-string=0,_"
46 make
47
48 %install
49 mkdir -p $RPM_BUILD_ROOT/usr/bin
50 mkdir -p $RPM_BUILD_ROOT/etc/init.d
51 mkdir -p $RPM_BUILD_ROOT/vsys
52 #cp factory/* $RPM_BUILD_ROOT/vsys
53 cp -p vsys $RPM_BUILD_ROOT/usr/bin
54 cp -p vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
55 cp -p vsys.conf $RPM_BUILD_ROOT/etc
56
57 install -D -p -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(-,root,root,-)
64 /usr/bin/vsys
65 /etc/init.d/vsys
66 /vsys
67 %config(noreplace) /etc/vsys.conf
68 %{_sysconfdir}/logrotate.d/vsys
69
70 %post
71 chkconfig --add vsys
72 chkconfig vsys on
73 if [ "$PL_BOOTCD" != "1" ] ; then
74     service vsys restart
75 fi
76
77 %postun
78
79 %changelog
80 * Tue Feb 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-3
81 - only cosmetic changes
82
83 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-2
84 - split the vsyssh package in a separate specfile
85 - so we can preinstall vsyssh in the sliver space
86
87 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-1
88 - vsyssh is a simple shell to use vsys through, in the vsys-vsyssh rpm
89 - fix build dep to require ocaml-ocamldoc instead of ocaml-docs
90
91 * Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
92 - Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
93 - git/master.
94
95 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
96 - fix build for f12
97
98 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
99 - The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous
100  version of vsys.
101
102 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
103 - Getting rid of factory scripts from the main vsys. They now live elsewhere.
104
105 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
106 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
107 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
108 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
109 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
110 - vsys-factory/bm_socket for more details.
111 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
112 - stability audit.
113 - * Version 0.95 (trunk) is the new development version.
114
115 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
116 - Tagging to force an update.
117
118 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
119
120 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
121
122 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
123
124 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
125 - Tagging a trivial fix.
126
127 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
128 - includes new portsummary script for CoMon
129
130 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
131 - trying to fix the taglevel relative to the branch name
132
133 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
134 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
135
136 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
137 - * Don't kill vsys twice on restarts, do it only once
138 - * Restart vsys following a reinstall
139
140 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
141 - Usability changes that are necessary for the stability of CoMon
142
143 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
144 - added patch to pl-ps needed by slicestat
145 -
146 -
147
148 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
149 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
150
151 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
152 - accept '-' in filenames also
153 -
154
155 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
156 - don't overwrite the config file that already exists.
157 -
158
159 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
160 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
161 -
162 -
163
164 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
165 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for
166 - it to show up in all slices.
167 -
168 -
169
170 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
171 - Added a vsys script for CoMon.
172 -
173
174 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
175 - ignore non-existent directories after restart.
176 -
177
178 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
179 - added logrotate configuration to package.
180 -
181
182 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
183 - Added two new scripts for CoMon on 4.2
184 -
185
186 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
187 -
188 - Corrected directory that the script mounts to the correct one:
189 - /var/local/fprobe
190 -
191
192 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
193 - Pulling the latest changes for the 4.2rc2 release
194 -
195
196 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
197 - * daemonization, writing to a logfile, and saving the pid
198 -