Build a vsyssh package.
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define url $URL$
10
11 %define name vsys
12 %define version 0.99
13 %define taglevel 0
14
15 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
21
22 Summary: Vsys filesystem 
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: GPL
27 Group: System Environment/Kernel
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
29 #Requires: 
30 BuildRequires: inotify-tools-devel
31 BuildRequires: ocaml
32 BuildRequires: ocaml-docs
33
34 Source0: vsys-%{version}.tar.gz
35
36 %description
37 vsys is a file-system-based interface that lets slices on PlanetLab safely
38 invoke services installed by the PlanetLab administration. Slices invoke and
39 interact with these services through fifo pipes. Services can be added and
40 removed dynamically.
41
42 %package -n vsyssh
43 Summary: Vsys client
44 Group: System Environment/Libraries
45
46 %description -n vsyssh
47 vsyssh is a simple shell to use vsys through.
48
49 %prep
50 %setup
51
52 %build
53 rm -rf $RPM_BUILD_ROOT
54 make
55 make -C vsyssh
56
57 %install
58 mkdir -p $RPM_BUILD_ROOT/usr/bin
59 mkdir -p $RPM_BUILD_ROOT/etc/init.d
60 mkdir -p $RPM_BUILD_ROOT/vsys
61 #cp factory/* $RPM_BUILD_ROOT/vsys
62 cp -p vsys $RPM_BUILD_ROOT/usr/bin
63 cp -p vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
64 cp -p vsys.conf $RPM_BUILD_ROOT/etc
65 cp -p vsyssh/vsyssh $RPM_BUILD_ROOT/usr/bin
66
67 install -D -p -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
68
69 %clean
70 rm -rf $RPM_BUILD_ROOT
71
72 %files
73 %defattr(-,root,root,-)
74 /usr/bin/vsys
75 /etc/init.d/vsys
76 /vsys
77 %config(noreplace) /etc/vsys.conf
78 %{_sysconfdir}/logrotate.d/vsys
79
80 %files -n vsyssh
81 %defattr(-,root,root,-)
82 /usr/bin/vsyssh
83
84 %post
85 chkconfig --add vsys
86 chkconfig vsys on
87 if [ "$PL_BOOTCD" != "1" ] ; then
88         service vsys restart
89 fi
90
91 %postun
92
93 %changelog
94 * Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
95 - Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
96 - git/master.
97
98 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
99 - fix build for f12
100
101 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
102 - The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous
103  version of vsys.
104
105 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
106 - Getting rid of factory scripts from the main vsys. They now live elsewhere.
107
108 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
109 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
110 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
111 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
112 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
113 - vsys-factory/bm_socket for more details.
114 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
115 - stability audit.
116 - * Version 0.95 (trunk) is the new development version.
117
118 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
119 - Tagging to force an update.
120
121 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
122
123 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
124
125 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
126
127 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
128 - Tagging a trivial fix.
129
130 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
131 - includes new portsummary script for CoMon
132
133 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
134 - trying to fix the taglevel relative to the branch name
135
136 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
137 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
138
139 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
140 - * Don't kill vsys twice on restarts, do it only once
141 - * Restart vsys following a reinstall
142
143 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
144 - Usability changes that are necessary for the stability of CoMon
145
146 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
147 - added patch to pl-ps needed by slicestat
148
149
150
151 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
152 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
153
154 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
155 - accept '-' in filenames also
156
157
158 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
159 - don't overwrite the config file that already exists.
160
161
162 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
163 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
164
165
166
167 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
168 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
169 - it to show up in all slices.
170
171
172
173 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
174 - Added a vsys script for CoMon.
175
176
177 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
178 - ignore non-existent directories after restart.
179
180
181 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
182 - added logrotate configuration to package.
183
184
185 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
186 - Added two new scripts for CoMon on 4.2
187
188
189 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
190
191 - Corrected directory that the script mounts to the correct one:
192 - /var/local/fprobe
193
194
195 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
196 - Pulling the latest changes for the 4.2rc2 release
197
198
199 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
200 - * daemonization, writing to a logfile, and saving the pid
201
202