fix URL in specfile - rm svn-keywords
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5
6 %define name vsys
7 %define version 0.9
8 %define taglevel 5
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Vsys filesystem 
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Kernel
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 #Requires: 
25 BuildRequires: inotify-tools-devel
26 BuildRequires: ocaml
27 BuildRequires: ocaml-ocamldoc
28
29 Source0: vsys-%{version}.tar.gz
30
31 %description
32 vsys is a file-system-based interface that lets slices on PlanetLab safely
33 invoke services installed by the PlanetLab administration. Slices invoke and
34 interact with these services through fifo pipes. Services can be added and
35 removed dynamically.
36
37 %prep
38 %setup
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42 make
43
44 %install
45 mkdir -p $RPM_BUILD_ROOT/usr/bin
46 mkdir -p $RPM_BUILD_ROOT/etc/init.d
47 mkdir -p $RPM_BUILD_ROOT/vsys
48 #cp factory/* $RPM_BUILD_ROOT/vsys
49 cp vsys $RPM_BUILD_ROOT/usr/bin
50 cp vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
51 cp vsys.conf $RPM_BUILD_ROOT/etc
52
53 install -D -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 /usr/bin/vsys
60 /etc/init.d/vsys
61 /vsys
62 %config(noreplace) /etc/vsys.conf
63 %{_sysconfdir}/logrotate.d/vsys
64
65 %post
66 chkconfig --add vsys
67 chkconfig vsys on
68 if [ "$PL_BOOTCD" != "1" ] ; then
69         service vsys restart
70 fi
71
72 %postun
73
74 %changelog
75 * Mon Jul 05 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - vsys-0.9-5
76 - fix dependencies and docs generation
77
78 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
79 - fix build for f12
80
81 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
82 - The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous version of vsys.
83
84 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
85 - Getting rid of factory scripts from the main vsys. They now live elsewhere.
86
87 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
88 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
89 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
90 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
91 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
92 - vsys-factory/bm_socket for more details.
93 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
94 - stability audit.
95 - * Version 0.95 (trunk) is the new development version.
96
97 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
98 - Tagging to force an update.
99
100 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
101
102 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
103
104 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
105
106 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
107 - Tagging a trivial fix.
108
109 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
110 - includes new portsummary script for CoMon
111
112 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
113 - trying to fix the taglevel relative to the branch name
114
115 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
116 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
117
118 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
119 - * Don't kill vsys twice on restarts, do it only once
120 - * Restart vsys following a reinstall
121
122 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
123 - Usability changes that are necessary for the stability of CoMon
124
125 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
126 - added patch to pl-ps needed by slicestat
127
128
129
130 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
131 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
132
133 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
134 - accept '-' in filenames also
135
136
137 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
138 - don't overwrite the config file that already exists.
139
140
141 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
142 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
143
144
145
146 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
147 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
148 - it to show up in all slices.
149
150
151
152 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
153 - Added a vsys script for CoMon.
154
155
156 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
157 - ignore non-existent directories after restart.
158
159
160 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
161 - added logrotate configuration to package.
162
163
164 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
165 - Added two new scripts for CoMon on 4.2
166
167
168 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
169
170 - Corrected directory that the script mounts to the correct one:
171 - /var/local/fprobe
172
173
174 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
175 - Pulling the latest changes for the 4.2rc2 release
176
177
178 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
179 - * daemonization, writing to a logfile, and saving the pid
180
181