cc42bf595bf7309cc3b63f1bf456e53a9cca8d1c
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define url $URL$
10
11 %define name vsys
12 %define version 0.9
13 %define taglevel 1
14
15 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
21
22 Summary: Vsys filesystem 
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: GPL
27 Group: System Environment/Kernel
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
29 #Requires: 
30 BuildRequires: inotify-tools-devel
31 BuildRequires: ocaml
32 BuildRequires: ocaml-docs
33
34 Source0: vsys-%{version}.tar.gz
35
36 %description
37 vsys is a file-system-based interface that lets slices on PlanetLab safely
38 invoke services installed by the PlanetLab administration. Slices invoke and
39 interact with these services through fifo pipes. Services can be added and
40 removed dynamically.
41
42 %prep
43 %setup
44
45 %build
46 rm -rf $RPM_BUILD_ROOT
47 make
48
49 %install
50 mkdir -p $RPM_BUILD_ROOT/usr/bin
51 mkdir -p $RPM_BUILD_ROOT/etc/init.d
52 mkdir -p $RPM_BUILD_ROOT/vsys
53 #cp factory/* $RPM_BUILD_ROOT/vsys
54 cp vsys $RPM_BUILD_ROOT/usr/bin
55 cp vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
56 cp vsys.conf $RPM_BUILD_ROOT/etc
57
58 install -D -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 /usr/bin/vsys
65 /etc/init.d/vsys
66 /vsys/*
67 %config(noreplace) /etc/vsys.conf
68 %{_sysconfdir}/logrotate.d/vsys
69
70 %post
71 chkconfig --add vsys
72 chkconfig vsys on
73 if [ "$PL_BOOTCD" != "1" ] ; then
74         service vsys restart
75 fi
76
77 %postun
78
79 %changelog
80 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
81 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
82 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
83 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
84 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
85 - vsys-factory/bm_socket for more details.
86 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
87 - stability audit.
88 - * Version 0.95 (trunk) is the new development version.
89
90 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
91 - Tagging to force an update.
92
93 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
94
95 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
96
97 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
98
99 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
100 - Tagging a trivial fix.
101
102 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
103 - includes new portsummary script for CoMon
104
105 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
106 - trying to fix the taglevel relative to the branch name
107
108 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
109 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
110
111 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
112 - * Don't kill vsys twice on restarts, do it only once
113 - * Restart vsys following a reinstall
114
115 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
116 - Usability changes that are necessary for the stability of CoMon
117
118 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
119 - added patch to pl-ps needed by slicestat
120
121
122
123 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
124 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
125
126 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
127 - accept '-' in filenames also
128
129
130 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
131 - don't overwrite the config file that already exists.
132
133
134 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
135 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
136
137
138
139 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
140 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
141 - it to show up in all slices.
142
143
144
145 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
146 - Added a vsys script for CoMon.
147
148
149 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
150 - ignore non-existent directories after restart.
151
152
153 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
154 - added logrotate configuration to package.
155
156
157 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
158 - Added two new scripts for CoMon on 4.2
159
160
161 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
162
163 - Corrected directory that the script mounts to the correct one:
164 - /var/local/fprobe
165
166
167 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
168 - Pulling the latest changes for the 4.2rc2 release
169
170
171 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
172 - * daemonization, writing to a logfile, and saving the pid
173
174