take vsyssh rpm out of vsys specfile into new vsyssh.spec
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5
6 %define name vsys
7 %define version 0.99
8 %define taglevel 1
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Vsys filesystem 
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Kernel
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 #Requires: 
25 BuildRequires: inotify-tools-devel
26 BuildRequires: ocaml
27 BuildRequires: ocaml-ocamldoc
28
29 Source0: vsys-%{version}.tar.gz
30
31 %description
32 vsys is a file-system-based interface that lets slices on PlanetLab safely
33 invoke services installed by the PlanetLab administration. Slices invoke and
34 interact with these services through fifo pipes. Services can be added and
35 removed dynamically.
36
37 %prep
38 %setup
39
40 %build
41 rm -rf $RPM_BUILD_ROOT
42 make
43
44 %install
45 mkdir -p $RPM_BUILD_ROOT/usr/bin
46 mkdir -p $RPM_BUILD_ROOT/etc/init.d
47 mkdir -p $RPM_BUILD_ROOT/vsys
48 #cp factory/* $RPM_BUILD_ROOT/vsys
49 cp -p vsys $RPM_BUILD_ROOT/usr/bin
50 cp -p vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
51 cp -p vsys.conf $RPM_BUILD_ROOT/etc
52
53 install -D -p -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(-,root,root,-)
60 /usr/bin/vsys
61 /etc/init.d/vsys
62 /vsys
63 %config(noreplace) /etc/vsys.conf
64 %{_sysconfdir}/logrotate.d/vsys
65
66 %post
67 chkconfig --add vsys
68 chkconfig vsys on
69 if [ "$PL_BOOTCD" != "1" ] ; then
70         service vsys restart
71 fi
72
73 %postun
74
75 %changelog
76 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-1
77 - vsyssh is a simple shell to use vsys through, in the vsys-vsyssh rpm
78 - fix build dep to require ocaml-ocamldoc instead of ocaml-docs
79
80 * Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
81 - Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
82 - git/master.
83
84 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
85 - fix build for f12
86
87 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
88 - The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous
89  version of vsys.
90
91 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
92 - Getting rid of factory scripts from the main vsys. They now live elsewhere.
93
94 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
95 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
96 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
97 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
98 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
99 - vsys-factory/bm_socket for more details.
100 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
101 - stability audit.
102 - * Version 0.95 (trunk) is the new development version.
103
104 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
105 - Tagging to force an update.
106
107 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
108
109 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
110
111 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
112
113 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
114 - Tagging a trivial fix.
115
116 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
117 - includes new portsummary script for CoMon
118
119 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
120 - trying to fix the taglevel relative to the branch name
121
122 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
123 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
124
125 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
126 - * Don't kill vsys twice on restarts, do it only once
127 - * Restart vsys following a reinstall
128
129 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
130 - Usability changes that are necessary for the stability of CoMon
131
132 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
133 - added patch to pl-ps needed by slicestat
134
135
136
137 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
138 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
139
140 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
141 - accept '-' in filenames also
142
143
144 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
145 - don't overwrite the config file that already exists.
146
147
148 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
149 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
150
151
152
153 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
154 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
155 - it to show up in all slices.
156
157
158
159 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
160 - Added a vsys script for CoMon.
161
162
163 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
164 - ignore non-existent directories after restart.
165
166
167 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
168 - added logrotate configuration to package.
169
170
171 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
172 - Added two new scripts for CoMon on 4.2
173
174
175 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
176
177 - Corrected directory that the script mounts to the correct one:
178 - /var/local/fprobe
179
180
181 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
182 - Pulling the latest changes for the 4.2rc2 release
183
184
185 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
186 - * daemonization, writing to a logfile, and saving the pid
187
188