Setting tag vsys-0.99-1
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5
6 %define name vsys
7 %define version 0.99
8 %define taglevel 1
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Vsys filesystem 
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Kernel
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24 #Requires: 
25 BuildRequires: inotify-tools-devel
26 BuildRequires: ocaml
27 BuildRequires: ocaml-ocamldoc
28
29 Source0: vsys-%{version}.tar.gz
30
31 %description
32 vsys is a file-system-based interface that lets slices on PlanetLab safely
33 invoke services installed by the PlanetLab administration. Slices invoke and
34 interact with these services through fifo pipes. Services can be added and
35 removed dynamically.
36
37 %package -n vsyssh
38 Summary: Vsys client
39 Group: System Environment/Libraries
40
41 %description -n vsyssh
42 vsyssh is a simple shell to use vsys through.
43
44 %prep
45 %setup
46
47 %build
48 rm -rf $RPM_BUILD_ROOT
49 make
50 make -C vsyssh
51
52 %install
53 mkdir -p $RPM_BUILD_ROOT/usr/bin
54 mkdir -p $RPM_BUILD_ROOT/etc/init.d
55 mkdir -p $RPM_BUILD_ROOT/vsys
56 #cp factory/* $RPM_BUILD_ROOT/vsys
57 cp -p vsys $RPM_BUILD_ROOT/usr/bin
58 cp -p vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
59 cp -p vsys.conf $RPM_BUILD_ROOT/etc
60 cp -p vsyssh/vsyssh $RPM_BUILD_ROOT/usr/bin
61
62 install -D -p -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(-,root,root,-)
69 /usr/bin/vsys
70 /etc/init.d/vsys
71 /vsys
72 %config(noreplace) /etc/vsys.conf
73 %{_sysconfdir}/logrotate.d/vsys
74
75 %files -n vsyssh
76 %defattr(-,root,root,-)
77 /usr/bin/vsyssh
78
79 %post
80 chkconfig --add vsys
81 chkconfig vsys on
82 if [ "$PL_BOOTCD" != "1" ] ; then
83         service vsys restart
84 fi
85
86 %postun
87
88 %changelog
89 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-1
90 - vsyssh is a simple shell to use vsys through, in the vsys-vsyssh rpm
91 - fix build dep to require ocaml-ocamldoc instead of ocaml-docs
92
93 * Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
94 - Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
95 - git/master.
96
97 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
98 - fix build for f12
99
100 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
101 - The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous
102  version of vsys.
103
104 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
105 - Getting rid of factory scripts from the main vsys. They now live elsewhere.
106
107 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
108 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
109 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
110 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
111 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
112 - vsys-factory/bm_socket for more details.
113 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
114 - stability audit.
115 - * Version 0.95 (trunk) is the new development version.
116
117 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
118 - Tagging to force an update.
119
120 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
121
122 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
123
124 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
125
126 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
127 - Tagging a trivial fix.
128
129 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
130 - includes new portsummary script for CoMon
131
132 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
133 - trying to fix the taglevel relative to the branch name
134
135 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
136 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
137
138 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
139 - * Don't kill vsys twice on restarts, do it only once
140 - * Restart vsys following a reinstall
141
142 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
143 - Usability changes that are necessary for the stability of CoMon
144
145 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
146 - added patch to pl-ps needed by slicestat
147
148
149
150 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
151 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
152
153 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
154 - accept '-' in filenames also
155
156
157 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
158 - don't overwrite the config file that already exists.
159
160
161 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
162 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
163
164
165
166 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
167 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
168 - it to show up in all slices.
169
170
171
172 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
173 - Added a vsys script for CoMon.
174
175
176 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
177 - ignore non-existent directories after restart.
178
179
180 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
181 - added logrotate configuration to package.
182
183
184 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
185 - Added two new scripts for CoMon on 4.2
186
187
188 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
189
190 - Corrected directory that the script mounts to the correct one:
191 - /var/local/fprobe
192
193
194 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
195 - Pulling the latest changes for the 4.2rc2 release
196
197
198 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
199 - * daemonization, writing to a logfile, and saving the pid
200
201