Cleaned up a bit
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id$
7 #
8
9 %define url $URL$
10
11 %define name vsys
12 %define version 0.9
13 %define taglevel 0
14
15 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
16
17 Vendor: PlanetLab
18 Packager: PlanetLab Central <support@planet-lab.org>
19 Distribution: PlanetLab %{plrelease}
20 URL: %(echo %{url} | cut -d ' ' -f 2)
21
22 Summary: Vsys filesystem 
23 Name: %{name}
24 Version: %{version}
25 Release: %{release}
26 License: GPL
27 Group: System Environment/Kernel
28 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
29 #Requires: 
30 BuildRequires: inotify-tools-devel
31 BuildRequires: ocaml
32 BuildRequires: ocaml-docs
33
34 Source0: vsys-%{version}.tar.gz
35
36 %description
37 vsys is a file-system-based interface that lets slices on PlanetLab safely
38 invoke services installed by the PlanetLab administration. Slices invoke and
39 interact with these services through fifo pipes. Services can be added and
40 removed dynamically.
41
42 %prep
43 %setup
44
45 %build
46 rm -rf $RPM_BUILD_ROOT
47 make
48
49 %install
50 mkdir -p $RPM_BUILD_ROOT/usr/bin
51 mkdir -p $RPM_BUILD_ROOT/etc/init.d
52 mkdir -p $RPM_BUILD_ROOT/vsys
53 cp factory/* $RPM_BUILD_ROOT/vsys
54 cp vsys $RPM_BUILD_ROOT/usr/bin
55 cp vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
56 cp vsys.conf $RPM_BUILD_ROOT/etc
57
58 install -D -m 644 vsys.logrotate $RPM_BUILD_ROOT/%{_sysconfdir}/logrotate.d/vsys
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 /usr/bin/vsys
65 /etc/init.d/vsys
66 /vsys/*
67 %config(noreplace) /etc/vsys.conf
68 %{_sysconfdir}/logrotate.d/vsys
69
70 %post
71 chkconfig --add vsys
72 chkconfig vsys on
73 if [ "$PL_BOOTCD" != "1" ] ; then
74         service vsys restart
75 fi
76
77 %postun
78
79 %changelog
80 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
81 - Tagging to force an update.
82
83 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
84
85 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
86
87 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
88
89 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
90 - Tagging a trivial fix.
91
92 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
93 - includes new portsummary script for CoMon
94
95 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
96 - trying to fix the taglevel relative to the branch name
97
98 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
99 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
100
101 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
102 - * Don't kill vsys twice on restarts, do it only once
103 - * Restart vsys following a reinstall
104
105 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
106 - Usability changes that are necessary for the stability of CoMon
107
108 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
109 - added patch to pl-ps needed by slicestat
110
111
112
113 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
114 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
115
116 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
117 - accept '-' in filenames also
118
119
120 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
121 - don't overwrite the config file that already exists.
122
123
124 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
125 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
126
127
128
129 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
130 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
131 - it to show up in all slices.
132
133
134
135 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
136 - Added a vsys script for CoMon.
137
138
139 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
140 - ignore non-existent directories after restart.
141
142
143 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
144 - added logrotate configuration to package.
145
146
147 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
148 - Added two new scripts for CoMon on 4.2
149
150
151 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
152
153 - Corrected directory that the script mounts to the correct one:
154 - /var/local/fprobe
155
156
157 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
158 - Pulling the latest changes for the 4.2rc2 release
159
160
161 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
162 - * daemonization, writing to a logfile, and saving the pid
163
164