Explicitly require various rpm packages in order to build this vsys.
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id: vsys.spec,v 1.40 2007/04/03 02:08:55 mef Exp $
7 #
8
9 %define name vsys
10 %define version 0.6
11 %define release 2%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Vendor: PlanetLab
14 Packager: PlanetLab Central <support@planet-lab.org>
15 Distribution: PlanetLab 4.0
16 URL: http://cvs.planet-lab.org/cvs/vsys
17
18 Summary: Vsys filesystem 
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: GPL
23 Group: System Environment/Kernel
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
25 #Requires: 
26 BuildRequires: inotify-tools-devel
27 BuildRequires: ocaml
28 BuildRequires: ocaml-ocamldocs
29
30 Source0: vsys-%{version}.tar.gz
31
32 %description
33 vsys is a file-system-based interface that lets slices on PlanetLab safely
34 invoke services installed by the PlanetLab administration. Slices invoke and
35 interact with these services through fifo pipes. Services can be added and
36 removed dynamically.
37
38 %prep
39 %setup
40
41 %build
42 rm -rf $RPM_BUILD_ROOT
43 make
44
45 %install
46 mkdir -p $RPM_BUILD_ROOT/usr/bin
47 mkdir -p $RPM_BUILD_ROOT/etc/init.d
48 cp vsys $RPM_BUILD_ROOT/usr/bin
49 cp vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 /usr/bin/vsys
56 /etc/init.d/vsys
57
58 %post
59 chkconfig --add vsys
60 chkconfig vsys on
61
62 %postun
63
64 %changelog