(no commit message)
[vsys.git] / vsys.spec
1 #
2 # Vsys filesystem
3 #
4 # RPM spec file
5 #
6 # $Id: vsys.spec,v 1.40 2007/04/03 02:08:55 mef Exp $
7 #
8
9 %define name vsys
10 %define version 0.4
11 %define release 2%{?pldistro:.%{pldistro}}%{?date:.%{date}}
12
13 Vendor: PlanetLab
14 Packager: PlanetLab Central <support@planet-lab.org>
15 Distribution: PlanetLab 4.0
16 URL: http://cvs.planet-lab.org/cvs/vsys
17
18 Summary: Vsys filesystem 
19 Name: %{name}
20 Version: %{version}
21 Release: %{release}
22 License: GPL
23 Group: System Environment/Kernel
24 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
25 #Requires: 
26
27 Source0: vsys-%{version}.tar.gz
28
29 %description
30 vsys is a file-system-based interface that lets slices on PlanetLab safely
31 invoke services installed by the PlanetLab administration. Slices invoke and
32 interact with these services through fifo pipes. Services can be added and
33 removed dynamically.
34
35 %prep
36 %setup
37
38 %build
39 rm -rf $RPM_BUILD_ROOT
40 make
41
42 %install
43 mkdir -p $RPM_BUILD_ROOT/usr/bin
44 mkdir -p $RPM_BUILD_ROOT/etc/init.d
45 cp vsys $RPM_BUILD_ROOT/usr/bin
46 cp vsys-initscript $RPM_BUILD_ROOT/etc/init.d/vsys
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 /usr/bin/vsys
53 /etc/init.d/vsys
54
55 %post
56 chkconfig --add vsys
57 chkconfig vsys on
58
59 %postun
60
61 %changelog