768935e159091bad11f9d5b534a8e5a6183cc794
[vsys.git] / vsyssh.spec
1 #
2 # Vsys shell - sliverland utility
3 #
4 # RPM spec file
5
6 %define name vsyssh
7 %define version 0.99
8 %define taglevel 3
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Vsys shell - a sliverland vsys client
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Libraries
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24
25 Source0: vsyssh-%{version}.tar.gz
26
27 %description
28 vsyssh is a utility designed to be installed in the slivers, a helper to ease the invokation of vsys scripts.
29
30 %prep 
31 #%setup -q -n vsys-%{version} 
32 %setup
33
34 %build
35 rm -rf $RPM_BUILD_ROOT
36 make -C vsyssh
37
38 %install
39 mkdir -p $RPM_BUILD_ROOT/usr/bin
40 cp -p vsyssh/vsyssh $RPM_BUILD_ROOT/usr/bin
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(-,root,root,-)
47 /usr/bin/vsyssh
48
49 %changelog
50 * Tue Feb 26 2013 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-3
51 - only cosmetic changes
52
53 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-2
54 - split the vsyssh package in a separate specfile
55 - so we can preinstall vsyssh in the sliver space
56
57 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-1
58 - vsyssh is a simple shell to use vsys through, in the vsys-vsyssh rpm
59 - fix build dep to require ocaml-ocamldoc instead of ocaml-docs
60
61 * Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
62 - Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
63 - git/master.
64
65 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
66 - fix build for f12
67
68 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
69 - The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous
70  version of vsys.
71
72 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
73 - Getting rid of factory scripts from the main vsys. They now live elsewhere.
74
75 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
76 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
77 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
78 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
79 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
80 - vsys-factory/bm_socket for more details.
81 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
82 - stability audit.
83 - * Version 0.95 (trunk) is the new development version.
84
85 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
86 - Tagging to force an update.
87
88 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
89
90 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
91
92 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
93
94 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
95 - Tagging a trivial fix.
96
97 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
98 - includes new portsummary script for CoMon
99
100 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
101 - trying to fix the taglevel relative to the branch name
102
103 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
104 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
105
106 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
107 - * Don't kill vsys twice on restarts, do it only once
108 - * Restart vsys following a reinstall
109
110 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
111 - Usability changes that are necessary for the stability of CoMon
112
113 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
114 - added patch to pl-ps needed by slicestat
115
116
117
118 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
119 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
120
121 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
122 - accept '-' in filenames also
123
124
125 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
126 - don't overwrite the config file that already exists.
127
128
129 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
130 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
131
132
133
134 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
135 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
136 - it to show up in all slices.
137
138
139
140 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
141 - Added a vsys script for CoMon.
142
143
144 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
145 - ignore non-existent directories after restart.
146
147
148 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
149 - added logrotate configuration to package.
150
151
152 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
153 - Added two new scripts for CoMon on 4.2
154
155
156 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
157
158 - Corrected directory that the script mounts to the correct one:
159 - /var/local/fprobe
160
161
162 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
163 - Pulling the latest changes for the 4.2rc2 release
164
165
166 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
167 - * daemonization, writing to a logfile, and saving the pid
168
169