Setting tag vsys-0.99-2
[vsys.git] / vsyssh.spec
1 #
2 # Vsys shell - sliverland utility
3 #
4 # RPM spec file
5
6 %define name vsyssh
7 %define version 0.99
8 %define taglevel 2
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Vsys shell - a sliverland vsys client
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Libraries
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24
25 Source0: vsyssh-%{version}.tar.gz
26
27 %description
28 vsyssh is a utility designed to be installed in the slivers, a helper to ease the invokation of vsys scripts.
29
30 %prep 
31 #%setup -q -n vsys-%{version} 
32 %setup
33
34 %build
35 rm -rf $RPM_BUILD_ROOT
36 make -C vsyssh
37
38 %install
39 mkdir -p $RPM_BUILD_ROOT/usr/bin
40 cp -p vsyssh/vsyssh $RPM_BUILD_ROOT/usr/bin
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %files
46 %defattr(-,root,root,-)
47 /usr/bin/vsyssh
48
49 %changelog
50 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-2
51 - split the vsyssh package in a separate specfile
52 - so we can preinstall vsyssh in the sliver space
53
54 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-1
55 - vsyssh is a simple shell to use vsys through, in the vsys-vsyssh rpm
56 - fix build dep to require ocaml-ocamldoc instead of ocaml-docs
57
58 * Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
59 - Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
60 - git/master.
61
62 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
63 - fix build for f12
64
65 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
66 - The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous
67  version of vsys.
68
69 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
70 - Getting rid of factory scripts from the main vsys. They now live elsewhere.
71
72 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
73 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
74 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
75 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
76 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
77 - vsys-factory/bm_socket for more details.
78 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
79 - stability audit.
80 - * Version 0.95 (trunk) is the new development version.
81
82 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
83 - Tagging to force an update.
84
85 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
86
87 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
88
89 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
90
91 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
92 - Tagging a trivial fix.
93
94 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
95 - includes new portsummary script for CoMon
96
97 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
98 - trying to fix the taglevel relative to the branch name
99
100 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
101 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
102
103 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
104 - * Don't kill vsys twice on restarts, do it only once
105 - * Restart vsys following a reinstall
106
107 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
108 - Usability changes that are necessary for the stability of CoMon
109
110 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
111 - added patch to pl-ps needed by slicestat
112
113
114
115 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
116 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
117
118 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
119 - accept '-' in filenames also
120
121
122 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
123 - don't overwrite the config file that already exists.
124
125
126 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
127 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
128
129
130
131 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
132 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
133 - it to show up in all slices.
134
135
136
137 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
138 - Added a vsys script for CoMon.
139
140
141 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
142 - ignore non-existent directories after restart.
143
144
145 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
146 - added logrotate configuration to package.
147
148
149 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
150 - Added two new scripts for CoMon on 4.2
151
152
153 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
154
155 - Corrected directory that the script mounts to the correct one:
156 - /var/local/fprobe
157
158
159 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
160 - Pulling the latest changes for the 4.2rc2 release
161
162
163 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
164 - * daemonization, writing to a logfile, and saving the pid
165
166