take vsyssh rpm out of vsys specfile into new vsyssh.spec
[vsys.git] / vsyssh.spec
1 #
2 # Vsys shell - sliverland utility
3 #
4 # RPM spec file
5
6 %define name vsyssh
7 %define version 0.99
8 %define taglevel 1
9
10 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
11
12 Vendor: PlanetLab
13 Packager: PlanetLab Central <support@planet-lab.org>
14 Distribution: PlanetLab %{plrelease}
15 URL: %{SCMURL}
16
17 Summary: Vsys shell - a sliverland vsys client
18 Name: %{name}
19 Version: %{version}
20 Release: %{release}
21 License: GPL
22 Group: System Environment/Libraries
23 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
24
25 Source0: vsys-%{version}.tar.gz
26
27 %description
28 vsyssh is a utility designed to be installed in the slivers, a helper to ease the invokation of vsys scripts.
29
30 %prep 
31 %setup -q -n vsys-%{version} 
32
33 %build
34 rm -rf $RPM_BUILD_ROOT
35 make -C vsyssh
36
37 %install
38 mkdir -p $RPM_BUILD_ROOT/usr/bin
39 cp -p vsyssh/vsyssh $RPM_BUILD_ROOT/usr/bin
40
41 %clean
42 rm -rf $RPM_BUILD_ROOT
43
44 %files
45 %defattr(-,root,root,-)
46 /usr/bin/vsyssh
47
48 %changelog
49 * Thu Jan 27 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.99-1
50 - vsyssh is a simple shell to use vsys through, in the vsys-vsyssh rpm
51 - fix build dep to require ocaml-ocamldoc instead of ocaml-docs
52
53 * Thu Dec 16 2010 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.99-0
54 - Fixed a memory leak, mainly. The other changes are simply commits that got lost between the move from svn/head to
55 - git/master.
56
57 * Sun Dec 27 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.9-4
58 - fix build for f12
59
60 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-3
61 - The previous tag (0.9-2) doesn't build. This one is tested to build and install (or rather, upgrade) fine with the previous
62  version of vsys.
63
64 * Mon May 18 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-2
65 - Getting rid of factory scripts from the main vsys. They now live elsewhere.
66
67 * Tue Mar 31 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.9-1
68 - * The main change in version 0.9 is file-descriptor passing support. The way this works in Vsys is that you write a
69 - script whose name has the prefix "fd_". Such scripts show up within slices as ".control" files and can be used to
70 - exchange file descriptors with root context. Vsys scripts inherit the socket that corresponds to this channel, so they
71 - do not need to deal with connection setup and teardown. Please see vsys-wrappers/ and vsys-factory/fuse,
72 - vsys-factory/bm_socket for more details.
73 - * Version 0.9 is the current stable version of Vsys. It has a fix for a vulnerability in 0.7, and has undergone a
74 - stability audit.
75 - * Version 0.95 (trunk) is the new development version.
76
77 * Tue Feb 24 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-26
78 - Tagging to force an update.
79
80 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-25
81
82 * Fri Feb 20 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-24
83
84 * Thu Feb 19 2009 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-23
85
86 * Tue Sep 30 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-22
87 - Tagging a trivial fix.
88
89 * Thu Sep 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-21
90 - includes new portsummary script for CoMon
91
92 * Mon Aug 11 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-20
93 - trying to fix the taglevel relative to the branch name
94
95 * Thu Jul 17 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-18
96 - Change for someone at Imperial.ac.uk, who wants access to Netflow data.
97
98 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-17
99 - * Don't kill vsys twice on restarts, do it only once
100 - * Restart vsys following a reinstall
101
102 * Wed Jul 02 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - vsys-0.7-16
103 - Usability changes that are necessary for the stability of CoMon
104
105 * Wed Jun 25 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-15
106 - added patch to pl-ps needed by slicestat
107
108
109
110 * Mon Jun 23 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-14
111 - This change is an attempt to fix unexpected blocking after many days of uptime, reported by KyoungSoo.
112
113 * Thu Jun 19 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-13
114 - accept '-' in filenames also
115
116
117 * Wed Jun 18 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-12
118 - don't overwrite the config file that already exists.
119
120
121 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-11
122 - Suppress some temp file that RPM creates frmo showing up as a vsys script.
123
124
125
126 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-10
127 - Changed a policy in vsys. When an acl is empty, the script doesn't show up in ANY slice. The previous behavior was for 
128 - it to show up in all slices.
129
130
131
132 * Wed Jun 18 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - vsys-0.7-9
133 - Added a vsys script for CoMon.
134
135
136 * Mon Jun 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-8
137 - ignore non-existent directories after restart.
138
139
140 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-7
141 - added logrotate configuration to package.
142
143
144 * Mon May 12 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-6
145 - Added two new scripts for CoMon on 4.2
146
147
148 * Tue May 06 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-5
149
150 - Corrected directory that the script mounts to the correct one:
151 - /var/local/fprobe
152
153
154 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - vsys-0.7-4
155 - Pulling the latest changes for the 4.2rc2 release
156
157
158 * Fri Feb 15 2008 Faiyaz Ahmed <faiyaza@cs.princeton.edu> - vsys-0.7-2 vsys-0.7-3
159 - * daemonization, writing to a logfile, and saving the pid
160
161