a23b33cb32c2ac87d53e6d05cc9264bc697f9732
[yum.git] / original / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2  
3 Summary: RPM installer/updater
4 Name: yum
5 Version: 3.2.27
6 Release: 14%{?dist}
7 License: GPLv2+
8 Group: System Environment/Base
9 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
10 Source1: yum.conf.fedora
11 Source2: yum-updatesd.conf.fedora
12 Patch0: installonlyn-enable.patch
13 Patch1: yum-mirror-priority.patch
14 Patch2: yum-manpage-files.patch
15 Patch3: yum-multilib-policy-best.patch
16 Patch4: no-more-exactarchlist.patch
17 Patch5: geode-arch.patch
18 Patch6: BZ-528738-bugtracker.patch
19
20 Patch32: yum-distro-sync.patch
21 Patch33: yum-install-cmd-exit+provides-msgs+docs.patch
22 Patch34: yum-history-user.patch
23 Patch35: yum-PK-search-API.patch
24 Patch36: yum-history-list-errors+summary-user-column.patch
25 Patch37: yum-groupremove-leaf-only.patch
26 Patch38: yum-md-reget+yumvars+searchPrco.patch
27
28 Patch39: BZ-588911-yum.log-perms.patch
29 Patch40: BZ-577627-installroot-double-prefix.patch
30 Patch41: BZ-588910-nocontext-tsflag.patch
31 Patch42: BZ-588908-many-install-update-speedup.patch
32 Patch43: BZ-590340-move-rpmdb-from-cache.patch
33 Patch44: BZ-590339-edge-case-depsolving.patch
34 Patch45: BZ-593522-install-obs-arch.patch
35 Patch46: BZ-595553-akmods-cache-defense.patch
36 Patch47: BZ-602354-plugin-hooks-verify-transaction.patch
37 Patch48: BZ-584262-downgrade-dep-chain-remove.patch
38 Patch49: BZ-572770-int-flags-miscutils.patch
39 Patch50: BZ-598639-rpm-bindings-api-change-fix.patch
40 Patch51: BZ-603002-group_remove_leaf-empty-transaction.patch
41 Patch52: BZ-604080-localinstall-obsoleted.patch
42 Patch53: BZ-614496-traceback-no-proc-mounted.patch
43
44
45 Patch64: yum-ppc64-preferred.patch
46 Patch65: yum-3.2.27-i18n-off.patch
47
48 URL: http://yum.baseurl.org/
49 BuildArch: noarch
50 BuildRequires: python
51 BuildRequires: gettext
52 BuildRequires: intltool
53 Conflicts: pirut < 1.1.4
54 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
55 Requires: python-iniparse
56 Requires: python-sqlite
57 Requires: python-urlgrabber >= 3.9.0-8
58 Requires: yum-metadata-parser >= 1.1.0
59 Requires: pygpgme
60 Obsoletes: yum-skip-broken, yum-basearchonly
61 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
62
63 %description
64 Yum is a utility that can check for and automatically download and
65 install updated RPM packages. Dependencies are obtained and downloaded 
66 automatically prompting the user as necessary.
67
68 %package updatesd
69 Summary: Update notification daemon
70 Group: Applications/System
71 Requires: yum = %{version}-%{release}
72 Requires: dbus-python
73 Requires: pygobject2
74 Requires(preun): /sbin/chkconfig
75 Requires(post): /sbin/chkconfig
76 Requires(preun): /sbin/service
77 Requires(post): /sbin/service
78
79 %description updatesd
80 yum-updatesd provides a daemon which checks for available updates and 
81 can notify you when they are available via email, syslog or dbus. 
82
83 %prep
84 %setup -q
85 %patch1 -p0
86 %patch2 -p1
87 %patch3 -p0
88 %patch4 -p0
89 %patch5 -p1
90 %patch6 -p1
91 %patch32 -p1
92 %patch33 -p1
93 %patch34 -p1
94 %patch35 -p1
95 %patch36 -p1
96 %patch37 -p1
97 %patch38 -p1
98 %patch39 -p1
99 %patch40 -p1
100 %patch41 -p1
101 %patch42 -p1
102 %patch43 -p1
103 %patch44 -p1
104 %patch45 -p1
105 %patch46 -p1
106 %patch47 -p1
107 %patch48 -p1
108 %patch49 -p1
109 %patch50 -p1
110 %patch51 -p1
111 %patch52 -p1
112 %patch53 -p1
113 %patch64 -p0
114 %patch65 -p1
115
116 %build
117 make
118
119 %install
120 rm -rf $RPM_BUILD_ROOT
121 make DESTDIR=$RPM_BUILD_ROOT install
122 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/yum.conf
123 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
124
125 # for now, move repodir/yum.conf back
126 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
127 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
128
129 # yum-updatesd has moved to the separate source version
130 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
131 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
132 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
133 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
134 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
135 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
136
137 # Ghost files:
138 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/history
139 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/plugins
140 mkdir -p $RPM_BUILD_ROOT/var/lib/yum/yumdb
141 touch $RPM_BUILD_ROOT/var/lib/yum/uuid
142
143 %find_lang %name
144
145 %clean
146 rm -rf $RPM_BUILD_ROOT
147
148 %files -f %{name}.lang
149 %defattr(-, root, root, -)
150 %doc README AUTHORS COPYING TODO INSTALL ChangeLog
151 %config(noreplace) %{_sysconfdir}/yum.conf
152 %dir %{_sysconfdir}/yum
153 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
154 # %dir %{_sysconfdir}/yum/protected.d
155 %dir %{_sysconfdir}/yum.repos.d
156 %dir %{_sysconfdir}/yum/vars
157 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
158 %{_sysconfdir}/bash_completion.d
159 %dir %{_datadir}/yum-cli
160 %{_datadir}/yum-cli/*
161 %{_bindir}/yum
162 %{python_sitelib}/yum
163 %{python_sitelib}/rpmUtils
164 %dir /var/cache/yum
165 %dir /var/lib/yum
166 %ghost /var/lib/yum/uuid
167 %ghost /var/lib/yum/history
168 %ghost /var/lib/yum/plugins
169 %ghost /var/lib/yum/yumdb
170 %{_mandir}/man*/yum.*
171 %{_mandir}/man*/yum-shell*
172 # plugin stuff
173 %dir %{_sysconfdir}/yum/pluginconf.d 
174 %dir /usr/lib/yum-plugins
175
176 %changelog
177 * Tue Aug 24 2010 Seth Vidal <svidal@redhat.com> - 3.2.27-14
178 - fixed 588911 patch to be correct patch
179 - add patch file for 572770 to take the old date from the wrong patch from 588911
180
181 * Tue Jul 27 2010 James Antill <james.antill@redhat.com> - 3.2.27-13
182 - Don't traceback when proc isn't mounted.
183 - Resolves: rhbz#614496
184 - Own the /etc/yum/vars dir.
185 - Resolves: rhbz#611906
186
187 * Wed Jun 16 2010 James Antill <james.antill@redhat.com> - 3.2.27-12
188 - Stop allowing installation of obsoleted, only by installed.
189 - Resolves: rhbz#604080
190
191 * Fri Jun 11 2010 James Antill <james.antill@redhat.com> - 3.2.27-10
192 - Stop downgrade dep. chain removals
193 - Resolves: rhbz#584262
194 - Fix for rpm bindings api change
195 - Resolves: rhbz#598639
196 - Add plugin hooks for verify transaction pre/post.
197 - Resolves: rhbz#602354
198 - Fix groupremove_leaf_only when it empties the transaction.
199 - Resolves: rhbz#603002
200
201 * Tue May 25 2010 James Antill <james.antill@redhat.com> - 3.2.27-9
202 - Fix installs of obsoleted multiarch packages.
203 - Resolves: rhbz#593522
204 - Create a defense against akmod style postinst install hacks.
205 - Resolves: rhbz#595553
206
207 * Tue May 11 2010 James Antill <james.antill@redhat.com> - 3.2.27-8
208 - Move rpmdb cache/indexes to /var/lib
209 - Resolves: rhbz#590340
210 - Fix old missing recheck in depsolve
211 - Resolves: rhbz#590339
212
213 * Tue May  4 2010 James Antill <james.antill@redhat.com> - 3.2.27-7
214 - A few minor bugfixes from upstream
215 - yum.log perms
216 - Resolves: rhbz#588911
217 - installroot double prefixing, on anaconda/kickstart install
218 - Resolves: rhbz#577627
219 - Add nocontexts flag to tsflags, if available.
220 - Resolves: rhbz#588910
221 - Speedup many install/update of same pkg.
222 - Resolves: rhbz#588908
223 - Correct os.path.link => os.path.islink typo, for dynamic yum vars.
224 - Resolves: rhbz#588907
225
226 * Fri Apr 16 2010 James Antill <james.antill@redhat.com> - 3.2.27-4
227 - A few minor bugfixes from upstream
228 - Add dynamic FS based yumvars
229 - Resolves: rhbz#576703
230
231 * Fri Mar 26 2010 James Antill <james.antill@redhat.com> - 3.2.27-3
232 - 3.2.27 from Fedora, and a couple of minor patches
233 - Resolves: rhbz#576703
234
235 * Thu Mar 18 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-1
236 - 3.2.27 from upstream (more or less the same as 3.2.26-6 but with a new number
237
238 * Thu Mar 11 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-6
239 - should be the final HEAD update before 3.2.27
240
241 * Thu Feb 24 2010 James Antill <james@fedoraproject.org> - 3.2.26-5
242 - new HEAD, minor features and speed.
243
244 * Wed Feb 17 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-4
245 - new HEAD to fix the fix to the fix
246
247 * Tue Feb 16 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-3
248 - latest head - including fixes to searchPrcos
249
250 * Wed Feb 10 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-2
251 - grumble.
252
253 * Tue Feb  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-1
254 - final 3.2.26
255
256 * Mon Feb  8 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-14
257 - $uuid, pkgtags searching, latest HEAD patch - pre 3.2.26
258
259 * Fri Jan 28 2010 James Antill <james at fedoraproject.org> - 3.2.25-13
260 - A couple of bugfixes, most notably:
261 -  you can now install gpg keys again!
262 -  bad installed file requires don't get cached.
263
264 * Fri Jan 22 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-12
265 - someone forgot to push their changes
266
267 * Fri Jan 22 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-11
268 - more fixes, more fun
269
270 * Fri Jan 15 2010 James Antill <james at fedoraproject.org> - 3.2.25-10
271 - latest head
272 - Fixes for pungi, rpmdb caching and kernel-PAE-devel duplicates finding
273 - among others.
274
275 * Mon Jan  4 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-8
276 - latest head
277
278 * Thu Dec 10 2009 James Antill <james at fedoraproject.org> - 3.2.25-7
279 - Fixes the mash bug, lookup in the tsInfo too. :(
280 - And fix the txmbr/po confusion ... third build the charm.
281
282 * Fri Dec  4 2009 James Antill <james at fedoraproject.org> - 3.2.25-4
283 - Fixes for yum clean all, BZ 544173
284 - Also allow "yum clean rpmdb" to work, bad tester, bad.
285
286 * Thu Dec  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-2
287 - rebuild yum with latest HEAD patch
288 - add rpmdb caching patch james wrote to see if it breaks everyone :)
289
290
291 * Wed Oct 14 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-1
292 - 3.2.25
293
294 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-9
295 - revert yum. import patch b/c it breaks a bunch of things
296
297 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-8
298 - fix up broken build b/c of version-groups.conf file
299
300 * Tue Sep 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-7
301 - fixes for odd outputs from ts.run and logs for what we store in history
302
303 * Wed Sep 23 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-6
304 - new head patch - fixes some issues with history and chroots
305
306 * Mon Sep 21 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-5
307 - latest head patch - includes yum history feature.
308
309 * Tue Sep 15 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-4
310 - new head patch - translation updates and a few bug fixes
311
312 * Wed Sep  9 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-3
313 - add geode arch patch for https://bugzilla.redhat.com/show_bug.cgi?id=518415
314
315
316 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-2
317 - modify cachedir to include variables
318
319 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-1
320 - 3.2.24
321
322 * Wed Sep  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-16
323 - fix globbing issue 520810
324
325 * Mon Aug 31 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-15
326 - one more head update - fixes some fairly ugly but kind of minor bugs
327
328 * Tue Aug 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-14
329 - update to latest head pre 3.2.24
330 - add requirement on python-urlgrabber 3.9.0 and up
331
332 * Wed Aug  5 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-13
333 - latest head - right after freeze
334
335 * Tue Aug  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-12
336 - latest head - right before freeze :)
337
338 * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.23-11
339 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
340
341 * Wed Jul 22 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-10
342 - remove exactarchlist by request for rawhide
343
344 * Thu Jul  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-9
345 - update to latest head - make livecd creation work again in rawhide
346 - disable one of the man page patches until after 3.2.24 is released b/c
347   of the changes to the man page in the head patch
348
349
350 * Mon Jun 22 2009 James Antill <james at fedoraproject.org> - 3.2.23-8
351 - Update to latest head:
352 - Fix old recursion bug, found by new code.
353 - Resolves: bug#507220
354
355 * Sun Jun 21 2009 James Antill <james at fedoraproject.org> - 3.2.23-6
356 - Update to latest head:
357 - Unbreak delPackage() excludes.
358 - Other fixes/etc.
359
360 * Fri Jun 19 2009 James Antill <james at fedoraproject.org> - 3.2.23-5
361 - Actually apply the HEAD patch included yesterday :).
362
363 * Thu Jun 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-4
364 - update to latest head
365
366 * Mon Jun  8 2009 Seth Vidal <skvidal at fedoraproject.org>
367 - truncate changelog
368
369 * Wed May 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-2
370 - add patch to close rpmdb completely
371
372 * Tue May 19 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-1
373 - 3.2.23
374
375 * Mon May 11 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-5
376 - jump up to almost 3.2.23. 
377 - had to move patch0 around a bit until we rebase to 3.2.23
378
379 * Thu Apr  9 2009 James Antill <james at fedoraproject.org> - 3.2.22-4
380 - fix typo for yum-complete-transaction message.
381
382 * Wed Apr  8 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-3
383 - fix for file:// urls which makes things in pungi/mash work
384
385 * Tue Apr  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-2
386 - yum-HEAD minus the yumdb patches
387
388 * Tue Mar 24 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-1
389 - 3.2.22 - 3 patches beyond 3.2.21-16
390
391 * Mon Mar 16 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-16
392 - fix for 490490
393
394 * Fri Mar 13 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-15
395 - update to upstream git to fix conditionals problem on anaconda installs
396
397 * Thu Mar 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-14
398 - latest HEAD
399
400 * Tue Mar 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-13
401 - f11beta build
402
403 * Wed Mar  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-12
404 - second verse, same as the first
405
406 * Fri Feb 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-10
407 - merge up a lot of fixes from latest HEAD
408
409 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.21-10
410 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
411
412 * Tue Feb 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-9
413 - merge up to latest yum head - sort of a pre 3.2.22
414
415 * Wed Feb  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-8
416 - fix for YumHeaderPackages so it plays nicely w/createrepo and mergerepo, etc
417
418 * Thu Jan 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-7
419 - update HEAD patch to fix repodiff (and EVR comparisons in certain cases)
420
421 * Tue Jan 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-6
422 - patch to keep anaconda (and other callers) happy
423 - remove old 6hr patch which is now upstream
424
425 * Mon Jan 26 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-4
426 - patch to latest HEAD to test a number of fixes for alpha
427
428 * Tue Jan 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-3
429 - add a small patch to make things play a bit nicer with the logging module
430   in 2.6
431
432
433 * Wed Jan  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-1
434 - bump to 3.2.21
435
436 * Thu Dec 18 2008 James Antill <james@fedoraproject.org> - 3.2.20-8
437 - merge latest from upstream
438 - move to 6hr metadata
439
440 * Mon Dec  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-7
441 - merge patch from upstream and remove now old obsoletes patch
442
443 * Thu Dec 04 2008 Jesse Keating <jkeating@redhat.com> - 3.2.20-6
444 - Add patch from upstream to fix cases where obsoletes are disabled. (jantill)
445
446 * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.2.20-5
447 - Rebuild for Python 2.6
448
449 * Wed Nov 26 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-4
450 - update head patch
451
452 * Wed Oct 29 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-3
453 - full patch against HEAD for skipbroken fixes (among others)
454
455 * Mon Oct 27 2008 James Antill <james@fedoraproject.org> - 3.2.20-2
456 - Fix listTransaction for skipped packages.
457
458 * Mon Oct 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-1
459 - 3.2.20
460
461 * Thu Oct 23 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-6
462 - update HEAD patch
463
464 * Wed Oct 15 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-5
465 - rebase against 3.2.X HEAD
466
467 * Tue Oct 14 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-4
468 - pull patch from git to bring us up to current(ish)
469
470 * Wed Sep  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-3
471 - add patch to fix yum install name.arch matching
472
473 * Thu Aug 28 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-2
474 - add patch to fix mash's parser use.
475
476 * Wed Aug 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-1
477 - 3.2.19
478
479 * Thu Aug  7 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.18-1
480 - 3.2.18
481
482 * Wed Jul 10 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-2
483 - add patch from upstream for bug in compare_providers
484
485 * Wed Jul  9 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-1
486 - 3.2.17
487
488 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-4
489 - Add a couple more upstream patches for even more multilib fixes
490
491 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-3
492 - Add another patch from upstream for multilib policy and noarch
493
494 * Sun May 18 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-2
495 - stupid, stupid, stupid
496
497
498 * Fri May 16 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-1
499 - 3.2.16
500
501 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-9
502 - nine is the luckiest number that there will ever be
503
504 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-8
505 - after many tries - this one fixes translations AND pungi
506
507 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-5
508 - once more, with feeling
509
510 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-4
511 - another big-head-patch
512
513 * Wed Apr  9 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-3
514 - apply patch to bring this up to where HEAD is now.
515
516 * Tue Apr  8 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-1
517 - remove committed patch
518 - obsoletes yum-basearchonly
519
520 * Tue Apr  1 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-2
521 - fix minor typo in comps.py for jkeating
522
523 * Thu Mar 20 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-1
524 - 3.2.13
525
526 * Mon Mar 17 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-5
527 - update manpage patch to close bug 437703. Thakns to Kulbir Saini for the patch
528
529
530 * Fri Mar 14 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-4
531 - multilib_policy=best is  now the default
532
533 * Thu Mar 13 2008 Seth Vidal <skvidal at fedoraproject.org> 
534 - add jeff sheltren's patch to close rh bug 428825
535
536 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-3
537 - set failovermethod to 'priority' to make jkeating happy
538
539 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-2
540 - fix mutually obsoleting providers (like glibc!)
541
542 * Mon Mar  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.12-1
543 - 3.2.12
544
545 * Fri Feb  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.11-1
546 - 3.2.11
547
548 * Sun Jan 27 2008 James Bowes <jbowes@redhat.com> 3.2.10-3
549 - Remove yumupd.py
550
551 * Fri Jan 25 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.10-1
552 - 3.2.10
553 - add pygpgme dep
554