06191e05bbbaee61c1500af5c81bc49f43183b61
[yum.git] / yum.spec
1 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
2  
3 Summary: RPM installer/updater
4 Name: yum
5 Version: 3.2.25
6 Release: 12%{?dist}
7 License: GPLv2+
8 Group: System Environment/Base
9 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
10 Source1: yum.conf.fedora
11 Source2: yum-updatesd.conf.fedora
12 Patch0: installonlyn-enable.patch
13 Patch1: yum-mirror-priority.patch
14 Patch2: yum-manpage-files.patch
15 Patch3: yum-multilib-policy-best.patch
16 Patch4: no-more-exactarchlist.patch
17 Patch5: geode-arch.patch
18 Patch6: yum-HEAD.patch
19 Patch7: yum-xHEAD.patch
20 Patch8: yumvar-pungi-hack.patch
21 Patch9: rpmdb-problems+minor-cleanups.patch
22 Patch64: yum-ppc64-preferred.patch
23 Patch65: yum-3.2.25-i18n-off.patch
24 Patch66: yum-3.2.25-chroot.patch
25
26 URL: http://yum.baseurl.org/
27 BuildArch: noarch
28 BuildRequires: python
29 BuildRequires: gettext
30 BuildRequires: intltool
31 Conflicts: pirut < 1.1.4
32 Requires: python >= 2.4, rpm-python, rpm >= 0:4.4.2
33 Requires: python-iniparse
34 Requires: python-sqlite
35 Requires: python-urlgrabber >= 3.9.0-8
36 Requires: yum-metadata-parser >= 1.1.0
37 Requires: pygpgme
38 Obsoletes: yum-skip-broken, yum-basearchonly
39 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
40
41 %description
42 Yum is a utility that can check for and automatically download and
43 install updated RPM packages. Dependencies are obtained and downloaded 
44 automatically prompting the user as necessary.
45
46 %package updatesd
47 Summary: Update notification daemon
48 Group: Applications/System
49 Requires: yum = %{version}-%{release}
50 Requires: dbus-python
51 Requires: pygobject2
52 Requires(preun): /sbin/chkconfig
53 Requires(post): /sbin/chkconfig
54 Requires(preun): /sbin/service
55 Requires(post): /sbin/service
56
57 %description updatesd
58 yum-updatesd provides a daemon which checks for available updates and 
59 can notify you when they are available via email, syslog or dbus. 
60
61 %prep
62 %setup -q
63 %patch1 -p0
64 #%%%patch2 -p0
65 %patch3 -p0
66 %patch4 -p0
67 %patch5 -p1
68 %patch6 -p1
69 %patch7 -p1
70 %patch8 -p1
71 %patch9 -p1
72 %patch64 -p0
73 %patch65 -p1
74 %patch66 -p1
75
76 %build
77 make
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81 make DESTDIR=$RPM_BUILD_ROOT install
82 install -m 644 %{SOURCE1} $RPM_BUILD_ROOT/%{_sysconfdir}/yum.conf
83 mkdir -p $RPM_BUILD_ROOT/%{_sysconfdir}/yum/pluginconf.d $RPM_BUILD_ROOT/usr/lib/yum-plugins
84
85 # for now, move repodir/yum.conf back
86 mv $RPM_BUILD_ROOT/%{_sysconfdir}/yum/repos.d $RPM_BUILD_ROOT/%{_sysconfdir}/yum.repos.d
87 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum.conf
88
89 # yum-updatesd has moved to the separate source version
90 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/yum/yum-updatesd.conf 
91 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/rc.d/init.d/yum-updatesd
92 rm -f $RPM_BUILD_ROOT/%{_sysconfdir}/dbus-1/system.d/yum-updatesd.conf
93 rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
94 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
95 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
96
97 %find_lang %name
98
99 %clean
100 rm -rf $RPM_BUILD_ROOT
101
102 %files -f %{name}.lang
103 %defattr(-, root, root, -)
104 %doc README AUTHORS COPYING TODO INSTALL ChangeLog
105 %config(noreplace) %{_sysconfdir}/yum.conf
106 %dir %{_sysconfdir}/yum
107 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
108 %dir %{_sysconfdir}/yum.repos.d
109 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
110 %{_sysconfdir}/bash_completion.d
111 %dir %{_datadir}/yum-cli
112 %{_datadir}/yum-cli/*
113 %{_bindir}/yum
114 %{python_sitelib}/yum
115 %{python_sitelib}/rpmUtils
116 %dir /var/cache/yum
117 %dir /var/lib/yum
118 %{_mandir}/man*/yum.*
119 %{_mandir}/man*/yum-shell*
120 # plugin stuff
121 %dir %{_sysconfdir}/yum/pluginconf.d 
122 %dir /usr/lib/yum-plugins
123
124 %changelog
125 * Fri Jan 15 2010 James Antill <james.antill@redhat.com> - 3.2.25-12
126 - Some minor problems, esp. with check_duplicates() in problems path.
127 - Related: rhbz#543948
128
129 * Tue Jan 12 2010 James Antill <james.antill@redhat.com> - 3.2.25-11
130 - Fix rpmdb problems sorting, mainly for y-c-t.
131 - Related: rhbz#554733
132 - Also include a docs cleanup, obsoletes output cleanup and pgp
133 - errors edge case fix.
134
135 * Thu Jan  7 2010 James Antill <james.antill@redhat.com> - 3.2.25-10
136 - Work around Pungi config. hacks. Use .conf.yumvar instead of .yumvar
137 - Related: rhbz#543948
138
139 * Wed Jan  6 2010 James Antill <james.antill@redhat.com> - 3.2.25-9
140 - Rebuilt rawhide yum for for RHEL 6, lots of features and fixes. incl.
141 - Work around weird openssl md5==abort in FIPS mode.
142 - Resolves: rhbz#541974
143 - Add --rpmverbosity option.
144 - Resolves: 548341
145 - Related: rhbz#543948
146
147 * Tue Dec 08 2009 Dennis Gregorovic <dgregor@redhat.com> - 3.2.25-1.2
148 - Rebuilt for RHEL 6
149
150 * Tue Nov 10 2009 Dennis Gregorovic <dgregor@redhat.com> - 3.2.25-1.1
151 - Rebuild for RHEL 6
152
153 * Wed Oct 14 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-1
154 - 3.2.25
155
156 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-9
157 - revert yum. import patch b/c it breaks a bunch of things
158
159 * Wed Sep 30 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-8
160 - fix up broken build b/c of version-groups.conf file
161
162 * Tue Sep 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-7
163 - fixes for odd outputs from ts.run and logs for what we store in history
164
165 * Wed Sep 23 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-6
166 - new head patch - fixes some issues with history and chroots
167
168 * Mon Sep 21 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-5
169 - latest head patch - includes yum history feature.
170
171 * Tue Sep 15 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-4
172 - new head patch - translation updates and a few bug fixes
173
174 * Wed Sep  9 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-3
175 - add geode arch patch for https://bugzilla.redhat.com/show_bug.cgi?id=518415
176
177
178 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-2
179 - modify cachedir to include variables
180
181 * Thu Sep  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.24-1
182 - 3.2.24
183
184 * Wed Sep  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-16
185 - fix globbing issue 520810
186
187 * Mon Aug 31 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-15
188 - one more head update - fixes some fairly ugly but kind of minor bugs
189
190 * Tue Aug 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-14
191 - update to latest head pre 3.2.24
192 - add requirement on python-urlgrabber 3.9.0 and up
193
194 * Wed Aug  5 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-13
195 - latest head - right after freeze
196
197 * Tue Aug  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-12
198 - latest head - right before freeze :)
199
200 * Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.23-11
201 - Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
202
203 * Wed Jul 22 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-10
204 - remove exactarchlist by request for rawhide
205
206 * Thu Jul  2 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-9
207 - update to latest head - make livecd creation work again in rawhide
208 - disable one of the man page patches until after 3.2.24 is released b/c
209   of the changes to the man page in the head patch
210
211
212 * Mon Jun 22 2009 James Antill <james at fedoraproject.org> - 3.2.23-8
213 - Update to latest head:
214 - Fix old recursion bug, found by new code.
215 - Resolves: bug#507220
216
217 * Sun Jun 21 2009 James Antill <james at fedoraproject.org> - 3.2.23-6
218 - Update to latest head:
219 - Unbreak delPackage() excludes.
220 - Other fixes/etc.
221
222 * Fri Jun 19 2009 James Antill <james at fedoraproject.org> - 3.2.23-5
223 - Actually apply the HEAD patch included yesterday :).
224
225 * Thu Jun 18 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-4
226 - update to latest head
227
228 * Mon Jun  8 2009 Seth Vidal <skvidal at fedoraproject.org>
229 - truncate changelog
230
231 * Wed May 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-2
232 - add patch to close rpmdb completely
233
234 * Tue May 19 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.23-1
235 - 3.2.23
236
237 * Mon May 11 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-5
238 - jump up to almost 3.2.23. 
239 - had to move patch0 around a bit until we rebase to 3.2.23
240
241 * Thu Apr  9 2009 James Antill <james at fedoraproject.org> - 3.2.22-4
242 - fix typo for yum-complete-transaction message.
243
244 * Wed Apr  8 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-3
245 - fix for file:// urls which makes things in pungi/mash work
246
247 * Tue Apr  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-2
248 - yum-HEAD minus the yumdb patches
249
250 * Tue Mar 24 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.22-1
251 - 3.2.22 - 3 patches beyond 3.2.21-16
252
253 * Mon Mar 16 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-16
254 - fix for 490490
255
256 * Fri Mar 13 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-15
257 - update to upstream git to fix conditionals problem on anaconda installs
258
259 * Thu Mar 12 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-14
260 - latest HEAD
261
262 * Tue Mar 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-13
263 - f11beta build
264
265 * Wed Mar  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-12
266 - second verse, same as the first
267
268 * Fri Feb 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-10
269 - merge up a lot of fixes from latest HEAD
270
271 * Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 3.2.21-10
272 - Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
273
274 * Tue Feb 10 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-9
275 - merge up to latest yum head - sort of a pre 3.2.22
276
277 * Wed Feb  4 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-8
278 - fix for YumHeaderPackages so it plays nicely w/createrepo and mergerepo, etc
279
280 * Thu Jan 29 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-7
281 - update HEAD patch to fix repodiff (and EVR comparisons in certain cases)
282
283 * Tue Jan 27 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-6
284 - patch to keep anaconda (and other callers) happy
285 - remove old 6hr patch which is now upstream
286
287 * Mon Jan 26 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-4
288 - patch to latest HEAD to test a number of fixes for alpha
289
290 * Tue Jan 20 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-3
291 - add a small patch to make things play a bit nicer with the logging module
292   in 2.6
293
294
295 * Wed Jan  7 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.21-1
296 - bump to 3.2.21
297
298 * Thu Dec 18 2008 James Antill <james@fedoraproject.org> - 3.2.20-8
299 - merge latest from upstream
300 - move to 6hr metadata
301
302 * Mon Dec  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-7
303 - merge patch from upstream and remove now old obsoletes patch
304
305 * Thu Dec 04 2008 Jesse Keating <jkeating@redhat.com> - 3.2.20-6
306 - Add patch from upstream to fix cases where obsoletes are disabled. (jantill)
307
308 * Sat Nov 29 2008 Ignacio Vazquez-Abrams <ivazqueznet+rpm@gmail.com> - 3.2.20-5
309 - Rebuild for Python 2.6
310
311 * Wed Nov 26 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-4
312 - update head patch
313
314 * Wed Oct 29 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-3
315 - full patch against HEAD for skipbroken fixes (among others)
316
317 * Mon Oct 27 2008 James Antill <james@fedoraproject.org> - 3.2.20-2
318 - Fix listTransaction for skipped packages.
319
320 * Mon Oct 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.20-1
321 - 3.2.20
322
323 * Thu Oct 23 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-6
324 - update HEAD patch
325
326 * Wed Oct 15 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-5
327 - rebase against 3.2.X HEAD
328
329 * Tue Oct 14 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-4
330 - pull patch from git to bring us up to current(ish)
331
332 * Wed Sep  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-3
333 - add patch to fix yum install name.arch matching
334
335 * Thu Aug 28 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-2
336 - add patch to fix mash's parser use.
337
338 * Wed Aug 27 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.19-1
339 - 3.2.19
340
341 * Thu Aug  7 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.18-1
342 - 3.2.18
343
344 * Wed Jul 10 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-2
345 - add patch from upstream for bug in compare_providers
346
347 * Wed Jul  9 2008 Seth Vidal <skvidal@fedoraproject.org> - 3.2.17-1
348 - 3.2.17
349
350 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-4
351 - Add a couple more upstream patches for even more multilib fixes
352
353 * Tue Jun 24 2008 Jesse Keating <jkeating@redhat.com> - 3.2.16-3
354 - Add another patch from upstream for multilib policy and noarch
355
356 * Sun May 18 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-2
357 - stupid, stupid, stupid
358
359
360 * Fri May 16 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.16-1
361 - 3.2.16
362
363 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-9
364 - nine is the luckiest number that there will ever be
365
366 * Tue Apr 15 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-8
367 - after many tries - this one fixes translations AND pungi
368
369 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-5
370 - once more, with feeling
371
372 * Thu Apr 10 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-4
373 - another big-head-patch
374
375 * Wed Apr  9 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-3
376 - apply patch to bring this up to where HEAD is now.
377
378 * Tue Apr  8 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.14-1
379 - remove committed patch
380 - obsoletes yum-basearchonly
381
382 * Tue Apr  1 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-2
383 - fix minor typo in comps.py for jkeating
384
385 * Thu Mar 20 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.13-1
386 - 3.2.13
387
388 * Mon Mar 17 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-5
389 - update manpage patch to close bug 437703. Thakns to Kulbir Saini for the patch
390
391
392 * Fri Mar 14 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-4
393 - multilib_policy=best is  now the default
394
395 * Thu Mar 13 2008 Seth Vidal <skvidal at fedoraproject.org> 
396 - add jeff sheltren's patch to close rh bug 428825
397
398 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-3
399 - set failovermethod to 'priority' to make jkeating happy
400
401 * Tue Mar  4 2008 Seth Vidal <skvidal at fedoraproject.org> 3.2.12-2
402 - fix mutually obsoleting providers (like glibc!)
403
404 * Mon Mar  3 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.12-1
405 - 3.2.12
406
407 * Fri Feb  8 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.11-1
408 - 3.2.11
409
410 * Sun Jan 27 2008 James Bowes <jbowes@redhat.com> 3.2.10-3
411 - Remove yumupd.py
412
413 * Fri Jan 25 2008 Seth Vidal <skvidal at fedoraproject.org> - 3.2.10-1
414 - 3.2.10
415 - add pygpgme dep
416