Merge remote-tracking branch 'origin/f12' into rhel6
[yum.git] / yum.spec
index 06191e0..821844a 100644 (file)
--- a/yum.spec
+++ b/yum.spec
@@ -1,9 +1,12 @@
 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
+
+# the regular f14 yum is already tagged 5
+%global release 99chroot
  
 Summary: RPM installer/updater
 Name: yum
-Version: 3.2.25
-Release: 12%{?dist}
+Version: 3.2.28
+Release: %release
 License: GPLv2+
 Group: System Environment/Base
 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
@@ -11,17 +14,15 @@ Source1: yum.conf.fedora
 Source2: yum-updatesd.conf.fedora
 Patch0: installonlyn-enable.patch
 Patch1: yum-mirror-priority.patch
-Patch2: yum-manpage-files.patch
 Patch3: yum-multilib-policy-best.patch
 Patch4: no-more-exactarchlist.patch
 Patch5: geode-arch.patch
 Patch6: yum-HEAD.patch
-Patch7: yum-xHEAD.patch
-Patch8: yumvar-pungi-hack.patch
-Patch9: rpmdb-problems+minor-cleanups.patch
-Patch64: yum-ppc64-preferred.patch
-Patch65: yum-3.2.25-i18n-off.patch
-Patch66: yum-3.2.25-chroot.patch
+Patch7: yum-PK-auto-close-fix.patch
+
+Patch10: yum-3.2.28-chroot.patch
+
+Patch20: yum-manpage-files.patch
 
 URL: http://yum.baseurl.org/
 BuildArch: noarch
@@ -35,13 +36,25 @@ Requires: python-sqlite
 Requires: python-urlgrabber >= 3.9.0-8
 Requires: yum-metadata-parser >= 1.1.0
 Requires: pygpgme
-Obsoletes: yum-skip-broken, yum-basearchonly
+Obsoletes: yum-skip-broken <= 1.1.18
+Obsoletes: yum-basearchonly <= 1.1.9
+Obsoletes: yum-plugin-basearchonly <= 1.1.24
+Obsoletes: yum-allow-downgrade < 1.1.20-0
+Obsoletes: yum-plugin-allow-downgrade < 1.1.22-0
+Obsoletes: yum-plugin-protect-packages < 1.1.27-0
+Obsoletes: yum-plugin-download-order <= 0.2-2
+Provides: yum-skip-broken
+Provides: yum-basearchonly
+Provides: yum-allow-downgrade
+Provides: yum-plugin-allow-downgrade
+Provides: yum-protect-packages
+Provides: yum-plugin-protect-packages
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 %description
 Yum is a utility that can check for and automatically download and
 install updated RPM packages. Dependencies are obtained and downloaded 
-automatically prompting the user as necessary.
+automatically, prompting the user for permission as necessary.
 
 %package updatesd
 Summary: Update notification daemon
@@ -61,17 +74,15 @@ can notify you when they are available via email, syslog or dbus.
 %prep
 %setup -q
 %patch1 -p0
-#%%%patch2 -p0
 %patch3 -p0
 %patch4 -p0
 %patch5 -p1
 %patch6 -p1
 %patch7 -p1
-%patch8 -p1
-%patch9 -p1
-%patch64 -p0
-%patch65 -p1
-%patch66 -p1
+
+%patch10 -p1
+
+%patch20 -p1
 
 %build
 make
@@ -94,6 +105,12 @@ rm -f $RPM_BUILD_ROOT/%{_sbindir}/yum-updatesd
 rm -f $RPM_BUILD_ROOT/%{_mandir}/man*/yum-updatesd*
 rm -f $RPM_BUILD_ROOT/%{_datadir}/yum-cli/yumupd.py*
 
+# Ghost files:
+mkdir -p $RPM_BUILD_ROOT/var/lib/yum/history
+mkdir -p $RPM_BUILD_ROOT/var/lib/yum/plugins
+mkdir -p $RPM_BUILD_ROOT/var/lib/yum/yumdb
+touch $RPM_BUILD_ROOT/var/lib/yum/uuid
+
 %find_lang %name
 
 %clean
@@ -105,7 +122,9 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) %{_sysconfdir}/yum.conf
 %dir %{_sysconfdir}/yum
 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
+%dir %{_sysconfdir}/yum/protected.d
 %dir %{_sysconfdir}/yum.repos.d
+%dir %{_sysconfdir}/yum/vars
 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
 %{_sysconfdir}/bash_completion.d
 %dir %{_datadir}/yum-cli
@@ -115,6 +134,10 @@ rm -rf $RPM_BUILD_ROOT
 %{python_sitelib}/rpmUtils
 %dir /var/cache/yum
 %dir /var/lib/yum
+%ghost /var/lib/yum/uuid
+%ghost /var/lib/yum/history
+%ghost /var/lib/yum/plugins
+%ghost /var/lib/yum/yumdb
 %{_mandir}/man*/yum.*
 %{_mandir}/man*/yum-shell*
 # plugin stuff
@@ -122,33 +145,49 @@ rm -rf $RPM_BUILD_ROOT
 %dir /usr/lib/yum-plugins
 
 %changelog
-* Fri Jan 15 2010 James Antill <james.antill@redhat.com> - 3.2.25-12
-- Some minor problems, esp. with check_duplicates() in problems path.
-- Related: rhbz#543948
-
-* Tue Jan 12 2010 James Antill <james.antill@redhat.com> - 3.2.25-11
-- Fix rpmdb problems sorting, mainly for y-c-t.
-- Related: rhbz#554733
-- Also include a docs cleanup, obsoletes output cleanup and pgp
-- errors edge case fix.
-
-* Thu Jan  7 2010 James Antill <james.antill@redhat.com> - 3.2.25-10
-- Work around Pungi config. hacks. Use .conf.yumvar instead of .yumvar
-- Related: rhbz#543948
-
-* Wed Jan  6 2010 James Antill <james.antill@redhat.com> - 3.2.25-9
-- Rebuilt rawhide yum for for RHEL 6, lots of features and fixes. incl.
-- Work around weird openssl md5==abort in FIPS mode.
-- Resolves: rhbz#541974
-- Add --rpmverbosity option.
-- Resolves: 548341
-- Related: rhbz#543948
-
-* Tue Dec 08 2009 Dennis Gregorovic <dgregor@redhat.com> - 3.2.25-1.2
-- Rebuilt for RHEL 6
-
-* Tue Nov 10 2009 Dennis Gregorovic <dgregor@redhat.com> - 3.2.25-1.1
-- Rebuild for RHEL 6
+* Tue Sep 14 2010 James Antill <james at fedoraproject.org> - 3.2.28-4
+- Fix auto-close bug with GPG key installs.
+- Resolves: bug#622179
+- Fix obsoletes on basearchonly.
+- Resolves: bug#629138
+
+* Fri Aug 27 2010 Seth Vidal <skvidal at fedoraproject.org> 
+- obsoleted yum-plugin-download-order
+
+* Thu Aug 12 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-3
+- latest head
+- fix gpg key import
+- more unicode fixes
+- output slightly more clear depsovling error msgs
+- sync up spec file with f13,f14
+
+* Mon Aug  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-2
+- fixes sqlite historydb conversion bug
+- patches up some unicide issues
+
+
+* Fri Jul 30 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-1
+- 3.2.28
+
+* Thu Apr  8 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-3
+- fix regets on metadata when we run into an old file that's larger
+  than the new one
+
+* Tue Mar 23 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-2
+- broke searching in PK, this patch fixes it.
+
+* Thu Mar 18 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-1
+- update to 3.2.27 - lots of fixes since 3.2.26
+
+* Thu Mar  4 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-3
+- up to head-as-f13-has and include the skip-broken fix
+
+
+* Wed Feb 10 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-2
+- grumble.
+
+* Tue Feb  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-1
+- final 3.2.26
 
 * Wed Oct 14 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-1
 - 3.2.25