Merge remote-tracking branch 'origin/f12' into rhel6
[yum.git] / yum.spec
index 2957326..821844a 100644 (file)
--- a/yum.spec
+++ b/yum.spec
@@ -1,9 +1,12 @@
 %{!?python_sitelib: %define python_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
+
+# the regular f14 yum is already tagged 5
+%global release 99chroot
  
 Summary: RPM installer/updater
 Name: yum
-Version: 3.2.27
-Release: 14%{?dist}.chroot1
+Version: 3.2.28
+Release: %release
 License: GPLv2+
 Group: System Environment/Base
 Source0: http://yum.baseurl.org/download/3.2/%{name}-%{version}.tar.gz
@@ -11,41 +14,15 @@ Source1: yum.conf.fedora
 Source2: yum-updatesd.conf.fedora
 Patch0: installonlyn-enable.patch
 Patch1: yum-mirror-priority.patch
-Patch2: yum-manpage-files.patch
 Patch3: yum-multilib-policy-best.patch
 Patch4: no-more-exactarchlist.patch
 Patch5: geode-arch.patch
-Patch6: BZ-528738-bugtracker.patch
-
-Patch32: yum-distro-sync.patch
-Patch33: yum-install-cmd-exit+provides-msgs+docs.patch
-Patch34: yum-history-user.patch
-Patch35: yum-PK-search-API.patch
-Patch36: yum-history-list-errors+summary-user-column.patch
-Patch37: yum-groupremove-leaf-only.patch
-Patch38: yum-md-reget+yumvars+searchPrco.patch
-
-Patch39: BZ-588911-yum.log-perms.patch
-Patch40: BZ-577627-installroot-double-prefix.patch
-Patch41: BZ-588910-nocontext-tsflag.patch
-Patch42: BZ-588908-many-install-update-speedup.patch
-Patch43: BZ-590340-move-rpmdb-from-cache.patch
-Patch44: BZ-590339-edge-case-depsolving.patch
-Patch45: BZ-593522-install-obs-arch.patch
-Patch46: BZ-595553-akmods-cache-defense.patch
-Patch47: BZ-602354-plugin-hooks-verify-transaction.patch
-Patch48: BZ-584262-downgrade-dep-chain-remove.patch
-Patch49: BZ-572770-int-flags-miscutils.patch
-Patch50: BZ-598639-rpm-bindings-api-change-fix.patch
-Patch51: BZ-603002-group_remove_leaf-empty-transaction.patch
-Patch52: BZ-604080-localinstall-obsoleted.patch
-Patch53: BZ-614496-traceback-no-proc-mounted.patch
-
-
-Patch64: yum-ppc64-preferred.patch
-Patch65: yum-3.2.27-i18n-off.patch
-
-Patch100: yum-3.2.27_el6-chroot.patch
+Patch6: yum-HEAD.patch
+Patch7: yum-PK-auto-close-fix.patch
+
+Patch10: yum-3.2.28-chroot.patch
+
+Patch20: yum-manpage-files.patch
 
 URL: http://yum.baseurl.org/
 BuildArch: noarch
@@ -59,13 +36,25 @@ Requires: python-sqlite
 Requires: python-urlgrabber >= 3.9.0-8
 Requires: yum-metadata-parser >= 1.1.0
 Requires: pygpgme
-Obsoletes: yum-skip-broken, yum-basearchonly
+Obsoletes: yum-skip-broken <= 1.1.18
+Obsoletes: yum-basearchonly <= 1.1.9
+Obsoletes: yum-plugin-basearchonly <= 1.1.24
+Obsoletes: yum-allow-downgrade < 1.1.20-0
+Obsoletes: yum-plugin-allow-downgrade < 1.1.22-0
+Obsoletes: yum-plugin-protect-packages < 1.1.27-0
+Obsoletes: yum-plugin-download-order <= 0.2-2
+Provides: yum-skip-broken
+Provides: yum-basearchonly
+Provides: yum-allow-downgrade
+Provides: yum-plugin-allow-downgrade
+Provides: yum-protect-packages
+Provides: yum-plugin-protect-packages
 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
 
 %description
 Yum is a utility that can check for and automatically download and
 install updated RPM packages. Dependencies are obtained and downloaded 
-automatically prompting the user as necessary.
+automatically, prompting the user for permission as necessary.
 
 %package updatesd
 Summary: Update notification daemon
@@ -85,37 +74,15 @@ can notify you when they are available via email, syslog or dbus.
 %prep
 %setup -q
 %patch1 -p0
-%patch2 -p1
 %patch3 -p0
 %patch4 -p0
 %patch5 -p1
 %patch6 -p1
-%patch32 -p1
-%patch33 -p1
-%patch34 -p1
-%patch35 -p1
-%patch36 -p1
-%patch37 -p1
-%patch38 -p1
-%patch39 -p1
-%patch40 -p1
-%patch41 -p1
-%patch42 -p1
-%patch43 -p1
-%patch44 -p1
-%patch45 -p1
-%patch46 -p1
-%patch47 -p1
-%patch48 -p1
-%patch49 -p1
-%patch50 -p1
-%patch51 -p1
-%patch52 -p1
-%patch53 -p1
-%patch64 -p0
-%patch65 -p1
-
-%patch100 -p1
+%patch7 -p1
+
+%patch10 -p1
+
+%patch20 -p1
 
 %build
 make
@@ -155,7 +122,7 @@ rm -rf $RPM_BUILD_ROOT
 %config(noreplace) %{_sysconfdir}/yum.conf
 %dir %{_sysconfdir}/yum
 %config(noreplace) %{_sysconfdir}/yum/version-groups.conf
-%dir %{_sysconfdir}/yum/protected.d
+%dir %{_sysconfdir}/yum/protected.d
 %dir %{_sysconfdir}/yum.repos.d
 %dir %{_sysconfdir}/yum/vars
 %config(noreplace) %{_sysconfdir}/logrotate.d/yum
@@ -178,119 +145,49 @@ rm -rf $RPM_BUILD_ROOT
 %dir /usr/lib/yum-plugins
 
 %changelog
-* Tue Aug 24 2010 Seth Vidal <svidal@redhat.com> - 3.2.27-14
-- fixed 588911 patch to be correct patch
-- add patch file for 572770 to take the old date from the wrong patch from 588911
-
-* Tue Jul 27 2010 James Antill <james.antill@redhat.com> - 3.2.27-13
-- Don't traceback when proc isn't mounted.
-- Resolves: rhbz#614496
-- Own the /etc/yum/vars dir.
-- Resolves: rhbz#611906
-
-* Wed Jun 16 2010 James Antill <james.antill@redhat.com> - 3.2.27-12
-- Stop allowing installation of obsoleted, only by installed.
-- Resolves: rhbz#604080
-
-* Fri Jun 11 2010 James Antill <james.antill@redhat.com> - 3.2.27-10
-- Stop downgrade dep. chain removals
-- Resolves: rhbz#584262
-- Fix for rpm bindings api change
-- Resolves: rhbz#598639
-- Add plugin hooks for verify transaction pre/post.
-- Resolves: rhbz#602354
-- Fix groupremove_leaf_only when it empties the transaction.
-- Resolves: rhbz#603002
-
-* Tue May 25 2010 James Antill <james.antill@redhat.com> - 3.2.27-9
-- Fix installs of obsoleted multiarch packages.
-- Resolves: rhbz#593522
-- Create a defense against akmod style postinst install hacks.
-- Resolves: rhbz#595553
-
-* Tue May 11 2010 James Antill <james.antill@redhat.com> - 3.2.27-8
-- Move rpmdb cache/indexes to /var/lib
-- Resolves: rhbz#590340
-- Fix old missing recheck in depsolve
-- Resolves: rhbz#590339
-
-* Tue May  4 2010 James Antill <james.antill@redhat.com> - 3.2.27-7
-- A few minor bugfixes from upstream
-- yum.log perms
-- Resolves: rhbz#588911
-- installroot double prefixing, on anaconda/kickstart install
-- Resolves: rhbz#577627
-- Add nocontexts flag to tsflags, if available.
-- Resolves: rhbz#588910
-- Speedup many install/update of same pkg.
-- Resolves: rhbz#588908
-- Correct os.path.link => os.path.islink typo, for dynamic yum vars.
-- Resolves: rhbz#588907
-
-* Fri Apr 16 2010 James Antill <james.antill@redhat.com> - 3.2.27-4
-- A few minor bugfixes from upstream
-- Add dynamic FS based yumvars
-- Resolves: rhbz#576703
-
-* Fri Mar 26 2010 James Antill <james.antill@redhat.com> - 3.2.27-3
-- 3.2.27 from Fedora, and a couple of minor patches
-- Resolves: rhbz#576703
-
-* Thu Mar 18 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-1
-- 3.2.27 from upstream (more or less the same as 3.2.26-6 but with a new number
-
-* Thu Mar 11 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-6
-- should be the final HEAD update before 3.2.27
-
-* Thu Feb 24 2010 James Antill <james@fedoraproject.org> - 3.2.26-5
-- new HEAD, minor features and speed.
+* Tue Sep 14 2010 James Antill <james at fedoraproject.org> - 3.2.28-4
+- Fix auto-close bug with GPG key installs.
+- Resolves: bug#622179
+- Fix obsoletes on basearchonly.
+- Resolves: bug#629138
 
-* Wed Feb 17 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-4
-- new HEAD to fix the fix to the fix
+* Fri Aug 27 2010 Seth Vidal <skvidal at fedoraproject.org> 
+- obsoleted yum-plugin-download-order
 
-* Tue Feb 16 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-3
-- latest head - including fixes to searchPrcos
-
-* Wed Feb 10 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-2
-- grumble.
-
-* Tue Feb  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-1
-- final 3.2.26
+* Thu Aug 12 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-3
+- latest head
+- fix gpg key import
+- more unicode fixes
+- output slightly more clear depsovling error msgs
+- sync up spec file with f13,f14
 
-* Mon Feb  8 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-14
-- $uuid, pkgtags searching, latest HEAD patch - pre 3.2.26
+* Mon Aug  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-2
+- fixes sqlite historydb conversion bug
+- patches up some unicide issues
 
-* Fri Jan 28 2010 James Antill <james at fedoraproject.org> - 3.2.25-13
-- A couple of bugfixes, most notably:
--  you can now install gpg keys again!
--  bad installed file requires don't get cached.
 
-* Fri Jan 22 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-12
-- someone forgot to push their changes
+* Fri Jul 30 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.28-1
+- 3.2.28
 
-* Fri Jan 22 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-11
-- more fixes, more fun
+* Thu Apr  8 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-3
+- fix regets on metadata when we run into an old file that's larger
+  than the new one
 
-* Fri Jan 15 2010 James Antill <james at fedoraproject.org> - 3.2.25-10
-- latest head
-- Fixes for pungi, rpmdb caching and kernel-PAE-devel duplicates finding
-- among others.
+* Tue Mar 23 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-2
+- broke searching in PK, this patch fixes it.
 
-* Mon Jan  4 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-8
-- latest head
+* Thu Mar 18 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.27-1
+- update to 3.2.27 - lots of fixes since 3.2.26
 
-* Thu Dec 10 2009 James Antill <james at fedoraproject.org> - 3.2.25-7
-- Fixes the mash bug, lookup in the tsInfo too. :(
-- And fix the txmbr/po confusion ... third build the charm.
+* Thu Mar  4 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-3
+- up to head-as-f13-has and include the skip-broken fix
 
-* Fri Dec  4 2009 James Antill <james at fedoraproject.org> - 3.2.25-4
-- Fixes for yum clean all, BZ 544173
-- Also allow "yum clean rpmdb" to work, bad tester, bad.
 
-* Thu Dec  3 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-2
-- rebuild yum with latest HEAD patch
-- add rpmdb caching patch james wrote to see if it breaks everyone :)
+* Wed Feb 10 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-2
+- grumble.
 
+* Tue Feb  9 2010 Seth Vidal <skvidal at fedoraproject.org> - 3.2.26-1
+- final 3.2.26
 
 * Wed Oct 14 2009 Seth Vidal <skvidal at fedoraproject.org> - 3.2.25-1
 - 3.2.25