add the 4.7 taxonomy_block module which is a needed feature for plc
[drupal.git] / drupal.spec
1 #
2 # $Id$
3 #
4
5 %define name drupal
6 %define version 4.7
7 %define taglevel 11
8
9 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10
11 Packager: PlanetLab Central <support@planet-lab.org>
12
13 # remain compliant with former planetlab practices
14 %define drupaldir /var/www/html
15 Name: %{name}
16 Version:  %{version}
17 Release:  %{release}
18 Summary: An open-source content-management platform
19
20 Group: Applications/Publishing
21 License: GPLv2+        
22 URL: http://www.drupal.org
23 Source0: http://ftp.osuosl.org/pub/drupal/files/projects/%{name}-%{version}.%{taglevel}.tar.gz
24 #Source1: drupal.conf
25 Source2: drupal-cron
26 Source3: http://ftp.drupal.org/files/projects/taxonomy_block-4.7.x-1.x-dev.tar.gz
27
28 BuildArch: noarch
29 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
30 Requires: php, php-gd, php-mbstring, wget
31
32 %description
33 Equipped with a powerful blend of features, Drupal is a Content Management 
34 System written in PHP that can support a variety of websites ranging from
35 personal weblogs to large community-driven websites.  Drupal is highly
36 configurable, skinnable, and secure.
37
38 %prep
39 %setup -q -n %{name}-%{version}.%{taglevel} -a 3
40
41 %build
42 mv taxonomy_block modules
43
44 %install
45 rm -rf %{buildroot}
46 install -d %{buildroot}%{drupaldir}
47 cp -pr * %{buildroot}%{drupaldir}
48 cp -pr .htaccess %{buildroot}%{drupaldir}
49 mkdir -p %{buildroot}%{_docdir}
50 install -D -p -m 0644 %{SOURCE2} %{buildroot}%{_sysconfdir}/cron.hourly/drupal 
51 mkdir %{buildroot}%{drupaldir}/files
52
53 %clean
54 rm -rf %{buildroot}
55
56 %files
57 %defattr(-,root,root,-)
58 %doc CHANGELOG.txt INSTALL* LICENSE* MAINTAINERS.txt UPGRADE.txt 
59 %{drupaldir}
60 %config(noreplace) %{drupaldir}/.htaccess
61 %exclude %{drupaldir}/CHANGELOG.txt
62 %exclude %{drupaldir}/INSTALL* 
63 %exclude %{drupaldir}/LICENSE* 
64 %exclude %{drupaldir}/MAINTAINERS.txt 
65 %exclude %{drupaldir}/UPGRADE.txt
66 %config(noreplace) %{drupaldir}/sites/default
67 %attr(755,root,apache) %{_sysconfdir}/cron.hourly/drupal
68 %dir %attr(775,root,apache) %{drupaldir}/files
69
70 %changelog
71 * Fri Jan 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> -
72 - plain drupal 4.7.11