creation
[drupal.git] / drupal.spec
1 #
2 # $Id: drupal.spec 1206 2008-03-03 15:49:07Z thierry $
3 #
4
5 %define name drupal
6 %define version 6.7
7 %define taglevel 0
8
9 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10
11 Packager: PlanetLab Central <support@planet-lab.org>
12
13 # remain compliant with former planetlab practices
14 %define drupaldir /var/www/html
15 Name: %{name}
16 Version:  %{version}
17 Release:  %{release}
18 Summary: An open-source content-management platform
19
20 Group: Applications/Publishing
21 License: GPLv2+        
22 URL: http://www.drupal.org
23 Source0: http://ftp.osuosl.org/pub/drupal/files/projects/%{name}-%{version}.tar.gz
24 #Source1: drupal.conf
25 Source2: drupal-README.fedora
26 Source3: drupal-cron
27 Source4: drupal-README.planetlab
28 Patch0: drupal-6.0-scripts-noshebang.patch
29
30 BuildArch: noarch
31 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
32 Requires: php, php-gd, php-mbstring, wget
33
34 %description
35 Equipped with a powerful blend of features, Drupal is a Content Management 
36 System written in PHP that can support a variety of websites ranging from
37 personal weblogs to large community-driven websites.  Drupal is highly
38 configurable, skinnable, and secure.
39
40 %prep
41
42 %setup -q
43
44 %patch0
45 chmod -x scripts/drupal.sh
46
47 %build
48
49 %install
50 rm -rf %{buildroot}
51 install -d %{buildroot}%{drupaldir}
52 cp -pr * %{buildroot}%{drupaldir}
53 cp -pr .htaccess %{buildroot}%{drupaldir}
54 #mkdir -p %{buildroot}%{_sysconfdir}/httpd
55 #mkdir -p %{buildroot}%{_sysconfdir}/httpd/conf.d
56 #cp -pr %SOURCE1 %{buildroot}%{_sysconfdir}/httpd/conf.d
57 #mkdir -p %{buildroot}%{_sysconfdir}/drupal
58 #mv %{buildroot}%{drupaldir}/sites/* %{buildroot}%{_sysconfdir}/drupal
59 #rmdir %{buildroot}%{drupaldir}/sites
60 #ln -s ../../..%{_sysconfdir}/drupal %{buildroot}%{drupaldir}/sites
61 mkdir -p %{buildroot}%{_docdir}
62 cp -pr %SOURCE2 .
63 cp -pr %SOURCE4 .
64 install -D -p -m 0644 %SOURCE3 %{buildroot}%{_sysconfdir}/cron.hourly/drupal 
65 mkdir -p %{buildroot}%{_localstatedir}/lib/drupal
66 ln -s ../../..%{_localstatedir}/lib/drupal %{buildroot}%{drupaldir}/files
67
68 %clean
69 rm -rf %{buildroot}
70
71 %files
72 %defattr(-,root,root,-)
73 %doc CHANGELOG.txt INSTALL* LICENSE* MAINTAINERS.txt UPGRADE.txt 
74 %doc drupal-README.fedora drupal-README.planetlab sites/all/README.txt
75 %{drupaldir}
76 %config(noreplace) %{drupaldir}/.htaccess
77 %exclude %{drupaldir}/CHANGELOG.txt
78 %exclude %{drupaldir}/INSTALL* 
79 %exclude %{drupaldir}/LICENSE* 
80 %exclude %{drupaldir}/MAINTAINERS.txt 
81 %exclude %{drupaldir}/UPGRADE.txt
82 #%dir %{_sysconfdir}/drupal/
83 #%config(noreplace) %{_sysconfdir}/drupal/all
84 %config(noreplace) %{drupaldir}/sites/all
85 #%exclude %{_sysconfdir}/drupal/all/README.txt
86 %exclude %{drupaldir}/sites/all/README.txt
87 #%config(noreplace) %{_sysconfdir}/drupal/default
88 %config(noreplace) %{drupaldir}/sites/default
89 #%config(noreplace) %{_sysconfdir}/httpd/conf.d/drupal.conf
90 %attr(755,root,apache) %{_sysconfdir}/cron.hourly/drupal
91 %dir %attr(775,root,apache) %{_localstatedir}/lib/drupal/
92
93 %changelog
94 * Thu Dec 11 2008 Jon Ciesla <limb@jcomserv.net> - 6.7-1
95 - Upgrade to 6.7, SA-2008-073.
96
97 * Wed Oct 22 2008 Jon Ciesla <limb@jcomserv.net> - 6.6-1
98 - Upgrade to 6.6, SA-2008-067.
99
100 * Thu Oct 09 2008 Jon Ciesla <limb@jcomserv.net> - 6.5-1
101 - Upgrade to 6.5, SA-2008-060.
102 - Added notes to README and drupal.conf re CVE-2008-3661.
103
104 * Thu Aug 14 2008 Jon Ciesla <limb@jcomserv.net> - 6.4-1
105 - Upgrade to 6.4, SA-2008-047.
106
107 * Thu Jul 10 2008 Jon Ciesla <limb@jcomserv.net> - 6.3-1
108 - Upgrade to 6.3, upstream security fixes, SA-2008-044.
109
110 * Thu Apr 10 2008 Jon Ciesla <limb@jcomserv.net> - 6.2-1
111 - Upgrade to 6.2, upstream security fixes, SA-2008-026.
112
113 * Thu Feb 28 2008 Jon Ciesla <limb@jcomserv.net> - 6.1-1
114 - Upgrade to 6.1, upstream security fixes, SA-2008-018.
115
116 * Fri Feb 22 2008 Jon Ciesla <limb@jcomserv.net> - 6.0-1
117 - Upgrade to 6.0.
118 - Updated noshebang patch.
119
120 * Mon Feb 04 2008 Jon Ciesla <limb@jcomserv.net> - 5.7-1
121 - Upgrade to 5.7, several non-security bugs fixed.
122
123 * Fri Jan 11 2008 Jon Ciesla <limb@jcomserv.net> - 5.6-1
124 - Upgrade to 5.6, upstream security fixes.
125
126 * Mon Jan 07 2008 Jon Ciesla <limb@jcomserv.net> - 5.5-2
127 - Include .htaccess file, BZ 427720.
128
129 * Mon Dec 10 2007 Jon Ciesla <limb@jcomserv.net> - 5.5-1
130 - Upgrade to 5.5, critical fixes.
131
132 * Thu Dec 06 2007 Jon Ciesla <limb@jcomserv.net> - 5.4-2
133 - Fix /files -> /var/lib/drupal dir perms, BZ 414761.
134
135 * Wed Dec 05 2007 Jon Ciesla <limb@jcomserv.net> - 5.4-1
136 - Upgrade to 5.4, advisory ID DRUPAL-SA-2007-031.
137 - Augmented README regarding symlinks, BZ 254228.
138
139 * Thu Oct 18 2007 Jon Ciesla <limb@jcomserv.net> - 5.3-1
140 - Upgrade to 5.3, fixes:
141 - HTTP response splitting.
142 - Arbitrary code execution.
143 - Cross-site scripting.
144 - Cross-site request forgery.
145 - Access bypass.
146
147 * Mon Sep 24 2007 Jon Ciesla <limb@jcomserv.net> - 5.2-3
148 - Minor doc correction, BZ 301541.
149
150 * Thu Aug 16 2007 Jon Ciesla <limb@jcomserv.net> - 5.2-2
151 - License tag correction.
152
153 * Thu Jul 26 2007 Jon Ciesla <limb@jcomserv.net> - 5.2-1
154 - Upgrade to 5.2, Cross-site request forgery fix.
155
156 * Fri Jul 20 2007 Jon Ciesla <limb@jcomserv.net> - 5.1-5
157 - Corrected buildroot.
158 - Moved /etc/drupal/all/README.txt to correct place.
159
160 * Wed Jul 04 2007 Jon Ciesla <limb@jcomserv.net> - 5.1-4
161 - Made settings.php not readonly by default, with note in drupal-README.fedora
162 - Locked down initial security configuration, documented steps required.
163 - Description cleanup.
164 - Added wget requires.
165
166 * Wed Jun 06 2007 Jon Ciesla <limb@jcomserv.net> - 5.1-3
167 - Fixed initial setting.php perms.
168 - Added files dir.
169
170 * Wed May 30 2007 Jon Ciesla <limb@jcomserv.net> - 5.1-2
171 - Fixed category, duped docs, apache restart, cron job.
172
173 * Wed May 30 2007 Jon Ciesla <limb@jcomserv.net> - 5.1-1
174 - Initial packaging.