back to 4.7
[drupal.git] / drupal.spec
1 #
2 # $Id$
3 #
4
5 %define name drupal
6 %define version 4.7.11
7 %define taglevel 0
8
9 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
10
11 Packager: PlanetLab Central <support@planet-lab.org>
12
13 # remain compliant with former planetlab practices
14 %define drupaldir /var/www/html
15 Name: %{name}
16 Version:  %{version}
17 Release:  %{release}
18 Summary: An open-source content-management platform
19
20 Group: Applications/Publishing
21 License: GPLv2+        
22 URL: http://www.drupal.org
23 Source0: http://ftp.osuosl.org/pub/drupal/files/projects/%{name}-%{version}.tar.gz
24 #Source1: drupal.conf
25 Source2: drupal-README.fedora
26 Source3: drupal-cron
27 Source4: drupal-README.planetlab
28 Patch0: drupal-6.0-scripts-noshebang.patch
29
30 BuildArch: noarch
31 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
32 Requires: php, php-gd, php-mbstring, wget
33
34 %description
35 Equipped with a powerful blend of features, Drupal is a Content Management 
36 System written in PHP that can support a variety of websites ranging from
37 personal weblogs to large community-driven websites.  Drupal is highly
38 configurable, skinnable, and secure.
39
40 %prep
41
42 %setup -q
43
44 %patch0
45 chmod -x scripts/drupal.sh
46
47 %build
48
49 %install
50 rm -rf %{buildroot}
51 install -d %{buildroot}%{drupaldir}
52 cp -pr * %{buildroot}%{drupaldir}
53 cp -pr .htaccess %{buildroot}%{drupaldir}
54 #mkdir -p %{buildroot}%{_sysconfdir}/httpd
55 #mkdir -p %{buildroot}%{_sysconfdir}/httpd/conf.d
56 #cp -pr %SOURCE1 %{buildroot}%{_sysconfdir}/httpd/conf.d
57 #mkdir -p %{buildroot}%{_sysconfdir}/drupal
58 #mv %{buildroot}%{drupaldir}/sites/* %{buildroot}%{_sysconfdir}/drupal
59 #rmdir %{buildroot}%{drupaldir}/sites
60 #ln -s ../../..%{_sysconfdir}/drupal %{buildroot}%{drupaldir}/sites
61 mkdir -p %{buildroot}%{_docdir}
62 cp -pr %SOURCE2 .
63 cp -pr %SOURCE4 .
64 install -D -p -m 0644 %SOURCE3 %{buildroot}%{_sysconfdir}/cron.hourly/drupal 
65 #mkdir -p %{buildroot}%{_localstatedir}/lib/drupal
66 #ln -s ../../..%{_localstatedir}/lib/drupal %{buildroot}%{drupaldir}/files
67 mkdir %{buildroot}%{drupaldir}/files
68
69 %clean
70 rm -rf %{buildroot}
71
72 %files
73 %defattr(-,root,root,-)
74 %doc CHANGELOG.txt INSTALL* LICENSE* MAINTAINERS.txt UPGRADE.txt 
75 %doc drupal-README.fedora drupal-README.planetlab sites/all/README.txt
76 %{drupaldir}
77 %config(noreplace) %{drupaldir}/.htaccess
78 %exclude %{drupaldir}/CHANGELOG.txt
79 %exclude %{drupaldir}/INSTALL* 
80 %exclude %{drupaldir}/LICENSE* 
81 %exclude %{drupaldir}/MAINTAINERS.txt 
82 %exclude %{drupaldir}/UPGRADE.txt
83 #%dir %{_sysconfdir}/drupal/
84 #%config(noreplace) %{_sysconfdir}/drupal/all
85 %config(noreplace) %{drupaldir}/sites/all
86 #%exclude %{_sysconfdir}/drupal/all/README.txt
87 %exclude %{drupaldir}/sites/all/README.txt
88 #%config(noreplace) %{_sysconfdir}/drupal/default
89 %config(noreplace) %{drupaldir}/sites/default
90 #%config(noreplace) %{_sysconfdir}/httpd/conf.d/drupal.conf
91 %attr(755,root,apache) %{_sysconfdir}/cron.hourly/drupal
92 #%dir %attr(775,root,apache) %{_localstatedir}/lib/drupal/
93 %dir %attr(775,root,apache) %{drupaldir}/files
94
95 %changelog
96 * Thu Dec 11 2008 Jon Ciesla <limb@jcomserv.net> - 6.7-1
97 - Upgrade to 6.7, SA-2008-073.
98
99 * Wed Oct 22 2008 Jon Ciesla <limb@jcomserv.net> - 6.6-1
100 - Upgrade to 6.6, SA-2008-067.
101
102 * Thu Oct 09 2008 Jon Ciesla <limb@jcomserv.net> - 6.5-1
103 - Upgrade to 6.5, SA-2008-060.
104 - Added notes to README and drupal.conf re CVE-2008-3661.
105
106 * Thu Aug 14 2008 Jon Ciesla <limb@jcomserv.net> - 6.4-1
107 - Upgrade to 6.4, SA-2008-047.
108
109 * Thu Jul 10 2008 Jon Ciesla <limb@jcomserv.net> - 6.3-1
110 - Upgrade to 6.3, upstream security fixes, SA-2008-044.
111
112 * Thu Apr 10 2008 Jon Ciesla <limb@jcomserv.net> - 6.2-1
113 - Upgrade to 6.2, upstream security fixes, SA-2008-026.
114
115 * Thu Feb 28 2008 Jon Ciesla <limb@jcomserv.net> - 6.1-1
116 - Upgrade to 6.1, upstream security fixes, SA-2008-018.
117
118 * Fri Feb 22 2008 Jon Ciesla <limb@jcomserv.net> - 6.0-1
119 - Upgrade to 6.0.
120 - Updated noshebang patch.
121
122 * Mon Feb 04 2008 Jon Ciesla <limb@jcomserv.net> - 5.7-1
123 - Upgrade to 5.7, several non-security bugs fixed.
124
125 * Fri Jan 11 2008 Jon Ciesla <limb@jcomserv.net> - 5.6-1
126 - Upgrade to 5.6, upstream security fixes.
127
128 * Mon Jan 07 2008 Jon Ciesla <limb@jcomserv.net> - 5.5-2
129 - Include .htaccess file, BZ 427720.
130
131 * Mon Dec 10 2007 Jon Ciesla <limb@jcomserv.net> - 5.5-1
132 - Upgrade to 5.5, critical fixes.
133
134 * Thu Dec 06 2007 Jon Ciesla <limb@jcomserv.net> - 5.4-2
135 - Fix /files -> /var/lib/drupal dir perms, BZ 414761.
136
137 * Wed Dec 05 2007 Jon Ciesla <limb@jcomserv.net> - 5.4-1
138 - Upgrade to 5.4, advisory ID DRUPAL-SA-2007-031.
139 - Augmented README regarding symlinks, BZ 254228.
140
141 * Thu Oct 18 2007 Jon Ciesla <limb@jcomserv.net> - 5.3-1
142 - Upgrade to 5.3, fixes:
143 - HTTP response splitting.
144 - Arbitrary code execution.
145 - Cross-site scripting.
146 - Cross-site request forgery.
147 - Access bypass.
148
149 * Mon Sep 24 2007 Jon Ciesla <limb@jcomserv.net> - 5.2-3
150 - Minor doc correction, BZ 301541.
151
152 * Thu Aug 16 2007 Jon Ciesla <limb@jcomserv.net> - 5.2-2
153 - License tag correction.
154
155 * Thu Jul 26 2007 Jon Ciesla <limb@jcomserv.net> - 5.2-1
156 - Upgrade to 5.2, Cross-site request forgery fix.
157
158 * Fri Jul 20 2007 Jon Ciesla <limb@jcomserv.net> - 5.1-5
159 - Corrected buildroot.
160 - Moved /etc/drupal/all/README.txt to correct place.
161
162 * Wed Jul 04 2007 Jon Ciesla <limb@jcomserv.net> - 5.1-4
163 - Made settings.php not readonly by default, with note in drupal-README.fedora
164 - Locked down initial security configuration, documented steps required.
165 - Description cleanup.
166 - Added wget requires.
167
168 * Wed Jun 06 2007 Jon Ciesla <limb@jcomserv.net> - 5.1-3
169 - Fixed initial setting.php perms.
170 - Added files dir.
171
172 * Wed May 30 2007 Jon Ciesla <limb@jcomserv.net> - 5.1-2
173 - Fixed category, duped docs, apache restart, cron job.
174
175 * Wed May 30 2007 Jon Ciesla <limb@jcomserv.net> - 5.1-1
176 - Initial packaging.