tweak for building in fedora20
[ipfw-google.git] / planetlab / ipfwroot.spec
1 #
2 # Marta Carbone <marta.carbone@iet.unipi.it>
3 # 2009 - Universita` di Pisa
4 # License is BSD.
5
6 # kernel_release, kernel_version and kernel_arch are expected to be set by the build to e.g.
7 # kernel_release : 24.onelab  (24 is then the planetlab taglevel)
8 # kernel_version : 2.6.27.57 | 2.6.32  (57 in the 27 case is the patch level)
9 # kernel_arch :    i686 | x86_64
10
11 # the 2012 release was pulled from http://info.iet.unipi.it/~marta/dummynet/ipfw3-20120610.tar.gz
12 # seel also          http://sourceforge.net/p/dummynet/code
13 # in 2013 Marta has moved to sourceforge at
14 # git clone git://git.code.sf.net/p/dummynet/code your read-only code
15 %define name ipfwroot
16 %define version 3
17 %define taglevel 1
18
19 # when no planetlab kernel is being built, kernel_version is defined but empty
20 %define _with_planetlab_kernel %{?kernel_version:1}%{!?kernel_version:0}
21 # we need to make sure that this rpm gets upgraded when the kernel release changes
22 %if %{_with_planetlab_kernel}
23 # with the planetlab kernel
24 %define pl_kernel_taglevel %( echo %{kernel_release} | cut -d. -f1 )
25 %define ipfw_release %{kernel_version}.%{pl_kernel_taglevel}
26 %else
27 # with the stock kernel
28 # this line below
29 #%define ipfw_release %( rpm -q --qf "%{version}" kernel-headers )
30 # causes recursive macro definition no matter how much you quote
31 %define percent %
32 %define braop \{
33 %define bracl \}
34 %define kernel_version %( rpm -q --qf %{percent}%{braop}version%{bracl} kernel-headers )
35 %define kernel_release %( rpm -q --qf %{percent}%{braop}release%{bracl} kernel-headers )
36 %define kernel_arch %( rpm -q --qf %{percent}%{braop}arch%{bracl} kernel-headers )
37 %define ipfw_release %{kernel_version}.%{kernel_release}
38 %endif
39
40 %define release %{ipfw_release}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
41
42 # guess which convention is used; k27 and before used dash, k32 uses dot
43 %define kernelpath_dash /usr/src/kernels/%{kernel_version}-%{kernel_release}-%{kernel_arch}
44 %define kernelpath_dot /usr/src/kernels/%{kernel_version}-%{kernel_release}.%{kernel_arch}
45 %define kernelpath %( [ -d %{kernelpath_dot} ] && echo %{kernelpath_dot} || echo %{kernelpath_dash} )
46
47 # the k32 kernel currently builds e.g. /lib/modules/2.6.32-0.onelab.2010.12.07-i686
48 # the k27 and before does not have the -i686 part
49 %define kernel_id_old %{kernel_version}-%{kernel_release}
50 %define kernel_id_new %{kernel_version}-%{kernel_release}.%{kernel_arch}
51 %define kernel_id %( [ -d %{kernelpath_dot} ] && echo %{kernel_id_new} || echo %{kernel_id_old} )
52
53 Summary: ipfw and dummynet for Linux
54 Name: %{name}
55 Version: %{version}
56 Release: %{release}
57 License: BSD
58 Group: System Environment/Kernel
59 Source0: %{name}-%{version}.tar.bz2
60 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
61 Requires: kernel = %{kernel_version}-%{kernel_release}
62 # in fedora20 cronie does not provide vixie-cronie anymore, just cronie
63 Requires: cronie
64 Requires: vsys-scripts
65 Obsoletes: ipfw
66
67 Vendor: unipi
68 Packager: PlanetLab <marta@onelab2.iet.unipi.it>
69 # XXX ask 
70 Distribution: PlanetLab %{plrelease}
71 URL: %{SCMURL}
72
73 %description
74 ipfw is the Linux port of the FreeBSD ipfw and dummynet packages
75
76 %prep
77 %setup
78
79 %build
80 # clean the rpm build directory
81 rm -rf $RPM_BUILD_ROOT
82
83 %__make KERNELPATH=%kernelpath clean
84 %__make KERNELPATH=%kernelpath IPFW_PLANETLAB=1
85
86 %install
87 install -D -m 755 kipfw-mod/ipfw_mod.ko $RPM_BUILD_ROOT/lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
88 install -D -m 755 ipfw/ipfw $RPM_BUILD_ROOT/sbin/ipfw
89 install -D -m 644 planetlab/ipfw.cron $RPM_BUILD_ROOT/%{_sysconfdir}/cron.d/ipfw.cron
90 install -D -m 755 planetlab/ipfw $RPM_BUILD_ROOT/etc/rc.d/init.d/ipfw
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %post
96 ### this script is also triggered while the node image is being created at build-time
97 # some parts of the script do not make sense in this context
98 # this is why the build exports PL_BOOTCD=1 in such cases
99 depmod -a %{kernel_id}
100 /sbin/chkconfig --add ipfw
101 # start the service if not building
102 [ -z "$PL_BOOTCD" ] && service ipfw start
103
104 %postun
105 # stop the service if not building
106 [ -z "$PL_BOOTCD" ] && service ipfw stop
107
108 # here there is a list of the final installation directories
109 %files
110 %defattr(-,root,root)
111 %dir /lib/modules/%{kernel_id}
112 /lib/modules/%{kernel_id}/net/netfilter/ipfw_mod.ko
113 /sbin/ipfw
114 %{_sysconfdir}/cron.d/ipfw.cron
115 /etc/rc.d/init.d/ipfw
116
117 %changelog
118 * Mon Jul 09 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-20120610-2
119 - cosmetic changes only in specfile
120
121 * Fri Jun 15 2012 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-20120610-1
122 - integrated ipfw3 as of 20120610 from upstream
123
124 * Mon Oct 24 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-23
125 - for building against k32 on f8
126
127 * Sun Oct 02 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-22
128 - rpm version number has the kernel taglevel embedded
129
130 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-21
131 - build tweaks for gcc-4.6 on f15
132
133 * Sun Jan 23 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-20
134 - tweaks for compiling on k32/64 bits
135
136 * Wed Dec 08 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-19
137 - fix detection of kernel conventions
138
139 * Tue Dec 07 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-18
140 - guess conventions for either <=k27 or >=k32
141
142 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-17
143 - testing git only module-tag
144
145 * Tue Jun 15 2010 Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-16
146 - tagging ipfw to test module-tools on (pure) git
147
148 * Wed May 12 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-15
149 - tagging for obsoletes
150
151 * Tue Apr 27 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-13
152 - Update to the ipfw3 version of the dummynet code.
153
154 * Mon Apr 12 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-11
155 - add ipfw initialization script to chkconfig
156
157 * Wed Mar 03 2010 Talip Baris Metin <Talip-Baris.Metin@sophia.inria.fr> - ipfw-0.9-10
158 - - Load module at installation - Marta
159
160 * Mon Jan 11 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-9
161 - consistent with vsys-scripts-0.95-13
162
163 * Mon Jan 11 2010 Marta Carbone <marta.carbone@iet.unipi.it>
164 - Integrated the ipfw rules cleanup into the backend
165
166 * Sat Jan 09 2010 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-8
167 - builds on 2.6.22 & 2.6.27 - for 32 and 64 bits
168
169 * Wed Jan 06 2010 Marta Carbone <marta.carbone@iet.unipi.it>
170 - move to dummynet2, added support for table lookup
171 - added the vsys-script dependencies and the ipfw initialization
172
173 * Tue Dec 15 2009 Marta Carbone <marta.carbone@iet.unipi.it>
174 - more work on the radix code, added sysctl read/write support
175
176 * Sun Nov 29 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-7
177 - added missing qsort.c - tag 0.9-6 was broken
178
179 * Thu Nov 26 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-6
180 - root: removed goto into the main ipfw switch, enabled slice_id matching
181 - slice: completely move netconfig checks into the backend
182
183 * Mon Nov 09 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-5
184 - additional features on matching packets, including uid match
185
186 * Mon Sep 07 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-4
187 - on behalf of Marta Carbone, more options and features
188
189 * Thu Jul 23 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-3
190 - fixed memory usage issue
191
192 * Wed Jul 15 2009 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - ipfw-0.9-2
193 - patch for building on x86_64
194
195 * Thu Jun 25 2009 Marta Carbone <marta.carbone@iet.unipi.it>
196 - post installation removed for deployment, moved manpages to the slice package
197
198 * Fri Apr 17 2009 Marta Carbone <marta.carbone@iet.unipi.it>
199 - Initial release