Setting tag iproute2-2.6.38-1
[iproute2.git] / iproute.spec
1 %define name iproute
2 %define version 2.6.38
3 %define taglevel 1
4
5 %define release %{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
6
7 %define cbq_version v0.7.3
8
9 Vendor: PlanetLab
10 Packager: PlanetLab Central <support@planet-lab.org>
11 Distribution: PlanetLab %{plrelease}
12 URL: %{SCMURL}
13
14 Summary: Advanced IP routing and network device configuration tools.
15 Name: %{name}
16 Version: %{version}
17 Release: %{release}
18 Group: Applications/System
19 #Source: http://developer.osdl.org/dev/iproute2/download/iproute2-%{version}-050314.tar.gz
20 #URL:    http://developer.osdl.org/dev/iproute2/
21 Source: iproute2-%{version}.tar.bz2
22 Patch1: gre.patch
23 Patch2: compile.patch
24 License: GNU GPL
25 BuildRoot: %{_tmppath}/%{name}-%{version}-root
26 BuildRequires: tetex-latex tetex-dvips psutils linuxdoc-tools db4-devel bison flex
27
28 %description
29 The iproute package contains networking utilities (ip and rtmon, for
30 example) which are designed to use the advanced networking
31 capabilities of the Linux 2.4.x and 2.6.x kernel.
32
33 %prep
34 %setup -q -n iproute2-%{version}
35 %patch1 -p1
36 %patch2 -p1
37
38 %build
39 make
40 #make -C doc
41
42 %install
43 #rm -rf $RPM_BUILD_ROOT
44 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
45
46 mkdir -p $RPM_BUILD_ROOT/sbin \
47          $RPM_BUILD_ROOT%{_sbindir} \
48          $RPM_BUILD_ROOT%{_mandir}/man8 \
49          $RPM_BUILD_ROOT/etc/iproute2 \
50          $RPM_BUILD_ROOT%{_datadir}/tc \
51
52 install -m 755 ip/ip ip/ifcfg ip/rtmon tc/tc $RPM_BUILD_ROOT/sbin
53 install -m 755 misc/ss misc/nstat misc/rtacct misc/lnstat misc/arpd $RPM_BUILD_ROOT%{_sbindir}
54 install -m 644 netem/normal.dist netem/pareto.dist netem/paretonormal.dist $RPM_BUILD_ROOT%{_datadir}/tc
55 install -m 644 man/man8/*.8 $RPM_BUILD_ROOT/%{_mandir}/man8
56 rm -r $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
57 iconv -f latin1 -t utf8 < man/man8/ss.8 > $RPM_BUILD_ROOT/%{_mandir}/man8/ss.8
58 install -m 755 examples/cbq.init-%{cbq_version} $RPM_BUILD_ROOT/sbin/cbq
59 install -d -m 755 $RPM_BUILD_ROOT/%{_sysconfdir}/sysconfig/cbq
60
61 cp -f etc/iproute2/* $RPM_BUILD_ROOT/etc/iproute2
62 rm -rf $RPM_BUILD_ROOT/%{_libdir}/debug/*
63
64 %clean
65 #rm -rf $RPM_BUILD_ROOT
66 [ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(-,root,root)
70 %dir /etc/iproute2
71 %doc README.decnet README.iproute2+tc RELNOTES
72 #%doc doc/*.ps
73 %doc examples
74 /sbin/*
75 %{_mandir}/man8/*
76 %attr(644,root,root) %config(noreplace) /etc/iproute2/*
77 %{_sbindir}/*
78 %dir %{_datadir}/tc
79 %{_datadir}/tc/*
80
81 %changelog
82 * Fri Oct 14 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iproute2-2.6.38-1
83 - remove spurious space
84
85 * Mon Sep 26 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iproute2-2.6.37-3
86 - no functional change, just pull main tarball from our mirror
87
88 * Fri Jun 10 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iproute2-2.6.37-2
89 - only a cleaner specfile
90
91 * Tue Jun 07 2011 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - iproute2-2.6.37-1
92 - dont rebuild doc
93
94 * Fri Apr 16 2010 S.Çağlar Onur <caglar@cs.princeton.edu> - iproute2-2.6.33-2
95 - Fix taglevel
96
97 * Thu Jun 26 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - iproute2-2.6.16-2
98 - Should fix build error caused by new version of kernel headers.:
99
100 * Tue Mar 15 2005 Radek Vokal <rvokal@redhat.com> 2.6.11-1
101 - update to iproute-2.6.11
102
103 * Fri Mar 04 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-2
104 - gcc4 rebuilt
105
106 * Wed Feb 16 2005 Radek Vokal <rvokal@redhat.com> 2.6.10-1
107 - update to iproute-2.6.10
108
109 * Thu Dec 23 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-6
110 - added arpd into sbin
111
112 * Mon Nov 29 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-5
113 - debug info removed from makefile and from spec (#140891)
114
115 * Tue Nov 16 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-4
116 - source file updated from snapshot version
117 - endian patch adding <endian.h> 
118
119 * Sat Sep 18 2004 Joshua Blanton <jblanton@cs.ohiou.edu> 2.6.9-3
120 - added installation of netem module for tc
121
122 * Mon Sep 06 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-2
123 - fixed possible buffer owerflow, path by Steve Grubb <linux_4ever@yahoo.com>
124
125 * Wed Sep 01 2004 Radek Vokal <rvokal@redhat.com> 2.6.9-1
126 - updated to iproute-2.6.9, spec file change, patches cleared
127
128 * Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
129 - rebuilt
130
131 * Wed May 26 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-16
132 - Took tons of manpages from debian, much more complete (#123952).
133
134 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-15
135 - rebuilt
136
137 * Thu May 06 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-13.2
138 - Built security errata version for FC1.
139
140 * Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.4.7-14
141 - Fixed -f option for ss (#118355).
142 - Small description fix (#110997).
143 - Added initialization of some vars (#74961). 
144 - Added patch to initialize "default" rule as well (#60693).
145
146 * Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
147 - rebuilt
148
149 * Wed Nov 05 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-12
150 - Security errata for netlink (CAN-2003-0856).
151
152 * Thu Oct 23 2003 Phil Knirsch <pknirsch@redhat.com>
153 - Updated to latest version. Used by other distros, so seems stable. ;-)
154 - Quite a few patches needed updating in that turn.
155 - Added ss (#107363) and several other new nifty tools.
156
157 * Tue Jun 17 2003 Phil Knirsch <pknirsch@redhat.com>
158 - rebuilt
159
160 * Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
161 - rebuilt
162
163 * Wed Jan 22 2003 Tim Powers <timp@redhat.com>
164 - rebuilt
165
166 * Thu Jan 16 2003 Phil Knirsch <pknirsch@redhat.com> 2.4.7-7
167 - Added htb3-tc patch from http://luxik.cdi.cz/~devik/qos/htb/ (#75486).
168
169 * Fri Oct 11 2002 Bill Nottingham <notting@redhat.com> 2.4.7-6
170 - remove flags patch at author's request
171
172 * Fri Jun 21 2002 Tim Powers <timp@redhat.com>
173 - automated rebuild
174
175 * Wed Jun 19 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-4
176 - Don't forcibly strip binaries
177
178 * Mon May 27 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-3
179 - Fixed missing diffserv and atm support in config (#57278).
180 - Fixed inconsistent numeric base problem for command line (#65473).
181
182 * Tue May 14 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-2
183 - Added patch to fix crosscompiling by Adrian Linkins.
184
185 * Fri Mar 15 2002 Phil Knirsch <pknirsch@redhat.com> 2.4.7-1
186 - Update to latest stable release 2.4.7-now-ss010824.
187 - Added simple man page for ip.
188
189 * Wed Aug  8 2001 Bill Nottingham <notting@redhat.com>
190 - allow setting of allmulti & promisc flags (#48669)
191
192 * Mon Jul 02 2001 Than Ngo <than@redhat.com>
193 - fix build problem in beehive if kernel-sources is not installed
194
195 * Fri May 25 2001 Helge Deller <hdeller@redhat.de>
196 - updated to iproute2-2.2.4-now-ss001007.tar.gz 
197 - bzip2 source tar file
198 - "License" replaces "Copyright"
199 - added "BuildPrereq: tetex-latex tetex-dvips psutils"
200 - rebuilt for 7.2
201
202 * Tue May  1 2001 Bill Nottingham <notting@redhat.com>
203 - use the system headers - the included ones are broken
204 - ETH_P_ECHO went away
205
206 * Sat Jan  6 2001 Jeff Johnson <jbj@redhat.com>
207 - test for specific KERNEL_INCLUDE directories.
208
209 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
210 - rebuild for 7.1
211
212 * Thu Oct 12 2000 Than Ngo <than@redhat.com>
213 - add default configuration files for iproute (Bug #10549, #18887)
214
215 * Tue Jul 25 2000 Jakub Jelinek <jakub@redhat.com>
216 - fix include-glibc/ to cope with glibc 2.2 new resolver headers
217
218 * Thu Jul 13 2000 Prospector <bugzilla@redhat.com>
219 - automatic rebuild
220
221 * Sun Jun 18 2000 Than Ngo <than@redhat.de>
222 - rebuilt in the new build environment
223 - use RPM macros
224 - handle RPM_OPT_FLAGS
225
226 * Sat Jun 03 2000 Than Ngo <than@redhat.de>
227 - fix iproute to build with new glibc
228
229 * Fri May 26 2000 Ngo Than <than@redhat.de>
230 - update to 2.2.4-now-ss000305
231 - add configuration files
232
233 * Mon Sep 13 1999 Bill Nottingham <notting@redhat.com>
234 - strip binaries
235
236 * Mon Aug 16 1999 Cristian Gafton <gafton@redhat.com>
237 - first build