593
[linux-2.6.git] / kernel-2.6-planetlab.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define builduml 0
8 %define buildxen 0
9 %define builddoc 0
10
11 # Versions of various parts
12
13 %define _with_netns 1
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 22
22 %define patchlevel 14
23 %define kversion 2.6.%{sublevel}
24 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
25
26 %define vsversion 2.3.0.29
27
28 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
29 # updated every time the PL kernel is updated.
30 %define vini_pl_patch 561
31
32 %define specrelease 1
33
34 %define release vs%{vsversion}.%{specrelease}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
35
36 %{!?pldistro:%global pldistro planetlab}
37
38 %define signmodules 0
39 %define make_target bzImage
40 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
41
42 # Override generic defaults with per-arch defaults
43
44 %define image_install_path boot
45
46 #
47 # Three sets of minimum package version requirements in the form of Conflicts:
48 # to versions below the minimum
49 #
50
51 #
52 # First the general kernel 2.6 required versions as per
53 # Documentation/Changes
54 #
55 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
56
57
58 # Then a series of requirements that are distribution specific, either 
59 # because we add patches for something, or the older versions have 
60 # problems with the newer kernel or lack certain things that make 
61 # integration in the distro harder than needed.
62 #
63 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
64
65 #
66 # Several packages had bugs in them that became obvious when the NPTL
67 # threading code got integrated.
68 #
69 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
70
71 #
72 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
73 #
74
75 # MEF commented out
76 # %define xen_conflicts glibc < 2.3.5-1
77
78 #
79 # Packages that need to be installed before the kernel is, because the %post
80 # scripts use them.
81 #
82 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
83
84 URL: http://svn.planet-lab.org/wiki/linux-2.6
85
86 Name: kernel
87 Group: System Environment/Kernel
88 License: GPLv2
89 Version: %{rpmversion}
90 Release: %{release}
91 ExclusiveOS: Linux
92 Provides: kernel = %{version}
93 Provides: kernel-drm = 4.3.0
94 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
95 Provides: kernel-smp = %{rpmversion}-%{release}
96 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
97 Prereq: %{kernel_prereq}
98 Conflicts: %{kernel_dot_org_conflicts}
99 Conflicts: %{package_conflicts}
100 Conflicts: %{nptl_conflicts}
101 # We can't let RPM do the dependencies automatic because it'll then pick up
102 # a correct but undesirable perl dependency from the module headers which
103 # isn't required for the kernel proper to function
104 AutoReqProv: no
105
106 #
107 # List the packages used during the kernel build
108 #
109 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
110 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
111 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
112 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
113
114
115 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
116
117 Source10: kernel-%{kversion}-i586-%{pldistro}.config
118 Source11: kernel-%{kversion}-i686-%{pldistro}.config
119 Source12: kernel-%{kversion}-x86_64-%{pldistro}.config
120 %if %{builduml}
121 Source20: kernel-%{kversion}-i686-uml-%{pldidstro}.config
122 %endif
123 %if %{buildxen}
124 Source30: kernel-%{kversion}-i686-xenU-%{pldistro}.config
125 %endif
126
127 # Mainline patches
128 %if "0%{patchlevel}"
129 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
130 %endif
131
132 Patch010: linux-2.6-010-e1000e.patch
133 Patch020: linux-2.6-020-build-id.patch
134 Patch030: linux-2.6-030-netns.patch
135
136 # These are patches picked up from Fedora/RHEL
137 Patch100: linux-2.6-100-build-nonintconfig.patch
138
139 # Linux-VServer
140 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
141
142 # IP sets
143 Patch250: linux-2.6-250-ipsets.patch
144
145 # PlanetLab
146 Patch500: linux-2.6-500-vserver-filesharing.patch
147 Patch510: linux-2.6-510-ipod.patch
148 Patch520: linux-2.6-520-vnet+.patch
149 Patch530: linux-2.6-530-built-by-support.patch
150 Patch540: linux-2.6-540-oom-kill.patch
151 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
152 Patch560: linux-2.6-560-mmconf.patch
153 Patch570: linux-2.6-570-tagxid.patch
154 Patch590: linux-2.6-590-trellis-mm1-netns.patch
155 Patch591: linux-2.6-591-unshare-netns.patch
156 Patch592: linux-2.6-592-ztun-sb.patch
157
158 %description
159 The kernel package contains the Linux kernel (vmlinuz), the core of any
160 Linux operating system.  The kernel handles the basic functions
161 of the operating system:  memory allocation, process allocation, device
162 input and output, etc.
163
164 %package devel
165 Summary: Development package for building kernel modules to match the kernel.
166 Group: System Environment/Kernel
167 AutoReqProv: no
168 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
169 Provides: kernel-smp-devel = %{rpmversion}-%{release}
170 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
171 Prereq: /usr/bin/find
172
173 %description devel
174 This package provides kernel headers and makefiles sufficient to build modules
175 against the kernel package.
176
177
178 %package doc
179 Summary: Various documentation bits found in the kernel source.
180 Group: Documentation
181
182 %description doc
183 This package contains documentation files from the kernel
184 source. Various bits of information about the Linux kernel and the
185 device drivers shipped with it are documented in these files.
186
187 You'll want to install this package if you need a reference to the
188 options that can be passed to Linux kernel modules at load time.
189
190 %package xenU
191 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
192
193 Group: System Environment/Kernel
194 Provides: kernel = %{version}
195 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
196 Prereq: %{kernel_prereq}
197 Conflicts: %{kernel_dot_org_conflicts}
198 Conflicts: %{package_conflicts}
199 Conflicts: %{nptl_conflicts}
200
201 # MEF commented out 
202 # Conflicts: %{xen_conflicts}
203
204 # We can't let RPM do the dependencies automatic because it'll then pick up
205 # a correct but undesirable perl dependency from the module headers which
206 # isn't required for the kernel proper to function
207 AutoReqProv: no
208
209 %description xenU
210 This package includes a version of the Linux kernel which
211 runs in Xen unprivileged guest VMs.  This should be installed
212 both inside the unprivileged guest (for the modules) and in
213 the guest0 domain.
214
215 %package xenU-devel
216 Summary: Development package for building kernel modules to match the kernel.
217 Group: System Environment/Kernel
218 AutoReqProv: no
219 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
220 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
221 Provides: kernel-devel = %{rpmversion}-%{release}xenU
222 Prereq: /usr/sbin/hardlink, /usr/bin/find
223
224 %description xenU-devel
225 This package provides kernel headers and makefiles sufficient to build modules
226 against the kernel package.
227
228 %package uml
229 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
230
231 Group: System Environment/Kernel
232
233 %description uml
234 This package includes a user mode version of the Linux kernel.
235
236 %package uml-devel
237 Summary: Development package for building kernel modules to match the UML kernel.
238 Group: System Environment/Kernel
239 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
240 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
241 Provides: kernel-devel = %{rpmversion}-%{release}smp
242 AutoReqProv: no
243 Prereq: /usr/sbin/hardlink, /usr/bin/find
244
245 %description uml-devel
246 This package provides kernel headers and makefiles sufficient to build modules
247 against the User Mode Linux kernel package.
248
249 %package uml-modules
250 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
251
252 Group: System Environment/Kernel
253
254 %description uml-modules
255 This package includes a user mode version of the Linux kernel modules.
256
257 %package vserver
258 Summary: A placeholder RPM that provides kernel and kernel-drm
259
260 Group: System Environment/Kernel
261 Provides: kernel = %{version}
262 Provides: kernel-drm = 4.3.0
263 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
264
265 %description vserver
266 VServers do not require and cannot use kernels, but some RPMs have
267 implicit or explicit dependencies on the "kernel" package
268 (e.g. tcpdump). This package installs no files but provides the
269 necessary dependencies to make rpm and yum happy.
270
271
272 %prep
273 # First we unpack the kernel tarball.
274 # If this isn't the first make prep, we use links to the existing clean tarball
275 # which speeds things up quite a bit.
276 if [ ! -d kernel-%{kversion}/vanilla ]; then
277   # Ok, first time we do a make prep.
278   rm -f pax_global_header
279 %setup -q -n %{name}-%{kversion} -c
280   mv linux-%{kversion} vanilla
281 else
282   # We already have a vanilla dir.
283   cd kernel-%{kversion}
284 fi
285
286 KERNEL_PREVIOUS=vanilla
287 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
288 %define ApplyPatch() \
289   rm -fr linux-%{kversion}-%1                           \
290   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
291   patchflag=-p1                                         \
292   test "%2" != "%%2" && patchflag="%2"                  \
293   PATCH="%{expand:%{PATCH%1}}"                          \
294   if test ! -e "$PATCH"; then                           \
295     echo "Patch %1 does not exist!"                     \
296     exit 1                                              \
297   fi                                                    \
298   case "$PATCH" in                                      \
299     *.bz2)  bzcat "$PATCH";;                            \
300     *.gz)   zcat "$PATCH";;                             \
301     *)      cat "$PATCH";;                              \
302   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
303   KERNEL_PREVIOUS=linux-%{kversion}-%1
304
305 # This is where the patches get applied
306 %if "0%{patchlevel}"
307 %ApplyPatch 0
308 %endif
309
310 %ApplyPatch 10
311 %ApplyPatch 20
312
313 %ApplyPatch 100
314
315 %ApplyPatch 200
316
317 %ApplyPatch 250
318
319 %ApplyPatch 500
320 %ApplyPatch 510
321 %ApplyPatch 520
322 %ApplyPatch 530
323 %ApplyPatch 540
324 %ApplyPatch 550
325 %ApplyPatch 560
326 %ApplyPatch 570
327
328
329 %if 0%{?_with_netns}
330 %ApplyPatch 590
331 %ApplyPatch 591
332 %ApplyPatch 592
333 %endif
334
335 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
336 # break with later patches.
337
338 rm -fr linux-%{kversion}
339 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
340 cd linux-%{kversion}
341
342
343 # make sure the kernel has the sublevel we know it has. This looks weird
344 # but for -pre and -rc versions we need it since we only want to use
345 # the higher version when the final kernel is released.
346 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
347 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
348
349 # get rid of unwanted files resulting from patch fuzz
350 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
351
352
353 ###
354 ### build
355 ###
356 %build
357
358 BuildKernel() {
359     MakeTarget=$1
360     Arch=$2
361     Flavour=$3
362
363     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
364     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
365     cd linux-%{_target_cpu}-%{kversion}$Flavour
366
367     # Pick the right config file for the kernel we're building
368     if [ -n "$Flavour" ] ; then
369       Config=kernel-%{kversion}-%{_target_cpu}-$Flavour-%{pldistro}.config
370       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
371       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
372     else
373       Config=kernel-%{kversion}-%{_target_cpu}-%{pldistro}.config
374       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
375       DevelLink=
376     fi
377
378     KernelVer=%{version}-%{release}$Flavour
379     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
380
381     # make sure EXTRAVERSION says what we want it to say
382     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
383
384     # and now to start the build process
385
386     make -s mrproper
387     cp %{_sourcedir}/$Config .config
388
389     #Arch=`head -1 .config | cut -b 3-`
390     echo USING ARCH=$Arch
391
392     make -s ARCH=$Arch nonint_oldconfig > /dev/null
393     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
394     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
395
396     # Start installing the results
397
398 %if "%{_enable_debug_packages}" == "1"
399     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
400 %endif
401     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
402     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
403     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
404     if [ -f arch/$Arch/boot/bzImage ]; then
405       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
406     fi
407     if [ -f arch/$Arch/boot/zImage.stub ]; then
408       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
409     fi
410     if [ "$Flavour" = "uml" ] ; then
411         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
412     fi
413
414     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
415     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
416
417     # And save the headers/makefiles etc for building modules against
418     #
419     # This all looks scary, but the end result is supposed to be:
420     # * all arch relevant include/ files
421     # * all Makefile/Kconfig files
422     # * all script/ files
423
424     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
425     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
426     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
427     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
428     # dirs for additional modules per module-init-tools, kbuild/modules.txt
429     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
430     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
431     # first copy everything
432     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
433         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
434     if [ "$Flavour" = "uml" ] ; then
435       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
436     fi
437     # then drop all but the needed Makefiles/Kconfig files
438     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
439     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
440     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
441     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
442     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
443     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
444     if [ -d arch/%{_arch}/scripts ]; then
445       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
446     fi
447     if [ -f arch/%{_arch}/*lds ]; then
448       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
449     fi
450     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
451     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
452     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
453     cd include
454     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
455     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
456     if [ "$Arch" = "x86_64" ]; then
457       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
458     fi
459 %if %{buildxen}
460     if [ "$Flavour" = "xenU" ]; then
461       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
462       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
463     fi
464 %endif
465 %if %{builduml}
466     if [ "$Flavour" = "uml" ] ; then
467       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
468     fi
469 %endif
470     # While arch/powerpc/include/asm is still a symlink to the old
471     # include/asm-ppc{64,} directory, include that in kernel-devel too.
472     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
473       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
474       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
475       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
476       ln -sf ../../../include/asm-ppc* asm
477       popd
478     fi
479
480     # Make sure the Makefile and version.h have a matching timestamp so that
481     # external modules can be built
482     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
483     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
484     cd ..
485
486     #
487     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
488     #
489 %if "%{_enable_debug_packages}" == "1"
490     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
491     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
492 %endif
493 %if %{buildxen}
494     if [ -f vmlinuz ]; then
495       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
496     fi
497 %endif
498
499     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
500
501     # mark modules executable so that strip-to-file can strip them
502     cat modnames | xargs chmod u+x
503
504     # remove files that will be auto generated by depmod at rpm -i time
505     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
506
507     # Move the devel headers out of the root file system
508     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
509     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
510     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
511     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
512 }
513
514 ###
515 # DO it...
516 ###
517
518 # prepare directories
519 rm -rf $RPM_BUILD_ROOT
520 mkdir -p $RPM_BUILD_ROOT/boot
521
522 %if "%{_target_cpu}" == "x86_64"
523 %define kernel_arch %{_target_cpu}
524 %endif
525 %if "%{_target_cpu}" == "i586"
526 %define kernel_arch i386
527 %endif
528 %if "%{_target_cpu}" == "i686"
529 %define kernel_arch i386
530 %endif
531
532 %if %{buildup}
533 BuildKernel %make_target %kernel_arch
534 %endif
535
536 %ifarch i686
537 %if %{builduml}
538 BuildKernel linux um uml
539 %endif
540
541 %if %{buildxen}
542 BuildKernel vmlinuz %kernel_arch xenU
543 %endif
544 %endif
545
546 ###
547 ### install
548 ###
549
550 %install
551
552 cd vanilla
553
554 %if %{buildxen} && "%{_target_cpu}" == "i686"
555 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
556 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
557 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
558 # This directive teaches ldconfig to search in nosegneg subdirectories
559 # and cache the DSOs there with extra bit 0 set in their hwcap match
560 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
561 # search in nosegneg subdirectories and to match this extra hwcap bit
562 # in the ld.so.cache file.
563 hwcap 0 nosegneg
564 EOF
565 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
566 %endif
567
568 %if %{builddoc}
569 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
570
571 # sometimes non-world-readable files sneak into the kernel source tree
572 chmod -R a+r *
573 # copy the source over
574 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
575 %endif
576
577 ###
578 ### clean
579 ###
580
581 %clean
582 rm -rf $RPM_BUILD_ROOT
583
584 ###
585 ### scripts
586 ###
587
588 # load the loop module for upgrades...in case the old modules get removed we have
589 # loopback in the kernel so that mkinitrd will work.
590 %pre
591 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
592 exit 0
593
594 %post
595 if [ -f /etc/sysconfig/kernel ]; then
596   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
597 fi
598
599 # trick mkinitrd in case the current environment does not have device mapper
600 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
601 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
602     if [ ! -f $rootdev ]; then
603         fake_root_lvm=1
604         mkdir -p $(dirname $rootdev)
605         touch $rootdev
606     fi
607 fi
608
609 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
610 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
611 # Older modutils do not support --package option
612 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
613
614 # remove fake handle
615 if [ -n "$fake_root_lvm" ]; then
616     rm -f $rootdev
617 fi
618
619 # make some useful links
620 pushd /boot > /dev/null ; {
621         ln -sf config-%{KVERREL} config
622         ln -sf config-%{KVERREL} configsmp
623         ln -sf initrd-%{KVERREL}.img initrd-boot
624         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
625         ln -sf vmlinuz-%{KVERREL} kernel-boot
626         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
627 }
628 popd > /dev/null
629
630 # ask for a reboot
631 mkdir -p /etc/planetlab
632 touch /etc/planetlab/update-reboot
633
634 %post devel
635 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
636 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
637   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
638   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
639   popd > /dev/null
640 fi
641
642 %post xenU
643 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
644 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
645
646 %post xenU-devel
647 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
648 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
649   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
650   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
651   popd > /dev/null
652 fi
653
654 %post uml-modules
655 depmod -ae %{KVERREL}uml
656
657 %preun
658 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
659 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
660
661 %preun xenU
662 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
663 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
664
665 %preun uml-modules
666 rm -f /lib/modules/%{KVERREL}uml/modules.*
667
668
669 ###
670 ### file lists
671 ###
672
673 %if %{buildup}
674 %files 
675 %defattr(-,root,root)
676 /%{image_install_path}/vmlinuz-%{KVERREL}
677 /boot/System.map-%{KVERREL}
678 /boot/config-%{KVERREL}
679 %dir /lib/modules/%{KVERREL}
680 /lib/modules/%{KVERREL}/kernel
681 /lib/modules/%{KVERREL}/build
682 /lib/modules/%{KVERREL}/source
683 /lib/modules/%{KVERREL}/extra
684 /lib/modules/%{KVERREL}/updates
685
686 %files devel
687 %defattr(-,root,root)
688 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
689 %endif
690
691 %if %{builduml} && "%{_target_cpu}" == "i686"
692 %files uml
693 %defattr(-,root,root)
694 %{_bindir}/linux
695
696 %files uml-devel
697 %defattr(-,root,root)
698 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
699 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
700
701 %files uml-modules
702 %defattr(-,root,root)
703 /boot/System.map-%{KVERREL}uml
704 /boot/config-%{KVERREL}uml
705 %dir /lib/modules/%{KVERREL}uml
706 /lib/modules/%{KVERREL}uml/kernel
707 /lib/modules/%{KVERREL}uml/build
708 /lib/modules/%{KVERREL}uml/source
709 /lib/modules/%{KVERREL}uml/extra
710 /lib/modules/%{KVERREL}uml/updates
711 %endif
712
713 %if %{buildxen} && "%{_target_cpu}" == "i686"
714 %files xenU
715 %defattr(-,root,root)
716 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
717 /boot/System.map-%{KVERREL}xenU
718 /boot/config-%{KVERREL}xenU
719 %dir /lib/modules/%{KVERREL}xenU
720 /lib/modules/%{KVERREL}xenU/kernel
721 /lib/modules/%{KVERREL}xenU/build
722 /lib/modules/%{KVERREL}xenU/source
723 /lib/modules/%{KVERREL}xenU/extra
724 /lib/modules/%{KVERREL}xenU/updates
725 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
726
727 %files xenU-devel
728 %defattr(-,root,root)
729 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
730 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
731 %endif
732
733 %files vserver
734 %defattr(-,root,root)
735 # no files
736
737 # only some architecture builds need kernel-doc
738
739 %if %{builddoc}
740 %files doc
741 %defattr(-,root,root)
742 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
743 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
744 %dir %{_datadir}/doc/kernel-doc-%{kversion}
745 %endif
746
747 %changelog
748 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
749 - 2.6.17.4
750 - Disable split pagetable lock.
751
752 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
753 - Get rid of stack backtrace on panic, which in most
754   cases actually caused a loss of info instead of a gain.
755
756 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
757 - 2.6.17.3
758
759 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
760 - 2.6.17.2
761 - Fix up the alsa list_add bug.
762
763 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
764 - Fix up various stupidities incurred by the last big rebase.
765   - Reenable SMP x86-64 builds.
766   - Reenable SMBFS.
767 - Enable PCI fake hotplug driver.
768 - Enable gameport/joystick on i586 builds. (#196581)
769
770 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
771 - Enable profiling for 586 kernels.
772
773 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
774 - Rebuild with slab debug off.
775
776 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
777 - 2.6.17.1
778
779 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
780 - 2.6.16.20
781
782 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
783 - 2.6.16.19
784
785 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
786 - Improved list_head debugging.
787
788 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
789 - 2.6.16.18
790
791 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
792 - 2.6.16.17
793
794 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
795 - 2.6.16.16
796
797 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
798 - 2.6.16.15
799 - make 16C950 UARTs work (again). (#126403)
800 - Fix exec-shield default, which should fix a few programs that
801   stopped running.
802
803 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
804 - 2.6.16.14
805
806 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
807 - 2.6.16.13
808
809 * Mon May  1 2006 Dave Jones <davej@redhat.com>
810 - 2.6.16.12
811
812 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
813 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
814
815 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
816 - 2.6.16.11
817
818 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
819 - Enable PCI MSI support.
820
821 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
822 - 2.6.16.9
823
824 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
825 - 2.6.16.7
826
827 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
828 - 2.6.16.6
829
830 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
831 - 2.6.16.5
832
833 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
834 - 2.6.16.2
835
836 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
837 - Reenable non-standard serial ports. (#187466)
838 - Reenable snd-es18xx for x86-32 (#187733)
839
840 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
841 - ship the .kernelrelease file in -devel too.
842 - Disable EDAC debug.
843
844 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
845 - 2.6.16.1
846
847 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
848 - Include patches posted for review for inclusion in 2.6.16.1
849 - Updated new audit msg types.
850 - Reenable HDLC driver (#186257)
851 - Make acpi-cpufreq 'sticky'
852 - Fix broken x86-64 32bit vDSO (#186924)
853
854 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
855 - Improve spinlock scalability on big machines.
856
857 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
858 - Sync with FC5's 2.6.16 kernel.
859 - Update Tux & Exec-shield to latest.
860