adding the patch file too
[linux-2.6.git] / kernel-2.6.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 Summary: The Linux kernel (the core of the Linux operating system)
7
8 # What parts do we want to build?  We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
10
11 %define buildup 1
12 %define builduml 0
13 %define buildxen 0
14 %define builddoc 0
15
16 # default is to not build this - to override, use something like
17 # kernel-SPECVARS := iwlwifi=1 
18 # rpm does not seem to have a syntax for defining overridable defaults
19 # any better solution would be more than welcome.
20 %define build_iwlwifi %{?iwlwifi:1}%{!?iwlwifi:0}
21
22 # Versions of various parts
23
24 # for module-tag.py - sublevel is used for the version (middle) part of tag names
25 %define name linux-2.6
26 %define module_version_varname sublevel
27 %define taglevel 12
28
29 #
30 # Polite request for people who spin their own kernel rpms:
31 # please modify the "release" field in a way that identifies
32 # that the kernel isn't the stock distribution kernel, for example by
33 # adding some text to the end of the version number.
34 #
35 %define sublevel 22
36 %define patchlevel 19
37 %define kversion 2.6.%{sublevel}
38 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
39
40 %define vsversion 2.3.0.34
41
42 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
43 # updated every time the PL kernel is updated.
44 %define vini_pl_patch 561
45
46 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
47
48 %{!?pldistro:%global pldistro planetlab}
49
50 %define signmodules 0
51 %define make_target bzImage
52 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
53
54 # Override generic defaults with per-arch defaults
55
56 %define image_install_path boot
57
58 #
59 # Three sets of minimum package version requirements in the form of Conflicts:
60 # to versions below the minimum
61 #
62
63 #
64 # First the general kernel 2.6 required versions as per
65 # Documentation/Changes
66 #
67 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
68
69
70 # Then a series of requirements that are distribution specific, either 
71 # because we add patches for something, or the older versions have 
72 # problems with the newer kernel or lack certain things that make 
73 # integration in the distro harder than needed.
74 #
75 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
76
77 #
78 # Several packages had bugs in them that became obvious when the NPTL
79 # threading code got integrated.
80 #
81 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
82
83 #
84 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
85 #
86
87 # MEF commented out
88 # %define xen_conflicts glibc < 2.3.5-1
89
90 #
91 # Packages that need to be installed before the kernel is, because the %post
92 # scripts use them.
93 #
94 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
95
96 Vendor: PlanetLab
97 Packager: PlanetLab Central <support@planet-lab.org>
98 Distribution: PlanetLab %{plrelease}
99 URL: %(echo %{url} | cut -d ' ' -f 2)
100
101 Name: kernel
102 Group: System Environment/Kernel
103 License: GPLv2
104 Version: %{rpmversion}
105 Release: %{release}
106 ExclusiveOS: Linux
107 Provides: kernel = %{version}
108 Provides: kernel-drm = 4.3.0
109 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
110 Provides: kernel-smp = %{rpmversion}-%{release}
111 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
112 Prereq: %{kernel_prereq}
113 Conflicts: %{kernel_dot_org_conflicts}
114 Conflicts: %{package_conflicts}
115 Conflicts: %{nptl_conflicts}
116 # We can't let RPM do the dependencies automatic because it'll then pick up
117 # a correct but undesirable perl dependency from the module headers which
118 # isn't required for the kernel proper to function
119 AutoReqProv: no
120
121 #
122 # List the packages used during the kernel build
123 #
124 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
125 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
126 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
127 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
128
129
130 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
131
132 Source10: %{pldistro}-%{kversion}-i586.config
133 Source11: %{pldistro}-%{kversion}-i686.config
134 Source12: %{pldistro}-%{kversion}-x86_64.config
135 %if %{builduml}
136 Source20: %{pldistro}-%{kversion}-i686-uml.config
137 %endif
138 %if %{buildxen}
139 Source30: %{pldistro}-%{kversion}-i686-xenU.config
140 %endif
141
142 # Mainline patches
143 %if "0%{patchlevel}"
144 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
145 %endif
146
147 Patch010: linux-2.6-010-e1000e.patch
148 Patch020: linux-2.6-020-build-id.patch
149 Patch030: linux-2.6-030-netns.patch
150 Patch040: linux-2.6-040-i_mutex-check.patch
151
152 # These are patches picked up from Fedora/RHEL
153 Patch100: linux-2.6-100-build-nonintconfig.patch
154
155 # Linux-VServer
156 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
157 Patch210: linux-2.6-210-vserver-cpu-sched.patch
158
159 # IP sets
160 Patch250: linux-2.6-250-ipsets.patch
161
162 # Support for libertas olpc driver
163 Patch300: linux-2.6-300-olpc.patch
164
165 # PlanetLab
166 Patch500: linux-2.6-500-vserver-filesharing.patch
167 Patch510: linux-2.6-510-ipod.patch
168 Patch520: linux-2.6-520-vnet+.patch
169 Patch521: linux-2.6-521-packet-tagging.patch
170 Patch522: linux-2.6-522-iptables-connection-tagging.patch
171 Patch523: linux-2.6-523-raw-sockets.patch
172 Patch524: linux-2.6-524-peercred.patch
173 Patch525: linux-2.6-525-sknid-elevator.patch
174 Patch526: linux-2.6-526-tun-tap.patch
175 Patch530: linux-2.6-530-built-by-support.patch
176 Patch540: linux-2.6-540-oom-kill.patch
177 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
178 Patch560: linux-2.6-560-mmconf.patch
179 Patch570: linux-2.6-570-tagxid.patch
180 Patch580: linux-2.6-580-show-proc-virt.patch
181 Patch590: linux-2.6-590-chopstix-intern.patch
182 Patch620: linux-2.6-620-kdb.patch
183 Patch630: linux-2.6-630-sched-fix.patch
184 Patch640: linux-2.6-640-netlink-audit-hack.patch
185 Patch650: linux-2.6-650-hangcheck-reboot.patch
186
187 # See also the file named 'sources' here for the related checksums
188 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
189 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
190 %if %{build_iwlwifi}
191 %define mac80211_version 10.0.4
192 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
193 %define iwlwifi_version 1.2.25
194 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
195 %endif
196
197 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
198
199 %description
200 The kernel package contains the Linux kernel (vmlinuz), the core of any
201 Linux operating system.  The kernel handles the basic functions
202 of the operating system:  memory allocation, process allocation, device
203 input and output, etc.
204
205 %package devel
206 Summary: Development package for building kernel modules to match the kernel.
207 Group: System Environment/Kernel
208 AutoReqProv: no
209 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
210 Provides: kernel-smp-devel = %{rpmversion}-%{release}
211 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
212 Prereq: /usr/bin/find
213
214 %description devel
215 This package provides kernel headers and makefiles sufficient to build modules
216 against the kernel package.
217
218
219 %package doc
220 Summary: Various documentation bits found in the kernel source.
221 Group: Documentation
222
223 %description doc
224 This package contains documentation files from the kernel
225 source. Various bits of information about the Linux kernel and the
226 device drivers shipped with it are documented in these files.
227
228 You'll want to install this package if you need a reference to the
229 options that can be passed to Linux kernel modules at load time.
230
231 %package xenU
232 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
233
234 Group: System Environment/Kernel
235 Provides: kernel = %{version}
236 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
237 Prereq: %{kernel_prereq}
238 Conflicts: %{kernel_dot_org_conflicts}
239 Conflicts: %{package_conflicts}
240 Conflicts: %{nptl_conflicts}
241
242 # MEF commented out 
243 # Conflicts: %{xen_conflicts}
244
245 # We can't let RPM do the dependencies automatic because it'll then pick up
246 # a correct but undesirable perl dependency from the module headers which
247 # isn't required for the kernel proper to function
248 AutoReqProv: no
249
250 %description xenU
251 This package includes a version of the Linux kernel which
252 runs in Xen unprivileged guest VMs.  This should be installed
253 both inside the unprivileged guest (for the modules) and in
254 the guest0 domain.
255
256 %package xenU-devel
257 Summary: Development package for building kernel modules to match the kernel.
258 Group: System Environment/Kernel
259 AutoReqProv: no
260 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
261 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
262 Provides: kernel-devel = %{rpmversion}-%{release}xenU
263 Prereq: /usr/sbin/hardlink, /usr/bin/find
264
265 %description xenU-devel
266 This package provides kernel headers and makefiles sufficient to build modules
267 against the kernel package.
268
269 %package uml
270 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
271
272 Group: System Environment/Kernel
273
274 %description uml
275 This package includes a user mode version of the Linux kernel.
276
277 %package uml-devel
278 Summary: Development package for building kernel modules to match the UML kernel.
279 Group: System Environment/Kernel
280 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
281 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
282 Provides: kernel-devel = %{rpmversion}-%{release}smp
283 AutoReqProv: no
284 Prereq: /usr/sbin/hardlink, /usr/bin/find
285
286 %description uml-devel
287 This package provides kernel headers and makefiles sufficient to build modules
288 against the User Mode Linux kernel package.
289
290 %package uml-modules
291 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
292
293 Group: System Environment/Kernel
294
295 %description uml-modules
296 This package includes a user mode version of the Linux kernel modules.
297
298 %package vserver
299 Summary: A placeholder RPM that provides kernel and kernel-drm
300
301 Group: System Environment/Kernel
302 Provides: kernel = %{version}
303 Provides: kernel-drm = 4.3.0
304 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
305
306 %description vserver
307 VServers do not require and cannot use kernels, but some RPMs have
308 implicit or explicit dependencies on the "kernel" package
309 (e.g. tcpdump). This package installs no files but provides the
310 necessary dependencies to make rpm and yum happy.
311
312
313 %prep
314 # First we unpack the kernel tarball.
315 # If this isn't the first make prep, we use links to the existing clean tarball
316 # which speeds things up quite a bit.
317 if [ ! -d kernel-%{kversion}/vanilla ]; then
318   # Ok, first time we do a make prep.
319   rm -f pax_global_header
320 %setup -q -n %{name}-%{kversion} -c
321   mv linux-%{kversion} vanilla
322 else
323   # We already have a vanilla dir.
324   cd kernel-%{kversion}
325 fi
326
327 KERNEL_PREVIOUS=vanilla
328 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
329 %define ApplyPatch() \
330   rm -fr linux-%{kversion}-%1                           \
331   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
332   patchflag=-p1                                         \
333   test "%2" != "%%2" && patchflag="%2"                  \
334   PATCH="%{expand:%{PATCH%1}}"                          \
335   if test ! -e "$PATCH"; then                           \
336     echo "Patch %1 does not exist!"                     \
337     exit 1                                              \
338   fi                                                    \
339   case "$PATCH" in                                      \
340     *.bz2)  bzcat "$PATCH";;                            \
341     *.gz)   zcat "$PATCH";;                             \
342     *)      cat "$PATCH";;                              \
343   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
344   KERNEL_PREVIOUS=linux-%{kversion}-%1
345
346 # This is where the patches get applied
347 %if 0%{?patchlevel}
348 %ApplyPatch 0
349 %endif
350
351 %ApplyPatch 10
352 %ApplyPatch 20
353
354 # NetNS patch for VINI
355 %if 0%{?with_netns}
356 %ApplyPatch 30
357 %endif
358 %ApplyPatch 40
359
360 %ApplyPatch 100
361
362 %ApplyPatch 200
363 %ApplyPatch 210
364
365 %ApplyPatch 250
366 %ApplyPatch 300
367
368 %ApplyPatch 500
369 %ApplyPatch 510
370
371 # VNET+ series
372 %ApplyPatch 521
373 %ApplyPatch 522
374 %ApplyPatch 523
375 %ApplyPatch 524
376 %ApplyPatch 525
377 %ApplyPatch 526
378
379 %ApplyPatch 530
380 %ApplyPatch 540
381 %ApplyPatch 550
382 %ApplyPatch 560
383 %ApplyPatch 570
384 %ApplyPatch 580
385 %ApplyPatch 590
386 %ApplyPatch 620
387 %ApplyPatch 630
388 %ApplyPatch 640
389 %ApplyPatch 650
390
391 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
392 # break with later patches.
393
394 %if 0%{?with_netns}
395 %ApplyPatch %vini_pl_patch
396 %endif
397
398 %if %{build_iwlwifi}
399 # Run the mac80211 stuff in the kernel tree holding the last patch
400 tar -xzf %{PATCH600}
401 pushd mac80211-%{mac80211_version}
402 mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
403 make $mac80211_makeflags modified
404 make $mac80211_makeflags source
405 make $mac80211_makeflags patch_kernel
406 popd
407
408 # Untar iwlwifi in the same place - needs to be compiled later
409 tar -xzf %{PATCH601}
410 # the install target is broken: first it does not pass the right -b flag to depmod
411 # second we do not need to invoke depmod at this stage anyway
412 # let's add our own patch/stuff in this Makefile for manual install later on
413 pushd iwlwifi-%{iwlwifi_version}
414 cat >> Makefile <<EOF
415 module-list:
416         @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
417 EOF
418 popd
419 %endif
420
421 rm -fr linux-%{kversion}
422 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
423 cd linux-%{kversion}
424
425
426 # make sure the kernel has the sublevel we know it has. This looks weird
427 # but for -pre and -rc versions we need it since we only want to use
428 # the higher version when the final kernel is released.
429 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
430 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
431
432 # get rid of unwanted files resulting from patch fuzz
433 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
434
435
436 ###
437 ### build
438 ###
439 %build
440
441 BuildKernel() {
442     MakeTarget=$1
443     Arch=$2
444     Flavour=$3
445
446     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
447     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
448     cd linux-%{_target_cpu}-%{kversion}$Flavour
449
450     # Pick the right config file for the kernel we're building
451     if [ -n "$Flavour" ] ; then
452       Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
453       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
454       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
455     else
456       Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
457       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
458       DevelLink=
459     fi
460
461     KernelVer=%{version}-%{release}$Flavour
462     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
463
464     # make sure EXTRAVERSION says what we want it to say
465     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
466
467     # and now to start the build process
468
469     make -s mrproper
470     cp %{_sourcedir}/$Config .config
471
472     #Arch=`head -1 .config | cut -b 3-`
473     echo USING ARCH=$Arch
474
475     make -s ARCH=$Arch nonint_oldconfig > /dev/null
476     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
477     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
478
479 %if %{build_iwlwifi}
480     # build the iwlwifi driver
481     make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
482       KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
483 %endif
484
485     # Start installing the results
486
487 %if "%{_enable_debug_packages}" == "1"
488     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
489 %endif
490     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
491     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
492     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
493     if [ -f arch/$Arch/boot/bzImage ]; then
494       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
495     fi
496     if [ -f arch/$Arch/boot/zImage.stub ]; then
497       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
498     fi
499     if [ "$Flavour" = "uml" ] ; then
500         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
501     fi
502
503     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
504     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
505
506 %if %{build_iwlwifi}
507     # install iwlwifi
508 #    make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
509 #         KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
510 #        KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
511     pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
512     iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
513     # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
514     iwlwifi_modules=$(make --no-print-directory module-list)
515     install -d $iwlwifi_dest
516     install -m 644 -c $iwlwifi_modules $iwlwifi_dest
517     popd
518 %endif
519
520     # And save the headers/makefiles etc for building modules against
521     #
522     # This all looks scary, but the end result is supposed to be:
523     # * all arch relevant include/ files
524     # * all Makefile/Kconfig files
525     # * all script/ files
526
527     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
528     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
529     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
530     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
531     # dirs for additional modules per module-init-tools, kbuild/modules.txt
532     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
533     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
534     # first copy everything
535     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
536         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
537     if [ "$Flavour" = "uml" ] ; then
538       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
539     fi
540     # then drop all but the needed Makefiles/Kconfig files
541     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
542     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
543     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
544     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
545     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
546     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
547     if [ -d arch/%{_arch}/scripts ]; then
548       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
549     fi
550     if [ -f arch/%{_arch}/*lds ]; then
551       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
552     fi
553     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
554     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
555     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
556     cd include
557     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
558     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
559     if [ "$Arch" = "x86_64" ]; then
560       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
561     fi
562 %if %{buildxen}
563     if [ "$Flavour" = "xenU" ]; then
564       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
565       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
566     fi
567 %endif
568 %if %{builduml}
569     if [ "$Flavour" = "uml" ] ; then
570       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
571     fi
572 %endif
573     # While arch/powerpc/include/asm is still a symlink to the old
574     # include/asm-ppc{64,} directory, include that in kernel-devel too.
575     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
576       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
577       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
578       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
579       ln -sf ../../../include/asm-ppc* asm
580       popd
581     fi
582
583     # Make sure the Makefile and version.h have a matching timestamp so that
584     # external modules can be built
585     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
586     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
587     cd ..
588
589     #
590     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
591     #
592 %if "%{_enable_debug_packages}" == "1"
593     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
594     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
595 %endif
596 %if %{buildxen}
597     if [ -f vmlinuz ]; then
598       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
599     fi
600 %endif
601
602     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
603
604     # mark modules executable so that strip-to-file can strip them
605     cat modnames | xargs chmod u+x
606
607     # remove files that will be auto generated by depmod at rpm -i time
608     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
609
610     # Move the devel headers out of the root file system
611     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
612     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
613     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
614     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
615 }
616
617 ###
618 # DO it...
619 ###
620
621 # prepare directories
622 rm -rf $RPM_BUILD_ROOT
623 mkdir -p $RPM_BUILD_ROOT/boot
624
625 %if "%{_target_cpu}" == "x86_64"
626 %define kernel_arch %{_target_cpu}
627 %endif
628 %if "%{_target_cpu}" == "i586"
629 %define kernel_arch i386
630 %endif
631 %if "%{_target_cpu}" == "i686"
632 %define kernel_arch i386
633 %endif
634
635 %if %{buildup}
636 BuildKernel %make_target %kernel_arch
637 %endif
638
639 %ifarch i686
640 %if %{builduml}
641 BuildKernel linux um uml
642 %endif
643
644 %if %{buildxen}
645 BuildKernel vmlinuz %kernel_arch xenU
646 %endif
647 %endif
648
649 ###
650 ### install
651 ###
652
653 %install
654
655 cd vanilla
656
657 %if %{buildxen} && "%{_target_cpu}" == "i686"
658 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
659 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
660 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
661 # This directive teaches ldconfig to search in nosegneg subdirectories
662 # and cache the DSOs there with extra bit 0 set in their hwcap match
663 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
664 # search in nosegneg subdirectories and to match this extra hwcap bit
665 # in the ld.so.cache file.
666 hwcap 0 nosegneg
667 EOF
668 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
669 %endif
670
671 %if %{builddoc}
672 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
673
674 # sometimes non-world-readable files sneak into the kernel source tree
675 chmod -R a+r *
676 # copy the source over
677 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
678 %endif
679
680 ###
681 ### clean
682 ###
683
684 %clean
685 rm -rf $RPM_BUILD_ROOT
686
687 ###
688 ### scripts
689 ###
690
691 # load the loop module for upgrades...in case the old modules get removed we have
692 # loopback in the kernel so that mkinitrd will work.
693 %pre
694 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
695 exit 0
696
697 %post
698 if [ -f /etc/sysconfig/kernel ]; then
699   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
700 fi
701
702 # trick mkinitrd in case the current environment does not have device mapper
703 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
704 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
705     if [ ! -f $rootdev ]; then
706         fake_root_lvm=1
707         mkdir -p $(dirname $rootdev)
708         touch $rootdev
709     fi
710 fi
711
712 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
713 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
714 # Older modutils do not support --package option
715 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
716
717 # remove fake handle
718 if [ -n "$fake_root_lvm" ]; then
719     rm -f $rootdev
720 fi
721
722 # make some useful links
723 pushd /boot > /dev/null ; {
724         ln -sf config-%{KVERREL} config
725         ln -sf config-%{KVERREL} configsmp
726         ln -sf initrd-%{KVERREL}.img initrd-boot
727         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
728         ln -sf vmlinuz-%{KVERREL} kernel-boot
729         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
730 }
731 popd > /dev/null
732
733 # ask for a reboot
734 mkdir -p /etc/planetlab
735 touch /etc/planetlab/update-reboot
736
737 %post devel
738 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
739 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
740   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
741   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
742   popd > /dev/null
743 fi
744
745 %post xenU
746 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
747 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
748
749 %post xenU-devel
750 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
751 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
752   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
753   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
754   popd > /dev/null
755 fi
756
757 %post uml-modules
758 depmod -ae %{KVERREL}uml
759
760 %preun
761 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
762 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
763
764 %preun xenU
765 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
766 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
767
768 %preun uml-modules
769 rm -f /lib/modules/%{KVERREL}uml/modules.*
770
771
772 ###
773 ### file lists
774 ###
775
776 %if %{buildup}
777 %files 
778 %defattr(-,root,root)
779 /%{image_install_path}/vmlinuz-%{KVERREL}
780 /boot/System.map-%{KVERREL}
781 /boot/config-%{KVERREL}
782 %dir /lib/modules/%{KVERREL}
783 /lib/modules/%{KVERREL}/kernel
784 /lib/modules/%{KVERREL}/build
785 /lib/modules/%{KVERREL}/source
786 /lib/modules/%{KVERREL}/extra
787 /lib/modules/%{KVERREL}/updates
788
789 %files devel
790 %defattr(-,root,root)
791 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
792 %endif
793
794 %if %{builduml} && "%{_target_cpu}" == "i686"
795 %files uml
796 %defattr(-,root,root)
797 %{_bindir}/linux
798
799 %files uml-devel
800 %defattr(-,root,root)
801 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
802 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
803
804 %files uml-modules
805 %defattr(-,root,root)
806 /boot/System.map-%{KVERREL}uml
807 /boot/config-%{KVERREL}uml
808 %dir /lib/modules/%{KVERREL}uml
809 /lib/modules/%{KVERREL}uml/kernel
810 /lib/modules/%{KVERREL}uml/build
811 /lib/modules/%{KVERREL}uml/source
812 /lib/modules/%{KVERREL}uml/extra
813 /lib/modules/%{KVERREL}uml/updates
814 %endif
815
816 %if %{buildxen} && "%{_target_cpu}" == "i686"
817 %files xenU
818 %defattr(-,root,root)
819 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
820 /boot/System.map-%{KVERREL}xenU
821 /boot/config-%{KVERREL}xenU
822 %dir /lib/modules/%{KVERREL}xenU
823 /lib/modules/%{KVERREL}xenU/kernel
824 /lib/modules/%{KVERREL}xenU/build
825 /lib/modules/%{KVERREL}xenU/source
826 /lib/modules/%{KVERREL}xenU/extra
827 /lib/modules/%{KVERREL}xenU/updates
828 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
829
830 %files xenU-devel
831 %defattr(-,root,root)
832 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
833 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
834 %endif
835
836 %files vserver
837 %defattr(-,root,root)
838 # no files
839
840 # only some architecture builds need kernel-doc
841
842 %if %{builddoc}
843 %files doc
844 %defattr(-,root,root)
845 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
846 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
847 %dir %{_datadir}/doc/kernel-doc-%{kversion}
848 %endif
849
850 %changelog
851 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-12
852 - * Bugfix in tuntap
853 - * Attempt to fix TCP-payload-related problems with tcpdump
854
855 * Wed Jul 09 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-11
856 - * Split up VNET+ module into its component patches
857 - * Added tun/tap support
858
859 * Tue Jul 08 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-10
860 - Filling a statically allocated buffer cannot fail, right?
861
862 * Wed Jun 25 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-9
863 - Enable the hangcheck timer driver, and build it in to the kernel.
864 - Dump relevant data on the scheduler bug instead of BUGing.
865
866 * Sat Jun 07 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-8
867 - * Partial fix for the UDP-packet-pollution problem
868 - * Support for PF_PACKET sockets
869 - * Support for SOCK_PACKET sockets
870 - * Disabled Chopstix with mutexes
871 - * Tested VNET+ under heavy loads
872
873
874
875 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-7
876 - Bringing this fix in for tcpdump and  ping
877
878
879 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-6
880 - Updated configuration to include COW again.
881
882 - Patches from Sapan to fix ping losses.
883
884 - Still need help with tcpdump traffic.
885
886
887 * Tue May 06 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-5
888 - Patch needs to be applied.
889
890 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-4
891
892
893 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-3
894 - Fix bug with looping in schedule()
895
896 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-2
897 - Includes changes from Sapan/Andy regarding the scheduler and vnet bugs.
898 - Should be safe to try a second deployment.
899
900
901 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
902 - 2.6.17.4
903 - Disable split pagetable lock.
904
905 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
906 - Get rid of stack backtrace on panic, which in most
907   cases actually caused a loss of info instead of a gain.
908
909 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
910 - 2.6.17.3
911
912 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
913 - 2.6.17.2
914 - Fix up the alsa list_add bug.
915
916 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
917 - Fix up various stupidities incurred by the last big rebase.
918   - Reenable SMP x86-64 builds.
919   - Reenable SMBFS.
920 - Enable PCI fake hotplug driver.
921 - Enable gameport/joystick on i586 builds. (#196581)
922
923 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
924 - Enable profiling for 586 kernels.
925
926 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
927 - Rebuild with slab debug off.
928
929 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
930 - 2.6.17.1
931
932 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
933 - 2.6.16.20
934
935 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
936 - 2.6.16.19
937
938 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
939 - Improved list_head debugging.
940
941 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
942 - 2.6.16.18
943
944 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
945 - 2.6.16.17
946
947 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
948 - 2.6.16.16
949
950 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
951 - 2.6.16.15
952 - make 16C950 UARTs work (again). (#126403)
953 - Fix exec-shield default, which should fix a few programs that
954   stopped running.
955
956 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
957 - 2.6.16.14
958
959 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
960 - 2.6.16.13
961
962 * Mon May  1 2006 Dave Jones <davej@redhat.com>
963 - 2.6.16.12
964
965 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
966 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
967
968 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
969 - 2.6.16.11
970
971 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
972 - Enable PCI MSI support.
973
974 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
975 - 2.6.16.9
976
977 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
978 - 2.6.16.7
979
980 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
981 - 2.6.16.6
982
983 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
984 - 2.6.16.5
985
986 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
987 - 2.6.16.2
988
989 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
990 - Reenable non-standard serial ports. (#187466)
991 - Reenable snd-es18xx for x86-32 (#187733)
992
993 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
994 - ship the .kernelrelease file in -devel too.
995 - Disable EDAC debug.
996
997 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
998 - 2.6.16.1
999
1000 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
1001 - Include patches posted for review for inclusion in 2.6.16.1
1002 - Updated new audit msg types.
1003 - Reenable HDLC driver (#186257)
1004 - Make acpi-cpufreq 'sticky'
1005 - Fix broken x86-64 32bit vDSO (#186924)
1006
1007 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
1008 - Improve spinlock scalability on big machines.
1009
1010 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
1011 - Sync with FC5's 2.6.16 kernel.
1012 - Update Tux & Exec-shield to latest.
1013