2.6.22.19-vs2.3.0.34
[linux-2.6.git] / kernel-2.6.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 Summary: The Linux kernel (the core of the Linux operating system)
7
8 # What parts do we want to build?  We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
10
11 %define buildup 1
12 %define builduml 0
13 %define buildxen 0
14 %define builddoc 0
15
16 # Versions of various parts
17
18 # for module-tag.py - sublevel is used for the version (middle) part of tag names
19 %define name linux-2.6
20 %define module_version_varname sublevel
21 %define taglevel 1
22
23 #
24 # Polite request for people who spin their own kernel rpms:
25 # please modify the "release" field in a way that identifies
26 # that the kernel isn't the stock distribution kernel, for example by
27 # adding some text to the end of the version number.
28 #
29 %define sublevel 22
30 %define patchlevel 19
31 %define kversion 2.6.%{sublevel}
32 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
33
34 %define vsversion 2.3.0.34
35
36 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
37 # updated every time the PL kernel is updated.
38 %define vini_pl_patch 561
39
40 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
41
42 %{!?pldistro:%global pldistro planetlab}
43
44 %define signmodules 0
45 %define make_target bzImage
46 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
47
48 # Override generic defaults with per-arch defaults
49
50 %define image_install_path boot
51
52 #
53 # Three sets of minimum package version requirements in the form of Conflicts:
54 # to versions below the minimum
55 #
56
57 #
58 # First the general kernel 2.6 required versions as per
59 # Documentation/Changes
60 #
61 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
62
63
64 # Then a series of requirements that are distribution specific, either 
65 # because we add patches for something, or the older versions have 
66 # problems with the newer kernel or lack certain things that make 
67 # integration in the distro harder than needed.
68 #
69 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
70
71 #
72 # Several packages had bugs in them that became obvious when the NPTL
73 # threading code got integrated.
74 #
75 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
76
77 #
78 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
79 #
80
81 # MEF commented out
82 # %define xen_conflicts glibc < 2.3.5-1
83
84 #
85 # Packages that need to be installed before the kernel is, because the %post
86 # scripts use them.
87 #
88 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
89
90 Vendor: PlanetLab
91 Packager: PlanetLab Central <support@planet-lab.org>
92 Distribution: PlanetLab %{plrelease}
93 URL: %(echo %{url} | cut -d ' ' -f 2)
94
95 Name: kernel
96 Group: System Environment/Kernel
97 License: GPLv2
98 Version: %{rpmversion}
99 Release: %{release}
100 ExclusiveOS: Linux
101 Provides: kernel = %{version}
102 Provides: kernel-drm = 4.3.0
103 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
104 Provides: kernel-smp = %{rpmversion}-%{release}
105 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
106 Prereq: %{kernel_prereq}
107 Conflicts: %{kernel_dot_org_conflicts}
108 Conflicts: %{package_conflicts}
109 Conflicts: %{nptl_conflicts}
110 # We can't let RPM do the dependencies automatic because it'll then pick up
111 # a correct but undesirable perl dependency from the module headers which
112 # isn't required for the kernel proper to function
113 AutoReqProv: no
114
115 #
116 # List the packages used during the kernel build
117 #
118 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
119 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
120 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
121 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
122
123
124 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
125
126 Source10: %{pldistro}-%{kversion}-i586.config
127 Source11: %{pldistro}-%{kversion}-i686.config
128 Source12: %{pldistro}-%{kversion}-x86_64.config
129 %if %{builduml}
130 Source20: %{pldistro}-%{kversion}-i686-uml.config
131 %endif
132 %if %{buildxen}
133 Source30: %{pldistro}-%{kversion}-i686-xenU.config
134 %endif
135
136 # Mainline patches
137 %if "0%{patchlevel}"
138 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
139 %endif
140
141 Patch010: linux-2.6-010-e1000e.patch
142 Patch020: linux-2.6-020-build-id.patch
143 Patch030: linux-2.6-030-netns.patch
144
145 # These are patches picked up from Fedora/RHEL
146 Patch100: linux-2.6-100-build-nonintconfig.patch
147
148 # Linux-VServer
149 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
150 Patch210: linux-2.6-210-vserver-cpu-sched.patch
151 Patch220: linux-2.6-220-lback-feat02.diff
152
153 # IP sets
154 Patch250: linux-2.6-250-ipsets.patch
155
156 # PlanetLab
157 Patch500: linux-2.6-500-vserver-filesharing.patch
158 Patch510: linux-2.6-510-ipod.patch
159 Patch520: linux-2.6-520-vnet+.patch
160 Patch530: linux-2.6-530-built-by-support.patch
161 Patch540: linux-2.6-540-oom-kill.patch
162 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
163 Patch560: linux-2.6-560-mmconf.patch
164 Patch570: linux-2.6-570-tagxid.patch
165 Patch580: linux-2.6-580-show-proc-virt.patch
166 Patch590: linux-2.6-590-chopstix-intern.patch
167
168 # See also the file named 'sources' here for the related checksums
169 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
170 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
171 %define mac80211_version 10.0.4
172 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
173 %define iwlwifi_version 1.2.23
174 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
175
176 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
177
178 %description
179 The kernel package contains the Linux kernel (vmlinuz), the core of any
180 Linux operating system.  The kernel handles the basic functions
181 of the operating system:  memory allocation, process allocation, device
182 input and output, etc.
183
184 %package devel
185 Summary: Development package for building kernel modules to match the kernel.
186 Group: System Environment/Kernel
187 AutoReqProv: no
188 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
189 Provides: kernel-smp-devel = %{rpmversion}-%{release}
190 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
191 Prereq: /usr/bin/find
192
193 %description devel
194 This package provides kernel headers and makefiles sufficient to build modules
195 against the kernel package.
196
197
198 %package doc
199 Summary: Various documentation bits found in the kernel source.
200 Group: Documentation
201
202 %description doc
203 This package contains documentation files from the kernel
204 source. Various bits of information about the Linux kernel and the
205 device drivers shipped with it are documented in these files.
206
207 You'll want to install this package if you need a reference to the
208 options that can be passed to Linux kernel modules at load time.
209
210 %package xenU
211 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
212
213 Group: System Environment/Kernel
214 Provides: kernel = %{version}
215 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
216 Prereq: %{kernel_prereq}
217 Conflicts: %{kernel_dot_org_conflicts}
218 Conflicts: %{package_conflicts}
219 Conflicts: %{nptl_conflicts}
220
221 # MEF commented out 
222 # Conflicts: %{xen_conflicts}
223
224 # We can't let RPM do the dependencies automatic because it'll then pick up
225 # a correct but undesirable perl dependency from the module headers which
226 # isn't required for the kernel proper to function
227 AutoReqProv: no
228
229 %description xenU
230 This package includes a version of the Linux kernel which
231 runs in Xen unprivileged guest VMs.  This should be installed
232 both inside the unprivileged guest (for the modules) and in
233 the guest0 domain.
234
235 %package xenU-devel
236 Summary: Development package for building kernel modules to match the kernel.
237 Group: System Environment/Kernel
238 AutoReqProv: no
239 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
240 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
241 Provides: kernel-devel = %{rpmversion}-%{release}xenU
242 Prereq: /usr/sbin/hardlink, /usr/bin/find
243
244 %description xenU-devel
245 This package provides kernel headers and makefiles sufficient to build modules
246 against the kernel package.
247
248 %package uml
249 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
250
251 Group: System Environment/Kernel
252
253 %description uml
254 This package includes a user mode version of the Linux kernel.
255
256 %package uml-devel
257 Summary: Development package for building kernel modules to match the UML kernel.
258 Group: System Environment/Kernel
259 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
260 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
261 Provides: kernel-devel = %{rpmversion}-%{release}smp
262 AutoReqProv: no
263 Prereq: /usr/sbin/hardlink, /usr/bin/find
264
265 %description uml-devel
266 This package provides kernel headers and makefiles sufficient to build modules
267 against the User Mode Linux kernel package.
268
269 %package uml-modules
270 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
271
272 Group: System Environment/Kernel
273
274 %description uml-modules
275 This package includes a user mode version of the Linux kernel modules.
276
277 %package vserver
278 Summary: A placeholder RPM that provides kernel and kernel-drm
279
280 Group: System Environment/Kernel
281 Provides: kernel = %{version}
282 Provides: kernel-drm = 4.3.0
283 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
284
285 %description vserver
286 VServers do not require and cannot use kernels, but some RPMs have
287 implicit or explicit dependencies on the "kernel" package
288 (e.g. tcpdump). This package installs no files but provides the
289 necessary dependencies to make rpm and yum happy.
290
291
292 %prep
293 # First we unpack the kernel tarball.
294 # If this isn't the first make prep, we use links to the existing clean tarball
295 # which speeds things up quite a bit.
296 if [ ! -d kernel-%{kversion}/vanilla ]; then
297   # Ok, first time we do a make prep.
298   rm -f pax_global_header
299 %setup -q -n %{name}-%{kversion} -c
300   mv linux-%{kversion} vanilla
301 else
302   # We already have a vanilla dir.
303   cd kernel-%{kversion}
304 fi
305
306 KERNEL_PREVIOUS=vanilla
307 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
308 %define ApplyPatch() \
309   rm -fr linux-%{kversion}-%1                           \
310   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
311   patchflag=-p1                                         \
312   test "%2" != "%%2" && patchflag="%2"                  \
313   PATCH="%{expand:%{PATCH%1}}"                          \
314   if test ! -e "$PATCH"; then                           \
315     echo "Patch %1 does not exist!"                     \
316     exit 1                                              \
317   fi                                                    \
318   case "$PATCH" in                                      \
319     *.bz2)  bzcat "$PATCH";;                            \
320     *.gz)   zcat "$PATCH";;                             \
321     *)      cat "$PATCH";;                              \
322   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
323   KERNEL_PREVIOUS=linux-%{kversion}-%1
324
325 # This is where the patches get applied
326 %if 0%{?patchlevel}
327 %ApplyPatch 0
328 %endif
329
330 %ApplyPatch 10
331 %ApplyPatch 20
332
333 # NetNS patch for VINI
334 %if 0%{?with_netns}
335 %ApplyPatch 30
336 %endif
337
338 %ApplyPatch 100
339
340 %ApplyPatch 200
341 %ApplyPatch 210
342 %ApplyPatch 220
343
344 %ApplyPatch 250
345
346 %ApplyPatch 500
347 %ApplyPatch 510
348 %ApplyPatch 520
349 %ApplyPatch 530
350 %ApplyPatch 540
351 %ApplyPatch 550
352 %ApplyPatch 560
353 %ApplyPatch 570
354 %ApplyPatch 580
355 %ApplyPatch 590
356
357 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
358 # break with later patches.
359
360 %if 0%{?with_netns}
361 %ApplyPatch %vini_pl_patch
362 %endif
363
364 # Run the mac80211 stuff in the kernel tree holding the last patch
365 tar -xzf %{PATCH600}
366 pushd mac80211-%{mac80211_version}
367 mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
368 make $mac80211_makeflags modified
369 make $mac80211_makeflags source
370 make $mac80211_makeflags patch_kernel
371 popd
372
373 # Untar iwlwifi in the same place - needs to be compiled later
374 tar -xzf %{PATCH601}
375 # the install target is broken: first it does not pass the right -b flag to depmod
376 # second we do not need to invoke depmod at this stage anyway
377 # let's add our own patch/stuff in this Makefile for manual install later on
378 pushd iwlwifi-%{iwlwifi_version}
379 cat >> Makefile <<EOF
380 module-list:
381         @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
382 EOF
383 popd
384
385 rm -fr linux-%{kversion}
386 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
387 cd linux-%{kversion}
388
389
390 # make sure the kernel has the sublevel we know it has. This looks weird
391 # but for -pre and -rc versions we need it since we only want to use
392 # the higher version when the final kernel is released.
393 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
394 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
395
396 # get rid of unwanted files resulting from patch fuzz
397 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
398
399
400 ###
401 ### build
402 ###
403 %build
404
405 BuildKernel() {
406     MakeTarget=$1
407     Arch=$2
408     Flavour=$3
409
410     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
411     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
412     cd linux-%{_target_cpu}-%{kversion}$Flavour
413
414     # Pick the right config file for the kernel we're building
415     if [ -n "$Flavour" ] ; then
416       Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
417       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
418       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
419     else
420       Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
421       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
422       DevelLink=
423     fi
424
425     KernelVer=%{version}-%{release}$Flavour
426     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
427
428     # make sure EXTRAVERSION says what we want it to say
429     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
430
431     # and now to start the build process
432
433     make -s mrproper
434     cp %{_sourcedir}/$Config .config
435
436     #Arch=`head -1 .config | cut -b 3-`
437     echo USING ARCH=$Arch
438
439     make -s ARCH=$Arch nonint_oldconfig > /dev/null
440     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
441     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
442
443     # build the iwlwifi driver
444     make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
445          KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
446
447     # Start installing the results
448
449 %if "%{_enable_debug_packages}" == "1"
450     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
451 %endif
452     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
453     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
454     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
455     if [ -f arch/$Arch/boot/bzImage ]; then
456       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
457     fi
458     if [ -f arch/$Arch/boot/zImage.stub ]; then
459       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
460     fi
461     if [ "$Flavour" = "uml" ] ; then
462         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
463     fi
464
465     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
466     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
467
468     # install iwlwifi
469 #    make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
470 #         KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
471 #        KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
472     pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
473     iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
474     # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
475     iwlwifi_modules=$(make --no-print-directory module-list)
476     install -d $iwlwifi_dest
477     install -m 644 -c $iwlwifi_modules $iwlwifi_dest
478     popd
479
480     # And save the headers/makefiles etc for building modules against
481     #
482     # This all looks scary, but the end result is supposed to be:
483     # * all arch relevant include/ files
484     # * all Makefile/Kconfig files
485     # * all script/ files
486
487     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
488     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
489     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
490     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
491     # dirs for additional modules per module-init-tools, kbuild/modules.txt
492     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
493     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
494     # first copy everything
495     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
496         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
497     if [ "$Flavour" = "uml" ] ; then
498       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
499     fi
500     # then drop all but the needed Makefiles/Kconfig files
501     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
502     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
503     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
504     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
505     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
506     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
507     if [ -d arch/%{_arch}/scripts ]; then
508       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
509     fi
510     if [ -f arch/%{_arch}/*lds ]; then
511       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
512     fi
513     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
514     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
515     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
516     cd include
517     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
518     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
519     if [ "$Arch" = "x86_64" ]; then
520       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
521     fi
522 %if %{buildxen}
523     if [ "$Flavour" = "xenU" ]; then
524       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
525       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
526     fi
527 %endif
528 %if %{builduml}
529     if [ "$Flavour" = "uml" ] ; then
530       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
531     fi
532 %endif
533     # While arch/powerpc/include/asm is still a symlink to the old
534     # include/asm-ppc{64,} directory, include that in kernel-devel too.
535     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
536       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
537       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
538       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
539       ln -sf ../../../include/asm-ppc* asm
540       popd
541     fi
542
543     # Make sure the Makefile and version.h have a matching timestamp so that
544     # external modules can be built
545     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
546     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
547     cd ..
548
549     #
550     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
551     #
552 %if "%{_enable_debug_packages}" == "1"
553     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
554     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
555 %endif
556 %if %{buildxen}
557     if [ -f vmlinuz ]; then
558       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
559     fi
560 %endif
561
562     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
563
564     # mark modules executable so that strip-to-file can strip them
565     cat modnames | xargs chmod u+x
566
567     # remove files that will be auto generated by depmod at rpm -i time
568     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
569
570     # Move the devel headers out of the root file system
571     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
572     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
573     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
574     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
575 }
576
577 ###
578 # DO it...
579 ###
580
581 # prepare directories
582 rm -rf $RPM_BUILD_ROOT
583 mkdir -p $RPM_BUILD_ROOT/boot
584
585 %if "%{_target_cpu}" == "x86_64"
586 %define kernel_arch %{_target_cpu}
587 %endif
588 %if "%{_target_cpu}" == "i586"
589 %define kernel_arch i386
590 %endif
591 %if "%{_target_cpu}" == "i686"
592 %define kernel_arch i386
593 %endif
594
595 %if %{buildup}
596 BuildKernel %make_target %kernel_arch
597 %endif
598
599 %ifarch i686
600 %if %{builduml}
601 BuildKernel linux um uml
602 %endif
603
604 %if %{buildxen}
605 BuildKernel vmlinuz %kernel_arch xenU
606 %endif
607 %endif
608
609 ###
610 ### install
611 ###
612
613 %install
614
615 cd vanilla
616
617 %if %{buildxen} && "%{_target_cpu}" == "i686"
618 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
619 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
620 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
621 # This directive teaches ldconfig to search in nosegneg subdirectories
622 # and cache the DSOs there with extra bit 0 set in their hwcap match
623 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
624 # search in nosegneg subdirectories and to match this extra hwcap bit
625 # in the ld.so.cache file.
626 hwcap 0 nosegneg
627 EOF
628 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
629 %endif
630
631 %if %{builddoc}
632 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
633
634 # sometimes non-world-readable files sneak into the kernel source tree
635 chmod -R a+r *
636 # copy the source over
637 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
638 %endif
639
640 ###
641 ### clean
642 ###
643
644 %clean
645 rm -rf $RPM_BUILD_ROOT
646
647 ###
648 ### scripts
649 ###
650
651 # load the loop module for upgrades...in case the old modules get removed we have
652 # loopback in the kernel so that mkinitrd will work.
653 %pre
654 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
655 exit 0
656
657 %post
658 if [ -f /etc/sysconfig/kernel ]; then
659   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
660 fi
661
662 # trick mkinitrd in case the current environment does not have device mapper
663 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
664 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
665     if [ ! -f $rootdev ]; then
666         fake_root_lvm=1
667         mkdir -p $(dirname $rootdev)
668         touch $rootdev
669     fi
670 fi
671
672 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
673 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
674 # Older modutils do not support --package option
675 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
676
677 # remove fake handle
678 if [ -n "$fake_root_lvm" ]; then
679     rm -f $rootdev
680 fi
681
682 # make some useful links
683 pushd /boot > /dev/null ; {
684         ln -sf config-%{KVERREL} config
685         ln -sf config-%{KVERREL} configsmp
686         ln -sf initrd-%{KVERREL}.img initrd-boot
687         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
688         ln -sf vmlinuz-%{KVERREL} kernel-boot
689         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
690 }
691 popd > /dev/null
692
693 # ask for a reboot
694 mkdir -p /etc/planetlab
695 touch /etc/planetlab/update-reboot
696
697 %post devel
698 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
699 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
700   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
701   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
702   popd > /dev/null
703 fi
704
705 %post xenU
706 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
707 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
708
709 %post xenU-devel
710 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
711 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
712   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
713   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
714   popd > /dev/null
715 fi
716
717 %post uml-modules
718 depmod -ae %{KVERREL}uml
719
720 %preun
721 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
722 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
723
724 %preun xenU
725 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
726 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
727
728 %preun uml-modules
729 rm -f /lib/modules/%{KVERREL}uml/modules.*
730
731
732 ###
733 ### file lists
734 ###
735
736 %if %{buildup}
737 %files 
738 %defattr(-,root,root)
739 /%{image_install_path}/vmlinuz-%{KVERREL}
740 /boot/System.map-%{KVERREL}
741 /boot/config-%{KVERREL}
742 %dir /lib/modules/%{KVERREL}
743 /lib/modules/%{KVERREL}/kernel
744 /lib/modules/%{KVERREL}/build
745 /lib/modules/%{KVERREL}/source
746 /lib/modules/%{KVERREL}/extra
747 /lib/modules/%{KVERREL}/updates
748
749 %files devel
750 %defattr(-,root,root)
751 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
752 %endif
753
754 %if %{builduml} && "%{_target_cpu}" == "i686"
755 %files uml
756 %defattr(-,root,root)
757 %{_bindir}/linux
758
759 %files uml-devel
760 %defattr(-,root,root)
761 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
762 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
763
764 %files uml-modules
765 %defattr(-,root,root)
766 /boot/System.map-%{KVERREL}uml
767 /boot/config-%{KVERREL}uml
768 %dir /lib/modules/%{KVERREL}uml
769 /lib/modules/%{KVERREL}uml/kernel
770 /lib/modules/%{KVERREL}uml/build
771 /lib/modules/%{KVERREL}uml/source
772 /lib/modules/%{KVERREL}uml/extra
773 /lib/modules/%{KVERREL}uml/updates
774 %endif
775
776 %if %{buildxen} && "%{_target_cpu}" == "i686"
777 %files xenU
778 %defattr(-,root,root)
779 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
780 /boot/System.map-%{KVERREL}xenU
781 /boot/config-%{KVERREL}xenU
782 %dir /lib/modules/%{KVERREL}xenU
783 /lib/modules/%{KVERREL}xenU/kernel
784 /lib/modules/%{KVERREL}xenU/build
785 /lib/modules/%{KVERREL}xenU/source
786 /lib/modules/%{KVERREL}xenU/extra
787 /lib/modules/%{KVERREL}xenU/updates
788 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
789
790 %files xenU-devel
791 %defattr(-,root,root)
792 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
793 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
794 %endif
795
796 %files vserver
797 %defattr(-,root,root)
798 # no files
799
800 # only some architecture builds need kernel-doc
801
802 %if %{builddoc}
803 %files doc
804 %defattr(-,root,root)
805 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
806 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
807 %dir %{_datadir}/doc/kernel-doc-%{kversion}
808 %endif
809
810 %changelog
811 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
812 - 2.6.17.4
813 - Disable split pagetable lock.
814
815 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
816 - Get rid of stack backtrace on panic, which in most
817   cases actually caused a loss of info instead of a gain.
818
819 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
820 - 2.6.17.3
821
822 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
823 - 2.6.17.2
824 - Fix up the alsa list_add bug.
825
826 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
827 - Fix up various stupidities incurred by the last big rebase.
828   - Reenable SMP x86-64 builds.
829   - Reenable SMBFS.
830 - Enable PCI fake hotplug driver.
831 - Enable gameport/joystick on i586 builds. (#196581)
832
833 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
834 - Enable profiling for 586 kernels.
835
836 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
837 - Rebuild with slab debug off.
838
839 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
840 - 2.6.17.1
841
842 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
843 - 2.6.16.20
844
845 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
846 - 2.6.16.19
847
848 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
849 - Improved list_head debugging.
850
851 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
852 - 2.6.16.18
853
854 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
855 - 2.6.16.17
856
857 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
858 - 2.6.16.16
859
860 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
861 - 2.6.16.15
862 - make 16C950 UARTs work (again). (#126403)
863 - Fix exec-shield default, which should fix a few programs that
864   stopped running.
865
866 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
867 - 2.6.16.14
868
869 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
870 - 2.6.16.13
871
872 * Mon May  1 2006 Dave Jones <davej@redhat.com>
873 - 2.6.16.12
874
875 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
876 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
877
878 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
879 - 2.6.16.11
880
881 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
882 - Enable PCI MSI support.
883
884 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
885 - 2.6.16.9
886
887 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
888 - 2.6.16.7
889
890 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
891 - 2.6.16.6
892
893 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
894 - 2.6.16.5
895
896 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
897 - 2.6.16.2
898
899 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
900 - Reenable non-standard serial ports. (#187466)
901 - Reenable snd-es18xx for x86-32 (#187733)
902
903 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
904 - ship the .kernelrelease file in -devel too.
905 - Disable EDAC debug.
906
907 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
908 - 2.6.16.1
909
910 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
911 - Include patches posted for review for inclusion in 2.6.16.1
912 - Updated new audit msg types.
913 - Reenable HDLC driver (#186257)
914 - Make acpi-cpufreq 'sticky'
915 - Fix broken x86-64 32bit vDSO (#186924)
916
917 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
918 - Improve spinlock scalability on big machines.
919
920 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
921 - Sync with FC5's 2.6.16 kernel.
922 - Update Tux & Exec-shield to latest.
923