* (Cleanup) Split up the VNET+ patch into its 5 component patches
[linux-2.6.git] / kernel-2.6.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 Summary: The Linux kernel (the core of the Linux operating system)
7
8 # What parts do we want to build?  We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
10
11 %define buildup 1
12 %define builduml 0
13 %define buildxen 0
14 %define builddoc 0
15
16 # default is to not build this - to override, use something like
17 # kernel-SPECVARS := iwlwifi=1 
18 # rpm does not seem to have a syntax for defining overridable defaults
19 # any better solution would be more than welcome.
20 %define build_iwlwifi %{?iwlwifi:1}%{!?iwlwifi:0}
21
22 # Versions of various parts
23
24 # for module-tag.py - sublevel is used for the version (middle) part of tag names
25 %define name linux-2.6
26 %define module_version_varname sublevel
27 %define taglevel 10
28
29 #
30 # Polite request for people who spin their own kernel rpms:
31 # please modify the "release" field in a way that identifies
32 # that the kernel isn't the stock distribution kernel, for example by
33 # adding some text to the end of the version number.
34 #
35 %define sublevel 22
36 %define patchlevel 19
37 %define kversion 2.6.%{sublevel}
38 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
39
40 %define vsversion 2.3.0.34
41
42 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
43 # updated every time the PL kernel is updated.
44 %define vini_pl_patch 561
45
46 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
47
48 %{!?pldistro:%global pldistro planetlab}
49
50 %define signmodules 0
51 %define make_target bzImage
52 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
53
54 # Override generic defaults with per-arch defaults
55
56 %define image_install_path boot
57
58 #
59 # Three sets of minimum package version requirements in the form of Conflicts:
60 # to versions below the minimum
61 #
62
63 #
64 # First the general kernel 2.6 required versions as per
65 # Documentation/Changes
66 #
67 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
68
69
70 # Then a series of requirements that are distribution specific, either 
71 # because we add patches for something, or the older versions have 
72 # problems with the newer kernel or lack certain things that make 
73 # integration in the distro harder than needed.
74 #
75 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
76
77 #
78 # Several packages had bugs in them that became obvious when the NPTL
79 # threading code got integrated.
80 #
81 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
82
83 #
84 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
85 #
86
87 # MEF commented out
88 # %define xen_conflicts glibc < 2.3.5-1
89
90 #
91 # Packages that need to be installed before the kernel is, because the %post
92 # scripts use them.
93 #
94 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
95
96 Vendor: PlanetLab
97 Packager: PlanetLab Central <support@planet-lab.org>
98 Distribution: PlanetLab %{plrelease}
99 URL: %(echo %{url} | cut -d ' ' -f 2)
100
101 Name: kernel
102 Group: System Environment/Kernel
103 License: GPLv2
104 Version: %{rpmversion}
105 Release: %{release}
106 ExclusiveOS: Linux
107 Provides: kernel = %{version}
108 Provides: kernel-drm = 4.3.0
109 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
110 Provides: kernel-smp = %{rpmversion}-%{release}
111 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
112 Prereq: %{kernel_prereq}
113 Conflicts: %{kernel_dot_org_conflicts}
114 Conflicts: %{package_conflicts}
115 Conflicts: %{nptl_conflicts}
116 # We can't let RPM do the dependencies automatic because it'll then pick up
117 # a correct but undesirable perl dependency from the module headers which
118 # isn't required for the kernel proper to function
119 AutoReqProv: no
120
121 #
122 # List the packages used during the kernel build
123 #
124 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
125 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
126 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
127 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
128
129
130 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
131
132 Source10: %{pldistro}-%{kversion}-i586.config
133 Source11: %{pldistro}-%{kversion}-i686.config
134 Source12: %{pldistro}-%{kversion}-x86_64.config
135 %if %{builduml}
136 Source20: %{pldistro}-%{kversion}-i686-uml.config
137 %endif
138 %if %{buildxen}
139 Source30: %{pldistro}-%{kversion}-i686-xenU.config
140 %endif
141
142 # Mainline patches
143 %if "0%{patchlevel}"
144 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
145 %endif
146
147 Patch010: linux-2.6-010-e1000e.patch
148 Patch020: linux-2.6-020-build-id.patch
149 Patch030: linux-2.6-030-netns.patch
150 Patch040: linux-2.6-040-i_mutex-check.patch
151
152 # These are patches picked up from Fedora/RHEL
153 Patch100: linux-2.6-100-build-nonintconfig.patch
154
155 # Linux-VServer
156 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
157 Patch210: linux-2.6-210-vserver-cpu-sched.patch
158
159 # IP sets
160 Patch250: linux-2.6-250-ipsets.patch
161
162 # PlanetLab
163 Patch500: linux-2.6-500-vserver-filesharing.patch
164 Patch510: linux-2.6-510-ipod.patch
165 Patch520: linux-2.6-520-vnet+.patch
166 Patch521: linux-2.6-521-packet-tagging.patch
167 Patch522: linux-2.6-522-iptables-connection-tagging.patch
168 Patch523: linux-2.6-523-raw-sockets.patch
169 Patch524: linux-2.6-524-peercred.patch
170 Patch525: linux-2.6-525-sknid-elevator.patch
171 Patch530: linux-2.6-530-built-by-support.patch
172 Patch540: linux-2.6-540-oom-kill.patch
173 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
174 Patch560: linux-2.6-560-mmconf.patch
175 Patch570: linux-2.6-570-tagxid.patch
176 Patch580: linux-2.6-580-show-proc-virt.patch
177 Patch590: linux-2.6-590-chopstix-intern.patch
178 Patch620: linux-2.6-620-kdb.patch
179 Patch630: linux-2.6-630-sched-fix.patch
180 Patch640: linux-2.6-640-netlink-audit-hack.patch
181 Patch650: linux-2.6-650-hangcheck-reboot.patch
182
183 # See also the file named 'sources' here for the related checksums
184 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
185 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
186 %if %{build_iwlwifi}
187 %define mac80211_version 10.0.4
188 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
189 %define iwlwifi_version 1.2.25
190 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
191 %endif
192
193 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
194
195 %description
196 The kernel package contains the Linux kernel (vmlinuz), the core of any
197 Linux operating system.  The kernel handles the basic functions
198 of the operating system:  memory allocation, process allocation, device
199 input and output, etc.
200
201 %package devel
202 Summary: Development package for building kernel modules to match the kernel.
203 Group: System Environment/Kernel
204 AutoReqProv: no
205 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
206 Provides: kernel-smp-devel = %{rpmversion}-%{release}
207 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
208 Prereq: /usr/bin/find
209
210 %description devel
211 This package provides kernel headers and makefiles sufficient to build modules
212 against the kernel package.
213
214
215 %package doc
216 Summary: Various documentation bits found in the kernel source.
217 Group: Documentation
218
219 %description doc
220 This package contains documentation files from the kernel
221 source. Various bits of information about the Linux kernel and the
222 device drivers shipped with it are documented in these files.
223
224 You'll want to install this package if you need a reference to the
225 options that can be passed to Linux kernel modules at load time.
226
227 %package xenU
228 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
229
230 Group: System Environment/Kernel
231 Provides: kernel = %{version}
232 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
233 Prereq: %{kernel_prereq}
234 Conflicts: %{kernel_dot_org_conflicts}
235 Conflicts: %{package_conflicts}
236 Conflicts: %{nptl_conflicts}
237
238 # MEF commented out 
239 # Conflicts: %{xen_conflicts}
240
241 # We can't let RPM do the dependencies automatic because it'll then pick up
242 # a correct but undesirable perl dependency from the module headers which
243 # isn't required for the kernel proper to function
244 AutoReqProv: no
245
246 %description xenU
247 This package includes a version of the Linux kernel which
248 runs in Xen unprivileged guest VMs.  This should be installed
249 both inside the unprivileged guest (for the modules) and in
250 the guest0 domain.
251
252 %package xenU-devel
253 Summary: Development package for building kernel modules to match the kernel.
254 Group: System Environment/Kernel
255 AutoReqProv: no
256 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
257 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
258 Provides: kernel-devel = %{rpmversion}-%{release}xenU
259 Prereq: /usr/sbin/hardlink, /usr/bin/find
260
261 %description xenU-devel
262 This package provides kernel headers and makefiles sufficient to build modules
263 against the kernel package.
264
265 %package uml
266 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
267
268 Group: System Environment/Kernel
269
270 %description uml
271 This package includes a user mode version of the Linux kernel.
272
273 %package uml-devel
274 Summary: Development package for building kernel modules to match the UML kernel.
275 Group: System Environment/Kernel
276 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
277 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
278 Provides: kernel-devel = %{rpmversion}-%{release}smp
279 AutoReqProv: no
280 Prereq: /usr/sbin/hardlink, /usr/bin/find
281
282 %description uml-devel
283 This package provides kernel headers and makefiles sufficient to build modules
284 against the User Mode Linux kernel package.
285
286 %package uml-modules
287 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
288
289 Group: System Environment/Kernel
290
291 %description uml-modules
292 This package includes a user mode version of the Linux kernel modules.
293
294 %package vserver
295 Summary: A placeholder RPM that provides kernel and kernel-drm
296
297 Group: System Environment/Kernel
298 Provides: kernel = %{version}
299 Provides: kernel-drm = 4.3.0
300 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
301
302 %description vserver
303 VServers do not require and cannot use kernels, but some RPMs have
304 implicit or explicit dependencies on the "kernel" package
305 (e.g. tcpdump). This package installs no files but provides the
306 necessary dependencies to make rpm and yum happy.
307
308
309 %prep
310 # First we unpack the kernel tarball.
311 # If this isn't the first make prep, we use links to the existing clean tarball
312 # which speeds things up quite a bit.
313 if [ ! -d kernel-%{kversion}/vanilla ]; then
314   # Ok, first time we do a make prep.
315   rm -f pax_global_header
316 %setup -q -n %{name}-%{kversion} -c
317   mv linux-%{kversion} vanilla
318 else
319   # We already have a vanilla dir.
320   cd kernel-%{kversion}
321 fi
322
323 KERNEL_PREVIOUS=vanilla
324 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
325 %define ApplyPatch() \
326   rm -fr linux-%{kversion}-%1                           \
327   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
328   patchflag=-p1                                         \
329   test "%2" != "%%2" && patchflag="%2"                  \
330   PATCH="%{expand:%{PATCH%1}}"                          \
331   if test ! -e "$PATCH"; then                           \
332     echo "Patch %1 does not exist!"                     \
333     exit 1                                              \
334   fi                                                    \
335   case "$PATCH" in                                      \
336     *.bz2)  bzcat "$PATCH";;                            \
337     *.gz)   zcat "$PATCH";;                             \
338     *)      cat "$PATCH";;                              \
339   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
340   KERNEL_PREVIOUS=linux-%{kversion}-%1
341
342 # This is where the patches get applied
343 %if 0%{?patchlevel}
344 %ApplyPatch 0
345 %endif
346
347 %ApplyPatch 10
348 %ApplyPatch 20
349
350 # NetNS patch for VINI
351 %if 0%{?with_netns}
352 %ApplyPatch 30
353 %endif
354 %ApplyPatch 40
355
356 %ApplyPatch 100
357
358 %ApplyPatch 200
359 %ApplyPatch 210
360
361 %ApplyPatch 250
362
363 %ApplyPatch 500
364 %ApplyPatch 510
365
366 # VNET+ series
367 %ApplyPatch 521
368 %ApplyPatch 522
369 %ApplyPatch 523
370 %ApplyPatch 524
371 %ApplyPatch 525
372
373 %ApplyPatch 530
374 %ApplyPatch 540
375 %ApplyPatch 550
376 %ApplyPatch 560
377 %ApplyPatch 570
378 %ApplyPatch 580
379 %ApplyPatch 590
380 %ApplyPatch 620
381 %ApplyPatch 630
382 %ApplyPatch 640
383 %ApplyPatch 650
384
385 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
386 # break with later patches.
387
388 %if 0%{?with_netns}
389 %ApplyPatch %vini_pl_patch
390 %endif
391
392 %if %{build_iwlwifi}
393 # Run the mac80211 stuff in the kernel tree holding the last patch
394 tar -xzf %{PATCH600}
395 pushd mac80211-%{mac80211_version}
396 mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
397 make $mac80211_makeflags modified
398 make $mac80211_makeflags source
399 make $mac80211_makeflags patch_kernel
400 popd
401
402 # Untar iwlwifi in the same place - needs to be compiled later
403 tar -xzf %{PATCH601}
404 # the install target is broken: first it does not pass the right -b flag to depmod
405 # second we do not need to invoke depmod at this stage anyway
406 # let's add our own patch/stuff in this Makefile for manual install later on
407 pushd iwlwifi-%{iwlwifi_version}
408 cat >> Makefile <<EOF
409 module-list:
410         @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
411 EOF
412 popd
413 %endif
414
415 rm -fr linux-%{kversion}
416 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
417 cd linux-%{kversion}
418
419
420 # make sure the kernel has the sublevel we know it has. This looks weird
421 # but for -pre and -rc versions we need it since we only want to use
422 # the higher version when the final kernel is released.
423 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
424 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
425
426 # get rid of unwanted files resulting from patch fuzz
427 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
428
429
430 ###
431 ### build
432 ###
433 %build
434
435 BuildKernel() {
436     MakeTarget=$1
437     Arch=$2
438     Flavour=$3
439
440     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
441     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
442     cd linux-%{_target_cpu}-%{kversion}$Flavour
443
444     # Pick the right config file for the kernel we're building
445     if [ -n "$Flavour" ] ; then
446       Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
447       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
448       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
449     else
450       Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
451       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
452       DevelLink=
453     fi
454
455     KernelVer=%{version}-%{release}$Flavour
456     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
457
458     # make sure EXTRAVERSION says what we want it to say
459     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
460
461     # and now to start the build process
462
463     make -s mrproper
464     cp %{_sourcedir}/$Config .config
465
466     #Arch=`head -1 .config | cut -b 3-`
467     echo USING ARCH=$Arch
468
469     make -s ARCH=$Arch nonint_oldconfig > /dev/null
470     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
471     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
472
473 %if %{build_iwlwifi}
474     # build the iwlwifi driver
475     make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
476       KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
477 %endif
478
479     # Start installing the results
480
481 %if "%{_enable_debug_packages}" == "1"
482     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
483 %endif
484     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
485     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
486     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
487     if [ -f arch/$Arch/boot/bzImage ]; then
488       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
489     fi
490     if [ -f arch/$Arch/boot/zImage.stub ]; then
491       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
492     fi
493     if [ "$Flavour" = "uml" ] ; then
494         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
495     fi
496
497     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
498     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
499
500 %if %{build_iwlwifi}
501     # install iwlwifi
502 #    make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
503 #         KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
504 #        KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
505     pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
506     iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
507     # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
508     iwlwifi_modules=$(make --no-print-directory module-list)
509     install -d $iwlwifi_dest
510     install -m 644 -c $iwlwifi_modules $iwlwifi_dest
511     popd
512 %endif
513
514     # And save the headers/makefiles etc for building modules against
515     #
516     # This all looks scary, but the end result is supposed to be:
517     # * all arch relevant include/ files
518     # * all Makefile/Kconfig files
519     # * all script/ files
520
521     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
522     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
523     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
524     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
525     # dirs for additional modules per module-init-tools, kbuild/modules.txt
526     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
527     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
528     # first copy everything
529     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
530         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
531     if [ "$Flavour" = "uml" ] ; then
532       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
533     fi
534     # then drop all but the needed Makefiles/Kconfig files
535     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
536     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
537     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
538     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
539     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
540     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
541     if [ -d arch/%{_arch}/scripts ]; then
542       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
543     fi
544     if [ -f arch/%{_arch}/*lds ]; then
545       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
546     fi
547     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
548     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
549     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
550     cd include
551     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
552     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
553     if [ "$Arch" = "x86_64" ]; then
554       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
555     fi
556 %if %{buildxen}
557     if [ "$Flavour" = "xenU" ]; then
558       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
559       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
560     fi
561 %endif
562 %if %{builduml}
563     if [ "$Flavour" = "uml" ] ; then
564       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
565     fi
566 %endif
567     # While arch/powerpc/include/asm is still a symlink to the old
568     # include/asm-ppc{64,} directory, include that in kernel-devel too.
569     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
570       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
571       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
572       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
573       ln -sf ../../../include/asm-ppc* asm
574       popd
575     fi
576
577     # Make sure the Makefile and version.h have a matching timestamp so that
578     # external modules can be built
579     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
580     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
581     cd ..
582
583     #
584     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
585     #
586 %if "%{_enable_debug_packages}" == "1"
587     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
588     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
589 %endif
590 %if %{buildxen}
591     if [ -f vmlinuz ]; then
592       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
593     fi
594 %endif
595
596     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
597
598     # mark modules executable so that strip-to-file can strip them
599     cat modnames | xargs chmod u+x
600
601     # remove files that will be auto generated by depmod at rpm -i time
602     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
603
604     # Move the devel headers out of the root file system
605     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
606     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
607     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
608     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
609 }
610
611 ###
612 # DO it...
613 ###
614
615 # prepare directories
616 rm -rf $RPM_BUILD_ROOT
617 mkdir -p $RPM_BUILD_ROOT/boot
618
619 %if "%{_target_cpu}" == "x86_64"
620 %define kernel_arch %{_target_cpu}
621 %endif
622 %if "%{_target_cpu}" == "i586"
623 %define kernel_arch i386
624 %endif
625 %if "%{_target_cpu}" == "i686"
626 %define kernel_arch i386
627 %endif
628
629 %if %{buildup}
630 BuildKernel %make_target %kernel_arch
631 %endif
632
633 %ifarch i686
634 %if %{builduml}
635 BuildKernel linux um uml
636 %endif
637
638 %if %{buildxen}
639 BuildKernel vmlinuz %kernel_arch xenU
640 %endif
641 %endif
642
643 ###
644 ### install
645 ###
646
647 %install
648
649 cd vanilla
650
651 %if %{buildxen} && "%{_target_cpu}" == "i686"
652 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
653 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
654 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
655 # This directive teaches ldconfig to search in nosegneg subdirectories
656 # and cache the DSOs there with extra bit 0 set in their hwcap match
657 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
658 # search in nosegneg subdirectories and to match this extra hwcap bit
659 # in the ld.so.cache file.
660 hwcap 0 nosegneg
661 EOF
662 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
663 %endif
664
665 %if %{builddoc}
666 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
667
668 # sometimes non-world-readable files sneak into the kernel source tree
669 chmod -R a+r *
670 # copy the source over
671 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
672 %endif
673
674 ###
675 ### clean
676 ###
677
678 %clean
679 rm -rf $RPM_BUILD_ROOT
680
681 ###
682 ### scripts
683 ###
684
685 # load the loop module for upgrades...in case the old modules get removed we have
686 # loopback in the kernel so that mkinitrd will work.
687 %pre
688 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
689 exit 0
690
691 %post
692 if [ -f /etc/sysconfig/kernel ]; then
693   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
694 fi
695
696 # trick mkinitrd in case the current environment does not have device mapper
697 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
698 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
699     if [ ! -f $rootdev ]; then
700         fake_root_lvm=1
701         mkdir -p $(dirname $rootdev)
702         touch $rootdev
703     fi
704 fi
705
706 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
707 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
708 # Older modutils do not support --package option
709 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
710
711 # remove fake handle
712 if [ -n "$fake_root_lvm" ]; then
713     rm -f $rootdev
714 fi
715
716 # make some useful links
717 pushd /boot > /dev/null ; {
718         ln -sf config-%{KVERREL} config
719         ln -sf config-%{KVERREL} configsmp
720         ln -sf initrd-%{KVERREL}.img initrd-boot
721         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
722         ln -sf vmlinuz-%{KVERREL} kernel-boot
723         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
724 }
725 popd > /dev/null
726
727 # ask for a reboot
728 mkdir -p /etc/planetlab
729 touch /etc/planetlab/update-reboot
730
731 %post devel
732 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
733 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
734   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
735   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
736   popd > /dev/null
737 fi
738
739 %post xenU
740 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
741 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
742
743 %post xenU-devel
744 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
745 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
746   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
747   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
748   popd > /dev/null
749 fi
750
751 %post uml-modules
752 depmod -ae %{KVERREL}uml
753
754 %preun
755 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
756 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
757
758 %preun xenU
759 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
760 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
761
762 %preun uml-modules
763 rm -f /lib/modules/%{KVERREL}uml/modules.*
764
765
766 ###
767 ### file lists
768 ###
769
770 %if %{buildup}
771 %files 
772 %defattr(-,root,root)
773 /%{image_install_path}/vmlinuz-%{KVERREL}
774 /boot/System.map-%{KVERREL}
775 /boot/config-%{KVERREL}
776 %dir /lib/modules/%{KVERREL}
777 /lib/modules/%{KVERREL}/kernel
778 /lib/modules/%{KVERREL}/build
779 /lib/modules/%{KVERREL}/source
780 /lib/modules/%{KVERREL}/extra
781 /lib/modules/%{KVERREL}/updates
782
783 %files devel
784 %defattr(-,root,root)
785 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
786 %endif
787
788 %if %{builduml} && "%{_target_cpu}" == "i686"
789 %files uml
790 %defattr(-,root,root)
791 %{_bindir}/linux
792
793 %files uml-devel
794 %defattr(-,root,root)
795 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
796 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
797
798 %files uml-modules
799 %defattr(-,root,root)
800 /boot/System.map-%{KVERREL}uml
801 /boot/config-%{KVERREL}uml
802 %dir /lib/modules/%{KVERREL}uml
803 /lib/modules/%{KVERREL}uml/kernel
804 /lib/modules/%{KVERREL}uml/build
805 /lib/modules/%{KVERREL}uml/source
806 /lib/modules/%{KVERREL}uml/extra
807 /lib/modules/%{KVERREL}uml/updates
808 %endif
809
810 %if %{buildxen} && "%{_target_cpu}" == "i686"
811 %files xenU
812 %defattr(-,root,root)
813 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
814 /boot/System.map-%{KVERREL}xenU
815 /boot/config-%{KVERREL}xenU
816 %dir /lib/modules/%{KVERREL}xenU
817 /lib/modules/%{KVERREL}xenU/kernel
818 /lib/modules/%{KVERREL}xenU/build
819 /lib/modules/%{KVERREL}xenU/source
820 /lib/modules/%{KVERREL}xenU/extra
821 /lib/modules/%{KVERREL}xenU/updates
822 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
823
824 %files xenU-devel
825 %defattr(-,root,root)
826 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
827 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
828 %endif
829
830 %files vserver
831 %defattr(-,root,root)
832 # no files
833
834 # only some architecture builds need kernel-doc
835
836 %if %{builddoc}
837 %files doc
838 %defattr(-,root,root)
839 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
840 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
841 %dir %{_datadir}/doc/kernel-doc-%{kversion}
842 %endif
843
844 %changelog
845 * Tue Jul 08 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-10
846 - Filling a statically allocated buffer cannot fail, right?
847
848 * Wed Jun 25 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-9
849 - Enable the hangcheck timer driver, and build it in to the kernel.
850 - Dump relevant data on the scheduler bug instead of BUGing.
851
852 * Sat Jun 07 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-8
853 - * Partial fix for the UDP-packet-pollution problem
854 - * Support for PF_PACKET sockets
855 - * Support for SOCK_PACKET sockets
856 - * Disabled Chopstix with mutexes
857 - * Tested VNET+ under heavy loads
858
859
860
861 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-7
862 - Bringing this fix in for tcpdump and  ping
863
864
865 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-6
866 - Updated configuration to include COW again.
867
868 - Patches from Sapan to fix ping losses.
869
870 - Still need help with tcpdump traffic.
871
872
873 * Tue May 06 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-5
874 - Patch needs to be applied.
875
876 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-4
877
878
879 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-3
880 - Fix bug with looping in schedule()
881
882 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-2
883 - Includes changes from Sapan/Andy regarding the scheduler and vnet bugs.
884 - Should be safe to try a second deployment.
885
886
887 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
888 - 2.6.17.4
889 - Disable split pagetable lock.
890
891 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
892 - Get rid of stack backtrace on panic, which in most
893   cases actually caused a loss of info instead of a gain.
894
895 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
896 - 2.6.17.3
897
898 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
899 - 2.6.17.2
900 - Fix up the alsa list_add bug.
901
902 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
903 - Fix up various stupidities incurred by the last big rebase.
904   - Reenable SMP x86-64 builds.
905   - Reenable SMBFS.
906 - Enable PCI fake hotplug driver.
907 - Enable gameport/joystick on i586 builds. (#196581)
908
909 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
910 - Enable profiling for 586 kernels.
911
912 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
913 - Rebuild with slab debug off.
914
915 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
916 - 2.6.17.1
917
918 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
919 - 2.6.16.20
920
921 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
922 - 2.6.16.19
923
924 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
925 - Improved list_head debugging.
926
927 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
928 - 2.6.16.18
929
930 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
931 - 2.6.16.17
932
933 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
934 - 2.6.16.16
935
936 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
937 - 2.6.16.15
938 - make 16C950 UARTs work (again). (#126403)
939 - Fix exec-shield default, which should fix a few programs that
940   stopped running.
941
942 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
943 - 2.6.16.14
944
945 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
946 - 2.6.16.13
947
948 * Mon May  1 2006 Dave Jones <davej@redhat.com>
949 - 2.6.16.12
950
951 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
952 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
953
954 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
955 - 2.6.16.11
956
957 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
958 - Enable PCI MSI support.
959
960 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
961 - 2.6.16.9
962
963 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
964 - 2.6.16.7
965
966 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
967 - 2.6.16.6
968
969 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
970 - 2.6.16.5
971
972 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
973 - 2.6.16.2
974
975 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
976 - Reenable non-standard serial ports. (#187466)
977 - Reenable snd-es18xx for x86-32 (#187733)
978
979 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
980 - ship the .kernelrelease file in -devel too.
981 - Disable EDAC debug.
982
983 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
984 - 2.6.16.1
985
986 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
987 - Include patches posted for review for inclusion in 2.6.16.1
988 - Updated new audit msg types.
989 - Reenable HDLC driver (#186257)
990 - Make acpi-cpufreq 'sticky'
991 - Fix broken x86-64 32bit vDSO (#186924)
992
993 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
994 - Improve spinlock scalability on big machines.
995
996 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
997 - Sync with FC5's 2.6.16 kernel.
998 - Update Tux & Exec-shield to latest.
999