Tagging module linux-2.6 - linux-2.6-22-12
[linux-2.6.git] / kernel-2.6.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 Summary: The Linux kernel (the core of the Linux operating system)
7
8 # What parts do we want to build?  We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
10
11 %define buildup 1
12 %define builduml 0
13 %define buildxen 0
14 %define builddoc 0
15
16 # default is to not build this - to override, use something like
17 # kernel-SPECVARS := iwlwifi=1 
18 # rpm does not seem to have a syntax for defining overridable defaults
19 # any better solution would be more than welcome.
20 %define build_iwlwifi %{?iwlwifi:1}%{!?iwlwifi:0}
21
22 # Versions of various parts
23
24 # for module-tag.py - sublevel is used for the version (middle) part of tag names
25 %define name linux-2.6
26 %define module_version_varname sublevel
27 %define taglevel 12
28
29 #
30 # Polite request for people who spin their own kernel rpms:
31 # please modify the "release" field in a way that identifies
32 # that the kernel isn't the stock distribution kernel, for example by
33 # adding some text to the end of the version number.
34 #
35 %define sublevel 22
36 %define patchlevel 19
37 %define kversion 2.6.%{sublevel}
38 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
39
40 %define vsversion 2.3.0.34
41
42 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
43 # updated every time the PL kernel is updated.
44 %define vini_pl_patch 561
45
46 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
47
48 %{!?pldistro:%global pldistro planetlab}
49
50 %define signmodules 0
51 %define make_target bzImage
52 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
53
54 # Override generic defaults with per-arch defaults
55
56 %define image_install_path boot
57
58 #
59 # Three sets of minimum package version requirements in the form of Conflicts:
60 # to versions below the minimum
61 #
62
63 #
64 # First the general kernel 2.6 required versions as per
65 # Documentation/Changes
66 #
67 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
68
69
70 # Then a series of requirements that are distribution specific, either 
71 # because we add patches for something, or the older versions have 
72 # problems with the newer kernel or lack certain things that make 
73 # integration in the distro harder than needed.
74 #
75 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
76
77 #
78 # Several packages had bugs in them that became obvious when the NPTL
79 # threading code got integrated.
80 #
81 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
82
83 #
84 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
85 #
86
87 # MEF commented out
88 # %define xen_conflicts glibc < 2.3.5-1
89
90 #
91 # Packages that need to be installed before the kernel is, because the %post
92 # scripts use them.
93 #
94 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
95
96 Vendor: PlanetLab
97 Packager: PlanetLab Central <support@planet-lab.org>
98 Distribution: PlanetLab %{plrelease}
99 URL: %(echo %{url} | cut -d ' ' -f 2)
100
101 Name: kernel
102 Group: System Environment/Kernel
103 License: GPLv2
104 Version: %{rpmversion}
105 Release: %{release}
106 ExclusiveOS: Linux
107 Provides: kernel = %{version}
108 Provides: kernel-drm = 4.3.0
109 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
110 Provides: kernel-smp = %{rpmversion}-%{release}
111 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
112 Prereq: %{kernel_prereq}
113 Conflicts: %{kernel_dot_org_conflicts}
114 Conflicts: %{package_conflicts}
115 Conflicts: %{nptl_conflicts}
116 # We can't let RPM do the dependencies automatic because it'll then pick up
117 # a correct but undesirable perl dependency from the module headers which
118 # isn't required for the kernel proper to function
119 AutoReqProv: no
120
121 #
122 # List the packages used during the kernel build
123 #
124 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
125 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
126 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
127 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
128
129
130 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
131
132 Source10: %{pldistro}-%{kversion}-i586.config
133 Source11: %{pldistro}-%{kversion}-i686.config
134 Source12: %{pldistro}-%{kversion}-x86_64.config
135 %if %{builduml}
136 Source20: %{pldistro}-%{kversion}-i686-uml.config
137 %endif
138 %if %{buildxen}
139 Source30: %{pldistro}-%{kversion}-i686-xenU.config
140 %endif
141
142 # Mainline patches
143 %if "0%{patchlevel}"
144 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
145 %endif
146
147 Patch010: linux-2.6-010-e1000e.patch
148 Patch020: linux-2.6-020-build-id.patch
149 Patch030: linux-2.6-030-netns.patch
150 Patch040: linux-2.6-040-i_mutex-check.patch
151
152 # These are patches picked up from Fedora/RHEL
153 Patch100: linux-2.6-100-build-nonintconfig.patch
154
155 # Linux-VServer
156 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
157 Patch210: linux-2.6-210-vserver-cpu-sched.patch
158
159 # IP sets
160 Patch250: linux-2.6-250-ipsets.patch
161
162 # PlanetLab
163 Patch500: linux-2.6-500-vserver-filesharing.patch
164 Patch510: linux-2.6-510-ipod.patch
165 Patch520: linux-2.6-520-vnet+.patch
166 Patch521: linux-2.6-521-packet-tagging.patch
167 Patch522: linux-2.6-522-iptables-connection-tagging.patch
168 Patch523: linux-2.6-523-raw-sockets.patch
169 Patch524: linux-2.6-524-peercred.patch
170 Patch525: linux-2.6-525-sknid-elevator.patch
171 Patch526: linux-2.6-526-tun-tap.patch
172 Patch530: linux-2.6-530-built-by-support.patch
173 Patch540: linux-2.6-540-oom-kill.patch
174 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
175 Patch560: linux-2.6-560-mmconf.patch
176 Patch570: linux-2.6-570-tagxid.patch
177 Patch580: linux-2.6-580-show-proc-virt.patch
178 Patch590: linux-2.6-590-chopstix-intern.patch
179 Patch620: linux-2.6-620-kdb.patch
180 Patch630: linux-2.6-630-sched-fix.patch
181 Patch640: linux-2.6-640-netlink-audit-hack.patch
182 Patch650: linux-2.6-650-hangcheck-reboot.patch
183
184 # See also the file named 'sources' here for the related checksums
185 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
186 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
187 %if %{build_iwlwifi}
188 %define mac80211_version 10.0.4
189 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
190 %define iwlwifi_version 1.2.25
191 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
192 %endif
193
194 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
195
196 %description
197 The kernel package contains the Linux kernel (vmlinuz), the core of any
198 Linux operating system.  The kernel handles the basic functions
199 of the operating system:  memory allocation, process allocation, device
200 input and output, etc.
201
202 %package devel
203 Summary: Development package for building kernel modules to match the kernel.
204 Group: System Environment/Kernel
205 AutoReqProv: no
206 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
207 Provides: kernel-smp-devel = %{rpmversion}-%{release}
208 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
209 Prereq: /usr/bin/find
210
211 %description devel
212 This package provides kernel headers and makefiles sufficient to build modules
213 against the kernel package.
214
215
216 %package doc
217 Summary: Various documentation bits found in the kernel source.
218 Group: Documentation
219
220 %description doc
221 This package contains documentation files from the kernel
222 source. Various bits of information about the Linux kernel and the
223 device drivers shipped with it are documented in these files.
224
225 You'll want to install this package if you need a reference to the
226 options that can be passed to Linux kernel modules at load time.
227
228 %package xenU
229 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
230
231 Group: System Environment/Kernel
232 Provides: kernel = %{version}
233 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
234 Prereq: %{kernel_prereq}
235 Conflicts: %{kernel_dot_org_conflicts}
236 Conflicts: %{package_conflicts}
237 Conflicts: %{nptl_conflicts}
238
239 # MEF commented out 
240 # Conflicts: %{xen_conflicts}
241
242 # We can't let RPM do the dependencies automatic because it'll then pick up
243 # a correct but undesirable perl dependency from the module headers which
244 # isn't required for the kernel proper to function
245 AutoReqProv: no
246
247 %description xenU
248 This package includes a version of the Linux kernel which
249 runs in Xen unprivileged guest VMs.  This should be installed
250 both inside the unprivileged guest (for the modules) and in
251 the guest0 domain.
252
253 %package xenU-devel
254 Summary: Development package for building kernel modules to match the kernel.
255 Group: System Environment/Kernel
256 AutoReqProv: no
257 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
258 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
259 Provides: kernel-devel = %{rpmversion}-%{release}xenU
260 Prereq: /usr/sbin/hardlink, /usr/bin/find
261
262 %description xenU-devel
263 This package provides kernel headers and makefiles sufficient to build modules
264 against the kernel package.
265
266 %package uml
267 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
268
269 Group: System Environment/Kernel
270
271 %description uml
272 This package includes a user mode version of the Linux kernel.
273
274 %package uml-devel
275 Summary: Development package for building kernel modules to match the UML kernel.
276 Group: System Environment/Kernel
277 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
278 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
279 Provides: kernel-devel = %{rpmversion}-%{release}smp
280 AutoReqProv: no
281 Prereq: /usr/sbin/hardlink, /usr/bin/find
282
283 %description uml-devel
284 This package provides kernel headers and makefiles sufficient to build modules
285 against the User Mode Linux kernel package.
286
287 %package uml-modules
288 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
289
290 Group: System Environment/Kernel
291
292 %description uml-modules
293 This package includes a user mode version of the Linux kernel modules.
294
295 %package vserver
296 Summary: A placeholder RPM that provides kernel and kernel-drm
297
298 Group: System Environment/Kernel
299 Provides: kernel = %{version}
300 Provides: kernel-drm = 4.3.0
301 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
302
303 %description vserver
304 VServers do not require and cannot use kernels, but some RPMs have
305 implicit or explicit dependencies on the "kernel" package
306 (e.g. tcpdump). This package installs no files but provides the
307 necessary dependencies to make rpm and yum happy.
308
309
310 %prep
311 # First we unpack the kernel tarball.
312 # If this isn't the first make prep, we use links to the existing clean tarball
313 # which speeds things up quite a bit.
314 if [ ! -d kernel-%{kversion}/vanilla ]; then
315   # Ok, first time we do a make prep.
316   rm -f pax_global_header
317 %setup -q -n %{name}-%{kversion} -c
318   mv linux-%{kversion} vanilla
319 else
320   # We already have a vanilla dir.
321   cd kernel-%{kversion}
322 fi
323
324 KERNEL_PREVIOUS=vanilla
325 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
326 %define ApplyPatch() \
327   rm -fr linux-%{kversion}-%1                           \
328   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
329   patchflag=-p1                                         \
330   test "%2" != "%%2" && patchflag="%2"                  \
331   PATCH="%{expand:%{PATCH%1}}"                          \
332   if test ! -e "$PATCH"; then                           \
333     echo "Patch %1 does not exist!"                     \
334     exit 1                                              \
335   fi                                                    \
336   case "$PATCH" in                                      \
337     *.bz2)  bzcat "$PATCH";;                            \
338     *.gz)   zcat "$PATCH";;                             \
339     *)      cat "$PATCH";;                              \
340   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
341   KERNEL_PREVIOUS=linux-%{kversion}-%1
342
343 # This is where the patches get applied
344 %if 0%{?patchlevel}
345 %ApplyPatch 0
346 %endif
347
348 %ApplyPatch 10
349 %ApplyPatch 20
350
351 # NetNS patch for VINI
352 %if 0%{?with_netns}
353 %ApplyPatch 30
354 %endif
355 %ApplyPatch 40
356
357 %ApplyPatch 100
358
359 %ApplyPatch 200
360 %ApplyPatch 210
361
362 %ApplyPatch 250
363
364 %ApplyPatch 500
365 %ApplyPatch 510
366
367 # VNET+ series
368 %ApplyPatch 521
369 %ApplyPatch 522
370 %ApplyPatch 523
371 %ApplyPatch 524
372 %ApplyPatch 525
373 %ApplyPatch 526
374
375 %ApplyPatch 530
376 %ApplyPatch 540
377 %ApplyPatch 550
378 %ApplyPatch 560
379 %ApplyPatch 570
380 %ApplyPatch 580
381 %ApplyPatch 590
382 %ApplyPatch 620
383 %ApplyPatch 630
384 %ApplyPatch 640
385 %ApplyPatch 650
386
387 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
388 # break with later patches.
389
390 %if 0%{?with_netns}
391 %ApplyPatch %vini_pl_patch
392 %endif
393
394 %if %{build_iwlwifi}
395 # Run the mac80211 stuff in the kernel tree holding the last patch
396 tar -xzf %{PATCH600}
397 pushd mac80211-%{mac80211_version}
398 mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
399 make $mac80211_makeflags modified
400 make $mac80211_makeflags source
401 make $mac80211_makeflags patch_kernel
402 popd
403
404 # Untar iwlwifi in the same place - needs to be compiled later
405 tar -xzf %{PATCH601}
406 # the install target is broken: first it does not pass the right -b flag to depmod
407 # second we do not need to invoke depmod at this stage anyway
408 # let's add our own patch/stuff in this Makefile for manual install later on
409 pushd iwlwifi-%{iwlwifi_version}
410 cat >> Makefile <<EOF
411 module-list:
412         @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
413 EOF
414 popd
415 %endif
416
417 rm -fr linux-%{kversion}
418 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
419 cd linux-%{kversion}
420
421
422 # make sure the kernel has the sublevel we know it has. This looks weird
423 # but for -pre and -rc versions we need it since we only want to use
424 # the higher version when the final kernel is released.
425 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
426 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
427
428 # get rid of unwanted files resulting from patch fuzz
429 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
430
431
432 ###
433 ### build
434 ###
435 %build
436
437 BuildKernel() {
438     MakeTarget=$1
439     Arch=$2
440     Flavour=$3
441
442     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
443     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
444     cd linux-%{_target_cpu}-%{kversion}$Flavour
445
446     # Pick the right config file for the kernel we're building
447     if [ -n "$Flavour" ] ; then
448       Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
449       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
450       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
451     else
452       Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
453       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
454       DevelLink=
455     fi
456
457     KernelVer=%{version}-%{release}$Flavour
458     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
459
460     # make sure EXTRAVERSION says what we want it to say
461     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
462
463     # and now to start the build process
464
465     make -s mrproper
466     cp %{_sourcedir}/$Config .config
467
468     #Arch=`head -1 .config | cut -b 3-`
469     echo USING ARCH=$Arch
470
471     make -s ARCH=$Arch nonint_oldconfig > /dev/null
472     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
473     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
474
475 %if %{build_iwlwifi}
476     # build the iwlwifi driver
477     make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
478       KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
479 %endif
480
481     # Start installing the results
482
483 %if "%{_enable_debug_packages}" == "1"
484     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
485 %endif
486     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
487     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
488     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
489     if [ -f arch/$Arch/boot/bzImage ]; then
490       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
491     fi
492     if [ -f arch/$Arch/boot/zImage.stub ]; then
493       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
494     fi
495     if [ "$Flavour" = "uml" ] ; then
496         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
497     fi
498
499     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
500     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
501
502 %if %{build_iwlwifi}
503     # install iwlwifi
504 #    make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
505 #         KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
506 #        KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
507     pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
508     iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
509     # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
510     iwlwifi_modules=$(make --no-print-directory module-list)
511     install -d $iwlwifi_dest
512     install -m 644 -c $iwlwifi_modules $iwlwifi_dest
513     popd
514 %endif
515
516     # And save the headers/makefiles etc for building modules against
517     #
518     # This all looks scary, but the end result is supposed to be:
519     # * all arch relevant include/ files
520     # * all Makefile/Kconfig files
521     # * all script/ files
522
523     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
524     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
525     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
526     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
527     # dirs for additional modules per module-init-tools, kbuild/modules.txt
528     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
529     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
530     # first copy everything
531     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
532         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
533     if [ "$Flavour" = "uml" ] ; then
534       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
535     fi
536     # then drop all but the needed Makefiles/Kconfig files
537     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
538     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
539     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
540     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
541     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
542     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
543     if [ -d arch/%{_arch}/scripts ]; then
544       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
545     fi
546     if [ -f arch/%{_arch}/*lds ]; then
547       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
548     fi
549     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
550     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
551     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
552     cd include
553     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
554     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
555     if [ "$Arch" = "x86_64" ]; then
556       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
557     fi
558 %if %{buildxen}
559     if [ "$Flavour" = "xenU" ]; then
560       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
561       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
562     fi
563 %endif
564 %if %{builduml}
565     if [ "$Flavour" = "uml" ] ; then
566       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
567     fi
568 %endif
569     # While arch/powerpc/include/asm is still a symlink to the old
570     # include/asm-ppc{64,} directory, include that in kernel-devel too.
571     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
572       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
573       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
574       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
575       ln -sf ../../../include/asm-ppc* asm
576       popd
577     fi
578
579     # Make sure the Makefile and version.h have a matching timestamp so that
580     # external modules can be built
581     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
582     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
583     cd ..
584
585     #
586     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
587     #
588 %if "%{_enable_debug_packages}" == "1"
589     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
590     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
591 %endif
592 %if %{buildxen}
593     if [ -f vmlinuz ]; then
594       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
595     fi
596 %endif
597
598     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
599
600     # mark modules executable so that strip-to-file can strip them
601     cat modnames | xargs chmod u+x
602
603     # remove files that will be auto generated by depmod at rpm -i time
604     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
605
606     # Move the devel headers out of the root file system
607     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
608     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
609     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
610     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
611 }
612
613 ###
614 # DO it...
615 ###
616
617 # prepare directories
618 rm -rf $RPM_BUILD_ROOT
619 mkdir -p $RPM_BUILD_ROOT/boot
620
621 %if "%{_target_cpu}" == "x86_64"
622 %define kernel_arch %{_target_cpu}
623 %endif
624 %if "%{_target_cpu}" == "i586"
625 %define kernel_arch i386
626 %endif
627 %if "%{_target_cpu}" == "i686"
628 %define kernel_arch i386
629 %endif
630
631 %if %{buildup}
632 BuildKernel %make_target %kernel_arch
633 %endif
634
635 %ifarch i686
636 %if %{builduml}
637 BuildKernel linux um uml
638 %endif
639
640 %if %{buildxen}
641 BuildKernel vmlinuz %kernel_arch xenU
642 %endif
643 %endif
644
645 ###
646 ### install
647 ###
648
649 %install
650
651 cd vanilla
652
653 %if %{buildxen} && "%{_target_cpu}" == "i686"
654 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
655 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
656 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
657 # This directive teaches ldconfig to search in nosegneg subdirectories
658 # and cache the DSOs there with extra bit 0 set in their hwcap match
659 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
660 # search in nosegneg subdirectories and to match this extra hwcap bit
661 # in the ld.so.cache file.
662 hwcap 0 nosegneg
663 EOF
664 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
665 %endif
666
667 %if %{builddoc}
668 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
669
670 # sometimes non-world-readable files sneak into the kernel source tree
671 chmod -R a+r *
672 # copy the source over
673 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
674 %endif
675
676 ###
677 ### clean
678 ###
679
680 %clean
681 rm -rf $RPM_BUILD_ROOT
682
683 ###
684 ### scripts
685 ###
686
687 # load the loop module for upgrades...in case the old modules get removed we have
688 # loopback in the kernel so that mkinitrd will work.
689 %pre
690 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
691 exit 0
692
693 %post
694 if [ -f /etc/sysconfig/kernel ]; then
695   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
696 fi
697
698 # trick mkinitrd in case the current environment does not have device mapper
699 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
700 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
701     if [ ! -f $rootdev ]; then
702         fake_root_lvm=1
703         mkdir -p $(dirname $rootdev)
704         touch $rootdev
705     fi
706 fi
707
708 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
709 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
710 # Older modutils do not support --package option
711 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
712
713 # remove fake handle
714 if [ -n "$fake_root_lvm" ]; then
715     rm -f $rootdev
716 fi
717
718 # make some useful links
719 pushd /boot > /dev/null ; {
720         ln -sf config-%{KVERREL} config
721         ln -sf config-%{KVERREL} configsmp
722         ln -sf initrd-%{KVERREL}.img initrd-boot
723         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
724         ln -sf vmlinuz-%{KVERREL} kernel-boot
725         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
726 }
727 popd > /dev/null
728
729 # ask for a reboot
730 mkdir -p /etc/planetlab
731 touch /etc/planetlab/update-reboot
732
733 %post devel
734 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
735 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
736   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
737   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
738   popd > /dev/null
739 fi
740
741 %post xenU
742 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
743 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
744
745 %post xenU-devel
746 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
747 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
748   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
749   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
750   popd > /dev/null
751 fi
752
753 %post uml-modules
754 depmod -ae %{KVERREL}uml
755
756 %preun
757 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
758 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
759
760 %preun xenU
761 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
762 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
763
764 %preun uml-modules
765 rm -f /lib/modules/%{KVERREL}uml/modules.*
766
767
768 ###
769 ### file lists
770 ###
771
772 %if %{buildup}
773 %files 
774 %defattr(-,root,root)
775 /%{image_install_path}/vmlinuz-%{KVERREL}
776 /boot/System.map-%{KVERREL}
777 /boot/config-%{KVERREL}
778 %dir /lib/modules/%{KVERREL}
779 /lib/modules/%{KVERREL}/kernel
780 /lib/modules/%{KVERREL}/build
781 /lib/modules/%{KVERREL}/source
782 /lib/modules/%{KVERREL}/extra
783 /lib/modules/%{KVERREL}/updates
784
785 %files devel
786 %defattr(-,root,root)
787 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
788 %endif
789
790 %if %{builduml} && "%{_target_cpu}" == "i686"
791 %files uml
792 %defattr(-,root,root)
793 %{_bindir}/linux
794
795 %files uml-devel
796 %defattr(-,root,root)
797 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
798 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
799
800 %files uml-modules
801 %defattr(-,root,root)
802 /boot/System.map-%{KVERREL}uml
803 /boot/config-%{KVERREL}uml
804 %dir /lib/modules/%{KVERREL}uml
805 /lib/modules/%{KVERREL}uml/kernel
806 /lib/modules/%{KVERREL}uml/build
807 /lib/modules/%{KVERREL}uml/source
808 /lib/modules/%{KVERREL}uml/extra
809 /lib/modules/%{KVERREL}uml/updates
810 %endif
811
812 %if %{buildxen} && "%{_target_cpu}" == "i686"
813 %files xenU
814 %defattr(-,root,root)
815 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
816 /boot/System.map-%{KVERREL}xenU
817 /boot/config-%{KVERREL}xenU
818 %dir /lib/modules/%{KVERREL}xenU
819 /lib/modules/%{KVERREL}xenU/kernel
820 /lib/modules/%{KVERREL}xenU/build
821 /lib/modules/%{KVERREL}xenU/source
822 /lib/modules/%{KVERREL}xenU/extra
823 /lib/modules/%{KVERREL}xenU/updates
824 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
825
826 %files xenU-devel
827 %defattr(-,root,root)
828 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
829 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
830 %endif
831
832 %files vserver
833 %defattr(-,root,root)
834 # no files
835
836 # only some architecture builds need kernel-doc
837
838 %if %{builddoc}
839 %files doc
840 %defattr(-,root,root)
841 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
842 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
843 %dir %{_datadir}/doc/kernel-doc-%{kversion}
844 %endif
845
846 %changelog
847 * Tue Jul 15 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-12
848 - * Bugfix in tuntap
849 - * Attempt to fix TCP-payload-related problems with tcpdump
850
851 * Wed Jul 09 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-11
852 - * Split up VNET+ module into its component patches
853 - * Added tun/tap support
854
855 * Tue Jul 08 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-10
856 - Filling a statically allocated buffer cannot fail, right?
857
858 * Wed Jun 25 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-9
859 - Enable the hangcheck timer driver, and build it in to the kernel.
860 - Dump relevant data on the scheduler bug instead of BUGing.
861
862 * Sat Jun 07 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-8
863 - * Partial fix for the UDP-packet-pollution problem
864 - * Support for PF_PACKET sockets
865 - * Support for SOCK_PACKET sockets
866 - * Disabled Chopstix with mutexes
867 - * Tested VNET+ under heavy loads
868
869
870
871 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-7
872 - Bringing this fix in for tcpdump and  ping
873
874
875 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-6
876 - Updated configuration to include COW again.
877
878 - Patches from Sapan to fix ping losses.
879
880 - Still need help with tcpdump traffic.
881
882
883 * Tue May 06 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-5
884 - Patch needs to be applied.
885
886 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-4
887
888
889 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-3
890 - Fix bug with looping in schedule()
891
892 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-2
893 - Includes changes from Sapan/Andy regarding the scheduler and vnet bugs.
894 - Should be safe to try a second deployment.
895
896
897 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
898 - 2.6.17.4
899 - Disable split pagetable lock.
900
901 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
902 - Get rid of stack backtrace on panic, which in most
903   cases actually caused a loss of info instead of a gain.
904
905 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
906 - 2.6.17.3
907
908 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
909 - 2.6.17.2
910 - Fix up the alsa list_add bug.
911
912 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
913 - Fix up various stupidities incurred by the last big rebase.
914   - Reenable SMP x86-64 builds.
915   - Reenable SMBFS.
916 - Enable PCI fake hotplug driver.
917 - Enable gameport/joystick on i586 builds. (#196581)
918
919 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
920 - Enable profiling for 586 kernels.
921
922 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
923 - Rebuild with slab debug off.
924
925 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
926 - 2.6.17.1
927
928 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
929 - 2.6.16.20
930
931 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
932 - 2.6.16.19
933
934 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
935 - Improved list_head debugging.
936
937 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
938 - 2.6.16.18
939
940 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
941 - 2.6.16.17
942
943 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
944 - 2.6.16.16
945
946 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
947 - 2.6.16.15
948 - make 16C950 UARTs work (again). (#126403)
949 - Fix exec-shield default, which should fix a few programs that
950   stopped running.
951
952 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
953 - 2.6.16.14
954
955 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
956 - 2.6.16.13
957
958 * Mon May  1 2006 Dave Jones <davej@redhat.com>
959 - 2.6.16.12
960
961 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
962 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
963
964 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
965 - 2.6.16.11
966
967 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
968 - Enable PCI MSI support.
969
970 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
971 - 2.6.16.9
972
973 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
974 - 2.6.16.7
975
976 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
977 - 2.6.16.6
978
979 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
980 - 2.6.16.5
981
982 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
983 - 2.6.16.2
984
985 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
986 - Reenable non-standard serial ports. (#187466)
987 - Reenable snd-es18xx for x86-32 (#187733)
988
989 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
990 - ship the .kernelrelease file in -devel too.
991 - Disable EDAC debug.
992
993 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
994 - 2.6.16.1
995
996 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
997 - Include patches posted for review for inclusion in 2.6.16.1
998 - Updated new audit msg types.
999 - Reenable HDLC driver (#186257)
1000 - Make acpi-cpufreq 'sticky'
1001 - Fix broken x86-64 32bit vDSO (#186924)
1002
1003 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
1004 - Improve spinlock scalability on big machines.
1005
1006 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
1007 - Sync with FC5's 2.6.16 kernel.
1008 - Update Tux & Exec-shield to latest.
1009