build compliance
[linux-2.6.git] / kernel-2.6.spec
1 Summary: The Linux kernel (the core of the Linux operating system)
2
3 # What parts do we want to build?  We must build at least one kernel.
4 # These are the kernels that are built IF the architecture allows it.
5
6 %define buildup 1
7 %define builduml 0
8 %define buildxen 0
9 %define builddoc 0
10
11 # Versions of various parts
12
13 %define _with_netns 1
14
15 #
16 # Polite request for people who spin their own kernel rpms:
17 # please modify the "release" field in a way that identifies
18 # that the kernel isn't the stock distribution kernel, for example by
19 # adding some text to the end of the version number.
20 #
21 %define sublevel 22
22 %define patchlevel 14
23 %define kversion 2.6.%{sublevel}
24 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
25
26 %define vsversion 2.3.0.29
27
28 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
29 # updated every time the PL kernel is updated.
30 %define vini_pl_patch 561
31
32 %define specrelease 1
33
34 %define release vs%{vsversion}.%{specrelease}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
35
36 %{!?pldistro:%global pldistro planetlab}
37
38 %define signmodules 0
39 %define make_target bzImage
40 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
41
42 # Override generic defaults with per-arch defaults
43
44 %define image_install_path boot
45
46 #
47 # Three sets of minimum package version requirements in the form of Conflicts:
48 # to versions below the minimum
49 #
50
51 #
52 # First the general kernel 2.6 required versions as per
53 # Documentation/Changes
54 #
55 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
56
57
58 # Then a series of requirements that are distribution specific, either 
59 # because we add patches for something, or the older versions have 
60 # problems with the newer kernel or lack certain things that make 
61 # integration in the distro harder than needed.
62 #
63 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
64
65 #
66 # Several packages had bugs in them that became obvious when the NPTL
67 # threading code got integrated.
68 #
69 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
70
71 #
72 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
73 #
74
75 # MEF commented out
76 # %define xen_conflicts glibc < 2.3.5-1
77
78 #
79 # Packages that need to be installed before the kernel is, because the %post
80 # scripts use them.
81 #
82 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
83
84 URL: http://svn.planet-lab.org/wiki/linux-2.6
85
86 Name: kernel
87 Group: System Environment/Kernel
88 License: GPLv2
89 Version: %{rpmversion}
90 Release: %{release}
91 ExclusiveOS: Linux
92 Provides: kernel = %{version}
93 Provides: kernel-drm = 4.3.0
94 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
95 Provides: kernel-smp = %{rpmversion}-%{release}
96 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
97 Prereq: %{kernel_prereq}
98 Conflicts: %{kernel_dot_org_conflicts}
99 Conflicts: %{package_conflicts}
100 Conflicts: %{nptl_conflicts}
101 # We can't let RPM do the dependencies automatic because it'll then pick up
102 # a correct but undesirable perl dependency from the module headers which
103 # isn't required for the kernel proper to function
104 AutoReqProv: no
105
106 #
107 # List the packages used during the kernel build
108 #
109 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
110 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
111 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
112 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
113
114
115 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
116
117 Source10: kernel-%{kversion}-i586-%{pldistro}.config
118 Source11: kernel-%{kversion}-i686-%{pldistro}.config
119 Source12: kernel-%{kversion}-x86_64-%{pldistro}.config
120 %if %{builduml}
121 Source20: kernel-%{kversion}-i686-uml-%{pldidstro}.config
122 %endif
123 %if %{buildxen}
124 Source30: kernel-%{kversion}-i686-xenU-%{pldistro}.config
125 %endif
126
127 # Mainline patches
128 %if "0%{patchlevel}"
129 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
130 %endif
131
132 Patch010: linux-2.6-010-e1000e.patch
133 Patch020: linux-2.6-020-build-id.patch
134 Patch030: linux-2.6-030-netns.patch
135
136 # These are patches picked up from Fedora/RHEL
137 Patch100: linux-2.6-100-build-nonintconfig.patch
138
139 # Linux-VServer
140 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
141
142 # IP sets
143 Patch250: linux-2.6-250-ipsets.patch
144
145 # PlanetLab
146 Patch500: linux-2.6-500-vserver-filesharing.patch
147 Patch510: linux-2.6-510-ipod.patch
148 Patch520: linux-2.6-520-vnet+.patch
149 Patch530: linux-2.6-530-built-by-support.patch
150 Patch540: linux-2.6-540-oom-kill.patch
151 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
152 Patch560: linux-2.6-560-mmconf.patch
153 Patch570: linux-2.6-570-tagxid.patch
154 Patch590: linux-2.6-590-trellis-mm1-netns.patch
155 Patch591: linux-2.6-591-unshare-netns.patch
156 Patch592: linux-2.6-592-ztun-sb.patch
157 Patch593: linux-2.6-593-egre.patch
158 Patch594: linux-2.6-594-new_ns_pid.patch
159 Patch595: linux-2.6-595-vserver-new-netns.patch
160 Patch596: linux-2.6-596-debug.patch
161 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
162
163 %description
164 The kernel package contains the Linux kernel (vmlinuz), the core of any
165 Linux operating system.  The kernel handles the basic functions
166 of the operating system:  memory allocation, process allocation, device
167 input and output, etc.
168
169 %package devel
170 Summary: Development package for building kernel modules to match the kernel.
171 Group: System Environment/Kernel
172 AutoReqProv: no
173 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
174 Provides: kernel-smp-devel = %{rpmversion}-%{release}
175 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
176 Prereq: /usr/bin/find
177
178 %description devel
179 This package provides kernel headers and makefiles sufficient to build modules
180 against the kernel package.
181
182
183 %package doc
184 Summary: Various documentation bits found in the kernel source.
185 Group: Documentation
186
187 %description doc
188 This package contains documentation files from the kernel
189 source. Various bits of information about the Linux kernel and the
190 device drivers shipped with it are documented in these files.
191
192 You'll want to install this package if you need a reference to the
193 options that can be passed to Linux kernel modules at load time.
194
195 %package xenU
196 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
197
198 Group: System Environment/Kernel
199 Provides: kernel = %{version}
200 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
201 Prereq: %{kernel_prereq}
202 Conflicts: %{kernel_dot_org_conflicts}
203 Conflicts: %{package_conflicts}
204 Conflicts: %{nptl_conflicts}
205
206 # MEF commented out 
207 # Conflicts: %{xen_conflicts}
208
209 # We can't let RPM do the dependencies automatic because it'll then pick up
210 # a correct but undesirable perl dependency from the module headers which
211 # isn't required for the kernel proper to function
212 AutoReqProv: no
213
214 %description xenU
215 This package includes a version of the Linux kernel which
216 runs in Xen unprivileged guest VMs.  This should be installed
217 both inside the unprivileged guest (for the modules) and in
218 the guest0 domain.
219
220 %package xenU-devel
221 Summary: Development package for building kernel modules to match the kernel.
222 Group: System Environment/Kernel
223 AutoReqProv: no
224 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
225 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
226 Provides: kernel-devel = %{rpmversion}-%{release}xenU
227 Prereq: /usr/sbin/hardlink, /usr/bin/find
228
229 %description xenU-devel
230 This package provides kernel headers and makefiles sufficient to build modules
231 against the kernel package.
232
233 %package uml
234 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
235
236 Group: System Environment/Kernel
237
238 %description uml
239 This package includes a user mode version of the Linux kernel.
240
241 %package uml-devel
242 Summary: Development package for building kernel modules to match the UML kernel.
243 Group: System Environment/Kernel
244 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
245 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
246 Provides: kernel-devel = %{rpmversion}-%{release}smp
247 AutoReqProv: no
248 Prereq: /usr/sbin/hardlink, /usr/bin/find
249
250 %description uml-devel
251 This package provides kernel headers and makefiles sufficient to build modules
252 against the User Mode Linux kernel package.
253
254 %package uml-modules
255 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
256
257 Group: System Environment/Kernel
258
259 %description uml-modules
260 This package includes a user mode version of the Linux kernel modules.
261
262 %package vserver
263 Summary: A placeholder RPM that provides kernel and kernel-drm
264
265 Group: System Environment/Kernel
266 Provides: kernel = %{version}
267 Provides: kernel-drm = 4.3.0
268 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
269
270 %description vserver
271 VServers do not require and cannot use kernels, but some RPMs have
272 implicit or explicit dependencies on the "kernel" package
273 (e.g. tcpdump). This package installs no files but provides the
274 necessary dependencies to make rpm and yum happy.
275
276
277 %prep
278 # First we unpack the kernel tarball.
279 # If this isn't the first make prep, we use links to the existing clean tarball
280 # which speeds things up quite a bit.
281 if [ ! -d kernel-%{kversion}/vanilla ]; then
282   # Ok, first time we do a make prep.
283   rm -f pax_global_header
284 %setup -q -n %{name}-%{kversion} -c
285   mv linux-%{kversion} vanilla
286 else
287   # We already have a vanilla dir.
288   cd kernel-%{kversion}
289 fi
290
291 KERNEL_PREVIOUS=vanilla
292 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
293 %define ApplyPatch() \
294   rm -fr linux-%{kversion}-%1                           \
295   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
296   patchflag=-p1                                         \
297   test "%2" != "%%2" && patchflag="%2"                  \
298   PATCH="%{expand:%{PATCH%1}}"                          \
299   if test ! -e "$PATCH"; then                           \
300     echo "Patch %1 does not exist!"                     \
301     exit 1                                              \
302   fi                                                    \
303   case "$PATCH" in                                      \
304     *.bz2)  bzcat "$PATCH";;                            \
305     *.gz)   zcat "$PATCH";;                             \
306     *)      cat "$PATCH";;                              \
307   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
308   KERNEL_PREVIOUS=linux-%{kversion}-%1
309
310 # This is where the patches get applied
311 %if "0%{patchlevel}"
312 %ApplyPatch 0
313 %endif
314
315 %ApplyPatch 10
316 %ApplyPatch 20
317
318 %ApplyPatch 100
319
320 %ApplyPatch 200
321
322 %ApplyPatch 250
323
324 %ApplyPatch 500
325 %ApplyPatch 510
326 %ApplyPatch 520
327 %ApplyPatch 530
328 %ApplyPatch 540
329 %ApplyPatch 550
330 %ApplyPatch 560
331 %ApplyPatch 570
332
333
334 %if 0%{?_with_netns}
335 %ApplyPatch 590
336 %ApplyPatch 591
337 %ApplyPatch 592
338 %ApplyPatch 593
339 %ApplyPatch 594
340 %ApplyPatch 595
341 %ApplyPatch 596
342 %endif
343
344 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
345 # break with later patches.
346
347 rm -fr linux-%{kversion}
348 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
349 cd linux-%{kversion}
350
351
352 # make sure the kernel has the sublevel we know it has. This looks weird
353 # but for -pre and -rc versions we need it since we only want to use
354 # the higher version when the final kernel is released.
355 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
356 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
357
358 # get rid of unwanted files resulting from patch fuzz
359 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
360
361
362 ###
363 ### build
364 ###
365 %build
366
367 BuildKernel() {
368     MakeTarget=$1
369     Arch=$2
370     Flavour=$3
371
372     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
373     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
374     cd linux-%{_target_cpu}-%{kversion}$Flavour
375
376     # Pick the right config file for the kernel we're building
377     if [ -n "$Flavour" ] ; then
378       Config=kernel-%{kversion}-%{_target_cpu}-$Flavour-%{pldistro}.config
379       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
380       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
381     else
382       Config=kernel-%{kversion}-%{_target_cpu}-%{pldistro}.config
383       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
384       DevelLink=
385     fi
386
387     KernelVer=%{version}-%{release}$Flavour
388     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
389
390     # make sure EXTRAVERSION says what we want it to say
391     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
392
393     # and now to start the build process
394
395     make -s mrproper
396     cp %{_sourcedir}/$Config .config
397
398     #Arch=`head -1 .config | cut -b 3-`
399     echo USING ARCH=$Arch
400
401     make -s ARCH=$Arch nonint_oldconfig > /dev/null
402     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
403     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
404
405     # Start installing the results
406
407 %if "%{_enable_debug_packages}" == "1"
408     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
409 %endif
410     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
411     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
412     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
413     if [ -f arch/$Arch/boot/bzImage ]; then
414       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
415     fi
416     if [ -f arch/$Arch/boot/zImage.stub ]; then
417       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
418     fi
419     if [ "$Flavour" = "uml" ] ; then
420         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
421     fi
422
423     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
424     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
425
426     # And save the headers/makefiles etc for building modules against
427     #
428     # This all looks scary, but the end result is supposed to be:
429     # * all arch relevant include/ files
430     # * all Makefile/Kconfig files
431     # * all script/ files
432
433     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
434     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
435     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
436     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
437     # dirs for additional modules per module-init-tools, kbuild/modules.txt
438     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
439     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
440     # first copy everything
441     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
442         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
443     if [ "$Flavour" = "uml" ] ; then
444       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
445     fi
446     # then drop all but the needed Makefiles/Kconfig files
447     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
448     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
449     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
450     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
451     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
452     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
453     if [ -d arch/%{_arch}/scripts ]; then
454       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
455     fi
456     if [ -f arch/%{_arch}/*lds ]; then
457       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
458     fi
459     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
460     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
461     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
462     cd include
463     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
464     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
465     if [ "$Arch" = "x86_64" ]; then
466       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
467     fi
468 %if %{buildxen}
469     if [ "$Flavour" = "xenU" ]; then
470       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
471       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
472     fi
473 %endif
474 %if %{builduml}
475     if [ "$Flavour" = "uml" ] ; then
476       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
477     fi
478 %endif
479     # While arch/powerpc/include/asm is still a symlink to the old
480     # include/asm-ppc{64,} directory, include that in kernel-devel too.
481     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
482       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
483       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
484       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
485       ln -sf ../../../include/asm-ppc* asm
486       popd
487     fi
488
489     # Make sure the Makefile and version.h have a matching timestamp so that
490     # external modules can be built
491     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
492     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
493     cd ..
494
495     #
496     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
497     #
498 %if "%{_enable_debug_packages}" == "1"
499     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
500     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
501 %endif
502 %if %{buildxen}
503     if [ -f vmlinuz ]; then
504       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
505     fi
506 %endif
507
508     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
509
510     # mark modules executable so that strip-to-file can strip them
511     cat modnames | xargs chmod u+x
512
513     # remove files that will be auto generated by depmod at rpm -i time
514     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
515
516     # Move the devel headers out of the root file system
517     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
518     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
519     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
520     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
521 }
522
523 ###
524 # DO it...
525 ###
526
527 # prepare directories
528 rm -rf $RPM_BUILD_ROOT
529 mkdir -p $RPM_BUILD_ROOT/boot
530
531 %if "%{_target_cpu}" == "x86_64"
532 %define kernel_arch %{_target_cpu}
533 %endif
534 %if "%{_target_cpu}" == "i586"
535 %define kernel_arch i386
536 %endif
537 %if "%{_target_cpu}" == "i686"
538 %define kernel_arch i386
539 %endif
540
541 %if %{buildup}
542 BuildKernel %make_target %kernel_arch
543 %endif
544
545 %ifarch i686
546 %if %{builduml}
547 BuildKernel linux um uml
548 %endif
549
550 %if %{buildxen}
551 BuildKernel vmlinuz %kernel_arch xenU
552 %endif
553 %endif
554
555 ###
556 ### install
557 ###
558
559 %install
560
561 cd vanilla
562
563 %if %{buildxen} && "%{_target_cpu}" == "i686"
564 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
565 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
566 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
567 # This directive teaches ldconfig to search in nosegneg subdirectories
568 # and cache the DSOs there with extra bit 0 set in their hwcap match
569 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
570 # search in nosegneg subdirectories and to match this extra hwcap bit
571 # in the ld.so.cache file.
572 hwcap 0 nosegneg
573 EOF
574 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
575 %endif
576
577 %if %{builddoc}
578 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
579
580 # sometimes non-world-readable files sneak into the kernel source tree
581 chmod -R a+r *
582 # copy the source over
583 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
584 %endif
585
586 ###
587 ### clean
588 ###
589
590 %clean
591 rm -rf $RPM_BUILD_ROOT
592
593 ###
594 ### scripts
595 ###
596
597 # load the loop module for upgrades...in case the old modules get removed we have
598 # loopback in the kernel so that mkinitrd will work.
599 %pre
600 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
601 exit 0
602
603 %post
604 if [ -f /etc/sysconfig/kernel ]; then
605   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
606 fi
607
608 # trick mkinitrd in case the current environment does not have device mapper
609 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
610 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
611     if [ ! -f $rootdev ]; then
612         fake_root_lvm=1
613         mkdir -p $(dirname $rootdev)
614         touch $rootdev
615     fi
616 fi
617
618 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
619 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
620 # Older modutils do not support --package option
621 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
622
623 # remove fake handle
624 if [ -n "$fake_root_lvm" ]; then
625     rm -f $rootdev
626 fi
627
628 # make some useful links
629 pushd /boot > /dev/null ; {
630         ln -sf config-%{KVERREL} config
631         ln -sf config-%{KVERREL} configsmp
632         ln -sf initrd-%{KVERREL}.img initrd-boot
633         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
634         ln -sf vmlinuz-%{KVERREL} kernel-boot
635         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
636 }
637 popd > /dev/null
638
639 # ask for a reboot
640 mkdir -p /etc/planetlab
641 touch /etc/planetlab/update-reboot
642
643 %post devel
644 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
645 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
646   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
647   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
648   popd > /dev/null
649 fi
650
651 %post xenU
652 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
653 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
654
655 %post xenU-devel
656 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
657 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
658   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
659   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
660   popd > /dev/null
661 fi
662
663 %post uml-modules
664 depmod -ae %{KVERREL}uml
665
666 %preun
667 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
668 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
669
670 %preun xenU
671 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
672 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
673
674 %preun uml-modules
675 rm -f /lib/modules/%{KVERREL}uml/modules.*
676
677
678 ###
679 ### file lists
680 ###
681
682 %if %{buildup}
683 %files 
684 %defattr(-,root,root)
685 /%{image_install_path}/vmlinuz-%{KVERREL}
686 /boot/System.map-%{KVERREL}
687 /boot/config-%{KVERREL}
688 %dir /lib/modules/%{KVERREL}
689 /lib/modules/%{KVERREL}/kernel
690 /lib/modules/%{KVERREL}/build
691 /lib/modules/%{KVERREL}/source
692 /lib/modules/%{KVERREL}/extra
693 /lib/modules/%{KVERREL}/updates
694
695 %files devel
696 %defattr(-,root,root)
697 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
698 %endif
699
700 %if %{builduml} && "%{_target_cpu}" == "i686"
701 %files uml
702 %defattr(-,root,root)
703 %{_bindir}/linux
704
705 %files uml-devel
706 %defattr(-,root,root)
707 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
708 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
709
710 %files uml-modules
711 %defattr(-,root,root)
712 /boot/System.map-%{KVERREL}uml
713 /boot/config-%{KVERREL}uml
714 %dir /lib/modules/%{KVERREL}uml
715 /lib/modules/%{KVERREL}uml/kernel
716 /lib/modules/%{KVERREL}uml/build
717 /lib/modules/%{KVERREL}uml/source
718 /lib/modules/%{KVERREL}uml/extra
719 /lib/modules/%{KVERREL}uml/updates
720 %endif
721
722 %if %{buildxen} && "%{_target_cpu}" == "i686"
723 %files xenU
724 %defattr(-,root,root)
725 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
726 /boot/System.map-%{KVERREL}xenU
727 /boot/config-%{KVERREL}xenU
728 %dir /lib/modules/%{KVERREL}xenU
729 /lib/modules/%{KVERREL}xenU/kernel
730 /lib/modules/%{KVERREL}xenU/build
731 /lib/modules/%{KVERREL}xenU/source
732 /lib/modules/%{KVERREL}xenU/extra
733 /lib/modules/%{KVERREL}xenU/updates
734 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
735
736 %files xenU-devel
737 %defattr(-,root,root)
738 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
739 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
740 %endif
741
742 %files vserver
743 %defattr(-,root,root)
744 # no files
745
746 # only some architecture builds need kernel-doc
747
748 %if %{builddoc}
749 %files doc
750 %defattr(-,root,root)
751 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
752 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
753 %dir %{_datadir}/doc/kernel-doc-%{kversion}
754 %endif
755
756 %changelog
757 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
758 - 2.6.17.4
759 - Disable split pagetable lock.
760
761 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
762 - Get rid of stack backtrace on panic, which in most
763   cases actually caused a loss of info instead of a gain.
764
765 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
766 - 2.6.17.3
767
768 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
769 - 2.6.17.2
770 - Fix up the alsa list_add bug.
771
772 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
773 - Fix up various stupidities incurred by the last big rebase.
774   - Reenable SMP x86-64 builds.
775   - Reenable SMBFS.
776 - Enable PCI fake hotplug driver.
777 - Enable gameport/joystick on i586 builds. (#196581)
778
779 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
780 - Enable profiling for 586 kernels.
781
782 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
783 - Rebuild with slab debug off.
784
785 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
786 - 2.6.17.1
787
788 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
789 - 2.6.16.20
790
791 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
792 - 2.6.16.19
793
794 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
795 - Improved list_head debugging.
796
797 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
798 - 2.6.16.18
799
800 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
801 - 2.6.16.17
802
803 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
804 - 2.6.16.16
805
806 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
807 - 2.6.16.15
808 - make 16C950 UARTs work (again). (#126403)
809 - Fix exec-shield default, which should fix a few programs that
810   stopped running.
811
812 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
813 - 2.6.16.14
814
815 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
816 - 2.6.16.13
817
818 * Mon May  1 2006 Dave Jones <davej@redhat.com>
819 - 2.6.16.12
820
821 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
822 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
823
824 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
825 - 2.6.16.11
826
827 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
828 - Enable PCI MSI support.
829
830 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
831 - 2.6.16.9
832
833 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
834 - 2.6.16.7
835
836 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
837 - 2.6.16.6
838
839 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
840 - 2.6.16.5
841
842 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
843 - 2.6.16.2
844
845 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
846 - Reenable non-standard serial ports. (#187466)
847 - Reenable snd-es18xx for x86-32 (#187733)
848
849 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
850 - ship the .kernelrelease file in -devel too.
851 - Disable EDAC debug.
852
853 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
854 - 2.6.16.1
855
856 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
857 - Include patches posted for review for inclusion in 2.6.16.1
858 - Updated new audit msg types.
859 - Reenable HDLC driver (#186257)
860 - Make acpi-cpufreq 'sticky'
861 - Fix broken x86-64 32bit vDSO (#186924)
862
863 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
864 - Improve spinlock scalability on big machines.
865
866 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
867 - Sync with FC5's 2.6.16 kernel.
868 - Update Tux & Exec-shield to latest.
869