Add hack to workaround "audit_log_user_command(): Connection refused" from sudo.
[linux-2.6.git] / kernel-2.6.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 Summary: The Linux kernel (the core of the Linux operating system)
7
8 # What parts do we want to build?  We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
10
11 %define buildup 1
12 %define builduml 0
13 %define buildxen 0
14 %define builddoc 0
15
16 # default is to not build this - to override, use something like
17 # kernel-SPECVARS := iwlwifi=1 
18 # rpm does not seem to have a syntax for defining overridable defaults
19 # any better solution would be more than welcome.
20 %define build_iwlwifi %{?iwlwifi:1}%{!?iwlwifi:0}
21
22 # Versions of various parts
23
24 # for module-tag.py - sublevel is used for the version (middle) part of tag names
25 %define name linux-2.6
26 %define module_version_varname sublevel
27 %define taglevel 3
28
29 #
30 # Polite request for people who spin their own kernel rpms:
31 # please modify the "release" field in a way that identifies
32 # that the kernel isn't the stock distribution kernel, for example by
33 # adding some text to the end of the version number.
34 #
35 %define sublevel 22
36 %define patchlevel 19
37 %define kversion 2.6.%{sublevel}
38 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
39
40 %define vsversion 2.3.0.34
41
42 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
43 # updated every time the PL kernel is updated.
44 %define vini_pl_patch 561
45
46 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
47
48 %{!?pldistro:%global pldistro planetlab}
49
50 %define signmodules 0
51 %define make_target bzImage
52 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
53
54 # Override generic defaults with per-arch defaults
55
56 %define image_install_path boot
57
58 #
59 # Three sets of minimum package version requirements in the form of Conflicts:
60 # to versions below the minimum
61 #
62
63 #
64 # First the general kernel 2.6 required versions as per
65 # Documentation/Changes
66 #
67 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
68
69
70 # Then a series of requirements that are distribution specific, either 
71 # because we add patches for something, or the older versions have 
72 # problems with the newer kernel or lack certain things that make 
73 # integration in the distro harder than needed.
74 #
75 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
76
77 #
78 # Several packages had bugs in them that became obvious when the NPTL
79 # threading code got integrated.
80 #
81 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
82
83 #
84 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
85 #
86
87 # MEF commented out
88 # %define xen_conflicts glibc < 2.3.5-1
89
90 #
91 # Packages that need to be installed before the kernel is, because the %post
92 # scripts use them.
93 #
94 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
95
96 Vendor: PlanetLab
97 Packager: PlanetLab Central <support@planet-lab.org>
98 Distribution: PlanetLab %{plrelease}
99 URL: %(echo %{url} | cut -d ' ' -f 2)
100
101 Name: kernel
102 Group: System Environment/Kernel
103 License: GPLv2
104 Version: %{rpmversion}
105 Release: %{release}
106 ExclusiveOS: Linux
107 Provides: kernel = %{version}
108 Provides: kernel-drm = 4.3.0
109 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
110 Provides: kernel-smp = %{rpmversion}-%{release}
111 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
112 Prereq: %{kernel_prereq}
113 Conflicts: %{kernel_dot_org_conflicts}
114 Conflicts: %{package_conflicts}
115 Conflicts: %{nptl_conflicts}
116 # We can't let RPM do the dependencies automatic because it'll then pick up
117 # a correct but undesirable perl dependency from the module headers which
118 # isn't required for the kernel proper to function
119 AutoReqProv: no
120
121 #
122 # List the packages used during the kernel build
123 #
124 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
125 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
126 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
127 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
128
129
130 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
131
132 Source10: %{pldistro}-%{kversion}-i586.config
133 Source11: %{pldistro}-%{kversion}-i686.config
134 Source12: %{pldistro}-%{kversion}-x86_64.config
135 %if %{builduml}
136 Source20: %{pldistro}-%{kversion}-i686-uml.config
137 %endif
138 %if %{buildxen}
139 Source30: %{pldistro}-%{kversion}-i686-xenU.config
140 %endif
141
142 # Mainline patches
143 %if "0%{patchlevel}"
144 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
145 %endif
146
147 Patch010: linux-2.6-010-e1000e.patch
148 Patch020: linux-2.6-020-build-id.patch
149 Patch030: linux-2.6-030-netns.patch
150 Patch040: linux-2.6-040-i_mutex-check.patch
151
152 # These are patches picked up from Fedora/RHEL
153 Patch100: linux-2.6-100-build-nonintconfig.patch
154
155 # Linux-VServer
156 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
157 Patch210: linux-2.6-210-vserver-cpu-sched.patch
158
159 # IP sets
160 Patch250: linux-2.6-250-ipsets.patch
161
162 # PlanetLab
163 Patch500: linux-2.6-500-vserver-filesharing.patch
164 Patch510: linux-2.6-510-ipod.patch
165 Patch520: linux-2.6-520-vnet+.patch
166 Patch530: linux-2.6-530-built-by-support.patch
167 Patch540: linux-2.6-540-oom-kill.patch
168 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
169 Patch560: linux-2.6-560-mmconf.patch
170 Patch570: linux-2.6-570-tagxid.patch
171 Patch580: linux-2.6-580-show-proc-virt.patch
172 Patch590: linux-2.6-590-chopstix-intern.patch
173 Patch620: linux-2.6-620-kdb.patch
174 Patch630: linux-2.6-630-sched-fix.patch
175 Patch640: linux-2.6-640-netlink-audit-hack.patch
176
177 # See also the file named 'sources' here for the related checksums
178 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
179 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
180 %if %{build_iwlwifi}
181 %define mac80211_version 10.0.4
182 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
183 %define iwlwifi_version 1.2.25
184 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
185 %endif
186
187 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
188
189 %description
190 The kernel package contains the Linux kernel (vmlinuz), the core of any
191 Linux operating system.  The kernel handles the basic functions
192 of the operating system:  memory allocation, process allocation, device
193 input and output, etc.
194
195 %package devel
196 Summary: Development package for building kernel modules to match the kernel.
197 Group: System Environment/Kernel
198 AutoReqProv: no
199 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
200 Provides: kernel-smp-devel = %{rpmversion}-%{release}
201 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
202 Prereq: /usr/bin/find
203
204 %description devel
205 This package provides kernel headers and makefiles sufficient to build modules
206 against the kernel package.
207
208
209 %package doc
210 Summary: Various documentation bits found in the kernel source.
211 Group: Documentation
212
213 %description doc
214 This package contains documentation files from the kernel
215 source. Various bits of information about the Linux kernel and the
216 device drivers shipped with it are documented in these files.
217
218 You'll want to install this package if you need a reference to the
219 options that can be passed to Linux kernel modules at load time.
220
221 %package xenU
222 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
223
224 Group: System Environment/Kernel
225 Provides: kernel = %{version}
226 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
227 Prereq: %{kernel_prereq}
228 Conflicts: %{kernel_dot_org_conflicts}
229 Conflicts: %{package_conflicts}
230 Conflicts: %{nptl_conflicts}
231
232 # MEF commented out 
233 # Conflicts: %{xen_conflicts}
234
235 # We can't let RPM do the dependencies automatic because it'll then pick up
236 # a correct but undesirable perl dependency from the module headers which
237 # isn't required for the kernel proper to function
238 AutoReqProv: no
239
240 %description xenU
241 This package includes a version of the Linux kernel which
242 runs in Xen unprivileged guest VMs.  This should be installed
243 both inside the unprivileged guest (for the modules) and in
244 the guest0 domain.
245
246 %package xenU-devel
247 Summary: Development package for building kernel modules to match the kernel.
248 Group: System Environment/Kernel
249 AutoReqProv: no
250 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
251 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
252 Provides: kernel-devel = %{rpmversion}-%{release}xenU
253 Prereq: /usr/sbin/hardlink, /usr/bin/find
254
255 %description xenU-devel
256 This package provides kernel headers and makefiles sufficient to build modules
257 against the kernel package.
258
259 %package uml
260 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
261
262 Group: System Environment/Kernel
263
264 %description uml
265 This package includes a user mode version of the Linux kernel.
266
267 %package uml-devel
268 Summary: Development package for building kernel modules to match the UML kernel.
269 Group: System Environment/Kernel
270 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
271 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
272 Provides: kernel-devel = %{rpmversion}-%{release}smp
273 AutoReqProv: no
274 Prereq: /usr/sbin/hardlink, /usr/bin/find
275
276 %description uml-devel
277 This package provides kernel headers and makefiles sufficient to build modules
278 against the User Mode Linux kernel package.
279
280 %package uml-modules
281 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
282
283 Group: System Environment/Kernel
284
285 %description uml-modules
286 This package includes a user mode version of the Linux kernel modules.
287
288 %package vserver
289 Summary: A placeholder RPM that provides kernel and kernel-drm
290
291 Group: System Environment/Kernel
292 Provides: kernel = %{version}
293 Provides: kernel-drm = 4.3.0
294 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
295
296 %description vserver
297 VServers do not require and cannot use kernels, but some RPMs have
298 implicit or explicit dependencies on the "kernel" package
299 (e.g. tcpdump). This package installs no files but provides the
300 necessary dependencies to make rpm and yum happy.
301
302
303 %prep
304 # First we unpack the kernel tarball.
305 # If this isn't the first make prep, we use links to the existing clean tarball
306 # which speeds things up quite a bit.
307 if [ ! -d kernel-%{kversion}/vanilla ]; then
308   # Ok, first time we do a make prep.
309   rm -f pax_global_header
310 %setup -q -n %{name}-%{kversion} -c
311   mv linux-%{kversion} vanilla
312 else
313   # We already have a vanilla dir.
314   cd kernel-%{kversion}
315 fi
316
317 KERNEL_PREVIOUS=vanilla
318 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
319 %define ApplyPatch() \
320   rm -fr linux-%{kversion}-%1                           \
321   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
322   patchflag=-p1                                         \
323   test "%2" != "%%2" && patchflag="%2"                  \
324   PATCH="%{expand:%{PATCH%1}}"                          \
325   if test ! -e "$PATCH"; then                           \
326     echo "Patch %1 does not exist!"                     \
327     exit 1                                              \
328   fi                                                    \
329   case "$PATCH" in                                      \
330     *.bz2)  bzcat "$PATCH";;                            \
331     *.gz)   zcat "$PATCH";;                             \
332     *)      cat "$PATCH";;                              \
333   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
334   KERNEL_PREVIOUS=linux-%{kversion}-%1
335
336 # This is where the patches get applied
337 %if 0%{?patchlevel}
338 %ApplyPatch 0
339 %endif
340
341 %ApplyPatch 10
342 %ApplyPatch 20
343
344 # NetNS patch for VINI
345 %if 0%{?with_netns}
346 %ApplyPatch 30
347 %endif
348 %ApplyPatch 40
349
350 %ApplyPatch 100
351
352 %ApplyPatch 200
353 %ApplyPatch 210
354
355 %ApplyPatch 250
356
357 %ApplyPatch 500
358 %ApplyPatch 510
359 %ApplyPatch 520
360 %ApplyPatch 530
361 %ApplyPatch 540
362 %ApplyPatch 550
363 %ApplyPatch 560
364 %ApplyPatch 570
365 %ApplyPatch 580
366 %ApplyPatch 590
367 %ApplyPatch 620
368 %ApplyPatch 630
369
370 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
371 # break with later patches.
372
373 %if 0%{?with_netns}
374 %ApplyPatch %vini_pl_patch
375 %endif
376
377 %if %{build_iwlwifi}
378 # Run the mac80211 stuff in the kernel tree holding the last patch
379 tar -xzf %{PATCH600}
380 pushd mac80211-%{mac80211_version}
381 mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
382 make $mac80211_makeflags modified
383 make $mac80211_makeflags source
384 make $mac80211_makeflags patch_kernel
385 popd
386
387 # Untar iwlwifi in the same place - needs to be compiled later
388 tar -xzf %{PATCH601}
389 # the install target is broken: first it does not pass the right -b flag to depmod
390 # second we do not need to invoke depmod at this stage anyway
391 # let's add our own patch/stuff in this Makefile for manual install later on
392 pushd iwlwifi-%{iwlwifi_version}
393 cat >> Makefile <<EOF
394 module-list:
395         @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
396 EOF
397 popd
398 %endif
399
400 rm -fr linux-%{kversion}
401 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
402 cd linux-%{kversion}
403
404
405 # make sure the kernel has the sublevel we know it has. This looks weird
406 # but for -pre and -rc versions we need it since we only want to use
407 # the higher version when the final kernel is released.
408 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
409 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
410
411 # get rid of unwanted files resulting from patch fuzz
412 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
413
414
415 ###
416 ### build
417 ###
418 %build
419
420 BuildKernel() {
421     MakeTarget=$1
422     Arch=$2
423     Flavour=$3
424
425     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
426     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
427     cd linux-%{_target_cpu}-%{kversion}$Flavour
428
429     # Pick the right config file for the kernel we're building
430     if [ -n "$Flavour" ] ; then
431       Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
432       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
433       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
434     else
435       Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
436       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
437       DevelLink=
438     fi
439
440     KernelVer=%{version}-%{release}$Flavour
441     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
442
443     # make sure EXTRAVERSION says what we want it to say
444     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
445
446     # and now to start the build process
447
448     make -s mrproper
449     cp %{_sourcedir}/$Config .config
450
451     #Arch=`head -1 .config | cut -b 3-`
452     echo USING ARCH=$Arch
453
454     make -s ARCH=$Arch nonint_oldconfig > /dev/null
455     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
456     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
457
458 %if %{build_iwlwifi}
459     # build the iwlwifi driver
460     make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
461       KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
462 %endif
463
464     # Start installing the results
465
466 %if "%{_enable_debug_packages}" == "1"
467     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
468 %endif
469     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
470     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
471     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
472     if [ -f arch/$Arch/boot/bzImage ]; then
473       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
474     fi
475     if [ -f arch/$Arch/boot/zImage.stub ]; then
476       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
477     fi
478     if [ "$Flavour" = "uml" ] ; then
479         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
480     fi
481
482     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
483     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
484
485 %if %{build_iwlwifi}
486     # install iwlwifi
487 #    make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
488 #         KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
489 #        KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
490     pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
491     iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
492     # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
493     iwlwifi_modules=$(make --no-print-directory module-list)
494     install -d $iwlwifi_dest
495     install -m 644 -c $iwlwifi_modules $iwlwifi_dest
496     popd
497 %endif
498
499     # And save the headers/makefiles etc for building modules against
500     #
501     # This all looks scary, but the end result is supposed to be:
502     # * all arch relevant include/ files
503     # * all Makefile/Kconfig files
504     # * all script/ files
505
506     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
507     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
508     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
509     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
510     # dirs for additional modules per module-init-tools, kbuild/modules.txt
511     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
512     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
513     # first copy everything
514     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
515         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
516     if [ "$Flavour" = "uml" ] ; then
517       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
518     fi
519     # then drop all but the needed Makefiles/Kconfig files
520     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
521     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
522     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
523     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
524     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
525     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
526     if [ -d arch/%{_arch}/scripts ]; then
527       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
528     fi
529     if [ -f arch/%{_arch}/*lds ]; then
530       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
531     fi
532     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
533     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
534     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
535     cd include
536     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
537     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
538     if [ "$Arch" = "x86_64" ]; then
539       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
540     fi
541 %if %{buildxen}
542     if [ "$Flavour" = "xenU" ]; then
543       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
544       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
545     fi
546 %endif
547 %if %{builduml}
548     if [ "$Flavour" = "uml" ] ; then
549       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
550     fi
551 %endif
552     # While arch/powerpc/include/asm is still a symlink to the old
553     # include/asm-ppc{64,} directory, include that in kernel-devel too.
554     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
555       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
556       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
557       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
558       ln -sf ../../../include/asm-ppc* asm
559       popd
560     fi
561
562     # Make sure the Makefile and version.h have a matching timestamp so that
563     # external modules can be built
564     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
565     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
566     cd ..
567
568     #
569     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
570     #
571 %if "%{_enable_debug_packages}" == "1"
572     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
573     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
574 %endif
575 %if %{buildxen}
576     if [ -f vmlinuz ]; then
577       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
578     fi
579 %endif
580
581     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
582
583     # mark modules executable so that strip-to-file can strip them
584     cat modnames | xargs chmod u+x
585
586     # remove files that will be auto generated by depmod at rpm -i time
587     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
588
589     # Move the devel headers out of the root file system
590     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
591     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
592     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
593     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
594 }
595
596 ###
597 # DO it...
598 ###
599
600 # prepare directories
601 rm -rf $RPM_BUILD_ROOT
602 mkdir -p $RPM_BUILD_ROOT/boot
603
604 %if "%{_target_cpu}" == "x86_64"
605 %define kernel_arch %{_target_cpu}
606 %endif
607 %if "%{_target_cpu}" == "i586"
608 %define kernel_arch i386
609 %endif
610 %if "%{_target_cpu}" == "i686"
611 %define kernel_arch i386
612 %endif
613
614 %if %{buildup}
615 BuildKernel %make_target %kernel_arch
616 %endif
617
618 %ifarch i686
619 %if %{builduml}
620 BuildKernel linux um uml
621 %endif
622
623 %if %{buildxen}
624 BuildKernel vmlinuz %kernel_arch xenU
625 %endif
626 %endif
627
628 ###
629 ### install
630 ###
631
632 %install
633
634 cd vanilla
635
636 %if %{buildxen} && "%{_target_cpu}" == "i686"
637 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
638 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
639 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
640 # This directive teaches ldconfig to search in nosegneg subdirectories
641 # and cache the DSOs there with extra bit 0 set in their hwcap match
642 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
643 # search in nosegneg subdirectories and to match this extra hwcap bit
644 # in the ld.so.cache file.
645 hwcap 0 nosegneg
646 EOF
647 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
648 %endif
649
650 %if %{builddoc}
651 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
652
653 # sometimes non-world-readable files sneak into the kernel source tree
654 chmod -R a+r *
655 # copy the source over
656 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
657 %endif
658
659 ###
660 ### clean
661 ###
662
663 %clean
664 rm -rf $RPM_BUILD_ROOT
665
666 ###
667 ### scripts
668 ###
669
670 # load the loop module for upgrades...in case the old modules get removed we have
671 # loopback in the kernel so that mkinitrd will work.
672 %pre
673 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
674 exit 0
675
676 %post
677 if [ -f /etc/sysconfig/kernel ]; then
678   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
679 fi
680
681 # trick mkinitrd in case the current environment does not have device mapper
682 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
683 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
684     if [ ! -f $rootdev ]; then
685         fake_root_lvm=1
686         mkdir -p $(dirname $rootdev)
687         touch $rootdev
688     fi
689 fi
690
691 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
692 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
693 # Older modutils do not support --package option
694 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
695
696 # remove fake handle
697 if [ -n "$fake_root_lvm" ]; then
698     rm -f $rootdev
699 fi
700
701 # make some useful links
702 pushd /boot > /dev/null ; {
703         ln -sf config-%{KVERREL} config
704         ln -sf config-%{KVERREL} configsmp
705         ln -sf initrd-%{KVERREL}.img initrd-boot
706         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
707         ln -sf vmlinuz-%{KVERREL} kernel-boot
708         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
709 }
710 popd > /dev/null
711
712 # ask for a reboot
713 mkdir -p /etc/planetlab
714 touch /etc/planetlab/update-reboot
715
716 %post devel
717 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
718 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
719   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
720   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
721   popd > /dev/null
722 fi
723
724 %post xenU
725 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
726 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
727
728 %post xenU-devel
729 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
730 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
731   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
732   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
733   popd > /dev/null
734 fi
735
736 %post uml-modules
737 depmod -ae %{KVERREL}uml
738
739 %preun
740 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
741 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
742
743 %preun xenU
744 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
745 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
746
747 %preun uml-modules
748 rm -f /lib/modules/%{KVERREL}uml/modules.*
749
750
751 ###
752 ### file lists
753 ###
754
755 %if %{buildup}
756 %files 
757 %defattr(-,root,root)
758 /%{image_install_path}/vmlinuz-%{KVERREL}
759 /boot/System.map-%{KVERREL}
760 /boot/config-%{KVERREL}
761 %dir /lib/modules/%{KVERREL}
762 /lib/modules/%{KVERREL}/kernel
763 /lib/modules/%{KVERREL}/build
764 /lib/modules/%{KVERREL}/source
765 /lib/modules/%{KVERREL}/extra
766 /lib/modules/%{KVERREL}/updates
767
768 %files devel
769 %defattr(-,root,root)
770 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
771 %endif
772
773 %if %{builduml} && "%{_target_cpu}" == "i686"
774 %files uml
775 %defattr(-,root,root)
776 %{_bindir}/linux
777
778 %files uml-devel
779 %defattr(-,root,root)
780 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
781 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
782
783 %files uml-modules
784 %defattr(-,root,root)
785 /boot/System.map-%{KVERREL}uml
786 /boot/config-%{KVERREL}uml
787 %dir /lib/modules/%{KVERREL}uml
788 /lib/modules/%{KVERREL}uml/kernel
789 /lib/modules/%{KVERREL}uml/build
790 /lib/modules/%{KVERREL}uml/source
791 /lib/modules/%{KVERREL}uml/extra
792 /lib/modules/%{KVERREL}uml/updates
793 %endif
794
795 %if %{buildxen} && "%{_target_cpu}" == "i686"
796 %files xenU
797 %defattr(-,root,root)
798 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
799 /boot/System.map-%{KVERREL}xenU
800 /boot/config-%{KVERREL}xenU
801 %dir /lib/modules/%{KVERREL}xenU
802 /lib/modules/%{KVERREL}xenU/kernel
803 /lib/modules/%{KVERREL}xenU/build
804 /lib/modules/%{KVERREL}xenU/source
805 /lib/modules/%{KVERREL}xenU/extra
806 /lib/modules/%{KVERREL}xenU/updates
807 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
808
809 %files xenU-devel
810 %defattr(-,root,root)
811 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
812 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
813 %endif
814
815 %files vserver
816 %defattr(-,root,root)
817 # no files
818
819 # only some architecture builds need kernel-doc
820
821 %if %{builddoc}
822 %files doc
823 %defattr(-,root,root)
824 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
825 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
826 %dir %{_datadir}/doc/kernel-doc-%{kversion}
827 %endif
828
829 %changelog
830 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-3
831 - Fix bug with looping in schedule()
832
833 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-2
834 - Includes changes from Sapan/Andy regarding the scheduler and vnet bugs.
835 - Should be safe to try a second deployment.
836
837
838 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
839 - 2.6.17.4
840 - Disable split pagetable lock.
841
842 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
843 - Get rid of stack backtrace on panic, which in most
844   cases actually caused a loss of info instead of a gain.
845
846 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
847 - 2.6.17.3
848
849 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
850 - 2.6.17.2
851 - Fix up the alsa list_add bug.
852
853 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
854 - Fix up various stupidities incurred by the last big rebase.
855   - Reenable SMP x86-64 builds.
856   - Reenable SMBFS.
857 - Enable PCI fake hotplug driver.
858 - Enable gameport/joystick on i586 builds. (#196581)
859
860 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
861 - Enable profiling for 586 kernels.
862
863 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
864 - Rebuild with slab debug off.
865
866 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
867 - 2.6.17.1
868
869 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
870 - 2.6.16.20
871
872 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
873 - 2.6.16.19
874
875 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
876 - Improved list_head debugging.
877
878 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
879 - 2.6.16.18
880
881 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
882 - 2.6.16.17
883
884 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
885 - 2.6.16.16
886
887 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
888 - 2.6.16.15
889 - make 16C950 UARTs work (again). (#126403)
890 - Fix exec-shield default, which should fix a few programs that
891   stopped running.
892
893 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
894 - 2.6.16.14
895
896 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
897 - 2.6.16.13
898
899 * Mon May  1 2006 Dave Jones <davej@redhat.com>
900 - 2.6.16.12
901
902 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
903 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
904
905 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
906 - 2.6.16.11
907
908 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
909 - Enable PCI MSI support.
910
911 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
912 - 2.6.16.9
913
914 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
915 - 2.6.16.7
916
917 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
918 - 2.6.16.6
919
920 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
921 - 2.6.16.5
922
923 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
924 - 2.6.16.2
925
926 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
927 - Reenable non-standard serial ports. (#187466)
928 - Reenable snd-es18xx for x86-32 (#187733)
929
930 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
931 - ship the .kernelrelease file in -devel too.
932 - Disable EDAC debug.
933
934 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
935 - 2.6.16.1
936
937 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
938 - Include patches posted for review for inclusion in 2.6.16.1
939 - Updated new audit msg types.
940 - Reenable HDLC driver (#186257)
941 - Make acpi-cpufreq 'sticky'
942 - Fix broken x86-64 32bit vDSO (#186924)
943
944 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
945 - Improve spinlock scalability on big machines.
946
947 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
948 - Sync with FC5's 2.6.16 kernel.
949 - Update Tux & Exec-shield to latest.
950