Make hangcheck reboot by default, and build it in to the kernel.
[linux-2.6.git] / kernel-2.6.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 Summary: The Linux kernel (the core of the Linux operating system)
7
8 # What parts do we want to build?  We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
10
11 %define buildup 1
12 %define builduml 0
13 %define buildxen 0
14 %define builddoc 0
15
16 # default is to not build this - to override, use something like
17 # kernel-SPECVARS := iwlwifi=1 
18 # rpm does not seem to have a syntax for defining overridable defaults
19 # any better solution would be more than welcome.
20 %define build_iwlwifi %{?iwlwifi:1}%{!?iwlwifi:0}
21
22 # Versions of various parts
23
24 # for module-tag.py - sublevel is used for the version (middle) part of tag names
25 %define name linux-2.6
26 %define module_version_varname sublevel
27 %define taglevel 8
28
29 #
30 # Polite request for people who spin their own kernel rpms:
31 # please modify the "release" field in a way that identifies
32 # that the kernel isn't the stock distribution kernel, for example by
33 # adding some text to the end of the version number.
34 #
35 %define sublevel 22
36 %define patchlevel 19
37 %define kversion 2.6.%{sublevel}
38 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
39
40 %define vsversion 2.3.0.34
41
42 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
43 # updated every time the PL kernel is updated.
44 %define vini_pl_patch 561
45
46 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
47
48 %{!?pldistro:%global pldistro planetlab}
49
50 %define signmodules 0
51 %define make_target bzImage
52 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
53
54 # Override generic defaults with per-arch defaults
55
56 %define image_install_path boot
57
58 #
59 # Three sets of minimum package version requirements in the form of Conflicts:
60 # to versions below the minimum
61 #
62
63 #
64 # First the general kernel 2.6 required versions as per
65 # Documentation/Changes
66 #
67 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
68
69
70 # Then a series of requirements that are distribution specific, either 
71 # because we add patches for something, or the older versions have 
72 # problems with the newer kernel or lack certain things that make 
73 # integration in the distro harder than needed.
74 #
75 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
76
77 #
78 # Several packages had bugs in them that became obvious when the NPTL
79 # threading code got integrated.
80 #
81 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
82
83 #
84 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
85 #
86
87 # MEF commented out
88 # %define xen_conflicts glibc < 2.3.5-1
89
90 #
91 # Packages that need to be installed before the kernel is, because the %post
92 # scripts use them.
93 #
94 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
95
96 Vendor: PlanetLab
97 Packager: PlanetLab Central <support@planet-lab.org>
98 Distribution: PlanetLab %{plrelease}
99 URL: %(echo %{url} | cut -d ' ' -f 2)
100
101 Name: kernel
102 Group: System Environment/Kernel
103 License: GPLv2
104 Version: %{rpmversion}
105 Release: %{release}
106 ExclusiveOS: Linux
107 Provides: kernel = %{version}
108 Provides: kernel-drm = 4.3.0
109 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
110 Provides: kernel-smp = %{rpmversion}-%{release}
111 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
112 Prereq: %{kernel_prereq}
113 Conflicts: %{kernel_dot_org_conflicts}
114 Conflicts: %{package_conflicts}
115 Conflicts: %{nptl_conflicts}
116 # We can't let RPM do the dependencies automatic because it'll then pick up
117 # a correct but undesirable perl dependency from the module headers which
118 # isn't required for the kernel proper to function
119 AutoReqProv: no
120
121 #
122 # List the packages used during the kernel build
123 #
124 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
125 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
126 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
127 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
128
129
130 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
131
132 Source10: %{pldistro}-%{kversion}-i586.config
133 Source11: %{pldistro}-%{kversion}-i686.config
134 Source12: %{pldistro}-%{kversion}-x86_64.config
135 %if %{builduml}
136 Source20: %{pldistro}-%{kversion}-i686-uml.config
137 %endif
138 %if %{buildxen}
139 Source30: %{pldistro}-%{kversion}-i686-xenU.config
140 %endif
141
142 # Mainline patches
143 %if "0%{patchlevel}"
144 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
145 %endif
146
147 Patch010: linux-2.6-010-e1000e.patch
148 Patch020: linux-2.6-020-build-id.patch
149 Patch030: linux-2.6-030-netns.patch
150 Patch040: linux-2.6-040-i_mutex-check.patch
151
152 # These are patches picked up from Fedora/RHEL
153 Patch100: linux-2.6-100-build-nonintconfig.patch
154
155 # Linux-VServer
156 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
157 Patch210: linux-2.6-210-vserver-cpu-sched.patch
158
159 # IP sets
160 Patch250: linux-2.6-250-ipsets.patch
161
162 # PlanetLab
163 Patch500: linux-2.6-500-vserver-filesharing.patch
164 Patch510: linux-2.6-510-ipod.patch
165 Patch520: linux-2.6-520-vnet+.patch
166 Patch530: linux-2.6-530-built-by-support.patch
167 Patch540: linux-2.6-540-oom-kill.patch
168 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
169 Patch560: linux-2.6-560-mmconf.patch
170 Patch570: linux-2.6-570-tagxid.patch
171 Patch580: linux-2.6-580-show-proc-virt.patch
172 Patch590: linux-2.6-590-chopstix-intern.patch
173 Patch620: linux-2.6-620-kdb.patch
174 Patch630: linux-2.6-630-sched-fix.patch
175 Patch640: linux-2.6-640-netlink-audit-hack.patch
176 Patch650: linux-2.6-650-hangcheck-reboot.patch
177
178 # See also the file named 'sources' here for the related checksums
179 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
180 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
181 %if %{build_iwlwifi}
182 %define mac80211_version 10.0.4
183 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
184 %define iwlwifi_version 1.2.25
185 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
186 %endif
187
188 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
189
190 %description
191 The kernel package contains the Linux kernel (vmlinuz), the core of any
192 Linux operating system.  The kernel handles the basic functions
193 of the operating system:  memory allocation, process allocation, device
194 input and output, etc.
195
196 %package devel
197 Summary: Development package for building kernel modules to match the kernel.
198 Group: System Environment/Kernel
199 AutoReqProv: no
200 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
201 Provides: kernel-smp-devel = %{rpmversion}-%{release}
202 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
203 Prereq: /usr/bin/find
204
205 %description devel
206 This package provides kernel headers and makefiles sufficient to build modules
207 against the kernel package.
208
209
210 %package doc
211 Summary: Various documentation bits found in the kernel source.
212 Group: Documentation
213
214 %description doc
215 This package contains documentation files from the kernel
216 source. Various bits of information about the Linux kernel and the
217 device drivers shipped with it are documented in these files.
218
219 You'll want to install this package if you need a reference to the
220 options that can be passed to Linux kernel modules at load time.
221
222 %package xenU
223 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
224
225 Group: System Environment/Kernel
226 Provides: kernel = %{version}
227 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
228 Prereq: %{kernel_prereq}
229 Conflicts: %{kernel_dot_org_conflicts}
230 Conflicts: %{package_conflicts}
231 Conflicts: %{nptl_conflicts}
232
233 # MEF commented out 
234 # Conflicts: %{xen_conflicts}
235
236 # We can't let RPM do the dependencies automatic because it'll then pick up
237 # a correct but undesirable perl dependency from the module headers which
238 # isn't required for the kernel proper to function
239 AutoReqProv: no
240
241 %description xenU
242 This package includes a version of the Linux kernel which
243 runs in Xen unprivileged guest VMs.  This should be installed
244 both inside the unprivileged guest (for the modules) and in
245 the guest0 domain.
246
247 %package xenU-devel
248 Summary: Development package for building kernel modules to match the kernel.
249 Group: System Environment/Kernel
250 AutoReqProv: no
251 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
252 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
253 Provides: kernel-devel = %{rpmversion}-%{release}xenU
254 Prereq: /usr/sbin/hardlink, /usr/bin/find
255
256 %description xenU-devel
257 This package provides kernel headers and makefiles sufficient to build modules
258 against the kernel package.
259
260 %package uml
261 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
262
263 Group: System Environment/Kernel
264
265 %description uml
266 This package includes a user mode version of the Linux kernel.
267
268 %package uml-devel
269 Summary: Development package for building kernel modules to match the UML kernel.
270 Group: System Environment/Kernel
271 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
272 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
273 Provides: kernel-devel = %{rpmversion}-%{release}smp
274 AutoReqProv: no
275 Prereq: /usr/sbin/hardlink, /usr/bin/find
276
277 %description uml-devel
278 This package provides kernel headers and makefiles sufficient to build modules
279 against the User Mode Linux kernel package.
280
281 %package uml-modules
282 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
283
284 Group: System Environment/Kernel
285
286 %description uml-modules
287 This package includes a user mode version of the Linux kernel modules.
288
289 %package vserver
290 Summary: A placeholder RPM that provides kernel and kernel-drm
291
292 Group: System Environment/Kernel
293 Provides: kernel = %{version}
294 Provides: kernel-drm = 4.3.0
295 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
296
297 %description vserver
298 VServers do not require and cannot use kernels, but some RPMs have
299 implicit or explicit dependencies on the "kernel" package
300 (e.g. tcpdump). This package installs no files but provides the
301 necessary dependencies to make rpm and yum happy.
302
303
304 %prep
305 # First we unpack the kernel tarball.
306 # If this isn't the first make prep, we use links to the existing clean tarball
307 # which speeds things up quite a bit.
308 if [ ! -d kernel-%{kversion}/vanilla ]; then
309   # Ok, first time we do a make prep.
310   rm -f pax_global_header
311 %setup -q -n %{name}-%{kversion} -c
312   mv linux-%{kversion} vanilla
313 else
314   # We already have a vanilla dir.
315   cd kernel-%{kversion}
316 fi
317
318 KERNEL_PREVIOUS=vanilla
319 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
320 %define ApplyPatch() \
321   rm -fr linux-%{kversion}-%1                           \
322   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
323   patchflag=-p1                                         \
324   test "%2" != "%%2" && patchflag="%2"                  \
325   PATCH="%{expand:%{PATCH%1}}"                          \
326   if test ! -e "$PATCH"; then                           \
327     echo "Patch %1 does not exist!"                     \
328     exit 1                                              \
329   fi                                                    \
330   case "$PATCH" in                                      \
331     *.bz2)  bzcat "$PATCH";;                            \
332     *.gz)   zcat "$PATCH";;                             \
333     *)      cat "$PATCH";;                              \
334   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
335   KERNEL_PREVIOUS=linux-%{kversion}-%1
336
337 # This is where the patches get applied
338 %if 0%{?patchlevel}
339 %ApplyPatch 0
340 %endif
341
342 %ApplyPatch 10
343 %ApplyPatch 20
344
345 # NetNS patch for VINI
346 %if 0%{?with_netns}
347 %ApplyPatch 30
348 %endif
349 %ApplyPatch 40
350
351 %ApplyPatch 100
352
353 %ApplyPatch 200
354 %ApplyPatch 210
355
356 %ApplyPatch 250
357
358 %ApplyPatch 500
359 %ApplyPatch 510
360 %ApplyPatch 520
361 %ApplyPatch 530
362 %ApplyPatch 540
363 %ApplyPatch 550
364 %ApplyPatch 560
365 %ApplyPatch 570
366 %ApplyPatch 580
367 %ApplyPatch 590
368 %ApplyPatch 620
369 %ApplyPatch 630
370 %ApplyPatch 640
371 %ApplyPatch 650
372
373 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
374 # break with later patches.
375
376 %if 0%{?with_netns}
377 %ApplyPatch %vini_pl_patch
378 %endif
379
380 %if %{build_iwlwifi}
381 # Run the mac80211 stuff in the kernel tree holding the last patch
382 tar -xzf %{PATCH600}
383 pushd mac80211-%{mac80211_version}
384 mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
385 make $mac80211_makeflags modified
386 make $mac80211_makeflags source
387 make $mac80211_makeflags patch_kernel
388 popd
389
390 # Untar iwlwifi in the same place - needs to be compiled later
391 tar -xzf %{PATCH601}
392 # the install target is broken: first it does not pass the right -b flag to depmod
393 # second we do not need to invoke depmod at this stage anyway
394 # let's add our own patch/stuff in this Makefile for manual install later on
395 pushd iwlwifi-%{iwlwifi_version}
396 cat >> Makefile <<EOF
397 module-list:
398         @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
399 EOF
400 popd
401 %endif
402
403 rm -fr linux-%{kversion}
404 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
405 cd linux-%{kversion}
406
407
408 # make sure the kernel has the sublevel we know it has. This looks weird
409 # but for -pre and -rc versions we need it since we only want to use
410 # the higher version when the final kernel is released.
411 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
412 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
413
414 # get rid of unwanted files resulting from patch fuzz
415 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
416
417
418 ###
419 ### build
420 ###
421 %build
422
423 BuildKernel() {
424     MakeTarget=$1
425     Arch=$2
426     Flavour=$3
427
428     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
429     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
430     cd linux-%{_target_cpu}-%{kversion}$Flavour
431
432     # Pick the right config file for the kernel we're building
433     if [ -n "$Flavour" ] ; then
434       Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
435       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
436       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
437     else
438       Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
439       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
440       DevelLink=
441     fi
442
443     KernelVer=%{version}-%{release}$Flavour
444     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
445
446     # make sure EXTRAVERSION says what we want it to say
447     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
448
449     # and now to start the build process
450
451     make -s mrproper
452     cp %{_sourcedir}/$Config .config
453
454     #Arch=`head -1 .config | cut -b 3-`
455     echo USING ARCH=$Arch
456
457     make -s ARCH=$Arch nonint_oldconfig > /dev/null
458     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
459     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
460
461 %if %{build_iwlwifi}
462     # build the iwlwifi driver
463     make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
464       KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
465 %endif
466
467     # Start installing the results
468
469 %if "%{_enable_debug_packages}" == "1"
470     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
471 %endif
472     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
473     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
474     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
475     if [ -f arch/$Arch/boot/bzImage ]; then
476       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
477     fi
478     if [ -f arch/$Arch/boot/zImage.stub ]; then
479       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
480     fi
481     if [ "$Flavour" = "uml" ] ; then
482         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
483     fi
484
485     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
486     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
487
488 %if %{build_iwlwifi}
489     # install iwlwifi
490 #    make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
491 #         KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
492 #        KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
493     pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
494     iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
495     # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
496     iwlwifi_modules=$(make --no-print-directory module-list)
497     install -d $iwlwifi_dest
498     install -m 644 -c $iwlwifi_modules $iwlwifi_dest
499     popd
500 %endif
501
502     # And save the headers/makefiles etc for building modules against
503     #
504     # This all looks scary, but the end result is supposed to be:
505     # * all arch relevant include/ files
506     # * all Makefile/Kconfig files
507     # * all script/ files
508
509     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
510     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
511     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
512     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
513     # dirs for additional modules per module-init-tools, kbuild/modules.txt
514     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
515     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
516     # first copy everything
517     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
518         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
519     if [ "$Flavour" = "uml" ] ; then
520       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
521     fi
522     # then drop all but the needed Makefiles/Kconfig files
523     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
524     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
525     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
526     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
527     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
528     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
529     if [ -d arch/%{_arch}/scripts ]; then
530       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
531     fi
532     if [ -f arch/%{_arch}/*lds ]; then
533       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
534     fi
535     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
536     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
537     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
538     cd include
539     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
540     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
541     if [ "$Arch" = "x86_64" ]; then
542       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
543     fi
544 %if %{buildxen}
545     if [ "$Flavour" = "xenU" ]; then
546       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
547       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
548     fi
549 %endif
550 %if %{builduml}
551     if [ "$Flavour" = "uml" ] ; then
552       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
553     fi
554 %endif
555     # While arch/powerpc/include/asm is still a symlink to the old
556     # include/asm-ppc{64,} directory, include that in kernel-devel too.
557     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
558       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
559       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
560       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
561       ln -sf ../../../include/asm-ppc* asm
562       popd
563     fi
564
565     # Make sure the Makefile and version.h have a matching timestamp so that
566     # external modules can be built
567     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
568     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
569     cd ..
570
571     #
572     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
573     #
574 %if "%{_enable_debug_packages}" == "1"
575     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
576     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
577 %endif
578 %if %{buildxen}
579     if [ -f vmlinuz ]; then
580       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
581     fi
582 %endif
583
584     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
585
586     # mark modules executable so that strip-to-file can strip them
587     cat modnames | xargs chmod u+x
588
589     # remove files that will be auto generated by depmod at rpm -i time
590     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
591
592     # Move the devel headers out of the root file system
593     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
594     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
595     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
596     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
597 }
598
599 ###
600 # DO it...
601 ###
602
603 # prepare directories
604 rm -rf $RPM_BUILD_ROOT
605 mkdir -p $RPM_BUILD_ROOT/boot
606
607 %if "%{_target_cpu}" == "x86_64"
608 %define kernel_arch %{_target_cpu}
609 %endif
610 %if "%{_target_cpu}" == "i586"
611 %define kernel_arch i386
612 %endif
613 %if "%{_target_cpu}" == "i686"
614 %define kernel_arch i386
615 %endif
616
617 %if %{buildup}
618 BuildKernel %make_target %kernel_arch
619 %endif
620
621 %ifarch i686
622 %if %{builduml}
623 BuildKernel linux um uml
624 %endif
625
626 %if %{buildxen}
627 BuildKernel vmlinuz %kernel_arch xenU
628 %endif
629 %endif
630
631 ###
632 ### install
633 ###
634
635 %install
636
637 cd vanilla
638
639 %if %{buildxen} && "%{_target_cpu}" == "i686"
640 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
641 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
642 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
643 # This directive teaches ldconfig to search in nosegneg subdirectories
644 # and cache the DSOs there with extra bit 0 set in their hwcap match
645 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
646 # search in nosegneg subdirectories and to match this extra hwcap bit
647 # in the ld.so.cache file.
648 hwcap 0 nosegneg
649 EOF
650 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
651 %endif
652
653 %if %{builddoc}
654 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
655
656 # sometimes non-world-readable files sneak into the kernel source tree
657 chmod -R a+r *
658 # copy the source over
659 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
660 %endif
661
662 ###
663 ### clean
664 ###
665
666 %clean
667 rm -rf $RPM_BUILD_ROOT
668
669 ###
670 ### scripts
671 ###
672
673 # load the loop module for upgrades...in case the old modules get removed we have
674 # loopback in the kernel so that mkinitrd will work.
675 %pre
676 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
677 exit 0
678
679 %post
680 if [ -f /etc/sysconfig/kernel ]; then
681   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
682 fi
683
684 # trick mkinitrd in case the current environment does not have device mapper
685 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
686 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
687     if [ ! -f $rootdev ]; then
688         fake_root_lvm=1
689         mkdir -p $(dirname $rootdev)
690         touch $rootdev
691     fi
692 fi
693
694 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
695 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
696 # Older modutils do not support --package option
697 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
698
699 # remove fake handle
700 if [ -n "$fake_root_lvm" ]; then
701     rm -f $rootdev
702 fi
703
704 # make some useful links
705 pushd /boot > /dev/null ; {
706         ln -sf config-%{KVERREL} config
707         ln -sf config-%{KVERREL} configsmp
708         ln -sf initrd-%{KVERREL}.img initrd-boot
709         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
710         ln -sf vmlinuz-%{KVERREL} kernel-boot
711         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
712 }
713 popd > /dev/null
714
715 # ask for a reboot
716 mkdir -p /etc/planetlab
717 touch /etc/planetlab/update-reboot
718
719 %post devel
720 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
721 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
722   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
723   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
724   popd > /dev/null
725 fi
726
727 %post xenU
728 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
729 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
730
731 %post xenU-devel
732 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
733 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
734   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
735   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
736   popd > /dev/null
737 fi
738
739 %post uml-modules
740 depmod -ae %{KVERREL}uml
741
742 %preun
743 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
744 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
745
746 %preun xenU
747 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
748 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
749
750 %preun uml-modules
751 rm -f /lib/modules/%{KVERREL}uml/modules.*
752
753
754 ###
755 ### file lists
756 ###
757
758 %if %{buildup}
759 %files 
760 %defattr(-,root,root)
761 /%{image_install_path}/vmlinuz-%{KVERREL}
762 /boot/System.map-%{KVERREL}
763 /boot/config-%{KVERREL}
764 %dir /lib/modules/%{KVERREL}
765 /lib/modules/%{KVERREL}/kernel
766 /lib/modules/%{KVERREL}/build
767 /lib/modules/%{KVERREL}/source
768 /lib/modules/%{KVERREL}/extra
769 /lib/modules/%{KVERREL}/updates
770
771 %files devel
772 %defattr(-,root,root)
773 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
774 %endif
775
776 %if %{builduml} && "%{_target_cpu}" == "i686"
777 %files uml
778 %defattr(-,root,root)
779 %{_bindir}/linux
780
781 %files uml-devel
782 %defattr(-,root,root)
783 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
784 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
785
786 %files uml-modules
787 %defattr(-,root,root)
788 /boot/System.map-%{KVERREL}uml
789 /boot/config-%{KVERREL}uml
790 %dir /lib/modules/%{KVERREL}uml
791 /lib/modules/%{KVERREL}uml/kernel
792 /lib/modules/%{KVERREL}uml/build
793 /lib/modules/%{KVERREL}uml/source
794 /lib/modules/%{KVERREL}uml/extra
795 /lib/modules/%{KVERREL}uml/updates
796 %endif
797
798 %if %{buildxen} && "%{_target_cpu}" == "i686"
799 %files xenU
800 %defattr(-,root,root)
801 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
802 /boot/System.map-%{KVERREL}xenU
803 /boot/config-%{KVERREL}xenU
804 %dir /lib/modules/%{KVERREL}xenU
805 /lib/modules/%{KVERREL}xenU/kernel
806 /lib/modules/%{KVERREL}xenU/build
807 /lib/modules/%{KVERREL}xenU/source
808 /lib/modules/%{KVERREL}xenU/extra
809 /lib/modules/%{KVERREL}xenU/updates
810 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
811
812 %files xenU-devel
813 %defattr(-,root,root)
814 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
815 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
816 %endif
817
818 %files vserver
819 %defattr(-,root,root)
820 # no files
821
822 # only some architecture builds need kernel-doc
823
824 %if %{builddoc}
825 %files doc
826 %defattr(-,root,root)
827 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
828 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
829 %dir %{_datadir}/doc/kernel-doc-%{kversion}
830 %endif
831
832 %changelog
833 * Sat Jun 07 2008 Sapan Bhatia <sapanb@cs.princeton.edu> - linux-2.6-22-8
834 - * Partial fix for the UDP-packet-pollution problem
835 - * Support for PF_PACKET sockets
836 - * Support for SOCK_PACKET sockets
837 - * Disabled Chopstix with mutexes
838 - * Tested VNET+ under heavy loads
839
840
841
842 * Fri May 16 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-7
843 - Bringing this fix in for tcpdump and  ping
844
845
846 * Fri May 09 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-6
847 - Updated configuration to include COW again.
848
849 - Patches from Sapan to fix ping losses.
850
851 - Still need help with tcpdump traffic.
852
853
854 * Tue May 06 2008 Daniel Hokka Zakrisson <daniel@hozac.com> - linux-2.6-22-5
855 - Patch needs to be applied.
856
857 * Mon May 05 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-4
858
859
860 * Thu Apr 24 2008 Thierry Parmentelat <thierry.parmentelat@sophia.inria.fr> - linux-2.6-22-3
861 - Fix bug with looping in schedule()
862
863 * Wed Apr 23 2008 Stephen Soltesz <soltesz@cs.princeton.edu> - linux-2.6-22-2
864 - Includes changes from Sapan/Andy regarding the scheduler and vnet bugs.
865 - Should be safe to try a second deployment.
866
867
868 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
869 - 2.6.17.4
870 - Disable split pagetable lock.
871
872 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
873 - Get rid of stack backtrace on panic, which in most
874   cases actually caused a loss of info instead of a gain.
875
876 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
877 - 2.6.17.3
878
879 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
880 - 2.6.17.2
881 - Fix up the alsa list_add bug.
882
883 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
884 - Fix up various stupidities incurred by the last big rebase.
885   - Reenable SMP x86-64 builds.
886   - Reenable SMBFS.
887 - Enable PCI fake hotplug driver.
888 - Enable gameport/joystick on i586 builds. (#196581)
889
890 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
891 - Enable profiling for 586 kernels.
892
893 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
894 - Rebuild with slab debug off.
895
896 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
897 - 2.6.17.1
898
899 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
900 - 2.6.16.20
901
902 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
903 - 2.6.16.19
904
905 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
906 - Improved list_head debugging.
907
908 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
909 - 2.6.16.18
910
911 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
912 - 2.6.16.17
913
914 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
915 - 2.6.16.16
916
917 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
918 - 2.6.16.15
919 - make 16C950 UARTs work (again). (#126403)
920 - Fix exec-shield default, which should fix a few programs that
921   stopped running.
922
923 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
924 - 2.6.16.14
925
926 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
927 - 2.6.16.13
928
929 * Mon May  1 2006 Dave Jones <davej@redhat.com>
930 - 2.6.16.12
931
932 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
933 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
934
935 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
936 - 2.6.16.11
937
938 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
939 - Enable PCI MSI support.
940
941 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
942 - 2.6.16.9
943
944 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
945 - 2.6.16.7
946
947 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
948 - 2.6.16.6
949
950 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
951 - 2.6.16.5
952
953 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
954 - 2.6.16.2
955
956 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
957 - Reenable non-standard serial ports. (#187466)
958 - Reenable snd-es18xx for x86-32 (#187733)
959
960 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
961 - ship the .kernelrelease file in -devel too.
962 - Disable EDAC debug.
963
964 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
965 - 2.6.16.1
966
967 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
968 - Include patches posted for review for inclusion in 2.6.16.1
969 - Updated new audit msg types.
970 - Reenable HDLC driver (#186257)
971 - Make acpi-cpufreq 'sticky'
972 - Fix broken x86-64 32bit vDSO (#186924)
973
974 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
975 - Improve spinlock scalability on big machines.
976
977 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
978 - Sync with FC5's 2.6.16 kernel.
979 - Update Tux & Exec-shield to latest.
980