tuned for module-tag.py
[linux-2.6.git] / kernel-2.6.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 Summary: The Linux kernel (the core of the Linux operating system)
7
8 # What parts do we want to build?  We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
10
11 %define buildup 1
12 %define builduml 0
13 %define buildxen 0
14 %define builddoc 0
15
16 # Versions of various parts
17
18 # for module-tag.py - sublevel is used for the version (middle) part of tag names
19 %define name linux-2.6
20 %define module_version_varname sublevel
21 %define taglevel 1
22
23 #
24 # Polite request for people who spin their own kernel rpms:
25 # please modify the "release" field in a way that identifies
26 # that the kernel isn't the stock distribution kernel, for example by
27 # adding some text to the end of the version number.
28 #
29 %define sublevel 22
30 %define patchlevel 14
31 %define kversion 2.6.%{sublevel}
32 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
33
34 %define vsversion 2.3.0.29
35
36 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
37 # updated every time the PL kernel is updated.
38 %define vini_pl_patch 561
39
40 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
41
42 %{!?pldistro:%global pldistro planetlab}
43
44 %define signmodules 0
45 %define make_target bzImage
46 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
47
48 # Override generic defaults with per-arch defaults
49
50 %define image_install_path boot
51
52 #
53 # Three sets of minimum package version requirements in the form of Conflicts:
54 # to versions below the minimum
55 #
56
57 #
58 # First the general kernel 2.6 required versions as per
59 # Documentation/Changes
60 #
61 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
62
63
64 # Then a series of requirements that are distribution specific, either 
65 # because we add patches for something, or the older versions have 
66 # problems with the newer kernel or lack certain things that make 
67 # integration in the distro harder than needed.
68 #
69 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
70
71 #
72 # Several packages had bugs in them that became obvious when the NPTL
73 # threading code got integrated.
74 #
75 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
76
77 #
78 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
79 #
80
81 # MEF commented out
82 # %define xen_conflicts glibc < 2.3.5-1
83
84 #
85 # Packages that need to be installed before the kernel is, because the %post
86 # scripts use them.
87 #
88 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
89
90 Vendor: PlanetLab
91 Packager: PlanetLab Central <support@planet-lab.org>
92 Distribution: PlanetLab %{plrelease}
93 URL: %(echo %{url} | cut -d ' ' -f 2)
94
95 Name: kernel
96 Group: System Environment/Kernel
97 License: GPLv2
98 Version: %{rpmversion}
99 Release: %{release}
100 ExclusiveOS: Linux
101 Provides: kernel = %{version}
102 Provides: kernel-drm = 4.3.0
103 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
104 Provides: kernel-smp = %{rpmversion}-%{release}
105 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
106 Prereq: %{kernel_prereq}
107 Conflicts: %{kernel_dot_org_conflicts}
108 Conflicts: %{package_conflicts}
109 Conflicts: %{nptl_conflicts}
110 # We can't let RPM do the dependencies automatic because it'll then pick up
111 # a correct but undesirable perl dependency from the module headers which
112 # isn't required for the kernel proper to function
113 AutoReqProv: no
114
115 #
116 # List the packages used during the kernel build
117 #
118 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
119 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
120 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
121 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
122
123
124 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
125
126 Source10: %{pldistro}-%{kversion}-i586.config
127 Source11: %{pldistro}-%{kversion}-i686.config
128 Source12: %{pldistro}-%{kversion}-x86_64.config
129 %if %{builduml}
130 Source20: %{pldistro}-%{kversion}-i686-uml.config
131 %endif
132 %if %{buildxen}
133 Source30: %{pldistro}-%{kversion}-i686-xenU.config
134 %endif
135
136 # Mainline patches
137 %if "0%{patchlevel}"
138 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
139 %endif
140
141 Patch010: linux-2.6-010-e1000e.patch
142 Patch020: linux-2.6-020-build-id.patch
143 Patch030: linux-2.6-030-netns.patch
144
145 # These are patches picked up from Fedora/RHEL
146 Patch100: linux-2.6-100-build-nonintconfig.patch
147
148 # Linux-VServer
149 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
150
151 # IP sets
152 Patch250: linux-2.6-250-ipsets.patch
153
154 # PlanetLab
155 Patch500: linux-2.6-500-vserver-filesharing.patch
156 Patch510: linux-2.6-510-ipod.patch
157 Patch520: linux-2.6-520-vnet+.patch
158 Patch530: linux-2.6-530-built-by-support.patch
159 Patch540: linux-2.6-540-oom-kill.patch
160 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
161 Patch560: linux-2.6-560-mmconf.patch
162 Patch570: linux-2.6-570-tagxid.patch
163
164 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
165
166 %description
167 The kernel package contains the Linux kernel (vmlinuz), the core of any
168 Linux operating system.  The kernel handles the basic functions
169 of the operating system:  memory allocation, process allocation, device
170 input and output, etc.
171
172 %package devel
173 Summary: Development package for building kernel modules to match the kernel.
174 Group: System Environment/Kernel
175 AutoReqProv: no
176 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
177 Provides: kernel-smp-devel = %{rpmversion}-%{release}
178 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
179 Prereq: /usr/bin/find
180
181 %description devel
182 This package provides kernel headers and makefiles sufficient to build modules
183 against the kernel package.
184
185
186 %package doc
187 Summary: Various documentation bits found in the kernel source.
188 Group: Documentation
189
190 %description doc
191 This package contains documentation files from the kernel
192 source. Various bits of information about the Linux kernel and the
193 device drivers shipped with it are documented in these files.
194
195 You'll want to install this package if you need a reference to the
196 options that can be passed to Linux kernel modules at load time.
197
198 %package xenU
199 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
200
201 Group: System Environment/Kernel
202 Provides: kernel = %{version}
203 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
204 Prereq: %{kernel_prereq}
205 Conflicts: %{kernel_dot_org_conflicts}
206 Conflicts: %{package_conflicts}
207 Conflicts: %{nptl_conflicts}
208
209 # MEF commented out 
210 # Conflicts: %{xen_conflicts}
211
212 # We can't let RPM do the dependencies automatic because it'll then pick up
213 # a correct but undesirable perl dependency from the module headers which
214 # isn't required for the kernel proper to function
215 AutoReqProv: no
216
217 %description xenU
218 This package includes a version of the Linux kernel which
219 runs in Xen unprivileged guest VMs.  This should be installed
220 both inside the unprivileged guest (for the modules) and in
221 the guest0 domain.
222
223 %package xenU-devel
224 Summary: Development package for building kernel modules to match the kernel.
225 Group: System Environment/Kernel
226 AutoReqProv: no
227 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
228 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
229 Provides: kernel-devel = %{rpmversion}-%{release}xenU
230 Prereq: /usr/sbin/hardlink, /usr/bin/find
231
232 %description xenU-devel
233 This package provides kernel headers and makefiles sufficient to build modules
234 against the kernel package.
235
236 %package uml
237 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
238
239 Group: System Environment/Kernel
240
241 %description uml
242 This package includes a user mode version of the Linux kernel.
243
244 %package uml-devel
245 Summary: Development package for building kernel modules to match the UML kernel.
246 Group: System Environment/Kernel
247 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
248 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
249 Provides: kernel-devel = %{rpmversion}-%{release}smp
250 AutoReqProv: no
251 Prereq: /usr/sbin/hardlink, /usr/bin/find
252
253 %description uml-devel
254 This package provides kernel headers and makefiles sufficient to build modules
255 against the User Mode Linux kernel package.
256
257 %package uml-modules
258 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
259
260 Group: System Environment/Kernel
261
262 %description uml-modules
263 This package includes a user mode version of the Linux kernel modules.
264
265 %package vserver
266 Summary: A placeholder RPM that provides kernel and kernel-drm
267
268 Group: System Environment/Kernel
269 Provides: kernel = %{version}
270 Provides: kernel-drm = 4.3.0
271 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
272
273 %description vserver
274 VServers do not require and cannot use kernels, but some RPMs have
275 implicit or explicit dependencies on the "kernel" package
276 (e.g. tcpdump). This package installs no files but provides the
277 necessary dependencies to make rpm and yum happy.
278
279
280 %prep
281 # First we unpack the kernel tarball.
282 # If this isn't the first make prep, we use links to the existing clean tarball
283 # which speeds things up quite a bit.
284 if [ ! -d kernel-%{kversion}/vanilla ]; then
285   # Ok, first time we do a make prep.
286   rm -f pax_global_header
287 %setup -q -n %{name}-%{kversion} -c
288   mv linux-%{kversion} vanilla
289 else
290   # We already have a vanilla dir.
291   cd kernel-%{kversion}
292 fi
293
294 KERNEL_PREVIOUS=vanilla
295 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
296 %define ApplyPatch() \
297   rm -fr linux-%{kversion}-%1                           \
298   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
299   patchflag=-p1                                         \
300   test "%2" != "%%2" && patchflag="%2"                  \
301   PATCH="%{expand:%{PATCH%1}}"                          \
302   if test ! -e "$PATCH"; then                           \
303     echo "Patch %1 does not exist!"                     \
304     exit 1                                              \
305   fi                                                    \
306   case "$PATCH" in                                      \
307     *.bz2)  bzcat "$PATCH";;                            \
308     *.gz)   zcat "$PATCH";;                             \
309     *)      cat "$PATCH";;                              \
310   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
311   KERNEL_PREVIOUS=linux-%{kversion}-%1
312
313 # This is where the patches get applied
314 %if "0%{patchlevel}"
315 %ApplyPatch 0
316 %endif
317
318 %ApplyPatch 10
319 %ApplyPatch 20
320
321 # NetNS patch for VINI
322 %if 0%{?with_netns}
323 %ApplyPatch 30
324 %endif
325
326 %ApplyPatch 100
327
328 %ApplyPatch 200
329
330 %ApplyPatch 250
331
332 %ApplyPatch 500
333 %ApplyPatch 510
334 %ApplyPatch 520
335 %ApplyPatch 530
336 %ApplyPatch 540
337 %ApplyPatch 550
338 %ApplyPatch 560
339 %ApplyPatch 570
340
341 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
342 # break with later patches.
343
344 %if 0%{?with_netns}
345 %ApplyPatch %vini_pl_patch
346 %endif
347
348 rm -fr linux-%{kversion}
349 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
350 cd linux-%{kversion}
351
352
353 # make sure the kernel has the sublevel we know it has. This looks weird
354 # but for -pre and -rc versions we need it since we only want to use
355 # the higher version when the final kernel is released.
356 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
357 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
358
359 # get rid of unwanted files resulting from patch fuzz
360 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
361
362
363 ###
364 ### build
365 ###
366 %build
367
368 BuildKernel() {
369     MakeTarget=$1
370     Arch=$2
371     Flavour=$3
372
373     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
374     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
375     cd linux-%{_target_cpu}-%{kversion}$Flavour
376
377     # Pick the right config file for the kernel we're building
378     if [ -n "$Flavour" ] ; then
379       Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
380       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
381       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
382     else
383       Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
384       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
385       DevelLink=
386     fi
387
388     KernelVer=%{version}-%{release}$Flavour
389     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
390
391     # make sure EXTRAVERSION says what we want it to say
392     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
393
394     # and now to start the build process
395
396     make -s mrproper
397     cp %{_sourcedir}/$Config .config
398
399     #Arch=`head -1 .config | cut -b 3-`
400     echo USING ARCH=$Arch
401
402     make -s ARCH=$Arch nonint_oldconfig > /dev/null
403     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
404     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
405
406     # Start installing the results
407
408 %if "%{_enable_debug_packages}" == "1"
409     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
410 %endif
411     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
412     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
413     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
414     if [ -f arch/$Arch/boot/bzImage ]; then
415       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
416     fi
417     if [ -f arch/$Arch/boot/zImage.stub ]; then
418       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
419     fi
420     if [ "$Flavour" = "uml" ] ; then
421         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
422     fi
423
424     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
425     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
426
427     # And save the headers/makefiles etc for building modules against
428     #
429     # This all looks scary, but the end result is supposed to be:
430     # * all arch relevant include/ files
431     # * all Makefile/Kconfig files
432     # * all script/ files
433
434     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
435     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
436     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
437     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
438     # dirs for additional modules per module-init-tools, kbuild/modules.txt
439     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
440     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
441     # first copy everything
442     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
443         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
444     if [ "$Flavour" = "uml" ] ; then
445       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
446     fi
447     # then drop all but the needed Makefiles/Kconfig files
448     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
449     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
450     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
451     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
452     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
453     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
454     if [ -d arch/%{_arch}/scripts ]; then
455       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
456     fi
457     if [ -f arch/%{_arch}/*lds ]; then
458       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
459     fi
460     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
461     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
462     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
463     cd include
464     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
465     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
466     if [ "$Arch" = "x86_64" ]; then
467       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
468     fi
469 %if %{buildxen}
470     if [ "$Flavour" = "xenU" ]; then
471       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
472       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
473     fi
474 %endif
475 %if %{builduml}
476     if [ "$Flavour" = "uml" ] ; then
477       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
478     fi
479 %endif
480     # While arch/powerpc/include/asm is still a symlink to the old
481     # include/asm-ppc{64,} directory, include that in kernel-devel too.
482     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
483       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
484       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
485       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
486       ln -sf ../../../include/asm-ppc* asm
487       popd
488     fi
489
490     # Make sure the Makefile and version.h have a matching timestamp so that
491     # external modules can be built
492     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
493     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
494     cd ..
495
496     #
497     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
498     #
499 %if "%{_enable_debug_packages}" == "1"
500     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
501     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
502 %endif
503 %if %{buildxen}
504     if [ -f vmlinuz ]; then
505       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
506     fi
507 %endif
508
509     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
510
511     # mark modules executable so that strip-to-file can strip them
512     cat modnames | xargs chmod u+x
513
514     # remove files that will be auto generated by depmod at rpm -i time
515     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
516
517     # Move the devel headers out of the root file system
518     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
519     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
520     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
521     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
522 }
523
524 ###
525 # DO it...
526 ###
527
528 # prepare directories
529 rm -rf $RPM_BUILD_ROOT
530 mkdir -p $RPM_BUILD_ROOT/boot
531
532 %if "%{_target_cpu}" == "x86_64"
533 %define kernel_arch %{_target_cpu}
534 %endif
535 %if "%{_target_cpu}" == "i586"
536 %define kernel_arch i386
537 %endif
538 %if "%{_target_cpu}" == "i686"
539 %define kernel_arch i386
540 %endif
541
542 %if %{buildup}
543 BuildKernel %make_target %kernel_arch
544 %endif
545
546 %ifarch i686
547 %if %{builduml}
548 BuildKernel linux um uml
549 %endif
550
551 %if %{buildxen}
552 BuildKernel vmlinuz %kernel_arch xenU
553 %endif
554 %endif
555
556 ###
557 ### install
558 ###
559
560 %install
561
562 cd vanilla
563
564 %if %{buildxen} && "%{_target_cpu}" == "i686"
565 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
566 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
567 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
568 # This directive teaches ldconfig to search in nosegneg subdirectories
569 # and cache the DSOs there with extra bit 0 set in their hwcap match
570 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
571 # search in nosegneg subdirectories and to match this extra hwcap bit
572 # in the ld.so.cache file.
573 hwcap 0 nosegneg
574 EOF
575 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
576 %endif
577
578 %if %{builddoc}
579 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
580
581 # sometimes non-world-readable files sneak into the kernel source tree
582 chmod -R a+r *
583 # copy the source over
584 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
585 %endif
586
587 ###
588 ### clean
589 ###
590
591 %clean
592 rm -rf $RPM_BUILD_ROOT
593
594 ###
595 ### scripts
596 ###
597
598 # load the loop module for upgrades...in case the old modules get removed we have
599 # loopback in the kernel so that mkinitrd will work.
600 %pre
601 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
602 exit 0
603
604 %post
605 if [ -f /etc/sysconfig/kernel ]; then
606   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
607 fi
608
609 # trick mkinitrd in case the current environment does not have device mapper
610 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
611 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
612     if [ ! -f $rootdev ]; then
613         fake_root_lvm=1
614         mkdir -p $(dirname $rootdev)
615         touch $rootdev
616     fi
617 fi
618
619 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
620 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
621 # Older modutils do not support --package option
622 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
623
624 # remove fake handle
625 if [ -n "$fake_root_lvm" ]; then
626     rm -f $rootdev
627 fi
628
629 # make some useful links
630 pushd /boot > /dev/null ; {
631         ln -sf config-%{KVERREL} config
632         ln -sf config-%{KVERREL} configsmp
633         ln -sf initrd-%{KVERREL}.img initrd-boot
634         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
635         ln -sf vmlinuz-%{KVERREL} kernel-boot
636         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
637 }
638 popd > /dev/null
639
640 # ask for a reboot
641 mkdir -p /etc/planetlab
642 touch /etc/planetlab/update-reboot
643
644 %post devel
645 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
646 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
647   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
648   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
649   popd > /dev/null
650 fi
651
652 %post xenU
653 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
654 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
655
656 %post xenU-devel
657 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
658 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
659   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
660   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
661   popd > /dev/null
662 fi
663
664 %post uml-modules
665 depmod -ae %{KVERREL}uml
666
667 %preun
668 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
669 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
670
671 %preun xenU
672 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
673 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
674
675 %preun uml-modules
676 rm -f /lib/modules/%{KVERREL}uml/modules.*
677
678
679 ###
680 ### file lists
681 ###
682
683 %if %{buildup}
684 %files 
685 %defattr(-,root,root)
686 /%{image_install_path}/vmlinuz-%{KVERREL}
687 /boot/System.map-%{KVERREL}
688 /boot/config-%{KVERREL}
689 %dir /lib/modules/%{KVERREL}
690 /lib/modules/%{KVERREL}/kernel
691 /lib/modules/%{KVERREL}/build
692 /lib/modules/%{KVERREL}/source
693 /lib/modules/%{KVERREL}/extra
694 /lib/modules/%{KVERREL}/updates
695
696 %files devel
697 %defattr(-,root,root)
698 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
699 %endif
700
701 %if %{builduml} && "%{_target_cpu}" == "i686"
702 %files uml
703 %defattr(-,root,root)
704 %{_bindir}/linux
705
706 %files uml-devel
707 %defattr(-,root,root)
708 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
709 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
710
711 %files uml-modules
712 %defattr(-,root,root)
713 /boot/System.map-%{KVERREL}uml
714 /boot/config-%{KVERREL}uml
715 %dir /lib/modules/%{KVERREL}uml
716 /lib/modules/%{KVERREL}uml/kernel
717 /lib/modules/%{KVERREL}uml/build
718 /lib/modules/%{KVERREL}uml/source
719 /lib/modules/%{KVERREL}uml/extra
720 /lib/modules/%{KVERREL}uml/updates
721 %endif
722
723 %if %{buildxen} && "%{_target_cpu}" == "i686"
724 %files xenU
725 %defattr(-,root,root)
726 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
727 /boot/System.map-%{KVERREL}xenU
728 /boot/config-%{KVERREL}xenU
729 %dir /lib/modules/%{KVERREL}xenU
730 /lib/modules/%{KVERREL}xenU/kernel
731 /lib/modules/%{KVERREL}xenU/build
732 /lib/modules/%{KVERREL}xenU/source
733 /lib/modules/%{KVERREL}xenU/extra
734 /lib/modules/%{KVERREL}xenU/updates
735 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
736
737 %files xenU-devel
738 %defattr(-,root,root)
739 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
740 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
741 %endif
742
743 %files vserver
744 %defattr(-,root,root)
745 # no files
746
747 # only some architecture builds need kernel-doc
748
749 %if %{builddoc}
750 %files doc
751 %defattr(-,root,root)
752 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
753 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
754 %dir %{_datadir}/doc/kernel-doc-%{kversion}
755 %endif
756
757 %changelog
758 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
759 - 2.6.17.4
760 - Disable split pagetable lock.
761
762 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
763 - Get rid of stack backtrace on panic, which in most
764   cases actually caused a loss of info instead of a gain.
765
766 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
767 - 2.6.17.3
768
769 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
770 - 2.6.17.2
771 - Fix up the alsa list_add bug.
772
773 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
774 - Fix up various stupidities incurred by the last big rebase.
775   - Reenable SMP x86-64 builds.
776   - Reenable SMBFS.
777 - Enable PCI fake hotplug driver.
778 - Enable gameport/joystick on i586 builds. (#196581)
779
780 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
781 - Enable profiling for 586 kernels.
782
783 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
784 - Rebuild with slab debug off.
785
786 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
787 - 2.6.17.1
788
789 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
790 - 2.6.16.20
791
792 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
793 - 2.6.16.19
794
795 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
796 - Improved list_head debugging.
797
798 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
799 - 2.6.16.18
800
801 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
802 - 2.6.16.17
803
804 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
805 - 2.6.16.16
806
807 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
808 - 2.6.16.15
809 - make 16C950 UARTs work (again). (#126403)
810 - Fix exec-shield default, which should fix a few programs that
811   stopped running.
812
813 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
814 - 2.6.16.14
815
816 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
817 - 2.6.16.13
818
819 * Mon May  1 2006 Dave Jones <davej@redhat.com>
820 - 2.6.16.12
821
822 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
823 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
824
825 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
826 - 2.6.16.11
827
828 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
829 - Enable PCI MSI support.
830
831 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
832 - 2.6.16.9
833
834 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
835 - 2.6.16.7
836
837 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
838 - 2.6.16.6
839
840 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
841 - 2.6.16.5
842
843 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
844 - 2.6.16.2
845
846 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
847 - Reenable non-standard serial ports. (#187466)
848 - Reenable snd-es18xx for x86-32 (#187733)
849
850 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
851 - ship the .kernelrelease file in -devel too.
852 - Disable EDAC debug.
853
854 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
855 - 2.6.16.1
856
857 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
858 - Include patches posted for review for inclusion in 2.6.16.1
859 - Updated new audit msg types.
860 - Reenable HDLC driver (#186257)
861 - Make acpi-cpufreq 'sticky'
862 - Fix broken x86-64 32bit vDSO (#186924)
863
864 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
865 - Improve spinlock scalability on big machines.
866
867 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
868 - Sync with FC5's 2.6.16 kernel.
869 - Update Tux & Exec-shield to latest.
870