Commented out mac80211 and iwlwifi patches
[linux-2.6.git] / kernel-2.6.spec
1 #
2 # $Id$
3 #
4 %define url $URL$
5
6 Summary: The Linux kernel (the core of the Linux operating system)
7
8 # What parts do we want to build?  We must build at least one kernel.
9 # These are the kernels that are built IF the architecture allows it.
10
11 %define buildup 1
12 %define builduml 0
13 %define buildxen 0
14 %define builddoc 0
15
16 # Versions of various parts
17
18 # for module-tag.py - sublevel is used for the version (middle) part of tag names
19 %define name linux-2.6
20 %define module_version_varname sublevel
21 %define taglevel 1
22
23 #
24 # Polite request for people who spin their own kernel rpms:
25 # please modify the "release" field in a way that identifies
26 # that the kernel isn't the stock distribution kernel, for example by
27 # adding some text to the end of the version number.
28 #
29 %define sublevel 22
30 %define patchlevel 19
31 %define kversion 2.6.%{sublevel}
32 %define rpmversion 2.6.%{sublevel}%{?patchlevel:.%{patchlevel}}
33
34 %define vsversion 2.3.0.34
35
36 # Will go away when VServer supports NetNS in mainline. Currently, it must be 
37 # updated every time the PL kernel is updated.
38 %define vini_pl_patch 561
39
40 %define release vs%{vsversion}.%{taglevel}%{?pldistro:.%{pldistro}}%{?date:.%{date}}
41
42 %{!?pldistro:%global pldistro planetlab}
43
44 %define signmodules 0
45 %define make_target bzImage
46 %define KVERREL %{PACKAGE_VERSION}-%{PACKAGE_RELEASE}
47
48 # Override generic defaults with per-arch defaults
49
50 %define image_install_path boot
51
52 #
53 # Three sets of minimum package version requirements in the form of Conflicts:
54 # to versions below the minimum
55 #
56
57 #
58 # First the general kernel 2.6 required versions as per
59 # Documentation/Changes
60 #
61 %define kernel_dot_org_conflicts  ppp <= 2.3.15, pcmcia-cs <= 3.1.20, isdn4k-utils <= 3.0, mount < 2.10r-5, nfs-utils < 1.0.3, e2fsprogs < 1.29, util-linux < 2.10, jfsutils < 1.0.14, reiserfsprogs < 3.6.3, xfsprogs < 2.1.0, procps < 2.0.9, oprofile < 0.5.3
62
63
64 # Then a series of requirements that are distribution specific, either 
65 # because we add patches for something, or the older versions have 
66 # problems with the newer kernel or lack certain things that make 
67 # integration in the distro harder than needed.
68 #
69 %define package_conflicts  cipe < 1.4.5, kudzu <= 0.92, initscripts < 7.23, dev < 3.2-7, iptables < 1.2.5-3, bcm5820 < 1.81, nvidia-rh72 <= 1.0 selinux-policy-targeted < 1.23.16-1
70
71 #
72 # Several packages had bugs in them that became obvious when the NPTL
73 # threading code got integrated.
74 #
75 %define nptl_conflicts SysVinit < 2.84-13, pam < 0.75-48, vixie-cron < 3.0.1-73, privoxy < 3.0.0-8, spamassassin < 2.44-4.8.x,  cups < 1.1.17-13
76
77 #
78 # The ld.so.conf.d file we install uses syntax older ldconfig's don't grok.
79 #
80
81 # MEF commented out
82 # %define xen_conflicts glibc < 2.3.5-1
83
84 #
85 # Packages that need to be installed before the kernel is, because the %post
86 # scripts use them.
87 #
88 %define kernel_prereq  fileutils, module-init-tools, initscripts >= 5.83, mkinitrd >= 3.5.5
89
90 Vendor: PlanetLab
91 Packager: PlanetLab Central <support@planet-lab.org>
92 Distribution: PlanetLab %{plrelease}
93 URL: %(echo %{url} | cut -d ' ' -f 2)
94
95 Name: kernel
96 Group: System Environment/Kernel
97 License: GPLv2
98 Version: %{rpmversion}
99 Release: %{release}
100 ExclusiveOS: Linux
101 Provides: kernel = %{version}
102 Provides: kernel-drm = 4.3.0
103 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
104 Provides: kernel-smp = %{rpmversion}-%{release}
105 Provides: kernel-smp-%{_target_cpu} = %{rpmversion}-%{release}
106 Prereq: %{kernel_prereq}
107 Conflicts: %{kernel_dot_org_conflicts}
108 Conflicts: %{package_conflicts}
109 Conflicts: %{nptl_conflicts}
110 # We can't let RPM do the dependencies automatic because it'll then pick up
111 # a correct but undesirable perl dependency from the module headers which
112 # isn't required for the kernel proper to function
113 AutoReqProv: no
114
115 #
116 # List the packages used during the kernel build
117 #
118 BuildPreReq: module-init-tools, patch >= 2.5.4, bash >= 2.03, sh-utils, tar
119 BuildPreReq: bzip2, findutils, gzip, m4, perl, make >= 3.78, gnupg, diffutils
120 BuildRequires: gcc >= 3.3.3, binutils >= 2.12, redhat-rpm-config
121 BuildConflicts: rhbuildsys(DiskFree) < 500Mb
122
123
124 Source0: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-%{kversion}.tar.bz2
125
126 Source10: %{pldistro}-%{kversion}-i586.config
127 Source11: %{pldistro}-%{kversion}-i686.config
128 Source12: %{pldistro}-%{kversion}-x86_64.config
129 %if %{builduml}
130 Source20: %{pldistro}-%{kversion}-i686-uml.config
131 %endif
132 %if %{buildxen}
133 Source30: %{pldistro}-%{kversion}-i686-xenU.config
134 %endif
135
136 # Mainline patches
137 %if "0%{patchlevel}"
138 Patch000: ftp://ftp.kernel.org/pub/linux/kernel/v2.6/patch-%{rpmversion}.bz2
139 %endif
140
141 Patch010: linux-2.6-010-e1000e.patch
142 Patch020: linux-2.6-020-build-id.patch
143 Patch030: linux-2.6-030-netns.patch
144
145 # These are patches picked up from Fedora/RHEL
146 Patch100: linux-2.6-100-build-nonintconfig.patch
147
148 # Linux-VServer
149 Patch200: patch-%{rpmversion}-vs%{vsversion}.diff
150 Patch210: linux-2.6-210-vserver-cpu-sched.patch
151
152 # IP sets
153 Patch250: linux-2.6-250-ipsets.patch
154
155 # PlanetLab
156 Patch500: linux-2.6-500-vserver-filesharing.patch
157 Patch510: linux-2.6-510-ipod.patch
158 Patch520: linux-2.6-520-vnet+.patch
159 Patch530: linux-2.6-530-built-by-support.patch
160 Patch540: linux-2.6-540-oom-kill.patch
161 Patch550: linux-2.6-550-raise-default-nfile-ulimit.patch
162 Patch560: linux-2.6-560-mmconf.patch
163 Patch570: linux-2.6-570-tagxid.patch
164 Patch580: linux-2.6-580-show-proc-virt.patch
165 Patch590: linux-2.6-590-chopstix-intern.patch
166
167 # See also the file named 'sources' here for the related checksums
168 # NOTE. iwlwifi should be in-kernel starting from 2.6.24
169 # see http://bughost.org/bugzilla/show_bug.cgi?id=1584
170 %define mac80211_version 10.0.4
171 Patch600: http://intellinuxwireless.org/mac80211/downloads/mac80211-%{mac80211_version}.tgz
172 %define iwlwifi_version 1.2.23
173 Patch601: http://intellinuxwireless.org/iwlwifi/downloads/iwlwifi-%{iwlwifi_version}.tgz
174
175 BuildRoot: %{_tmppath}/kernel-%{KVERREL}-root
176
177 %description
178 The kernel package contains the Linux kernel (vmlinuz), the core of any
179 Linux operating system.  The kernel handles the basic functions
180 of the operating system:  memory allocation, process allocation, device
181 input and output, etc.
182
183 %package devel
184 Summary: Development package for building kernel modules to match the kernel.
185 Group: System Environment/Kernel
186 AutoReqProv: no
187 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}
188 Provides: kernel-smp-devel = %{rpmversion}-%{release}
189 Provides: kernel-smp-devel-%{_target_cpu} = %{rpmversion}-%{release}
190 Prereq: /usr/bin/find
191
192 %description devel
193 This package provides kernel headers and makefiles sufficient to build modules
194 against the kernel package.
195
196
197 %package doc
198 Summary: Various documentation bits found in the kernel source.
199 Group: Documentation
200
201 %description doc
202 This package contains documentation files from the kernel
203 source. Various bits of information about the Linux kernel and the
204 device drivers shipped with it are documented in these files.
205
206 You'll want to install this package if you need a reference to the
207 options that can be passed to Linux kernel modules at load time.
208
209 %package xenU
210 Summary: The Linux kernel compiled for unprivileged Xen guest VMs
211
212 Group: System Environment/Kernel
213 Provides: kernel = %{version}
214 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}xenU
215 Prereq: %{kernel_prereq}
216 Conflicts: %{kernel_dot_org_conflicts}
217 Conflicts: %{package_conflicts}
218 Conflicts: %{nptl_conflicts}
219
220 # MEF commented out 
221 # Conflicts: %{xen_conflicts}
222
223 # We can't let RPM do the dependencies automatic because it'll then pick up
224 # a correct but undesirable perl dependency from the module headers which
225 # isn't required for the kernel proper to function
226 AutoReqProv: no
227
228 %description xenU
229 This package includes a version of the Linux kernel which
230 runs in Xen unprivileged guest VMs.  This should be installed
231 both inside the unprivileged guest (for the modules) and in
232 the guest0 domain.
233
234 %package xenU-devel
235 Summary: Development package for building kernel modules to match the kernel.
236 Group: System Environment/Kernel
237 AutoReqProv: no
238 Provides: kernel-xenU-devel-%{_target_cpu} = %{rpmversion}-%{release}
239 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}xenU
240 Provides: kernel-devel = %{rpmversion}-%{release}xenU
241 Prereq: /usr/sbin/hardlink, /usr/bin/find
242
243 %description xenU-devel
244 This package provides kernel headers and makefiles sufficient to build modules
245 against the kernel package.
246
247 %package uml
248 Summary: The Linux kernel compiled for use in user mode (User Mode Linux).
249
250 Group: System Environment/Kernel
251
252 %description uml
253 This package includes a user mode version of the Linux kernel.
254
255 %package uml-devel
256 Summary: Development package for building kernel modules to match the UML kernel.
257 Group: System Environment/Kernel
258 Provides: kernel-uml-devel-%{_target_cpu} = %{rpmversion}-%{release}
259 Provides: kernel-devel-%{_target_cpu} = %{rpmversion}-%{release}smp
260 Provides: kernel-devel = %{rpmversion}-%{release}smp
261 AutoReqProv: no
262 Prereq: /usr/sbin/hardlink, /usr/bin/find
263
264 %description uml-devel
265 This package provides kernel headers and makefiles sufficient to build modules
266 against the User Mode Linux kernel package.
267
268 %package uml-modules
269 Summary: The Linux kernel modules compiled for use in user mode (User Mode Linux).
270
271 Group: System Environment/Kernel
272
273 %description uml-modules
274 This package includes a user mode version of the Linux kernel modules.
275
276 %package vserver
277 Summary: A placeholder RPM that provides kernel and kernel-drm
278
279 Group: System Environment/Kernel
280 Provides: kernel = %{version}
281 Provides: kernel-drm = 4.3.0
282 Provides: kernel-%{_target_cpu} = %{rpmversion}-%{release}
283
284 %description vserver
285 VServers do not require and cannot use kernels, but some RPMs have
286 implicit or explicit dependencies on the "kernel" package
287 (e.g. tcpdump). This package installs no files but provides the
288 necessary dependencies to make rpm and yum happy.
289
290
291 %prep
292 # First we unpack the kernel tarball.
293 # If this isn't the first make prep, we use links to the existing clean tarball
294 # which speeds things up quite a bit.
295 if [ ! -d kernel-%{kversion}/vanilla ]; then
296   # Ok, first time we do a make prep.
297   rm -f pax_global_header
298 %setup -q -n %{name}-%{kversion} -c
299   mv linux-%{kversion} vanilla
300 else
301   # We already have a vanilla dir.
302   cd kernel-%{kversion}
303 fi
304
305 KERNEL_PREVIOUS=vanilla
306 # Dark RPM-magic to apply each patch to a hardlinked copy of the tree.
307 %define ApplyPatch() \
308   rm -fr linux-%{kversion}-%1                           \
309   cp -al $KERNEL_PREVIOUS linux-%{kversion}-%1          \
310   patchflag=-p1                                         \
311   test "%2" != "%%2" && patchflag="%2"                  \
312   PATCH="%{expand:%{PATCH%1}}"                          \
313   if test ! -e "$PATCH"; then                           \
314     echo "Patch %1 does not exist!"                     \
315     exit 1                                              \
316   fi                                                    \
317   case "$PATCH" in                                      \
318     *.bz2)  bzcat "$PATCH";;                            \
319     *.gz)   zcat "$PATCH";;                             \
320     *)      cat "$PATCH";;                              \
321   esac | patch -F1 -s -d linux-%{kversion}-%1 $patchflag \
322   KERNEL_PREVIOUS=linux-%{kversion}-%1
323
324 # This is where the patches get applied
325 %if 0%{?patchlevel}
326 %ApplyPatch 0
327 %endif
328
329 %ApplyPatch 10
330 %ApplyPatch 20
331
332 # NetNS patch for VINI
333 %if 0%{?with_netns}
334 %ApplyPatch 30
335 %endif
336
337 %ApplyPatch 100
338
339 %ApplyPatch 200
340 %ApplyPatch 210
341
342 %ApplyPatch 250
343
344 %ApplyPatch 500
345 %ApplyPatch 510
346 %ApplyPatch 520
347 %ApplyPatch 530
348 %ApplyPatch 540
349 %ApplyPatch 550
350 %ApplyPatch 560
351 %ApplyPatch 570
352 %ApplyPatch 580
353 %ApplyPatch 590
354
355 # NetNS conflict-resolving patch for VINI. Will work with patch vini_pl_patch-1 but may
356 # break with later patches.
357
358 %if 0%{?with_netns}
359 %ApplyPatch %vini_pl_patch
360 %endif
361
362 # Run the mac80211 stuff in the kernel tree holding the last patch
363 # tar -xzf %{PATCH600}
364 # pushd mac80211-%{mac80211_version}
365 # mac80211_makeflags="KSRC=../$KERNEL_PREVIOUS"
366 # make $mac80211_makeflags modified
367 # make $mac80211_makeflags source
368 # make $mac80211_makeflags patch_kernel
369 # popd
370
371 # Untar iwlwifi in the same place - needs to be compiled later
372 # tar -xzf %{PATCH601}
373 # the install target is broken: first it does not pass the right -b flag to depmod
374 # second we do not need to invoke depmod at this stage anyway
375 # let's add our own patch/stuff in this Makefile for manual install later on
376 # pushd iwlwifi-%{iwlwifi_version}
377 # cat >> Makefile <<EOF
378 # module-list:
379 #       @echo \$(addprefix \$(DIR),\$(addsuffix .ko,\$(list-m)))
380 # EOF
381 # popd
382
383 rm -fr linux-%{kversion}
384 ln -sf $KERNEL_PREVIOUS linux-%{kversion}
385 cd linux-%{kversion}
386
387
388 # make sure the kernel has the sublevel we know it has. This looks weird
389 # but for -pre and -rc versions we need it since we only want to use
390 # the higher version when the final kernel is released.
391 perl -p -i -e "s/^SUBLEVEL.*/SUBLEVEL = %{sublevel}/" Makefile
392 perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = -prep/" Makefile
393
394 # get rid of unwanted files resulting from patch fuzz
395 find . \( -name "*.orig" -o -name "*~" \) -exec rm -f {} \; >/dev/null
396
397
398 ###
399 ### build
400 ###
401 %build
402
403 BuildKernel() {
404     MakeTarget=$1
405     Arch=$2
406     Flavour=$3
407
408     rm -rf linux-%{_target_cpu}-%{kversion}$Flavour
409     cp -rl linux-%{kversion}/ linux-%{_target_cpu}-%{kversion}$Flavour
410     cd linux-%{_target_cpu}-%{kversion}$Flavour
411
412     # Pick the right config file for the kernel we're building
413     if [ -n "$Flavour" ] ; then
414       Config=%{pldistro}-%{kversion}-%{_target_cpu}-$Flavour.config
415       DevelDir=/usr/src/kernels/%{KVERREL}-$Flavour-%{_target_cpu}
416       DevelLink=/usr/src/kernels/%{KVERREL}$Flavour-%{_target_cpu}
417     else
418       Config=%{pldistro}-%{kversion}-%{_target_cpu}.config
419       DevelDir=/usr/src/kernels/%{KVERREL}-%{_target_cpu}
420       DevelLink=
421     fi
422
423     KernelVer=%{version}-%{release}$Flavour
424     echo BUILDING A KERNEL FOR $Flavour %{_target_cpu}...
425
426     # make sure EXTRAVERSION says what we want it to say
427     perl -p -i -e "s/^EXTRAVERSION.*/EXTRAVERSION = %{?patchlevel:.%{patchlevel}}-%{release}$Flavour/" Makefile
428
429     # and now to start the build process
430
431     make -s mrproper
432     cp %{_sourcedir}/$Config .config
433
434     #Arch=`head -1 .config | cut -b 3-`
435     echo USING ARCH=$Arch
436
437     make -s ARCH=$Arch nonint_oldconfig > /dev/null
438     make -s ARCH=$Arch %{?_smp_mflags} $MakeTarget
439     make -s ARCH=$Arch %{?_smp_mflags} modules || exit 1
440
441     # build the iwlwifi driver
442 #     make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
443 #         KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour
444
445     # Start installing the results
446
447 %if "%{_enable_debug_packages}" == "1"
448     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/boot
449 %endif
450     mkdir -p $RPM_BUILD_ROOT/%{image_install_path}
451     install -m 644 .config $RPM_BUILD_ROOT/boot/config-$KernelVer
452     install -m 644 System.map $RPM_BUILD_ROOT/boot/System.map-$KernelVer
453     if [ -f arch/$Arch/boot/bzImage ]; then
454       cp arch/$Arch/boot/bzImage $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
455     fi
456     if [ -f arch/$Arch/boot/zImage.stub ]; then
457       cp arch/$Arch/boot/zImage.stub $RPM_BUILD_ROOT/%{image_install_path}/zImage.stub-$KernelVer || :
458     fi
459     if [ "$Flavour" = "uml" ] ; then
460         install -D -m 755 linux $RPM_BUILD_ROOT/%{_bindir}/linux
461     fi
462
463     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer
464     make -s ARCH=$Arch INSTALL_MOD_PATH=$RPM_BUILD_ROOT modules_install KERNELRELEASE=$KernelVer
465
466     # install iwlwifi
467 #    make -C %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version} ARCH=$Arch \
468 #         KSRC=%{_builddir}/kernel-%{kversion}/linux-%{_target_cpu}-%{kversion}$Flavour \
469 #        KMISC=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless install
470 #    pushd %{_builddir}/kernel-%{kversion}/iwlwifi-%{iwlwifi_version}
471 #    iwlwifi_dest=$RPM_BUILD_ROOT/lib/modules/$KernelVer/kernel/drivers/net/wireless
472     # get the list and location of modules to install - no need to pass KSRC nor anything, let's keep it simple
473 #    iwlwifi_modules=$(make --no-print-directory module-list)
474 #    install -d $iwlwifi_dest
475 #    install -m 644 -c $iwlwifi_modules $iwlwifi_dest
476 #    popd
477
478     # And save the headers/makefiles etc for building modules against
479     #
480     # This all looks scary, but the end result is supposed to be:
481     # * all arch relevant include/ files
482     # * all Makefile/Kconfig files
483     # * all script/ files
484
485     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
486     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/source
487     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
488     (cd $RPM_BUILD_ROOT/lib/modules/$KernelVer ; ln -s build source)
489     # dirs for additional modules per module-init-tools, kbuild/modules.txt
490     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/extra
491     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/updates
492     # first copy everything
493     cp --parents `find  -type f -name "Makefile*" -o -name "Kconfig*"` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build 
494         cp Module.symvers $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
495     if [ "$Flavour" = "uml" ] ; then
496       cp --parents -a `find arch/um -name include` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
497     fi
498     # then drop all but the needed Makefiles/Kconfig files
499     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Documentation
500     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts
501     rm -rf $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
502     cp arch/%{_arch}/kernel/asm-offsets.s $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/kernel || :
503     cp .config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
504     cp -a scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
505     if [ -d arch/%{_arch}/scripts ]; then
506       cp -a arch/%{_arch}/scripts $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch} || :
507     fi
508     if [ -f arch/%{_arch}/*lds ]; then
509       cp -a arch/%{_arch}/*lds $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/%{_arch}/ || :
510     fi
511     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*.o
512     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/scripts/*/*.o
513     mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
514     cd include
515     cp -a acpi config keys linux math-emu media mtd net pcmcia rdma rxrpc scsi sound video asm asm-generic $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
516     cp -a `readlink asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
517     if [ "$Arch" = "x86_64" ]; then
518       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
519     fi
520 %if %{buildxen}
521     if [ "$Flavour" = "xenU" ]; then
522       cp -a xen $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
523       cp -a asm-i386 $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
524     fi
525 %endif
526 %if %{builduml}
527     if [ "$Flavour" = "uml" ] ; then
528       cp -a `readlink -f asm/arch` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
529     fi
530 %endif
531     # While arch/powerpc/include/asm is still a symlink to the old
532     # include/asm-ppc{64,} directory, include that in kernel-devel too.
533     if [ "$Arch" = "powerpc" -a -r ../arch/powerpc/include/asm ]; then
534       cp -a `readlink ../arch/powerpc/include/asm` $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include
535       mkdir -p $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
536       pushd $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/arch/$Arch/include
537       ln -sf ../../../include/asm-ppc* asm
538       popd
539     fi
540
541     # Make sure the Makefile and version.h have a matching timestamp so that
542     # external modules can be built
543     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/Makefile $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/version.h
544     touch -r $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/.config $RPM_BUILD_ROOT/lib/modules/$KernelVer/build/include/linux/autoconf.h
545     cd ..
546
547     #
548     # save the vmlinux file for kernel debugging into the kernel-debuginfo rpm
549     #
550 %if "%{_enable_debug_packages}" == "1"
551     mkdir -p $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
552     cp vmlinux $RPM_BUILD_ROOT/usr/lib/debug/lib/modules/$KernelVer
553 %endif
554 %if %{buildxen}
555     if [ -f vmlinuz ]; then
556       cp vmlinuz $RPM_BUILD_ROOT/%{image_install_path}/vmlinuz-$KernelVer
557     fi
558 %endif
559
560     find $RPM_BUILD_ROOT/lib/modules/$KernelVer -name "*.ko" -type f >modnames
561
562     # mark modules executable so that strip-to-file can strip them
563     cat modnames | xargs chmod u+x
564
565     # remove files that will be auto generated by depmod at rpm -i time
566     rm -f $RPM_BUILD_ROOT/lib/modules/$KernelVer/modules.*
567
568     # Move the devel headers out of the root file system
569     mkdir -p $RPM_BUILD_ROOT/usr/src/kernels
570     mv $RPM_BUILD_ROOT/lib/modules/$KernelVer/build $RPM_BUILD_ROOT/$DevelDir
571     ln -sf ../../..$DevelDir $RPM_BUILD_ROOT/lib/modules/$KernelVer/build
572     [ -z "$DevelLink" ] || ln -sf `basename $DevelDir` $RPM_BUILD_ROOT/$DevelLink
573 }
574
575 ###
576 # DO it...
577 ###
578
579 # prepare directories
580 rm -rf $RPM_BUILD_ROOT
581 mkdir -p $RPM_BUILD_ROOT/boot
582
583 %if "%{_target_cpu}" == "x86_64"
584 %define kernel_arch %{_target_cpu}
585 %endif
586 %if "%{_target_cpu}" == "i586"
587 %define kernel_arch i386
588 %endif
589 %if "%{_target_cpu}" == "i686"
590 %define kernel_arch i386
591 %endif
592
593 %if %{buildup}
594 BuildKernel %make_target %kernel_arch
595 %endif
596
597 %ifarch i686
598 %if %{builduml}
599 BuildKernel linux um uml
600 %endif
601
602 %if %{buildxen}
603 BuildKernel vmlinuz %kernel_arch xenU
604 %endif
605 %endif
606
607 ###
608 ### install
609 ###
610
611 %install
612
613 cd vanilla
614
615 %if %{buildxen} && "%{_target_cpu}" == "i686"
616 mkdir -p $RPM_BUILD_ROOT/etc/ld.so.conf.d
617 rm -f $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
618 cat > $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf <<\EOF
619 # This directive teaches ldconfig to search in nosegneg subdirectories
620 # and cache the DSOs there with extra bit 0 set in their hwcap match
621 # fields.  In Xen guest kernels, the vDSO tells the dynamic linker to
622 # search in nosegneg subdirectories and to match this extra hwcap bit
623 # in the ld.so.cache file.
624 hwcap 0 nosegneg
625 EOF
626 chmod 444 $RPM_BUILD_ROOT/etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
627 %endif
628
629 %if %{builddoc}
630 mkdir -p $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}/Documentation
631
632 # sometimes non-world-readable files sneak into the kernel source tree
633 chmod -R a+r *
634 # copy the source over
635 tar cf - Documentation | tar xf - -C $RPM_BUILD_ROOT/usr/share/doc/kernel-doc-%{kversion}
636 %endif
637
638 ###
639 ### clean
640 ###
641
642 %clean
643 rm -rf $RPM_BUILD_ROOT
644
645 ###
646 ### scripts
647 ###
648
649 # load the loop module for upgrades...in case the old modules get removed we have
650 # loopback in the kernel so that mkinitrd will work.
651 %pre
652 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
653 exit 0
654
655 %post
656 if [ -f /etc/sysconfig/kernel ]; then
657   /bin/sed -i -e 's/^DEFAULTKERNEL=kernel-smp$/DEFAULTKERNEL=kernel/' /etc/sysconfig/kernel
658 fi
659
660 # trick mkinitrd in case the current environment does not have device mapper
661 rootdev=$(awk '/^[ \t]*[^#]/ { if ($2 == "/") { print $1; }}' /etc/fstab)
662 if echo $rootdev |grep -q /dev/mapper 2>/dev/null ; then
663     if [ ! -f $rootdev ]; then
664         fake_root_lvm=1
665         mkdir -p $(dirname $rootdev)
666         touch $rootdev
667     fi
668 fi
669
670 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade %{rpmversion}-%{release}
671 #/sbin/new-kernel-pkg --package kernel --mkinitrd --depmod --install %{KVERREL}
672 # Older modutils do not support --package option
673 /sbin/new-kernel-pkg --mkinitrd --depmod --install %{KVERREL}
674
675 # remove fake handle
676 if [ -n "$fake_root_lvm" ]; then
677     rm -f $rootdev
678 fi
679
680 # make some useful links
681 pushd /boot > /dev/null ; {
682         ln -sf config-%{KVERREL} config
683         ln -sf config-%{KVERREL} configsmp
684         ln -sf initrd-%{KVERREL}.img initrd-boot
685         ln -sf initrd-%{KVERREL}.img initrd-bootsmp
686         ln -sf vmlinuz-%{KVERREL} kernel-boot
687         ln -sf vmlinuz-%{KVERREL} kernel-bootsmp
688 }
689 popd > /dev/null
690
691 # ask for a reboot
692 mkdir -p /etc/planetlab
693 touch /etc/planetlab/update-reboot
694
695 %post devel
696 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
697 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
698   pushd /usr/src/kernels/%{KVERREL}-%{_target_cpu} > /dev/null
699   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
700   popd > /dev/null
701 fi
702
703 %post xenU
704 [ ! -x /usr/sbin/module_upgrade ] || /usr/sbin/module_upgrade
705 [ ! -x /sbin/ldconfig ] || /sbin/ldconfig -X
706
707 %post xenU-devel
708 [ -f /etc/sysconfig/kernel ] && . /etc/sysconfig/kernel
709 if [ "$HARDLINK" != "no" -a -x /usr/sbin/hardlink ] ; then
710   pushd /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu} > /dev/null
711   /usr/bin/find . -type f | while read f; do hardlink -c /usr/src/kernels/*FC*/$f $f ; done
712   popd > /dev/null
713 fi
714
715 %post uml-modules
716 depmod -ae %{KVERREL}uml
717
718 %preun
719 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
720 /sbin/new-kernel-pkg --rminitrd --rmmoddep --remove %{KVERREL}
721
722 %preun xenU
723 /sbin/modprobe loop 2> /dev/null > /dev/null  || :
724 /sbin/new-kernel-pkg --rmmoddep --remove %{KVERREL}xenU
725
726 %preun uml-modules
727 rm -f /lib/modules/%{KVERREL}uml/modules.*
728
729
730 ###
731 ### file lists
732 ###
733
734 %if %{buildup}
735 %files 
736 %defattr(-,root,root)
737 /%{image_install_path}/vmlinuz-%{KVERREL}
738 /boot/System.map-%{KVERREL}
739 /boot/config-%{KVERREL}
740 %dir /lib/modules/%{KVERREL}
741 /lib/modules/%{KVERREL}/kernel
742 /lib/modules/%{KVERREL}/build
743 /lib/modules/%{KVERREL}/source
744 /lib/modules/%{KVERREL}/extra
745 /lib/modules/%{KVERREL}/updates
746
747 %files devel
748 %defattr(-,root,root)
749 %verify(not mtime) /usr/src/kernels/%{KVERREL}-%{_target_cpu}
750 %endif
751
752 %if %{builduml} && "%{_target_cpu}" == "i686"
753 %files uml
754 %defattr(-,root,root)
755 %{_bindir}/linux
756
757 %files uml-devel
758 %defattr(-,root,root)
759 %verify(not mtime) /usr/src/kernels/%{KVERREL}-uml-%{_target_cpu}
760 /usr/src/kernels/%{KVERREL}uml-%{_target_cpu}
761
762 %files uml-modules
763 %defattr(-,root,root)
764 /boot/System.map-%{KVERREL}uml
765 /boot/config-%{KVERREL}uml
766 %dir /lib/modules/%{KVERREL}uml
767 /lib/modules/%{KVERREL}uml/kernel
768 /lib/modules/%{KVERREL}uml/build
769 /lib/modules/%{KVERREL}uml/source
770 /lib/modules/%{KVERREL}uml/extra
771 /lib/modules/%{KVERREL}uml/updates
772 %endif
773
774 %if %{buildxen} && "%{_target_cpu}" == "i686"
775 %files xenU
776 %defattr(-,root,root)
777 /%{image_install_path}/vmlinuz-%{KVERREL}xenU
778 /boot/System.map-%{KVERREL}xenU
779 /boot/config-%{KVERREL}xenU
780 %dir /lib/modules/%{KVERREL}xenU
781 /lib/modules/%{KVERREL}xenU/kernel
782 /lib/modules/%{KVERREL}xenU/build
783 /lib/modules/%{KVERREL}xenU/source
784 /lib/modules/%{KVERREL}xenU/extra
785 /lib/modules/%{KVERREL}xenU/updates
786 /etc/ld.so.conf.d/kernelcap-%{KVERREL}.conf
787
788 %files xenU-devel
789 %defattr(-,root,root)
790 %verify(not mtime) /usr/src/kernels/%{KVERREL}-xenU-%{_target_cpu}
791 /usr/src/kernels/%{KVERREL}xenU-%{_target_cpu}
792 %endif
793
794 %files vserver
795 %defattr(-,root,root)
796 # no files
797
798 # only some architecture builds need kernel-doc
799
800 %if %{builddoc}
801 %files doc
802 %defattr(-,root,root)
803 %{_datadir}/doc/kernel-doc-%{kversion}/Documentation/*
804 %dir %{_datadir}/doc/kernel-doc-%{kversion}/Documentation
805 %dir %{_datadir}/doc/kernel-doc-%{kversion}
806 %endif
807
808 %changelog
809 * Tue Jul 11 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2142_FC4]
810 - 2.6.17.4
811 - Disable split pagetable lock.
812
813 * Wed Jul  5 2006 Dave Jones <davej@redhat.com>
814 - Get rid of stack backtrace on panic, which in most
815   cases actually caused a loss of info instead of a gain.
816
817 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2141_FC4]
818 - 2.6.17.3
819
820 * Fri Jun 30 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2140_FC4]
821 - 2.6.17.2
822 - Fix up the alsa list_add bug.
823
824 * Mon Jun 26 2006 Dave Jones <davej@redhat.com>
825 - Fix up various stupidities incurred by the last big rebase.
826   - Reenable SMP x86-64 builds.
827   - Reenable SMBFS.
828 - Enable PCI fake hotplug driver.
829 - Enable gameport/joystick on i586 builds. (#196581)
830
831 * Sat Jun 24 2006 Dave Jones <davej@redhat.com>
832 - Enable profiling for 586 kernels.
833
834 * Fri Jun 23 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2139_FC4]
835 - Rebuild with slab debug off.
836
837 * Tue Jun 20 2006 Dave Jones <davej@redhat.com> [2.6.17-1.2138_FC4]
838 - 2.6.17.1
839
840 * Mon Jun  5 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2115_FC4]
841 - 2.6.16.20
842
843 * Tue May 30 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2114_FC4]
844 - 2.6.16.19
845
846 * Mon May 29 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2113_FC4]
847 - Improved list_head debugging.
848
849 * Tue May 23 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2112_FC4]
850 - 2.6.16.18
851
852 * Sat May 20 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2111_FC4]
853 - 2.6.16.17
854
855 * Wed May 10 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2110_FC4]
856 - 2.6.16.16
857
858 * Tue May  9 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2109_FC4]
859 - 2.6.16.15
860 - make 16C950 UARTs work (again). (#126403)
861 - Fix exec-shield default, which should fix a few programs that
862   stopped running.
863
864 * Thu May  4 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2108_FC4]
865 - 2.6.16.14
866
867 * Tue May  2 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2107_FC4]
868 - 2.6.16.13
869
870 * Mon May  1 2006 Dave Jones <davej@redhat.com>
871 - 2.6.16.12
872
873 * Tue Apr 25 2006 Dave Jones <davej@redhat.com>
874 - Fix up SCSI errors with mymusix usb mp3 player (#186187)
875
876 * Mon Apr 24 2006 Dave Jones <davej@redhat.com>
877 - 2.6.16.11
878
879 * Wed Apr 19 2006 Dave Jones <davej@redhat.com>
880 - Enable PCI MSI support.
881
882 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2096_FC4]
883 - 2.6.16.9
884
885 * Tue Apr 18 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2093_FC4]
886 - 2.6.16.7
887
888 * Mon Apr 17 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2092_FC4]
889 - 2.6.16.6
890
891 * Sun Apr 16 2006 Dave Jones <davej@redhat.com>
892 - 2.6.16.5
893
894 * Fri Apr  7 2006 Dave Jones <davej@redhat.com>
895 - 2.6.16.2
896
897 * Tue Apr  4 2006 Dave Jones <davej@redhat.com>
898 - Reenable non-standard serial ports. (#187466)
899 - Reenable snd-es18xx for x86-32 (#187733)
900
901 * Thu Mar 30 2006 Dave Jones <davej@redhat.com>
902 - ship the .kernelrelease file in -devel too.
903 - Disable EDAC debug.
904
905 * Tue Mar 26 2006 Dave Jones <davej@redhat.com> [2.6.16-1.2069_FC4]
906 - 2.6.16.1
907
908 * Mon Mar 25 2006 Dave Jones <davej@redhat.com>
909 - Include patches posted for review for inclusion in 2.6.16.1
910 - Updated new audit msg types.
911 - Reenable HDLC driver (#186257)
912 - Make acpi-cpufreq 'sticky'
913 - Fix broken x86-64 32bit vDSO (#186924)
914
915 * Tue Mar 21 2006 Dave Jones <davej@redhat.com>
916 - Improve spinlock scalability on big machines.
917
918 * Mon Mar 20 2006 Dave Jones <davej@redhat.com>
919 - Sync with FC5's 2.6.16 kernel.
920 - Update Tux & Exec-shield to latest.
921